Troubleshooting Your Design
with the TDS2000C Series Oscilloscopes
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Troubleshooting Your Design with the TDS2000C Series Oscilloscope
Today’s engineers and technicians face increasingly complex and
critical troubleshooting tasks. New digital designs often challenge
designers with new problems to find: race conditions, transients,
signal aberrations, bus contention problems, etc. And, of course,
competitive time-to-market pressures dictate that troubleshooting
must be completed quickly and accurately.
The TDS2000C Series delivers the performance, affordability and
portability that enable engineers and technicians to tackle these
challenges – quickly and easily. More than just a matter of basic
bandwidth, these oscilloscopes enable users to solve problems
quickly, helping them to establish that a problem exists, allowing
them to capture the problem accurately, and enabling them to
analyze it to determine the root cause.

The tips on the following pages are designed to further simplify
your troubleshooting tasks. But if you need more help, there is
plenty available. Simply contact your local Tektronix representative,
authorized distributor, or visit www.tektronix.com/oscilloscopes
50, 70, 100, and 200 MHz models
Up to 2 GS/s sample rate on all channels
Active TFT Color Display for easy viewing at a distance, at an
angle, or under dim lighting conditions
Built-in USB host and device ports standard
Easy documentation and analysis with PC connectivity software
Lifetime warranty*
* Limitations apply. For terms and conditions, visit
www.tektronix.com/lifetimewarranty
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Getting Started
To optimize your troubleshooting task at hand, it is important to start
at the beginning – with proper probe compensation and attenuation,
default setup, and automatic instrument setup.

To properly compensate and attenuate your probe,
follow these simple steps:
1. Connect the probe to channel 1.
2. Attach the probe tip and reference lead to the PROBE COMP
connectors. If using the probe hook-tip, ensure a proper
connection by firmly twisting the tip onto the probe.

PROBE COMP AUTOSET
button
Overcompensated

Undercompensated
CH 1
Compensated Correctly

3. Push PROBE CHECK.
4. The oscilloscope will automatically check the probe attenuation
and check the shape of the displayed waveform to determine if
your probe is compensated correctly.
5. If necessary, it will instruct you to adjust your probe compensation.

To ensure that you begin with factory initialization
settings, follow these simple steps:
TPP Series

1. Press the front panel DEFAULT SETUP button.
2. Press the front panel AUTOSET button.
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Capture Elusive Glitches
In today’s high-speed digital designs, elusive glitches and random
anomalies can cause circuits to fail. While finding these glitches has
never been easy, the TDS2000C Series simplifies this task with its

peak detect feature. Peak detect can capture narrow glitches, even
on low-frequency signals.

To use the Peak Detect feature:
1. Display the waveform on the screen.
2. Press the ACQUIRE front panel menu button.
3. Press the Peak Detect menu button.
4. Notice that the oscilloscope captures several very narrow glitches,
even at slow sweep speeds. Without peak detect, you would not
have seen many of these glitches.
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Capture Elusive Glitches (continued)
Intermittent signal anomalies can also be a challenge to see. The
TDS2000C Series provides variable- and infinite-persistence display
capabilities to provide you with information about the signal

variations over time, making it easier to understand the
characteristics of the transients you’ve captured.

To use Display Persistence:
1. Display the waveform on the screen.
2. Press the DISPLAY front panel menu button.
3. Press the Persist menu button until the desired amount of
persistence is selected.
4. Notice that the most recent signal is highlighted in the display.
By monitoring the screen updates, you can judge the relative
frequency-of-occurrence of the signal anomalies.
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Debug Digital Timing Problems
Digital designers need to quickly find and analyze a wide range of
circuit timing problems. For example, race conditions and transients
can cause circuits to perform inaccurately. The TDS2000C Series’

pulse width trigger can help troubleshoot such situations by
triggering when a signal pulse width is less than, greater than,
equal to or not equal to a specified pulse width.

To use the pulse width trigger:
1. Press the TRIG MENU front panel button.
2. In the side menu, press Type until Pulse is selected.
3. Press the When side menu button until < is selected.
4. Use the multipurpose knob to set the desired minimum
pulse width.
5. Select, as desired, Source, Polarity, Mode, and Coupling.
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Verify Timing Relationships
Electronics engineers often need to verify that their circuits
are working as designed. One of the most common types of
oscilloscope measurements is timing measurements, such as pulse

width, period, and frequency. The TDS2000C Series’ cursors can be
used to make such measurements quickly and easily.

To make timing measurements using cursors:
1. Press the CURSOR button.
2. Press the Type menu button until the Time cursor type is
selected.
3. Press the Cursor 1 menu button.
4. To measure the timing relationship between two signals, place
cursor 1 on the first edge of interest, using the multipurpose knob.
5. Press the Cursor 2 button and place cursor 2 on the second
edge of interest, at approximately the same Voltage.
6. The cursor readouts indicate the timing of the cursors relative
to the trigger point. In this example, the Δt readout indicates
the period of the waveform, and the 1/Δt is the frequency of
the signal.
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Check Signal Integrity
Electronics engineers may discover that a wide array of unintentional
electrical events will make a difference in how circuits function in the
real world. To characterize these events, engineers can measure

criteria such as overshoot, ringing, ground bounce, cross talk, and
other signal integrity issues. The TDS2000C Series’ cursors can be
used to make such measurements.

To make signal integrity measurements
using cursors:
1. Press the CURSOR button.
2. Press the Type menu button until the Amplitude cursor type is
selected.
3. Press the Cursor 1 menu button.
4. To measure the peak ringing below ground, place cursor 1 at 0
Volts, using the multipurpose knob.
5. Press the Cursor 2 menu button and place cursor 2 on the
negative peak, using the multipurpose knob.
6. View the absolute Voltage measurements on the cursor readouts
at the side of the display. The Δ readout indicates the difference
between the cursor positions.
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Check Signal Integrity (continued)
The TDS2000C Series’ automatic measurement system can also be
used to make such measurements quickly and automatically.

To make signal integrity measurements using
automatic measurement system:
1. Press the MEASURE front panel button.
2. Press a CH1 side menu button to add an automatic
measurement.
3. Press the Type side menu button until you find the desired
measurement, and then press Back.
4. Repeat steps 2 and 3 to select and display up to 5
measurements.
5. View the selected measurements on the right side of the display.
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Debugging Digital System Lock-up
One common cause of digital system lock-ups is an intermittent
clock. The TDS2000C Series trigger system can quickly and easily
identify unexpected interruptions in the clock signal.

1. Press TRIG MENU front panel button.
2. Press Type side button until Pulse is selected.
3. Press When until > is selected.
4. Using the multipurpose knob, set Pulse Width to slightly longer
than the clock pulse.
5. Press –more– and press Polarity until Negative is selected.
6. You can also adjust the TRIGGER LEVEL to capture lowamplitude or “runt” pulses.
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Test For The Presence of Video Signals
Video technicians must perform a quick check for the presence
of a video signal at different test points. If the site is in the field,
technicians will need lightweight, portable test equipment gear that

they can easily carry to each location. The TDS2000C Series’ video
trigger features make this oscilloscope a valuable tool for these
technicians.

1. Connect the video signal to the oscilloscope using proper
adapters and a 75 Ω terminator, if necessary.
2. Press the AUTOSET front panel button.
3. Press the Line/Field side button to select video line triggering. If a
broadcast-standard video waveform is present, the oscilloscope
will display a stable video waveform that is triggered on all lines.
4. To add some display persistence, press DISPLAY and press
Persist to select the desired persistence.
5. Adjust vertical position and scale as desired.
6. To adjust trigger setup, press TRIG MENU and change Source,
Polarity, and video Standard.
7. If desired, reconnect the oscilloscope to other test points. You do
not need to change any oscilloscope settings.
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Look for Unintentional Circuit Noise
Developers need to check for unintended noise in their prototypes.
However, noisy signals can be difficult to analyze in the time domain,
as shown below.

Engineers and technicians can use the Fast Fourier Transform
(FFT) to break down signals into component frequencies, which
the oscilloscope uses to display a graph of the frequency domain
of a signal, as opposed to the oscilloscope’s standard time
domain graph.
Developers can then associate those frequencies with known
system frequencies, such as system clocks, oscillators, read/write
strobes, display signals, or switching power supplies.
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Look for Unintentional Circuit Noise (continued)
The TDS2000C Series offers a standard FFT feature, making it an
ideal tool for these identifying sources of noise in a circuit. To create
FFT display:

1. Press the front panel MATH button.
2. Press the Operation menu button until FFT is selected.
3. Press the Window menu button until the Hanning window is
selected, which provides the highest frequency resolution.
4. If desired, use the vertical and horizontal POSITION and SCALE
controls to magnify and position the FFT waveform.
5. Cursors can be used to accurately measure the FFT waveform.
Press CURSOR.
6. Press the Source menu button until MATH is selected.
7. Press the Type menu button until Frequency is selected.
8. Press the Cursor 1 menu button. Using the multipurpose knob,
position cursor 1 at the left side of the display.
9. Press the Cursor 2 menu button. Position cursor 2 on the highest
point in the display.
10. The readout indicates one of the sources of noise. In this case,
the 20 MHz signal is the system clock, which is coupling into the
signal.
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Power Line Harmonic Analysis
Power circuit designers often need to analyze the effects of their
circuits on the power line. Although an ideal power supply would
present a constant load on a power line, real power supply circuits

do not, creating harmonics on the power line. The TDS2000C
provide simple tools to measure power supply currents and analyze
the harmonics on a power line.

To display the power line harmonics on a current
waveform:
1. Press the CH 1 MENU front panel button.
2. Press the Probe side menu button.
3. Press the Current side menu button to select current probe
support.
4. Press the Scale side menu button to select the appropriate
current probe scale factor.
5. Notice the readouts at the bottom of the display, where the
waveform’s vertical units are now in milliAmps (mA).
6. Press the MATH front panel button.
7. Press the Operation side menu button until FFT is selected.
8. Press the Window side menu button until Flattop is selected.
This window is best for measuring amplitudes accurately.
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Power Line Harmonic Analysis (continued)
The FFT display provides a frequency-domain display of the power
line signal, including the fundamental power line frequency and the
harmonics at integer multiples of the fundamental frequency. The

TDS2000C cursor measurements provide an easy and accurate way
to analyze this complex display.

1. Press the CURSOR front panel button.
2. Press the Source side menu button until MATH is selected.
3. Press the Type side menu button until Frequency is selected.
4. Press the Cursor 1 side menu button and use the multipurpose
knob to align the cross-hair cursor on the left-most peak (the
fundamental).
5. Press the Cursor 2 side menu button and use the multipurpose
knob to align the cross-hair cursor on the next-highest peak (the
3rd harmonic, in this case).
6. The readouts at the right of the screen indicated the absolute
and relative frequencies and magnitudes.
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Make a Quick Pass/Fail Test of Your Device
Design engineers doing validation test and debug or manufacturing
engineers performing repetitive tests often need to compare live
waveform signals against a know good reference signal. The
TDS2000C offers quick pass/fail testing, also known as limit
testing, by comparing active signals against a user defined template
waveform. The oscilloscope can be set up to count both passing

and failing waveforms. You can also set a user defined stop
condition, including stop on manual control, elapsed time, waveform
count, or waveform violations. When a failure condition occurs, the
oscilloscope can be set to stop acquisition or save a screen image
and/or waveform file to a USB device, enabling complete unattended
operation.

To create a template for limit testing and perform
a limit test:
1. Press the Utility front panel button.
2. Press the Limit Test side menu button to select Limit Test.
3. Press Template Setup side menu button to set up your template.
4. Set the vertical and horizontal limits of the template waveform.
5. Press Apply Template side menu button to store the limit test
template.
6. Press the Stop side menu button to setup stop options.
7. Press Action on Violation side menu button to setup the action
the oscilloscope should take when a violation occurs.
8. Press the Run/Stop Test side menu to start/stop the test.
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Automatically Capture and Save Elusive Waveform Anomalies
Engineers often spend hours trying to capture specific events or
waveform anomalies. The TDS2000C offers a data logging function
that allows the oscilloscope to capture signals based on userspecified trigger conditions, Multiple triggered waveforms can be

recorded based on user-defined time durations, selectable in 30
minute increments up to 8 hours of total time. Waveforms are time
stamped and recorded to USB device and stored in CSV file format.

To use the data logging feature
1. Setup an appropriate trigger mode and acquisition mode.
2. Plug in your USB device to the oscilloscope’s front-panel USB
port.
3. Press the Utility front panel button.
4. Press the Data Logging side menu button to select the data
logging function.
5. Setup the duration time from 30 minutes to 8 hours.
6. Press the Data Logging side menu button to start/stop the test.
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Documenting Your Results with OpenChoice® Software
Design engineers in the lab and technicians in the field often need to
document the work they do with their oscilloscope. They can save
screen images to a removable memory device and then manually

copy the files to their PC. The easy-to-use OpenChoice Desktop
simplifies these documentation tasks by directly transferring screen
images to your PC over USB.

1. Acquire the signal.
2. Connect the oscilloscope to the PC using a USB cable.
3. Launch the OpenChoice Desktop program.
4. Click Select Instrument, choose the correct USB instrument,
and click OK.
5. Click Get Screen to capture the screen image.
6. Click Save As to save the screen image to a file on the PC.
7. Click Copy to Clipboard. You can then launch your
documentation program and paste the image into the document.
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Waveform Measurements Logging
A common task for engineers and technicians is to make
measurements on their oscilloscope and then manually record
measurements to document circuit performance variations over time.

However, this is time-consuming and can lead to inconsistent quality
of documentation. The easy-to-use TekXL toolbar simplifies data
gathering and documentation tasks inside Excel.

1 Acquire the signal.
2. Connect the oscilloscope to the PC using a USB cable.
3. Launch Excel and enable the TekXL toolbar by selecting
Tools > Add-ins… and checking the box next to Tekxltoolbar.
4. Press the TekXL Connection icon, select the desired instrument,
and press OK.
5. Press the TekXL Measurements icon.
6. On the Selection tab, choose Frequency.
7. On the Timing tab, select 45 samples.
8. On the Charting tab, choose Upon Completion.
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Waveform Analysis Using NI SignalExpress™ Tektronix Edition Software
Although the TDS2000C provide significant on-board analysis
capabilities, there are applications where the analysis requirements
are better met with PC-based applications. SignalExpress Tektronix

Edition provides advanced analysis capabilities with the ease of USB
plug-and-play.

1. Acquire the signal.
2. Connect the oscilloscope to the PC using a USB cable.
3. Launch the SignalExpress TE program.
4. SignalExpress will open with the instrument automatically
connected and transferring data to the PC.
5. To conduct a limit test of the signal against specified limits, select
Add Step > Analog > Test Limit > Test.
6. To display the histogram of the signal, select Add Step >
Analog > Time-Domain Measurements > Histogram.
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Contact Tektronix:
ASEAN / Australasia (65) 6356 3900
Austria* 00800 2255 4835
Balkans, Israel, South Africa and other ISE Countries +41 52 675 3777
Belgium* 00800 2255 4835
Brazil +55 (11) 3759 7600
Canada 1 (800) 833-9200
Central East Europe, Ukraine and the Baltics +41 52 675 3777
Central Europe & Greece +41 52 675 3777
Denmark +45 80 88 1401
Finland +41 52 675 3777
France* 00800 2255 4835
Germany* 00800 2255 4835
Hong Kong 400-820-5835
India 000-800-650-1835
Italy* 00800 2255 4835
Japan 81 (3) 6714-3010
Luxembourg +41 52 675 3777
Mexico, Central/South America & Caribbean 52 (55) 56 04 50 90
Middle East, Asia and North Africa +41 52 675 3777
The Netherlands* 00800 2255 4835
Norway 800 16098
People’s Republic of China 400-820-5835
Poland +41 52 675 3777
Portugal 80 08 12370
Republic of Korea 001-800-8255-2835
Russia & CIS +7 (495) 7484900
South Africa +27 11 206 8360
Spain* 00800 2255 4835
Sweden* 00800 2255 4835
Switzerland* 00800 2255 4835
Taiwan 886 (2) 2722-9622
United Kingdom & Ireland* 00800 2255 4835
USA 1 (800) 833-9200
* If the European phone number above is not accessible, please call: +41 52 675 3777
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