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A collection of lab exercises to help you hone your skills at using the 
MSO5000/DPO5000 Series Digital Phosphor Oscilloscopes. 

 

NOTE: Always use the latest instrument software for demonstrations. Go to www.tek.com/software and search 
for “MSO5000” or “DPO5000”. Follow the installation instructions on the web page.

 

http://www.tek.com/software
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MSO5000/DPO5000 Series 
User Interface Exploration Lab 

 

 
 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.1.1 
One TPP0500 or TPP1000 passive probe 
USB keyboard and mouse 
Optional stylus (119-6107-00) 
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Understanding the MSO/DPO5000 Series User Interface 

This lab provides an overview of the MSO/DPO5000 Series user interface and outlines a few quick ways to 
demonstrate important usability advantages of the MSO/DPO5000 family. Learn a few favorites to highlight 
the products’ usability and to improve your productivity when running the instrument. 

There are three key themes with respect to this user interface: 

 Intuitive operation in any common engineering environment 

 Instrument control in a way you prefer 

 Achieving results more quickly using efficient controls and shortcuts 

Display 

In addition to the waveforms, the display contains various status readouts, icons, and other user 
interface information. Throughout this lab, notice all of the display changes as you control the 
instrument. For those users who are familiar with the Tektronix DPO7000 and MSO/DSA/DPO70000 
Series, the MSO/DPO5000 display interface will seem almost identical. 

There are a variety of ways to operate the instrument. Each successive level within the user interface 
enables a deeper feature set and greater control. This lab will highlight some of the advantages of each type 
of instrument control. 

Direct controls 

With the familiar front panel controls, the user has direct access to the most commonly-used 
controls to set up a stable oscilloscope display of one or more analog channels. Most of the controls 
are the same as you would find on any analog or digital oscilloscope front panel. For those users 
who are familiar with the Tektronix MSO/DPO4000/3000/2000 Series, the MSO/DPO5000 front 
panels will seem almost identical. 

Touch screen, toolbar, and multipurpose controls 

The next level of controls are available through the on-screen controls. These controls are logically 
grouped by function and can be accessed either through pressing the on-screen toolbar buttons at 
the top of the display or by pressing the corresponding front panel buttons, similar to the menu 
interface on the MSO/DPO4000/3000/2000 Series. 

Windows menu interface 

The most complete set of instrument controls are available through the Windows menu bar. These 
controls are logically grouped by function, with familiar File and Edit menus on the left, instrument 
control menus in the middle, and Utilities and Help on the right. These menus can be operated with 
the touch screen, but are optimized for use with a mouse. For those users who are familiar with the 
Tektronix DPO7000 and MSO/DSA/DPO70000 Series, the MSO/DPO5000 Windows menu interface 
will seem almost identical. 

Mouse and right-clicks 

A growing number of users prefer mouse-driven operation for anything but the most basic 
instrument control. This is especially true when an instrument is located on a shelf above a bench. 
The MSO/DPO5000 series provides a rich array of mouse actions and right-mouse-click menus for 
context-sensitive direct access to instrument features. The mouse scroll wheel is included as an 
interactive device to allow fine adjustment without letting go of the mouse. Again, those users who 
are familiar with the Tektronix DPO7000 and MSO/DSA/DPO70000 Series will find these 
capabilities familiar. 
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MyScope™ Control Windows 

The MyScope feature allows the user to quickly and easily build their own custom control windows 
that contain only the controls, features, and capabilities they care about and are important in their 
job. Again, those users who are familiar with the Tektronix DPO7000 and MSO/DSA/DPO70000 
Series will find this capability familiar. 

User Preferences 

The MSO/DPO5000 also allows the user to customize the user interface behavior with some user 
preferences and menu settings. This lab will highlight a few of the settings that will make the 
MSO/DPO5000 behavior more closely match the behaviors of the MSO/DPO4000/3000/2000 
products. 

This lab does not go through every instance of each of these control mechanisms, but provides examples of 
each mechanism in the context of common oscilloscope usage. 

 

Objectives 

- Learn how to verify instrument status by understanding on-screen readouts and icons. 

- Learn basic oscilloscope setup using only the direct front panel controls. 

- Learn more complex control techniques using the touch screen and button toolbar. 

- Learn full instrument control techniques using the Windows menu bar and a mouse. 

- Learn how to adjust the display using mouse actions and right-click menus. 

- Learn how to set up some of the more common user preferences. 



 

MSO5000 / DPO5000 Lab Exercise Book 

Version 1.1   5/11/2012 48W-26279-3   9 of 394 

 

MSO/DPO5000 Series Display Interface 

The MSO/DPO5000 series display interface design includes the learnings of 60+ years of designing 
oscilloscopes. Although the primary focus of the display is on the acquired waveforms, there are many other 
important pieces of information presented. 

For those users who are familiar with the Tektronix DPO7000 and MSO/DSA/DPO70000 Series, the 
MSO/DPO5000 display interface will seem almost identical: 

1. Menu Bar: Access to instrument control functions, file system, and online help 

2. Buttons/Menu: Click to toggle between toolbar and menu bar modes and to customize the toolbar 

3. Multipurpose Control Readouts: Adjust and display selected parameters with the multipurpose 
controls 

4. Display: Live, reference, math, digital, and bus waveforms are displayed here, along with cursors 

5. Waveform Handle: Click and drag to change vertical position of a waveform or bus. Click the 
handle and change the position and scale using the multipurpose controls 

6. Controls Status: Quick reference to vertical selections, scale, offset, and parameters 

7. Readouts: Display cursor and measurement readouts in this area. Measurements are selectable 
from the menu bar or toolbar. If a control window is displayed, some combinations of readouts move 
to the graticule area 

8. Status: Display of acquisition status, mode, and number of acquisitions; trigger status; date; time; 
and quick reference to record length and horizontal parameters 

 

As you work through this lab, refer back to this page and identify the display icon and readout changes that 
occur as you change the instrument controls. 
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MSO/DPO5000 Series Display Readouts 

Key Take Away Points 

 As with other Tektronix oscilloscopes, the MSO/DPO5000 
status readouts are shown at the bottom of the display: 

 

 The vertical readouts are shown in the lower left corner of 
the display. Vertical scale factors, offset, termination, 
coupling, and bandwidth information are provided for each 
analog channel. Horizontal and vertical information is given 
for all math, zoom, and references. 

 

 The trigger status is shown at the bottom of the display, 
near the center. As with other Tek oscilloscopes, the trigger 
source, trigger type, trigger level (if applicable), and 
horizontal trigger delay (if applicable) are shown. 

 

 The horizontal and acquisition status, including horizontal 
scale, sample rate, record length, acquisition status (Run, 
Stop, Single, FastAcq), acquisition mode (Sample, Pk 
Detect, Hi Res, Envelope, Average, WfmDB), and 
acquisition counter are shown in the readouts in the lower 
right corner of the display. The time and date are also 
shown in this box. 

 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. 

 Connect the probe ground to the 
GND and connect the probe tip to 
the PROBE COMP test point in 
the lower right corner of the 
instrument. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Press the front panel Autoset 
button to automatically adjust 
vertical, horizontal, and trigger 
settings to get a stable display of 
the selected channels. 

 As you do the following steps, 
notice the changes to the 
readouts at the bottom of the 
display. 

 Press the white front panel R 
button to turn on the Reference 
menu. 

 If there is no Reference waveform 
available, press the Save button, 
press the Ref1 icon, and press 
the Save button. 

 Press the Display On button.  

 Change the Horizontal Scale 
control. Notice that the Reference 
Horizontal scale does not change 
and is now different from the 
acquisition’s Horizontal Scale. 

 Press the red front panel M button 
to turn on the Math menu. 

 Press the Ch1-Ch2 button. 

 Press the Menu Off button. 

 Draw a box around the edge at 
the center of the display and 
select Zoom 1 On. 
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Key Take Away Points 

 By default, the Automatic horizontal mode is selected. For 
this signal, Autoset has selected a horizontal scale of 500 
µs/div, a sample rate of 200 kS/s, and a record length of 
1000 points, as indicated in the readout in the lower right 
corner of the display. The Automatic horizontal mode is 
indicated by the “Auto” text next to the date: 

 

 For most trouble-shooting applications, the Auto horizontal 
mode is the easiest to use. Up to the maximum real-time 
sample rate, the front panel Horizontal Scale control 
adjusts the sample rate. 

 At fast horizontal settings, the oscilloscope must make a 
tradeoff. Since the horizontal scale is the product of the 
sample rate and the record length, you can either increase 
the sample rate or decrease the record length. 

 By default, the oscilloscope will use interpolation to 
increase the effective sample rate beyond the maximum 
real-time value. When the maximum sample rate is 
reached, the acquisition system begins to interpolate the 
sampled data, as indicated by the “IT” readout: 

 

 Notice that in IT mode, the real-time sample rate (which 
has a maximum value of 10 GS/s in 1- or 2-channel mode 
on the 1 and 2 GHz models) remains at the maximum 
value, but the time/point readout in the upper right corner 
changes with the amount of interpolation. 

MSO/DPO5000 Series Procedure: 

 Press the Default Setup button. 

 Press the Autoset button. 

 Select Horiz/Acq -> 
Horizontal/Acquisition Setup…. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Turn the Horizontal Scale control 
clockwise until you reach 5 
ns/div. 

 Notice that the sample rate 
increases, while the record length 
remains at about 1000 points. 

 Press the Acquisition tab at the 
left side of the control window. 

 Notice that the IT (Interpolate) 
Sampling Mode has been 
selected by default. 
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Key Take Away Points 

 However, extreme interpolation can add DSP artifacts to 
the display. To prevent such artifacts, one alternative is to 
disable the interpolation and simply stop increasing the 
horizontal scale when the maximum real-time sample rate 
is reached: 

 

 Another alternative (which only works for repetitive signals!) 
is to use equivalent time (ET) sampling. ET allows very 
high effective sample rates (up to 400 GS/s) to sample a 
few points of each triggered waveform and build up a 
composite display over time. 

 

 Constant Sample Rate horizontal mode is very convenient 
when capturing signals with a known single-shot 
bandwidth, for acquiring data for off-line digital signal 
processing, or when using software filtering on the scope. 

 

MSO/DPO5000 Series Procedure: 

 Press the RT Real Time Sampling 
Modes button. 

 Turn the Horizontal Scale control 
clockwise. 

 Notice that once the maximum 
real-time sample rate has been 
achieved, the horizontal scale 
does not change. 

 

 

 

 

 Press the ET Equivalent time 
button. 

 Turn the Horizontal Scale control 
fully clockwise and notice the 
readout. 

 

 

 

 

 

 

 Press the Autoset button. 

 Select the Constant Sample 
Rate mode. 

 You can adjust the Sample Rate 
with the Multipurpose a control. 

 You can adjust the Horizontal 
Scale with front panel Horizontal 
Scale or the Multipurpose b 
controls. 

 Turn the Horizontal Scale control 
clockwise and counter-clockwise. 

 Watch the sample rate readout 
and notice that the sample rate 
has been limited to the specified 
value. 
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Key Take Away Points 

 In some other applications, where predictable/controlled file 
size is required, you should use Manual mode: 

 

 When you turn on digital channels, a fourth line is added to 
the horizontal readout, indicating the time resolution 
(reciprocal of the digital channel sample rate): 

 

 Up to the point where the requested sample rate exceeds 
the maximum digital sample rate, the analog and digital 
sample time resolutions will match. Beyond that point, the 
digital time resolution will remain at 2 ns/pt: 

 

 As you increase the record length, you will hit the digital 
channel maximum record length, at which point the 
displayed waveforms will no longer be 10 divisions wide. 

 

MSO/DPO5000 Series Procedure: 

 Press the Autoset button. 

 Select the Manual mode. 

 You can adjust the Sample Rate 
with the Multipurpose a control. 

 You can adjust the Record 
Length with the Multipurpose b 
control. 

 You can adjust the Horizontal 
Scale with front panel Horizontal 
Scale control. This also allows 
you to indirectly change the 
Sample Rate. 

 Press the front panel D15-D0 
button. 

 Press the Turn D7 – D0 On 
button. 

 Press the left arrow at the right 
side of the control window to 
return to the 
Horizontal/Acquisition control 
window. 

 Using the Multipurpose a control, 
select 500 MS/s sample rate. 
Notice that the analog and digital 
sample rate readouts both 
indicate 2 ns/pt (500 MS/s). 

 Continue turning the Multipurpose 
a control and notice that only the 
analog sample rate increases, 
because the maximum digital 
sample rate has been reached. 

 Using the Multipurpose a control, 
select 500 MS/s sample rate 
again. 

 Using the Multipurpose b control, 
select 10.0 M record length. 

 Notice that the analog and digital 
sample rate readouts both 
indicate 2 ns/pt (500 MS/s). 

 Continue turning the Multipurpose 
b control and notice that 
eventually the displayed 
waveforms are no longer 10 
divisions wide when the digital 
channel maximum record length 
is reached. 
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Key Take Away Points 

 On the front panel of the DPO7000 
and MSO/DSA/DPO70000 Series 
products, there are three LEDs in the 
Trigger section which indicate the 
trigger status and two which indicate 
the trigger Mode: 

 

 

 The MSO/DPO4000/3000/2000 Series products show the 
trigger status in the upper right corner of the display: 

 

 Because these indicators do not exist on the 
MSO/DPO5000 front panel, the trigger status readout has 
been expanded to include this trigger status information. 

 The cross-reference of trigger readouts looks like this: 

 
MSO/DPO 

4000 
MSO/DPO 

5000 
DPO7000 

Acquisition 
pre-fill 

PrTrig Armed Arm 

Waiting for A 
trigger 

Trig? Ready Normal Ready Norm 

Waiting for B 
trigger 

Trig? Ready Normal Ready Trig’d 

Triggered Trig’d 

Triggered 
Normal, 

Triggered 
Auto 

Trig’d Norm, 
Trig’d Auto 

Auto 
triggering 

Auto Ready Auto Ready Auto 

Stopped - None - 
 

MSO/DPO5000 Series Procedure: 

 After an Autoset, the trigger is in 
Auto mode. Notice that the trigger 
readout in the bottom center of 
the display indicates “Triggered 
Auto”: 

 

 As you do the following steps, 
notice the changes to the trigger 
readout at the bottom of the 
display. 

 Press the front panel Trigger 
Menu button, the Mode tab at the 
left side of the control window, 
and the Normal Trigger Mode 
button. 

 

 Using the front panel Trigger 
Level control, set the trigger level 
to about 5V. This will cause the 
acquisitions to stop. 

 

 Press the A->B Seq tab at the left 
side of the control window and 
press the Time Trig After Time 
button. 

 

 Press the nth event Trig on nth 
Event button. Press the 
Horizontal Delay Mode button. 
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MSO/DPO5000 Series Direct Controls 

The MSO/DPO5000 series front panel design incorporates feedback from significant user testing. The most 
commonly-used controls are readily available for direct control of the oscilloscope without creating a 
cluttered look. 

As with most oscilloscopes, the majority of the front panel controls are grouped and graphically outlined by 
category: Vertical, Horizontal, Trigger, and Wave Inspector. 

For those users who are familiar with the Tektronix MSO/DPO4000/3000/2000 Series, the MSO/DPO5000 
Series front panels will seem almost identical: 

 Wave Inspector manual and automatic search controls 

 Dedicated vertical scale and position controls for each analog channel 

 Dedicated horizontal scale and position controls 

 Autoset – automatically set up the vertical, horizontal, and trigger controls based on selected 
channels 

 Trigger Set to 50%, Force Trigger, and Trigger Level controls – provide additional tools to quickly 
get a stable display 

 Run/Stop and Single acquisition buttons 

 FastAcq – toggle in and out of FastAcq mode at the touch of a button 

 Default setup – quickly restore the oscilloscope to a known condition 

 One-button Save and Print – very fast and convenient 

 Menu Off – close all open control windows 
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Key Take Away Points 

 Because you may not know who was last using the 
oscilloscope or how it is set up, it is often wise to start from 
a known factory default setup. After restoring the 
instrument to its default setup and then automatically 
setting up the instrument, the display should look about like 
this: 

 

 By default, a single press of the Autoset button will start the 
Autoset process and a popup menu allows you to easily 
undo the process if you change your mind. There are User 
Preferences to require you confirm the Autoset selection 
and to suppress the undo popup menu. 

 With a few adjustments of the front panel controls, you can 
easily adjust the waveform display to meet your needs: 

 

 One unfamiliar item should be the vertical probe bandwidth 
readout, showing 1 GHz with the standard passive probe! 

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Press the front panel Autoset 
button to automatically adjust 
vertical, horizontal, and trigger 
settings to get a stable display of 
the selected channels. 

 You can also press the front 
panel Trigger Level control (Set 
to 50%) to automatically set just 
the trigger level. 

 

 

 

 

 

 

 

 Using the channel 1 Vertical 
Scale control, set the vertical 
scale to 500mV/div, as indicated 
in the readout in the lower left 
corner of the display. 

 Using the channel 1 Vertical 
Position control, center the 
waveform vertically on the 
display. 

 With the Horizontal Scale control, 
set the horizontal scale to 
1ms/div, as indicated in the 
readout in the lower right corner 
of the display. 

 With the Trigger Level control, set 
the trigger level to about 1 V, as 
indicated in the readout in the 
bottom center of the display. Also 
notice that the trigger level is 
indicated by the arrow at the right 
side of the display. 

 The point where the signal 
crosses through the trigger level 
is centered on the display. 
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Key Take Away Points 

 When Wave Inspector zoom is turned on, an overview of 
the entire waveform is show at the top of the display, and 
the graphically zoomed area (indicated by the yellow box in 
the overview area) is shown in the lower part of the display, 
about like this: 

 

 Wave Inspector zoom can provide a detailed display of a 
small portion of the waveform, such as the falling edge, like 
this: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Single 
button to capture a single 
waveform. 

 Turn the inner portion of the 
Wave Inspector Pan / Zoom 
control clockwise to turn on zoom 
and adjust the zoom factor to 
clearly view a complete cycle of 
the waveform. 

 

 

 

 

 

 

 

 

 

 

 Now, turn the inner portion of the 
Pan / Zoom control clockwise to 
select a higher zoom factor to 
view just the rising edge of the 
waveform. 

 Turn the spring-loaded outer 
portion of the Pan / Zoom control 
to position the falling edge of the 
signal in the center of the display. 

 

 

 To automatically scroll through 
the acquired waveform, press the 
Wave Inspector run/pause button. 
You can adjust the direction and 
speed of the scrolling by turning 
the outer Pan/Zoom control in the 
desired direction. 

 

 When you are done, press the 
magnifying glass button to turn off 
Wave Inspector zoom. 

 Press the Run/Stop button to 
restart acquisitions. 
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MSO/DPO5000 Series Touch Screen, Toolbar, and Multipurpose Controls 

The MSO/DPO5000 series contains many features that are not directly available through the front panel 
controls. The oscilloscope provides a variety of other control mechanisms. This section of the lab focuses on 
the touch screen, the front panel menu buttons, the button toolbar, and the multipurpose controls. 

Crowded lab benches, carts and floor-standing scope locations can make it difficult to use a mouse. The 
MSO/DPO5000 embraces touch screen operation as an efficient way to access all instrument features when 
a mouse is not available or not preferred. 

As with the MSO/DPO4000/3000/2000 Series products, there are many MSO/DPO5000 front panel menu 
buttons which provide access to the first level of control menus. For example: 

 The Vertical Menu button provides access to the Vertical Setup menu 

 The Acquire button provides access to the Horizontal / Acquisition Setup menu 

 The Trigger Menu button provides access to the Trigger Setup menu 

 The Measure button provides access to the Measurement Setup menu 

 The Search button provides access to the Wave Inspector automatic Search Setup menu 

 The red Math button provides access to the Math Setup menu 

 The white Ref button provides access to the Reference menu 

 The purple Bus button provides access to the Bus Setup menu 

 The blue D15-D0 button provides access to the Digital channel Setup menu 

The on-screen Toolbar provides similar access to the first-level menus. Because these easy-to-touch 
buttons are right on the display with the setup menus, this alternative makes the touch screen even more 
effective. 

 

The Windows Menu bar is displayed at the top of the display by default. You can easily select the Toolbar by 
pressing the down-arrow button at the right side of the Menu bar. 

 

Though many of the controls are simple selections with buttons, there are some parameters such as specific 
threshold levels or timing offsets that are more convenient if they are easily adjustable by the user. These 
parameters can be controlled in several ways, including the front panel Multipurpose controls and popup 
keypads. 

The large, comfortable Multipurpose controls merge the direct access of dedicated front-panel controls with 
the flexibility of on-screen menus. It’s easy to assign one of the controls to a parameter, set your hand on 
top of the instrument, and use your thumb to scroll through values while watching the display and the control 
readout. With the coarse and fine settings, the multipurpose controls provide a convenient way to make real-
time adjustments. 

On-demand keypads provide context-sensitive keyboards to allow the touch screen to provide numeric 
without the need for a physical keyboard. The touchscreen supports the use of your finger or a stylus. You 
can invoke the appropriate keypad by double-clicking on a numeric readout in a menu or the multipurpose 
control readout. 
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Key Take Away Points 

 

 

 

 

 The display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the Autoset button. 

 Press the front panel Vertical 
Menu button to display the 
vertical setup menu. 

 Press the AC Coupling button to 
remove the DC offset from the 
signal. 

 Press the Set to 50% button. 

 Notice that the Multipurpose 
controls to the Ch 1 Vertical 
Position and Scale controls. 

 Using the Multipurpose b control, 
set the vertical Scale to 500 
mV/div. 

 Touch the Position text box once. 
Notice the keypad icon next to the 
Position text box indicating that 
there is an on-screen keyboard 
available. Click on the text box to 
display the context-sensitive 
keypad. 

 Press the 0 button and the green 
Enter button to set the position to 
exactly 0. 

 Press the front panel Menu Off 
button or click the X in the upper 
right corner of the control window 
to close it and restore the full-
screen waveform display. 

 Select Horiz/Acq -> 
Horizontal/Acquisition Setup… 
to display the horizontal setup 
menu. 

 Using the Scale arrow keys, 
select a 200 µs/div horizontal 
Scale setting. 

 Press Menu Off or click the X in 
the upper right corner of the 
control window to close it and 
restore the full-screen waveform 
display. 

 Touch and hold somewhere 
within the Multipurpose control 
readouts. After a short dwell time, 
a “right-click” menu pops up. 
Select Deassign Multipurpose 
Knobs to remove the readout 
from the display. 
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Key Take Away Points 

 Notice how the familiar front panel button interface parallels 
the Windows menu interface for launching basic setup 
control windows. 

 The display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Trigger 
Menu button to display the trigger 
setup menu. 

 Press the front panel Menu Off 
button or click the X in the upper 
right corner of the control window 
to close it and restore the full-
screen waveform display. 

 Select Trig -> A Event (Main) 
Trigger Setup… to display the 
trigger setup menu. 

 Using the Trigger Type drop 
down menu, select Width in the 
list to select Pulse Width 
triggering. 

 You can also get directly to this 
Width trigger setup control 
window by selecting Trig -> 
Width Setup… which displays 
the trigger setup menu and pre-
selects Width Trigger Type. 

 Double-click on the Upper Limit 
text box. 

 Press 600, µ, and Enter to set the 
pulse width upper limit to 600 µs. 

 Double-click on the Lower Limit 
text box. 

 Press 400, µ, and Enter to set the 
pulse width upper limit to 400 µs. 

 Notice that the Multipurpose 
controls remain attached to the 
Upper Limit and Lower Limit 
controls. 

 Verify that Inside is selected in 
the Pulse Width text box. 

 Press the front panel Menu Off 
button or click the X in the upper 
right corner of the control window 
to close it and restore the full-
screen waveform display. 

Key Take Away Points 

 The down-arrow button at the top of the display allows you 
to toggle between the Windows Menu bar and the Toolbar 
interface. With the Toolbar selected, the interface should 
look like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the down-arrow button at 
the top of the display and press 
Show Buttons to select the 
Toolbar interface. 
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Key Take Away Points 

 With the Toolbar selected, the Trigger setup control window 
interface still looks the same: 

 

 The buttons on the toolbar are the most commonly-used 
controls. However, you can customize the toolbar to 
simplify access to other controls. For example: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Menu Off 
button or click the X in the upper 
right corner of the control window 
to close it and restore the full-
screen waveform display. 

 Press the down-arrow button at 
the top of the display and press 
Show Buttons to select the 
Toolbar interface. 

 Press the Trigger button on the 
Toolbar. Notice that the same 
control window is displayed as 
when you pressed the front panel 
Trigger Menu button. 

 Press the front panel Menu Off 
button or click the X in the upper 
right corner of the control window 
to close it and restore the full-
screen waveform display. 

 

 Press the down-arrow button at 
the top of the display and notice 
the list of additional function 
buttons. 

 You can press these buttons 
directly for a single usage. For 
example, press Clear to clear the 
currently-displayed waveform 
from the screen. 

 If you want to make one of these 
additional buttons available on 
the Toolbar, or you want to 
customize the Toolbar, press the 
down-arrow button at the top of 
the display and select 
Customize…. 

 For example, to add the Clear 
button to the Toolbar, select 
Clear in the lower window and 
press the Move Up button 
repeatedly until it is in the desired 
position in the list of Always 
Visible button. 

 Press the OK button. Notice that 
the Clear button has been added 
to the Toolbar in the position you 
specified and Help has been 
hidden. 
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Key Take Away Points 

 When you press a front panel menu button or a button on 
the Toolbar, the waveform graticule is reduced in size to fit 
in the top half of the display and a first-level menu or 
control window appears in the lower half of the display: 

 

 In some cases, there are tabs on the left side of the control 
window to select between categories of controls. In the 
case of the Vertical Setup menu, these tabs select which 
analog channel is being controlled. 

 When a smaller control window is adequate, the graticule is 
enlarged and the mini control window appears at the 
bottom of the display: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Vertical 
Menu button or the Vertical 
button on the Toolbar. 

 

 

 

 

 Press the Chan 2 tab on the left 
side of the control window. 

 Notice there are blue buttons, 
such as Display Off, which cause 
immediate action. Press the 
Display Off button twice to turn 
channel 2 on and off. 

 There are also cyan buttons 
which launch another control 
window. 

 

 

 

 

 Press the cyan Channel Atten 
button near the right side of the 
display and notice that the 
Vertical control menu is replaced 
with the Deskew/Attenuation 
menu. 

 

 Notice the white arrows 
(“navigation buttons”) at the right 
side of the control window. These 
arrows provide browser-style 
navigation back and forth 
between recently used control 
windows with one click. 

 Press the left arrow to return to 
the Vertical control menu. 

 Press the front panel Menu Off 
button or click the X in the upper 
right corner of the control window 
to close it and restore the full-
screen waveform display. 
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MSO/DPO5000 Series Windows Menu User Interface 

For many MSO/DPO5000 Series users, the Windows menu interface will be the most comfortable, 
especially if their lab environment supports the use of a mouse. These menus can be operated with the 
touch screen or a keyboard, but are optimized for use with a mouse. This section of the lab focuses on the 
use of the Windows menu, mouse, and keyboard to control the instrument. 

As with most Windows applications, the menu bar at the top of the screen provides convenient access to the 
first-level menus, but also many second-level menu items. The Windows Menu bar is displayed at the top of 
the display by default. You can easily toggle between the Windows Menu bar and the Toolbar by pressing 
the down-arrow button at the right side of the Menu bar. 

 

These controls are logically grouped by function, with familiar File and Edit menus on the left, instrument 
control menus in the middle, and Utilities and Help on the right. 

 File contains waveform and setup save and recall controls, printer setup, and Windows controls like 
Minimize, Shutdown, and Exit. 

 Edit contains Autoset Undo, Clear, Select for Copy, and Copy commands. 

 Vertical provides access to first-level menus such as Vertical Setup as well as second-level menus 
such as Bandwidth and Zoom control menus. 

 Digital (MSO5000 Series only) provides access to Digital Channel and Bus Setup menus, as well 
as MagniVu acquisition mode. 

 Horiz/Acq provides access to first-level menus such as Horizontal / Acquisition Setup as well as 
second-level menus such as Autoset and the FastFrame control menu. 

 Trig provides access to the first-level Trigger Setup menu as well as second-level menus for each of 
the trigger modes. 

 Display provides access to menus to control the waveform display parameters, the graticule, and 
the on-screen icons. 

 Cursors provides access to the first-level Cursor Setup menu as well as second-level controls for 
Cursor Mode and Cursor Type. 

 Measure provides access to the first-level Measurement Setup menu as well as the direct selection 
of automatic measurements and the Histogram Setup menu. 

 Mask provides control of the pass/fail mask testing features via the first-level Mask Setup menu and 
second-level Pass/Fail and Mask Editing menus. 

 Math provides access to the first-level Math Setup menu as well as the direct selection of the 
Predefined Functions and the Equation Editor menu. 

 MyScope allows customization of the user interface. There is a later lab section devoted to this. 

 Analyze provides menu access to the optional analysis applications which you are running on the 
oscilloscope. 

 Utilities contains controls for configuring the instrument, user preferences, and option installation. 

 Help provides access to standard Windows-style help files and the About TekScope status window. 
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Key Take Away Points 

 The Trigger Setup menu looks like this: 

 

 The Trigger control window and trigger type select window 
look like this: 

 

 Sometimes the touchscreen provides the most convenient 
way to drive the oscilloscope. However, especially on a 
bench, a mouse might provide easier and more familiar 
control of a Windows-based oscilloscope. 

MSO/DPO5000 Series Procedure: 

 Using the touch screen, touch the 
down-arrow button at the top of 
the display and touch Show 
Menu to select the Windows 
menu interface. 

 You can use the touch screen to 
operate the oscilloscope from the 
Windows menu bar. It may be 
easiest to use a stylus or your 
fingernail to accurately select 
menu items. 

 Touch the Trig menu to display 
the menu choices. 

 Touch the A Event (Main) 
Trigger Setup… selection. 

 Notice that there is a drop-down 
menu under Trigger Type. Touch 
the down arrow to display the list 
of choices. 

 In the Trigger Type section, press 
the Select button and select 
Edge. When operating this control 
window with a touch screen, the 
Select button provides an easier-
to-use interface. 

 

 

 

 

 

 

 

 

 

 When you are done, touch the X 
in the upper right corner of each 
of the control windows to close 
them and restore the full-screen 
waveform display. 
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Key Take Away Points 

 The File menu looks like this: 

 

 Notice that the File menu contains familiar Windows File 
menu controls, as well as some that are specific to 
handling files on a Windows oscilloscope. 

 The Vertical menu looks like this, with all of the menu items 
specifically relating to the operation of the vertical section 
of an oscilloscope: 

 

 Notice that the menu items are organized in groups, with 
the most commonly-used controls near the top of the list 
and the less-frequently-used controls near the bottom of 
the list. 

MSO/DPO5000 Series Procedure: 

 Connect a USB mouse to one of 
the oscilloscope’s USB host ports. 

 Using the mouse, position the 
cursor over the File menu 
selection. 

 Click the left mouse button once 
and then slowly move the mouse 
over the other menu selections to 
get a quick overview of the 
available features and their 
locations in the user interface. 

 

 

 

 

 

 

 

 

 

 Left-click once on the Vertical 
menu to display the menu 
choices. 

 Notice that the Vertical Setup… 
menu selection is at the top of the 
list. This selection displays the full 
Vertical Setup control window. 

 Notice that most of the remaining 
menu items also end with an 
ellipsis (…) indicating that these 
selections will launch a control 
window. 
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Key Take Away Points 

 The Trigger menu looks like this: 

 

 The Trigger Quick Select menu interface allows quick 
selection of trigger type without launching a control window: 

 

MSO/DPO5000 Series Procedure: 

 Left-click once on the Trig menu 
to display the menu choices. 

 Notice that the A Event (Main) 
Trigger Setup… menu selection 
is at the top of the list. This 
selection displays the full Trigger 
Setup control window, just like 
pressing the front panel Trigger 
Menu button. 

 Click on the B Event (Delayed) 
Trigger Setup… menu selection. 
Notice that this launches the 
Trigger Setup control window, too, 
but also automatically selects the 
B Event tab. 

 Click once on the Trig menu to 
display the menu choices again. 

 Notice the Quick Select A 
Trigger selection has a right 
arrow next to it, indicating that it 
provides immediate action. Click 
on Quick Select A Trigger and 
select Edge trigger. Notice the 
trigger type changes immediately 
to Edge, without launching a 
control window. 

 Click on Quick Select A Trigger 
and select Width trigger. Notice 
the trigger type changes 
immediately to Width, retaining 
the Pulse Width trigger setup from 
earlier in the lab. 

 If you want a simple entrance into 
the Trigger Setup menu to control 
the Width trigger, click once on 
the Trig menu and click on Width 
Setup…. This launches the 
Trigger Setup menu with the 
Width trigger type preselected. 
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Key Take Away Points 

 The Windows menu bar keyboard shortcut interface looks 
like this: 

 

 The File menu bar keyboard shortcut interface looks like 
this: 

 

MSO/DPO5000 Series Procedure: 

 Connect a USB keyboard to one 
of the oscilloscope’s USB Host 
ports. Keyboard shortcuts can be 
a very efficient user interface for 
some oscilloscope users. 

 Press down on the Alt key on the 
keyboard. Notice that certain 
letters in the Windows menu bar 
are underlined, such as the ‘F’ in 
File, indicating a keyboard 
shortcut that can be used with the 
Alt key. 

 Press the F keyboard key to 
display the File menu. 

 Notice that some of the menu 
items have letters that are 
underlined and some have 
additional text to the right, such as 
Print…   Ctrl+P. This indicates 
that you can use the keyboard to 
select the Print menu by either 
pressing Alt P or Ctrl P. 

 Also notice Save As…   F12, 
which indicates that the keyboard 
can launch the Save As menu by 
pressing Alt A or the F12 function 
key. Where possible, the standard 
Windows function keys and 
keyboard shortcuts are used. 

 And, as with other Windows 
applications, the ESC key closes 
the menu. 
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MSO/DPO5000 Series Mouse and Right-click User Interface 

If you have a USB mouse connected to the MSO/DPO5000 series oscilloscope, there are many other 
control features available. This lab section will highlight the use of a mouse in four specific areas: 

 Using a mouse to directly manipulate waveforms and icons on the display 

 Using a mouse to graphically select portions of the waveforms for further analysis 

 Using a mouse to easily adjust parameter values 

 Using a mouse to directly access features without going through menus 

You never have to take your hand off the mouse! 

Key Take Away Points 

 There are many items on the display which can be 
manipulated with a mouse. 

 

 Notice that each of these mouse actions also attaches the 
Multipurpose controls to the appropriate parameters. 

 The mouse can also be used to invoke a context-sensitive 
shortcut menu by right-clicking anywhere in the graticule or 
on an object. 

MSO/DPO5000 Series Procedure: 

 You can use a mouse to directly 
manipulate waveforms and icons 
on the display: 

 Position the cursor on the 
yellow channel 1 ground 
reference icon at the left side 
of the display. Press down on 
the left-mouse button and 
move the mouse to adjust the 
vertical position of the 
selected waveform. 

 Position the cursor over the 
trigger level arrow at the right 
side of the screen. Press 
down on the left-mouse button 
and move the mouse to adjust 
the trigger level. 

 While the multipurpose control 
readout is visible, left-click on 
the text box. If your USB 
mouse has a wheel, you can 
use it to adjust the level, just 
like with the multipurpose 
controls. You can also click 
the mouse wheel to switch 
between fine and coarse 
increments, just like you can 
with the front panel Fine 
button. 

 Position the cursor over the 
orange trigger position 
indicator at the top of the 
screen. Press down on the 
left-mouse button and move 
the mouse to adjust the 
trigger horizontal position. 

 

Main view

Zoom view

MPK fields

Trace handle

Measurements

Cursors

Trace Readouts Trigger Readout

Horizontal 

Readout fields

Cursor 

Readout
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Key Take Away Points 

 Right-click shortcut menus can also be displayed for the 
readouts on the display. Some examples are shown below: 

 

MSO/DPO5000 Series Procedure: 

 You can also use right mouse 
clicks on these same icons to 
display relevant popup menus: 

 Position the cursor on the 
yellow channel 1 ground 
reference icon. Right click to 
display the menu of waveform 
parameter adjustments. 

 Position the cursor over the 
trigger level arrow. Right click 
to display the menu of trigger 
and graticule settings. 

 Position the cursor 
elsewhere. Right click to 
show a menu of display 
controls. 

 Click on Autoset. 

 You can also use right mouse 
clicks on the display readouts to 
display a relevant set of controls: 

 Right-click on the vertical 
readout in the lower left 
corner of the display and 
notice that many of the 
vertical menu items appear, 
along with other related 
functions such as adding a 
bus, adding a measurement, 
and saving the waveform. 

 Similarly, right-click on the 
trigger readout at the bottom 
of the screen and notice the 
trigger menu functions. 

 There are many different 
readouts in the lower right 
corner: 

 Right-clicking on the 
horizontal scale readout 
displays the horizontal 
controls. 

 Right-clicking on the 
Run/Stop status displays 
the run/stop menu items. 

 Right-clicking on the 
acquisition mode displays 
the choices for acquisition 
mode. 
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Key Take Away Points 

 The zoom box popup menu display should look about like 
this: 

 

 The zoom display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 You can also use a mouse to 
select portions of waveforms for 
analysis: 

 To view a portion of the 
signal, press the left mouse 
button and drag the mouse to 
draw a box on the display. 
When you let go of the mouse 
button, a menu of available 
actions is displayed. Use the 
mouse to select Zoom 1 On. 

 Similarly, you can set up 
vertical or horizontal 
waveform histogram displays. 

 

 

 

 

 Notice the thick bar at the 
bottom of the zoom area. 
Press the left mouse button 
and drag the bar to move the 
zoom window. 
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Key Take Away Points 

 The dual zoom display should look about like this: 

 

 The cursor display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 To view another portion of the 
signal, either in the main 
window or the zoom window, 
press the left mouse button 
and drag the mouse to draw a 
box on the display. When you 
let go of the mouse button, a 
menu of available actions is 
displayed. Use the mouse to 
select Zoom 2 On. 

 Right click on the Zoom 2 
waveform and select Zoom 2 
Off. 

 Right-click in the main 
graticule, select Cursors, and 
select Waveform. 

 Position the Windows cursor 
over the waveform cursor 
bars, press down on the left-
mouse button, and move the 
waveform cursors as desired. 

 Right-click on the cursor 
readouts or a cursor to get a 
shortcut menu of cursor 
controls. 

 Position the Windows cursor 
over a point of interest on the 
waveform, right-click, and 
select Move Cursor 1 Here. 

 

 

 

 When you are done with zoom, 
right-click somewhere in the 
graticule and select Zoom Off 
and Cursors Off. 
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Key Take Away Points 

 The fall time measurement display should look about like 
this: 

 

 With cursor gating, the fall time measurement looks like 
this: 

 

MSO/DPO5000 Series Procedure: 

 Right-click on the channel 1 
ground reference icon. 

 Slide the mouse across Add 
Measurement and Time, and 
right-click on Fall Time. 

 Notice that the fall time 
measurement is made on the first 
falling edge on the waveform. 

 Left-click and drag to draw a box 
near another falling edge. 

 Select Measurement Gating and 
Cursor. 

 Notice that the fall time 
measurement is now made on the 
selected edge on the waveform. 

 Left-click and drag the cursors to 
select a different waveform edge 
to measure. 

 Right-click on one of the cursors 
and select Cursors Off. 

 Right-click on the Fall label in the 
measurement readout. 

 Select Remove or Remove All to 
remove the measurement. 
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MSO/DPO5000 Series Multiview Zoom User Interface 

Key Take Away Points 

 When Multiview Zoom™ is turned on, an overview of the 
entire waveform is show at the top of the display, and the 
graphically zoomed area (indicated by the yellow box in the 
overview area) is shown in the lower part of the display, 
about like this: 

 

 Multiview Zoom allows you to zoom on the zoomed 
waveform to provide a more detailed display of a small 
portion of the waveform, such as the rising edge (shown in 
yellow). But Multiview Zoom allows you to simultaneously 
zoom on multiple regions, so you can also view a falling 
edge (shown in green), like this: 

 

MSO/DPO5000 Series Procedure: 

 With the mouse or the 
touchscreen, draw a rectangle, 
from the upper left to lower right 
corner, around a portion of the 
waveform and select Zoom 1 On. 

 Notice that the front panel 
Multiview Zoom button is now lit. 

 

 

 

 

 

 

 

 

 

 

 

 Draw a rectangle on the zoomed 
waveform, from the upper left to 
lower right corner, around a 
portion of the zoomed waveform. 

 Select Zoom 1 -> Resize. 

 Now, draw a rectangle on a 
different part of the overview 
waveform at the top of the 
display. 

 Select Zoom 2 On. 

 

 

 

 

 

 When you are done, right click 
somewhere in the graticule area 
and select Zoom 2 Off. 
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Key Take Away Points 

 If you want to move the zoom window, you can draw a new 
zoom window, or you can move the current zoom window 
with the Multipurpose controls or the mouse. 

 

 Notice that the MSO/DPO5000 Series provides both 
vertical and horizontal zoom. The 
MSO/DPO4000/3000/2000 Series provides only horizontal 
zoom. 

 You can also have Multiview Zoom automatically scroll 
through the acquired waveform using the scroll controls, 
like this: 

 

MSO/DPO5000 Series Procedure: 

 Select Vertical -> Zoom Setup. 

 Press the Controls button to 
minimize the size of the control 
window. 

 Press the Zoom tab at the left 
side of the control window. 

 You can use the Assign Knobs 
buttons to assign the 
Multipurpose controls to either 
horizontal or vertical zoom 
position and zoom factor. 

 Adjust the zoom view using the 
Multipurpose controls. 

 You can also drag the thick line at 
the bottom of the zoom box with 
the mouse to horizontally position 
the zoom window. 

 

 

 

 Press the Scroll tab at the left 
side of the control window. 

 You can use these controls to 
automatically pan through the 
acquired waveform. 

 Click on the Scroll Speed text 
box to attach the Multipurpose a 
control. 

 Using the Multipurpose a control, 
set the Scroll Speed to 10. 

 Press the right arrow (Play) 
button. 

 

 

 

 When you are done, press the 
magnifying glass button to turn off 
Multiview Zoom. 
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MSO/DPO5000 Series MyScope User Interface 

Like the end products they’re being used to validate, oscilloscopes are constantly expanding, not only in 
terms of performance capabilities (bandwidth, sample rate, record length, waveform capture rate, etc.), but 
also in the continual addition of new features and analysis packages. All of this capability, while certainly 
powerful and useful, can be intimidating to novice users as well as to intermittent users, who generally use 
only a fraction of an oscilloscope’s capabilities. Even experienced power users, who navigate through the 
same layers of menus to perform similar tasks hundreds of times each day, undoubtedly find the extra steps 
for each process irritating and a huge waste of time. 

When using an oscilloscope, have you ever been frustrated because ... 

 You can't find the feature that you really need, even though you know it’s there? 

 You know where the feature is, but it's buried three or four menu layers deep? 

 The feature you want is hidden amongst a menu full of other features you don’t care about? 

 You spend as much time navigating menus as you do doing real work? 

If you answered “yes” to one or more of these questions, then MyScope control windows will make you more 
efficient with the oscilloscope and more effective at your job. This feature allows you to quickly and easily 
build your own control windows that contain only the controls, features, and capabilities you care about and 
are important in your job. 
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Key Take Away Points 

 MyScope allows you to quickly and easily build a custom 
control window that contains only the features and 
functions of the oscilloscope which are important to you. 
Once you have created the control window, you will be 
more efficient using the oscilloscope because you do not 
have to search for features or bounce back and forth 
between numerous menus and control windows while 
performing your usual tasks. 

 The MyScope display should look about like this: 

 

 The control tree includes all of the controls available for use 
when building your MyScope control window. The first-level 
items listed in bold font are merely categories, not controls. 
When you click on the “+” symbol next to one of the 
categories, you see the list pop open to show the controls 
available in that category. The tree is organized in the 
same fashion as the menus in the regular UI to make it 
easy to find the feature you’re looking for. For example, all 
the controls that you normally find in the Vertical menu are 
included in the Vertical category. 

 When you select a control in the tree on the left, the control 
is previewed in window on the right. This allows you to see 
what the control looks like, how many grid locations it 
requires, and what components are included in it. 

 Many controls can be further customized by clicking the “+” 
symbol next to the control name and then checking and 
unchecking individual components. As you check and 
uncheck items, the previewed control changes size based 
on the number of components included. 

MSO/DPO5000 Series Procedure: 

 Click on MyScope in the 
Windows menu bar. 

 Select New Control Window…. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Click on the “+” symbol next to 
the Vertical category. 

 

 

 

 Click on the “+” symbol next to 
the Attenuation control. 

 Notice the size of the control in 
the preview window. 

 Uncheck the Set To Unity 
control. Notice that the Set To 
Unity button disappears and the 
size of the control is decreased. 

 Check the Set To Unity control. 
Notice that the Set To Unity 
button reappears and the size of 
the control is increased. 
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Key Take Away Points 

 The lower half of the setup screen represents your 
MyScope control window layout. It is the same size and 
shape as the standard control windows used throughout 
the instrument. 

 

 The layout area is divided up into a three-row by five-
column grid. Once you have selected a control and 
configured it the way you want it in the preview window, 
simply click and drag the previewed control to the desired 
location in the layout area: 

 

 When you fill up a tab, just click the “New Tab” button to 
add another tab to your MyScope control window to place 
additional controls. Up to eight tabs with user defined 
names can be used in a custom control window. 

MSO/DPO5000 Series Procedure: 

 Click on the Vertical control in the 
Vertical category in the control 
tree. Click on the Vertical control 
in the preview window and drag it 
down to the first column in the 
control window at the bottom of 
the display. 

 If you make a mistake, simply 
drag the control back out of the 
control window to remove it. 

 Click on the “+” symbol next to 
the Horizontal category. 

 Click on the Acquisition Mode 
control in the control tree, click on 
the Acquisition Mode control in 
the preview window, and drag it 
down to the second column in the 
control window at the bottom of 
the display. 

 Click on the “+” symbol next to 
the Trigger category. 

 Click on the “+” symbol next to 
the A - Trigger Type control. 
Check several of the trigger types 
to add them to the control. 

 Click on the Trigger control and 
drag it down to the control window 
at the bottom of the display. 

 

 

 

 

 

 Click the Rename Tab button. 

 Notice the tab’s text box is 
highlighted. Type in a name for 
the tab. 

 Click the New Tab button to 
create a new tab. 

 When you are done, press the 
Save As… button, type in a file 
name, and press the Save button. 
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Key Take Away Points 

 If you are using your oscilloscope in a shared environment, 
you can also specify your user preferences with your 
MyScope control window. When you load your MyScope 
control window, your user preferences are automatically 
restored. 

 One of the most powerful features of MyScope control 
windows is that you and your co-workers can create as 
many custom control windows as you like. MyScope 
windows are stored as files on the oscilloscope’s hard 
drive, making it simple to transfer your custom control 
windows to other oscilloscopes in your lab, or even to your 
co-workers around the world, by simply emailing the .TCW 
file. 

 Once you have created and saved a MyScope control 
window, you can easily launch it from either the Windows 
menu bar or from the Toolbar. From the menu bar, the 
MyScope interface looks like this: 

 

 

 

 

 

 

 

 

 The MyScope interface in the Toolbar looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the User Pref… button to 
display the user preference 
selections. 

 When you are done looking at 
this window, press the Cancel 
button. 

 Press the Close button to close 
the MyScope Setup window. 

 

 

 

 Click on MyScope in the 
Windows menu bar. 

 Select Current… to display the 
most recent MyScope control 
window, or you can select Open 
Control Window… to select a file 
through the Windows File Open 
dialog. 

 Click the X in the upper right 
corner of the MyScope control 
window to close it. 

 

 

 

 Press the down-arrow button at 
the top of the display and press 
Show Buttons to select the 
Toolbar interface. 

 Press the MyScope toolbar 
button to display the most recent 
MyScope control window. 
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MSO/DPO5000 Series User Preferences 

Key Take Away Points 

 The use of Windows in the MSO/DPO5000 Series user 
interface allows much more flexibility than can be 
supported by other oscilloscopes such as the 
MSO/DPO4000/3000/2000 Series. Although the 
MSO/DPO5000 gains user interface familiarity because of 
the Windows menu system, there are some familiar user 
interface elements which may not be visible, either by 
default or by the preferences of the previous user of the 
oscilloscope. 

 This section of the lab highlights a few of the common 
elements of the MSO/DPO4000/3000/2000 Series user 
interface which may be missing from the display and 
explains how to restore them. 

 As with many Windows controls, there are multiple ways to 
change these settings. For this lab, we will focus on the 
control windows as the control mechanisms. 

 The Display Setup control window looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Select Display -> Display 
Setup…. 

 Press the Appearance tab at the 
left side of the control window. 

 Press the Variable Persistence 
button and set the Persistence 
Time to about 50 ms to mimic the 
MSO/DPO series default display 
persistence. 

 Make sure Vectors Style and 
Sin(x)/x Interpolation are 
selected. 

 Press the Objects tab at the left 
side of the control window. 

 Press the Short Trigger Level 
Marker and Trigger ‘T’ buttons to 
mimic the MSO/DPO series 
display icons. Note that the 
Trigger T is locked to the trigger 
source waveform instead of 
appearing as an orange icon at 
the top of the display. 

 Press the Colors tab at the left 
side of the control window. 

 Press the Normal Record View 
Palette and Normal 
FastAcq/WfmDB  Palette buttons 
to mimic the colored, intensity-
graded MSO/DPO series 
displays. 

 Select Horiz/Acq -> Zoom 
Graticule Size -> 80/20% to 
mimic the MSO/DPO zoom 
display. 

 Press the front panel Trigger 
Menu button. 

 Notice the Settings text box in 
the lower left corner of the control 
window. When this control is set 
to Shared, the thresholds for the 
analog channels are tied 
together. If you want to want to 
have independent thresholds for 
the analog channels used for bus 
inputs, select Independent. 
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Key Take Away Points 

 The User Preferences control window looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Select Utilities -> User Pref… to 
display the user preference 
control window. 

 Press the Prompts tab at the left 
side of the control window. 

 Make sure that the Autoset and 
Default/Recall Setup buttons are 
set to Off to match the MSO/DPO 
series behavior. 

 Make sure that the 
Overwrite/Delete Setup button is 
set to On to match the MSO/DPO 
series behavior. You may or may 
not want to set Autoset Undo to 
On, as it will always pop up a 
notifier. 

 Press the Readouts tab at the left 
side of the control window. 

 Press the Always Visible MPK 
Readout Visibility button. 

 Set Highlight Readout Changes 
to Off. 

 Press the Measurement tab at 
the left side of the control window. 

 Press the Standard Annotation 
Type button. 

 Press the Units tab at the left 
side of the control window. 

 Press the 1-2-5 Vertical Scale 
Knobs button. 

 Press the Front Panel Buttons 
tab at the left side of the control 
window. 

 Check the Front Panel Print 
Button Saves to File selection to 
mimic the operation of the 
MSO/DPO Save button. 

 Select Factory in the Default 
Setup Button drop-down box. 

 Click the X in the upper right 
corner of the control window to 
close it. 
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MSO/DPO5000 Series MSO Option 

Key Take Away Points 

 The 16-channel digital input capability of the 
MSO/DPO5000 Series is enabled by both hardware and 
software. This capability is standard with all of the 
MSO5000 Series products. This same digital input 
capability is available as an upgrade for the DPO5000 
Series. The result is very similar, but not quite identical to 
an MSO5000. 

 A standard DPO5xxx has the following characteristics: 
o “DPO5xxx Digital Phosphor Oscilloscope” front 

panel label. 
o Help->About_TekScope indicates that the 

instrument is a “DPO5xxx” and that the MSOE 
option is not installed. 

o There is no “Digital” menu in the Windows menu. 
o A plastic plug is in the front panel connector. 

 An MSO5xxx has the following characteristics: 
o “MSO5xxx Mixed Signal Oscilloscope” front panel 

label. 
o Help->About_TekScope indicates that the 

instrument is an “MSO5xxx” and that the MSOE 
option is installed. 

o There is a “Digital” menu in the Windows menu. 

 When a DPO5xxx is upgraded with option MSOE, the front 
panel label and the instrument name in the Help-
>About_TekScope will still indicate that the instrument is a 
“DPO5xxx”, but the upgrade comes with a rear-panel label 
indicating that the option has been installed. There will be a 
“Digital” menu in the Windows menu, and the MSOE option 
will appear in the installed options list. And, of course, the 
upgrade includes the P6616 probe and accessory box. 

 An upgraded DPO5xxx looks like: 

 

MSO/DPO5000 Series Procedure: 

 Select Help -> About 
TekScope…. 
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MSO5000/DPO5000 Series 
Discover, Capture, and Search Lab 

 

 
 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.1.1 
One TPP0500 or TPP1000 passive probe 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this lab were made with the DPO Demo 3 board] 
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Discover, Capture, and Search 

As digital designs become more complex, engineers need tools to help find and diagnose problems quickly. 
Oscilloscopes are used in the design and debug process to discover problems quickly, capture events of 
interest, search for and gain insight into those events of interest, and then analyze the circuit behavior and 
solve the problem. This lab focuses on the first three of the four distinct steps of Discover, Capture, Search, 
and Analyze. 

Discover 
To solve a problem, you must first be able to find and visualize the problem. The first step to visualizing 
signals is accurately getting those signals into the instrument. To do this, you need to use the right probes to 
maintain high signal fidelity and minimize any loading effects on the circuit. 

Then you need a lively display of the signals so you can visualize how the signals are changing over time. 
Because an oscilloscope displays “snapshots” of the signals, you need an oscilloscope with a fast waveform 
capture rate. The result is the ability to see glitches or other infrequently occurring transients within seconds, 
revealing the true nature of faults. 

Seeing the problem is only half of the solution. You also need to understand how frequently the signal 
anomaly is occurring relative to the normal signals. This is where a DPO (Digital Phosphor Oscilloscope) 
with an intensity-graded display of waveforms shows a “history” of a signal’s activity by intensifying areas of 
the signal that occur more frequently. This provides a visual display of just how often anomalies are 
occurring relative to other signals. 

Capture 
Once you have an event of interest, you want to capture that event in memory and better understand the 
underlying causes of the event. Oscilloscopes use specialized triggers to narrow your focus to the events of 
interest by capturing specific digital events such as runts, glitches, pulse widths, setup and hold violations, 
and serial and parallel patterns. 

You will often want to view signals before and after the trigger event so you can understand the context 
around the event of interest or to capture many events of interest for further analysis. Or you may want to 
acquire only a few events of interest but retain enough sample point resolution to be able to zoom in on fine 
signal details. In either case, you will often want to use long record lengths to capture long time periods with 
high timing resolution.  Record length, one of the key specifications of an oscilloscope, is the number of 
samples it can digitize and store in a single acquisition. The longer the record length, the longer the time 
window you can capture with high resolution (high sample rate). 

In complex designs, you may need to capture several analog, serial, and parallel digital signals to 
understand the circuit conditions that are causing the trigger event. Mixed Signal Oscilloscopes (MSOs) are 
ideally suited to these applications. MSOs have unique capabilities for capturing digital signals, including 
Threshold controls which allow you to specify what voltage represents a digital ‘1’ and which represents a 
digital ‘0’. Some MSOs can automatically detect multiple transitions on digital edges. 

Search 
Finding one specific event in a long waveform record can be challenging. The MSO/DPO5000 oscilloscopes 
shows 1000 points of waveform data at one time on its display. An optional 200 million point record length 
represents 200,000 screens worth of data! Waveform navigation and search tools, such as Wave 
Inspector® on the MSO/DPO Series, simplify finding an event of interest. Wave Inspector offers dedicated 
front panel controls for panning and zooming of records for manual navigation and inspection of long data 
records. You can add your own marks to any location you want to reference later for further investigation. In 
addition, the automated search will search through millions of acquired data points looking for your specified 
event, including analog, digital, and serial bus data. Along the way it will automatically mark every 
occurrence of the event of interest so you can quickly move between matching events. 

Analyze 
Once you have discovered, captured, and located events of interest, you need to analyze the signals. 
Subsequent labs will demonstrate a variety of analysis techniques, including cursor measurements, 
automated measurements, waveform histograms, limit testing, and waveform math for analyzing signals. 
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Objectives 

- Obtain a basic understanding of the discovery and capture process. 

- Learn how to quickly discover anomalies on digital signals. 

- Learn how to easily capture those anomalies once you discover them. 

 

MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has a signal with 
random anomalies which we can use for this lab: 

 

 The DPO Demo 2 board (020-2924-XX) also has a signal 
with random anomalies which we can use for this lab: 

 

DPO Demo Board Procedure: 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the green POWER LED is 
lit. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to the 
FREQ_ANOM test point. 
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Discovering Intermittent Errors 

Key Take Away Points 

 By default, the oscilloscope is set to capture the signal 
whenever the signal rises above the trigger level (shown 
with the arrow along the right side of the display). The 
numerical trigger level value is also shown in the readout in 
the lower right corner of the display. 

 The display should look about like this: 

 

 Although this digital signal usually has “low” (about 0 Volts) 
or “high” (≥3 Volts) rectangular pulses, you will occasionally 
see narrow (<100 ns wide) pulses (“glitches”) and low-
amplitude pulses (“runt pulses”) on the display. To 
accumulate all of these anomalies for easier viewing, turn 
on infinite persistence. The resulting display should look 
about like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Press the front panel Autoset 
button to automatically set up the 
oscilloscope to get a stable 
display. 

 Press the front panel Intensity 
button. 

 Turn the Multipurpose a control 
fully clockwise to set the 
Waveform Intensity to 100%. 

 Press the front panel Intensity 
button. 

 Click on the Trig menu, select 
Holdoff…, and press the Auto 
button in the control window at 
the bottom of the display. 

 Press the Menu Off button. 

 

 

 Click on the Display menu, select 
Display Persistence, and select 
Infinite Persistence. 

 Infinite Persistence displays all 
captured waveforms on the 
display, preventing them from 
flashing on the display and then 
disappearing. 

 However, you may need to wait 
quite a while to get the rich 
display shown at the left. When 
you get tired of waiting, move on 
to the next page. 
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Key Take Away Points 

 Notice the acquisition counter in the readout in the lower 
right corner of the display. Watch the counter for ten 
seconds. In normal acquisition mode, you will see about 
60-70 acquisitions per second. 

 The display should look about like this: 

 

 Even when you have infinite persistence enabled, it may 
take a very long time to capture infrequent anomalies. 

 FastAcq provides very high waveform capture rate, often 
over 250,000 waveforms per second. Notice that we are 
seeing a similar waveform capture rate with this signal. 

 The resulting FastAcq display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Run/Stop 
button. 

 Press the front panel Clear button 
to clear the acquisition counter. 

 Press the front panel Run/Stop 
button to start acquisitions. 

 Wait for 10 seconds and press the 
front panel Run/Stop button. 

 Divide the contents of the 
acquisition counter by ten to 
estimate the waveform capture 
rate of the oscilloscope with 
FastAcq Off. 

 

 

 

 

 

 

 

 Press the front panel FastAcq 
button to turn on FastAcq. 

 Press the front panel Run/Stop 
button to start acquisitions. 

 Press the front panel Clear button 
to clear the acquisition counter. 

 Wait for 10 seconds and press the 
front panel Run/Stop button. 

 Divide the contents of the 
acquisition counter by ten to 
estimate the waveform capture 
rate of the oscilloscope with 
FastAcq On. 

 

 

 When you are done, press the 
front panel FastAcq button to turn 
off FastAcq. 

 Click on the Display menu, select 
Display Persistence, and select 
No Persistence. 

 Press the front panel Run/Stop 
button to start acquisitions. 
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Capturing Intermittent Errors 

Key Take Away Points 

 One of the anomalies that clearly appears in the display is 
a narrow pulse or “glitch”. 

 To capture a glitch, use Glitch triggering. (Glitch triggering 
is the same as Pulse Width triggering.) This trigger causes 
the oscilloscope to capture the signal only when it has a 
pulse width narrower than a specified value. The pulse 
width is measured at the amplitude specified by the trigger 
level. 

 

 Negative glitch triggering looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Trigger 
Menu button to display the 
Trigger Setup control window. 

 Press the Trigger Type drop-
down arrow or the Select button, 
and select Glitch. 

 Verify that Glitch Width is set to 
Less Than. 

 Touch the Width text box to 
attach the Multipurpose controls 
to the Level and Width controls. 

 Since the normal pulses are 
about 100 ns wide, set the trigger 
to find pulse widths that are 
significantly smaller. Using the 
Multipurpose b control, set the 
Width value to approximately 50 
ns. 

 Touch the Mode tab at the left 
side of the control window. 

 Press the Normal Trigger Mode 
button. 

 Touch the A Event tab at the left 
side of the control window. 

 Notice that the trailing (falling) 
edge of the narrow pulse is 
positioned in the center of the 
display. 

 By default, the Glitch trigger 
captures positive pulses. To 
capture negative pulses, press 
the Neg Polarity button. 

 Notice that the trailing (rising) 
edge of the narrow pulse is now 
positioned in the center of the 
display. 

 Press the front panel Trigger 
Menu button to remove the 
Trigger Setup control window. 
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Key Take Away Points 

 Another anomaly that appears in the display is a low-
amplitude pulse or “runt pulse”. 

 To capture a runt pulse, the Runt trigger is used. This 
trigger causes the oscilloscope to capture the signal only 
when a pulse back and forth through one threshold level 
but does not cross through a second threshold level. 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Trigger 
Menu button to display the 
Trigger Setup control window. 

 Press the Trigger Type drop-
down arrow or the Select button, 
and select Runt. 

 Verify that Runt is set to Occurs. 

 Touch the Upper Level or Lower 
Level text box to attach the 
Multipurpose controls to the Level 
controls. 

 Since the normal pulses are at 
least 3V high, and the runt pulses 
were around half of that, use the 
Multipurpose a control to set the 
Upper Level value to 
approximately 2V and use the 
Multipurpose b control to set the 
Lower Level value to 
approximately 1V. 

 Notice that the trailing (falling) 
edge of the runt pulse is 
positioned at the center of the 
display. 

 By default, the Runt trigger 
captures positive pulses. To see if 
there are any negative runt 
pulses in the signal, press the 
Neg Polarity button. 

 Since the activity on the display 
stops and the acquisition indicator 
in the lower right corner of the 
display turns yellow and says 
“Preview”, there are apparently no 
negative runt pulses in this signal. 

 To capture all runt pulses in the 
signal, press the Either Polarity 
button. 
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Searching for Intermittent Errors 

Key Take Away Points 

 As you have seen in this lab, triggering provides a way to 
capture a small time window around every occurrence of a 
specific anomaly in a signal. Because you have captured 
only a short time window of the signal and positioned the 
anomaly in the center of the display, the single anomaly is 
easy to find. 

 But what if you captured a lot of data? How would you find 
every occurrence of the anomaly, quickly and reliably? 

 One way to manually search for a signal event is to 
horizontally position the waveform on the display by 
changing the position of the trigger point on the display. 

 When horizontal Delay mode is turned On, the trigger point 
starts in the middle of the display and can be moved with 
the horizontal position control. The time delay between the 
trigger point and the center of the display is shown in the 
trigger readout at the bottom of the display. With Delay 
mode on, the trigger point can be moved off the display. 

 When horizontal Delay mode is Off (the default), the trigger 
point starts in the middle of the display and can be moved 
anywhere on the display with the horizontal position 
control. 

 Another way to manually search through a signal is to 
capture a long time window and then graphically zoom and 
pan through the displayed waveform. 

 Although the pan/zoom operation is easy with the front 
panel Wave Inspector controls, finding every occurrence of 
an anomaly is usually not a fast or reliable process. 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Acquire 
button. 

 Press the Delay Mode button to 
turn On Delay Mode. 

 Rotate the Horizontal Position 
control and notice that the orange 
triangle at the top of the display 
remains fixed, but that the trigger 
point moves, even to a position 
off-screen. 

 When Delay Mode is On, the 
trigger delay time appears in the 
trigger readout. 

 Press the Delay Mode button to 
turn Off Delay Mode. 

 Rotate the Horizontal Position 
control and notice that the orange 
triangle at the top of the display 
and the trigger point move across 
the display. 

 A readout of the horizontal 
position (from 0% to 100% of the 
screen width) is displayed in the 
control window. 

 Touch the Position text box and 
use the Multipurpose a control to 
set the Position to 10%. 

 Set the Horizontal Scale to 20 
ms/div. 

 Using the Sample Rate arrow 
keys, adjust the sample rate to 50 
MS/s, which will set the Record 
Length to 10M, as indicated in the 
readout in the lower left corner of 
the display. 

 Press the front panel Single 
button. 

 Turn the inner Wave Inspector 
control to select a 2µs/div zoom 
factor. 

 Using the spring-loaded outer 
Wave Inspector control, pan 
through the acquisition and see if 
you can find a runt pulse other 
than the one which is displayed at 
the trigger point. 
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Key Take Away Points 

 The automatic Wave Inspector search quickly and reliably 
finds every specified occurrence within the acquired signal. 
The simplest case is to search for the same signal 
characteristic as the trigger, although it can automatically 
search on almost any characteristic that it can trigger on. 

 

 In this case, let’s just use the same setup for search as we 
did for triggering. We can enter the parameters manually, 
or simply copy them with a push of a button: 

 

MSO/DPO5000 Series Procedure: 

 Click the X in the upper right 
corner of the Horizontal Setup 
control window to close it. 

 Press the front panel Search 
button to display the Search 
Setup control window. 

 Notice the similarities between 
the search types and the trigger 
types you used earlier in the lab. 

 Press the Runt button. 

 

 

 

 

 

 

 

 

 

 Press the Configure tab to 
configure the runt search. 

 Press the Copy button. 

 Notice From is set to A Trigger 
and To is set to Search 1. Press 
the Copy button to copy the 
trigger setup into the search 
setup. 

 Press the Close button. 

 In a matter of seconds, the 
automatic search finds all 
occurrences of the specified runt 
pulse. Notice that each 
occurrence is marked with a little 
triangle at the top of the display. 
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Key Take Away Points 

 The automatic search provides a tabular display like this, 
including the number of events found: 

 

 What if there are other anomalies in the signal? At the 
beginning of the lab, we saw glitches on this signal. Let’s 
search on them, too. 

 

MSO/DPO5000 Series Procedure: 

 Press the Results tab on the left 
side of the control window. Notice 
that two occurrences of the runt 
pulse have been found and time-
stamped. 

 

 

 

 

 

 

 

 

 

 

 

 Press the Select tab on the left 
side of the control window. 

 Pres the Glitch button. Notice 
that the search table now shows 
both runt and glitch search types. 
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Key Take Away Points 

 This time, configure the automatic search for positive 
glitches: 

 

 Now look at the search results for both runts and glitches: 

 

MSO/DPO5000 Series Procedure: 

 Press the Configure tab to 
configure the runt search. 

 Touch Glitch in the Type text 
box. 

 Touch the Level text box to 
attach the Multipurpose controls. 

 Using the Multipurpose a control, 
set the Level to about 2V. 

 Using the Multipurpose b control, 
set the Width to about 50 ns. 

 Press the Results tab on the left 
side of the control window. Notice 
that the occurrences of the runt 
pulses and glitches have been 
found and time-stamped. 
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MSO5000/DPO5000 Series 
I
2
C Triggering and Decoding Lab 

 

 
 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.4 and with the SR-EMBD option installed 
Two TPP0500 or TPP1000 passive probes 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this document were made with the DPO Demo 3 board] 
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Understanding the I2C Bus 

I
2
C (Inter-Integrated Circuit) bus, developed in the early 1980s by Philips, has become a worldwide 

standard for communications between integrated circuits in a system. This simple two-wire design has found 
its way into a wide variety of chips and can be found in many embedded designs today. I

2
C uses bi-

directional serial clock and data lines and supports three bit rates; 100 kbps standard mode, 400 kbps fast 
mode and 3.4 Mbps high speed mode. Data and clock are sent from the master and the data is clocked on 
the rising edge of SCLK. I

2
C supports multiple masters and slaves on the bus, but only one master may be 

active at any one time while slaves can transmit or receive data to the master. Each device is recognized by 
a unique address and can operate as either a transmitter or receiver, depending on the function of the 
device. 

Start/ 
SRep 

Addr R/W Ack 
Data 

 0 
Ack 

Data 
1 

Ack ..... 
Data 

N 
Ack Stop 

1 bit 7-bits 1-bit 1-bit 8-bits 1-bit 8-bits 1-bit 
0 – 8 
bytes 

8-bits 1-bit 1 bit 

 

Objectives 

- Obtain a basic understanding of the I
2
C serial bus. 

- Learn how to use oscilloscopes to measure and decode I
2
C. 

- Learn how to setup a decoded I
2
C serial bus display and trigger and search on I

2
C bus content with 

an MSO/DPO5000 Series oscilloscope. 

MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 I
2
C bus is an industry standard and can be found in many 

embedded designs today. 

 Traditional manual decoding methods to decode I
2
C buses 

with an oscilloscope are time-consuming. 

 With the SR-EMBD option installed, the MSO/DPO5000 
Series oscilloscope can trigger on, decode, and search I

2
C 

bus traffic. 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the SR-EMBD: I2C/SPI 
Serial Triggering and Analysis 
option is installed. 

 Press the OK button. 
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Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has an I
2
C signal 

which we can use for this lab: 

 

 The DPO Demo 2 board (020-2924-XX) also has an I
2
C 

signal which we can use for this lab: 

 

DPO Demo Board Procedure: 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the green POWER LED is 
lit. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to the 
I2C_CLK (clock) test point. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 2 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to the 
I2C_DATA (data) test point. 
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Key Take Away Points 

 

 

 

 

 

 

 

 

 

 The I
2
C signal display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Set channel 1 Vertical Scale to 
2V/div. 

 Turn on channel 2 by pressing 
the 2 button. 

 Set channel 2 Vertical Scale to 
2V/div. 

 Set the Horizontal Scale to 
500µs/div. 

 Use the Trigger Level control to 
adjust the trigger level to about 
1.7V. 

 Position channel 1 (clock) in the 
lower half of the display and 
position channel 2 (data) in the 
upper half of the display. 

 Press the front panel Single 
button. 

 Turn the inner portion of the Pan / 
Zoom control and adjust the zoom 
factor to 25µs/div or until one 
packet fills most of the display 
horizontally. 

 Turn the outer portion of the Pan / 
Zoom control to position the 
packet in the center of the 
display. 

 

Manual I2C Bus Decoding 

Key Take Away Points 

 The I
2
C bus is one of the easiest buses to manually 

decode. For years, this has been the way engineers have 
done this task. 

MSO/DPO5000 Series Procedure: 

 Using the I2C Quick Reference 
Guide below, record the 7 bit 
binary address of the packet on 
screen. 

 Record whether the packet is a 
read or write. 

 Record whether or not the device 
returned an Acknowledge. 

Conclusion: Manually decoding I
2
C packets is a time-consuming process. Engineers are looking for a 

better and faster way to do this. 
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MSO/DPO5000 Series I2C Bus Setup 

Introduction 

As you personally experienced in the last section, manually decoding I
2
C can be a time-consuming process. 

In this section we will learn how to use the MSO/DPO5000 Series oscilloscope to automatically decode I
2
C 

packet content. 

Key Take Away Points 

 Setting up a basic I
2
C bus waveform display takes only a 

few simple steps with the MSO/DPO5000 Series. 

 Notice that any of the analog or digital inputs or math 
signals can be used as a source for the I

2
C bus. The I

2
C 

Bus Setup menu looks like this: 

 

 The I
2
C bus Display menu looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Continue with same setup as 
previous lab. 

 Press the purple front panel Bus 
B button to display the Bus Setup 
menu. 

 Under Bus Type, select Serial. 

 Using the drop down menu, select 
I2C. 

 Verify that the SCLK signal is on 
Ch1 and the SDA signal is on 
Ch2. 

 Verify that the Threshold settings 
are about 1.4V. 

 Press the Bus 1 button to turn 
bus B1 On. 

 For simplicity, under Bus 1 
Config, verify that Include R/W in 
address is not checked. If 
Include R/W in address is 
checked, the decoded address 
value includes the R/W bit in the 
LSB. 

 Touch the Bus 1 Position text 
box to attach the Multipurpose a 
control. 

 Using the Multipurpose a control, 
position the bus waveform as 
desired. 

 Press the Display tab at the left 
side of the control window. 

 Under Bus 1 Display, verify that 
Busform Style and Hex Decode 
are selected. 

 When you are done with the 
setup, press the front panel Menu 
Off button or press the X in the 
upper right corner of the control 
window to close it. 
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Key Take Away Points 

 The decoded I
2
C signal display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Using the Wave Inspector 
controls, zoom in on one of the 
packets. 

 The green bar symbol represents 
the start of packet. Start is a high 
to low transition on the data 
signal while the clock is high. 

 Address packets are shown in 
yellow boxes. [R] Indicates a read 
and [W] indicates a write. 

 Data packets are shown in cyan 
boxes. 

 The red bar symbol represents 
the stop packet. Stop is a low to 
high transition on the data signal 
while the clock is high. 

 

MSO/DPO5000 Series I2C Bus Event Tables 

Key Take Away Points 

 Setting up a basic I
2
C bus event table display takes only a 

few simple steps with the MSO/DPO5000 Series. 

 The I
2
C bus event table display looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Select Vertical -> Bus Setup…. 

 Press the Display tab at the left 
side of the control window. 

 Press the Protocol Decode 
Event Table button. 

 Click on one of the rows in the 
Event Table and notice the zoom 
box is repositioned to correspond 
to the selected row. 

 

 

 

 

 

 

 When you are done with the 
setup, press the X in the upper 
right corner of the control window 
to close it. 
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MSO/DPO5000 Series I2C Bus Triggering 

Key Take Away Points 

 When debugging a system, you often want to capture the 
state of some key signals when a certain event occurs. 
One key event may be the transmission of specific content 
over the I

2
C serial bus. 

 The MSO/DPO5000 Series can trigger on Start, Stop, 
Repeat Start, Missing Ack, Address (7 or 10 bit), Data (1 – 
5 bytes), Address & Data, and Special Addresses. 

 

 By following this simple procedure, you can easily trigger 
the oscilloscope on a specified serial pattern on an I

2
C 

signal, capturing each occurrence. 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Trigger 
Menu button. 

 Using the Trigger Type drop down 
menu, select Bus triggering. 

 Using the Bus drop down menu, 
select B1. 

 Notice that, by default, Trigger On 
Start is selected. 

 Press the front panel Single 
button. 

 

 

 

 

 

 

 

 

 

 Using the Trigger On drop down 
menu, select Address. 

 The easiest way to enter the 
address is with the Pattern Editor. 
Press the Edit button at the right. 

 Select Hex format. 

 Double click on the Address text 
box and enter the address you 
recorded in the last section of this 
lab (for example, 50 hex). As you 
enter the values, notice that the 
values in the other radices are 
also updated. 

 In the Direction drop-down 
menu, select Write. 

 When you are done, press OK. 

 Press the front panel Single 
button. 

 Adjust the Wave Inspector pan 
and zoom controls as needed to 
view the I

2
C packets. 
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MSO/DPO5000 Series I2C Bus Searching 

Key Take Away Points 

 Once you have acquired a serial signal, you often want to 
find all occurrences of a certain event, such as the 
transmission of specific content over the I

2
C serial bus. 

 

 The MSO/DPO5000 Series can search on Start, Stop, 
Repeat Start, Missing Ack, Address (7 or 10 bit), Data (1 – 
5 bytes), Address & Data, and Special Addresses. 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Search 
button. 

 Press the Bus button in the 
control window. 

 

 

 

 

 

 

 

 

 

 

 

 Press the Configure tab at the 
left side of the control window. 

 Notice that, by default, Search 
For Start is selected. 

 Adjust the zoom window as 
needed to view the I

2
C packets 

and notice the packets which 
were marked. 
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Key Take Away Points 

 By following this simple procedure, you can easily search 
an acquisition for a specified serial pattern on an I

2
C signal, 

marking each occurrence. 

 

MSO/DPO5000 Series Procedure: 

 Using the Search For drop down 
menu, select Address. 

 The easiest way to enter the 
address is with the Pattern Editor. 
Press the Edit button at the right. 

 Select Hex format. 

 Double click on the Address text 
box and enter the address you 
recorded in the last section of this 
lab (for example, 50 hex). As you 
enter the values, notice that the 
values in the other radices are 
also updated. 

 When you are done, press OK. 

 In the Direction drop-down 
menu, select Don’t Care (X). 

 Using the front panel left and right 
arrows, navigate between search 
events. 

 Press the Results tab at the left 
side of the control window to 
display the table of search results. 
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MSO5000/DPO5000 Series 
SPI Triggering and Decoding Lab 
 

 
 

Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.4 and with the SR-EMBD option installed 
Three TPP0500 or TPP1000 passive probes 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this document were made with the DPO Demo 3 board] 
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Understanding the SPI Bus 

Introduction 

SPI (Serial Peripheral Interface) bus is a 4-wire serial communications interface used primarily in 
synchronous serial communication for both processors and peripherals. SPI is an interface standard defined 
by Motorola for use on their microcontrollers. Due to the popularity of the bus other manufacturers have 
adopted the standard, making a wide variety of parts available in the market. SPI uses a synchronous clock 
which shifts serial data into and out of the microcontroller, generally in blocks of 8 bits. SPI bus is a 
master/slave interface. Whenever two devices communicate, one is referred to as the "master" and the other 
as the "slave". The master drives the serial clock. When using SPI, data is simultaneously transmitted and 
received, making it a full-duplex protocol. 

As you can see in the following block diagrams, SPI is a flexible interface, supporting several different circuit 
topologies. In general, the master provides a clock to all slaves. When MOSI, SCLK, and SS are used, it is 
called the “3-wire” SPI connection. (This demo is based on the “3-wire” connection.) 

With the single-master, multi-slave topology, the master provides data (Master Out Slave In or MOSI) 
directly to each slave and controls them separately with slave select signals. In the case of the “4-wire” SPI 
connection, the MISO signal is routed from the selected slave back to the master so the master can verify 
the communication path. 

With the cascaded topology, the data (MOSI) from the master is “daisy-chained” through each of the slaves. 
In the case of the “4-wire” SPI connection, the MISO signal is routed from the last slave back to the master 
so the master can verify the communication path. The chain of slaves is enabled by a single SS signal, 
usually generated by the master. However, in the “2-wire” SPI connection, the SS inputs to the slave devices 
are permanently asserted (e.g. tied to ground). 

With the single-master-hardwired-to-single-slave topology, the master provides MOSI and SCLK. MISO is 
generally not used, and often a “2-wire” connection is used for simplicity. 
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Lab Objectives 

- Obtain a basic understanding of the SPI serial bus. 

- Learn how to use oscilloscopes to measure and decode SPI. 

- Learn how to setup a decoded SPI serial bus and trigger and search on SPI packet content with an 
MSO/DPO5000 Series oscilloscope. 

 

MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 SPI bus is an industry standard and can be found in many 
embedded designs today. 

 Traditional manual decoding methods to decode SPI buses 
with an oscilloscope are time-consuming. 

 With the SR-EMBD option installed, the MSO/DPO5000 
Series oscilloscope can trigger on, decode, and search SPI 
bus traffic. 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the SR-EMBD: I2C/SPI 
Serial Triggering and Analysis 
option is installed. 

 Press the OK button. 
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Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has an SPI signal 
which we can use for this lab: 

 

 The DPO Demo 2 board (020-2924-XX) also has an SPI 
signal which we can use for this lab: 

 

DPO Demo Board Procedure: 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the green POWER LED is 
lit. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to the 
SPI_SCLK test point. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 2 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to the SPI_SS 
test point. Be aware that this 
signal is called Chip Select (CS) 
by some and Slave Select (SS) by 
others. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 3 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to the 
SPI_MOSI test point. 
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Key Take Away Points 

 

 

 

 

 

 

 

 

 The SPI signal display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Set the Horizontal Scale to 
20µs/div. 

 Press the front panel 2 and 3 
buttons to turn on channels 2 and 
3. 

 Set the Vertical Scale for 
channels 1, 2, and 3 to 2V/div. 

 Use the Trigger Level control to 
adjust the trigger level to about 
1.7V. 

 Position the waveforms on the 
display as shown in the screen 
shot on the left. 

 Press the front panel Single 
button. 

 Turn the inner portion of the Pan / 
Zoom control and adjust the zoom 
factor to about 10 µs/div to get a 
single packet in the zoom 
window. 

 Turn the outer portion of the Pan / 
Zoom control to zoom in on the 
beginning of the packet. 
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Manual SPI Bus Decoding 

Key Take Away Points 

 The SPI bus is fairly easy to manually decode. For years, 
this has been the way engineers have done this task. 

MSO/DPO5000 Series Procedure: 

 Decode the data bus values by 
deciding whether the data signal 
is high or low on each of the rising 
edges of the clock signal, as 
shown below. 

 Record the decoded data value. 

Conclusion: Manually decoding SPI packets is a time-consuming process. Engineers are looking for a 
better and faster way to do this. 

SPI Quick Reference Guide 
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MSO/DPO5000 Series SPI Bus Setup and Decoding 

Introduction 

As you personally experienced in the last section, manually decoding SPI can be a time-consuming process. 
In this section we will learn how to use the MSO/DPO5000 Series oscilloscope to automatically decode SPI 
packet content. 

Key Take Away Points 

 Setting up a basic SPI bus waveform display takes only a 
few simple steps with the MSO/DPO5000 Series. 

 Notice that any of the analog or digital inputs or math 
signals can be used as a source for the SPI bus. The SPI 
bus selection menu looks like this: 

 

 The SPI bus Display menu looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the purple front panel Bus 
B button to display the Bus Setup 
menu. 

 Under Bus Type, select Serial. 

 Using the drop down menu, select 
SPI. 

 Verify that the SCLK is on is on 
Ch1, SS is on Ch2, and Data 
signal Ch3. 

 Press the arrow next to the 
channel 1 label and notice that 
any of the analog, digital, or math 
channels can be used as an 
input. 

 Verify that the Threshold settings 
are all about 1.4V. 

 Verify that SCLK is set to Rising 
edge, SS is set to Active Low, 
and Data is set to Active High. 

 Verify that Framing is set to SS. 

 Click on the Word Size (the 
number of bits in the packet) text 
box and set it to 8. 

 Using the Direction drop down 
menu, select MS First so the first 
bit in the packet is interpreted as 
the MSB. 

 Press the Bus 1 button to turn 
bus B1 On. 

 Touch the Bus 1 Position text 
box to attach the Multipurpose a 
control. 

 Using the Multipurpose a control, 
position the bus waveform as 
desired. 

 Press the Display tab at the left 
side of the control window. 

 Verify that Busform Style and 
Hex Decode are selected. 
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MSO/DPO5000 Series 2-Wire SPI Bus Decoding 

Key Take Away Points 

 Notice the Framing selection at the top of the control 
window. The default Framing setting “SS” provides 3-wire 
SPI functionality. 

 Notice that the Data (MOSI) packets are shown in cyan 
boxes. The green start of packet indicator corresponds to 
the falling edge of SS (active low) on channel 2 and the red 
end of packet indicator corresponds to the rising edge of 
the SS signal: 

 

 Before continuing on with the main lab, we need to stop 
and review a special case, “2-wire SPI”, which is supported 
by the MSO/DPO5000 Series. 

 In “2-wire SPI”, the framing timing is derived from the clock 
signal instead of the separate SS signal: 

o The frame ends after the final active clock edge 
occurs and the specified idle time has elapsed. 

o The frame begins with the first active edge of the 
clock after the idle state has been reached. 

MSO/DPO5000 Series Procedure: 

 Press the Config tab at the left 
side of the control window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Click on the Framing down arrow 
and select Idle. 

 Notice the Idle Time selection, 
indicating a default 5µs idle time. 
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Key Take Away Points 

 In “2-wire SPI” mode, notice that the green start of packet 
indicator corresponds to the first rising edge of the clock on 
channel 2 and the red end of packet indicator occurs after 
the final falling edge of the clock signal by an amount 
specified by the idle time: 

 

 Note that in “2-wire SPI” mode, the available SPI Bus 
trigger modes are “Start of Frame” and “Data”. 

MSO/DPO5000 Series Procedure: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 When you are done, click on the 

Framing down arrow and select 
SS. 
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MSO/DPO5000 Series SPI Bus Event Tables 

Key Take Away Points 

 Setting up a basic SPI bus event table display takes only a 
few simple steps with the MSO/DPO5000 Series. 

 With this oscilloscope setup, there is only one SPI packet 
within the acquisition, so the Event Table is very small. 
However, you can see what the pop-up SPI bus Display 
format looks like for the SPI bus: 

 

 You can also dock the Event Table so that it appears below 
the graticule for easy reference between the two displays: 

 

MSO/DPO5000 Series Procedure: 

 Press the Display tab at the left 
side of the control window. 

 Press the Protocol Decode 
Event Table button. 

 

 

 

 

 

 

 

 

 

 

 

 

 Press the Dock button. 

 Click on the X in the upper right 
corner of the control window to 
close it. 

 

 

 

 

 

 

 

 

 

 

 

 When you are done, press the X 
in the upper right corner of the 
Event Table to close it. 
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MSO/DPO5000 Series SPI Bus Triggering 

Key Take Away Points 

 When debugging a system, you often want to capture the 
state of some key signals when a certain event occurs. 
One key event may be the transmission of specific content 
over the SPI serial bus. The MSO/DPO5000 Series can 
trigger on SS Active and specific Data values. 

 This is what triggering on SS Active looks like: 

 

 By following this simple procedure, you can easily trigger 
the oscilloscope on a specified serial pattern on an SPI 
signal, capturing each occurrence. 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Trigger 
Menu button. 

 Using the Trigger Type drop down 
menu, select Bus triggering. 

 Using the Bus drop down menu, 
select B1. 

 The Trigger On selection, by 
default, is set to SS Active. (The 
active polarity was set in the Bus 
Setup menu.) 

 Press the front panel Single 
button. 

 

 

 

 

 

 

 

 Using the Trigger On drop down 
menu, select Data. 

 The easiest way to enter the 
address is with the Pattern Editor. 
Press the Edit button at the right. 

 Select Hex format. 

 Double click on the Data Value 
text box and enter the address 
you recorded in the last section of 
this lab (for example, 55 hex). As 
you enter the values, notice that 
the values in the other radices are 
also updated. 

 When you are done, press OK. 

 Adjust the Wave Inspector pan 
and zoom controls as needed to 
view the SPI packets. 
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MSO/DPO5000 Series SPI Bus Searching 

Key Take Away Points 

 Once you have acquired a serial signal, you often want to 
find all occurrences of a certain event, such as the 
transmission of specific content over the SPI serial bus. 
The MSO/DPO5000 Series can search on SS Active and 
specific Data values. 

 This is what searching on SS Active looks like: 

 

 By following this simple procedure, you can easily search 
an acquisition for a specified serial pattern on an SPI 
signal, marking each occurrence. 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Search 
button. 

 Press the Bus button in the 
control window. 

 Press the Configure tab at the 
left side of the control window. 

 The Search For selection, by 
default, is set to SS Active. (The 
active polarity was set in the Bus 
Setup menu.) 

 

 

 

 

 

 

 

 

 Using the Search For drop down 
menu, select Data. 

 The easiest way to enter the 
address is with the Pattern Editor. 
Press the Edit button at the right. 

 Select Hex format. 

 Double click on the Data Value 
text box and enter the data value 
you recorded in the last section of 
this lab (for example, 55 hex). As 
you enter the values, notice that 
the values in the other radices are 
also updated. 

 When you are done, press OK. 

 Adjust the zoom window as 
needed to view the SPI packets. 

 Using the front panel left and right 
arrows, navigate between search 
marks. 

 Press the Results tab at the left 
side of the control window to 
display the table of search results. 

 



 

MSO5000 / DPO5000 Lab Exercise Book 

Version 1.1   5/11/2012 48W-26279-3   75 of 394 

 

MSO5000/DPO5000 Series 
USB Triggering and Decoding Lab 
 

 
 

Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.4 and with the SR-USB option installed 
 NOTE: A ≥1 GHz oscilloscope is required for High-speed USB support 
Two TPP0500 or TPP1000 passive probes 
One TDP1000 differential probe 
Optional USB keyboard and mouse 
PC with USB2.0 Host ports 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) 
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Understanding the USB Bus 

Introduction 

Universal Serial Bus (USB) has replaced many of the personal computer external serial and parallel buses. 
USB is a simple and inexpensive interface that brought plug-and-play ease-of-use in connecting and using 
external devices with the computer. For example, USB devices can be hot-plugged into the computer with 
dynamically loadable drivers without the need to reboot. 

The USB Implementers Forum (USB-IF) manages and promotes USB standards and USB technology. USB 
specifications are available at the USB-IF web site at www.usb.org. 

Since the USB introduction in 1995 USB has grown beyond its original personal computer usage and it has 
become a ubiquitous interface used in many types of electronic devices. For example, the Inter-Chip USB 
(IC_USB) and the High-Speed Inter-Chip (HSIC) USB are use for chip-to-chip communications and these 
implementations do not have connectors, cables, or analog transceivers. 

USB 2.0 specifications that were released in 2000 cover most of the USB devices that are being used today. 
USB 2.0 added a high speed interface to the USB 1.1 specifications. Compliance to USB 2.0 does not 
require high speed operation. For example, a low-speed USB mouse can be compliant to USB 2.0 and 
advertise that it is an USB 2.0 device. Supplements to the USB 2.0 specifications cover IC_USB, HSIC and 
other enhancements. 

Controller Configuration 

The USB configuration is one host controller with 1 to 127 
devices. USB is a tiered-star topology with optional hubs 
to expand the bus, as shown at the right: 

The host is the only master and it controls all bus traffic. 
The host initiates all communications to devices and 
devices do not have the capability to interrupt the host. 

 

Enumeration 

Enumeration is the configuration process that occurs at power-on or when a device is hot plugged. The host 
detects the presence of the device on the USB bus. Next, the host polls the device with the SETUP token 
using address 0 and endpoint 0. Then, the host assigns a unique address to a device in the range of 1 to 
127. The host also identifies the device speed and data transfer type, and determines the device’s class. 
The device class defines a device’s functionality such as printer, mass storage, video, audio, human 
interface, etc. 

file:///C:/Documents%20and%20Settings/scottd/My%20Documents/Marketing/FlagShip/AnalogKid/Training/Catalina/Calico/www.usb.org


 

MSO5000 / DPO5000 Lab Exercise Book 

Version 1.1   5/11/2012 48W-26279-3   77 of 394 

 

Electrical 

The host uses an upstream “A” connector and devices use a downstream “B” connector. 

The USB 2.0 cable has four wires, shown at the right: 

Two wires are used for 5 V power (red wire) and ground (black 
wire) from the host. The connectors are designed so that the power 
and ground pins are connected before the data pins. The host 
provides current from 100 mA to 500 mA with intelligent power 
management. For example, power to a device can be monitored by 
the host or hub and switched off if an over-current condition occurs.  

A twisted differential pair D+ (green wire) and D- (white wire) is 
used for bidirectional communications using half-duplex, DC-
coupled differential signaling controlled by the host. Signal levels 
are listed in the table below: 

USB Speed Low State High State 

Low Speed <0.3V >2.8V 

Full Speed <0.3V >2.8V 

High Speed 0 V±10% 400 mV±10% 

 
The host pulls down both D+ and D- when no device is connected. This is called single-ended zero (SE0) 
state. As a result, the oscilloscope will show 0 V when probing a USB bus that has no device connected. 

Data transmission uses Non-Return-to-Zero-Inverted (NRZI) encoding. A logic ‘0’ is represented by the 
signal polarity toggling, while a logic ‘1’ is no change. The least significant bit is transmitted first and the 
most significant bit is transmitted last. To maintain adequate AC signal content, an extra ‘0’ is inserted after 
six consecutive 1s (called “bit stuffing”). 

Packets 

Packets are the fundamental elements of USB communications. 

For full-speed and low-speed USB, a packet starts from the idle state with an 8-bit synchronization (SYNC) 
field. For high-speed USB, a packet starts from the idle state with a 32-bit synchronization (SYNC) field. 

Then the Packet IDentifier (PID) is transmitted. The PID is 
composed of a 4-bit PID and its 4-bit PID complement for error 
checking. A PID encoding error is when the first PID 4-bits do not 
match the complement of the last PID 4-bits. The PID 4-bit value 
identifies 17 types of packets, shown in the table at the right: 

PIDs are grouped into four Types: token, data, handshake and 
special. 

Finally, the 3-bit end-of-packet (EOP) is transmitted. 

 

 

 

 

 

 

 

PID Type PID Name PID 

Token OUT 
IN 
SOF 
SETUP 

0001 
1001 
0101 
1101 

Data DATA0 
DATA1 
DATA2 
MDATA 

0011 
1011 
0111 
1111 

Handshake ACK 
NAK 
STALL 
NYET 

0010 
1010 
1110 
0110 

Special PRE 
ERR 
SPLIT 
PING 
Reserved 

1100 
1100 
1000 
0100 
0000 
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Handshake Packets 

Handshake packets such as data packet accepted (ACK) and data packet not accepted (NAK) are 
composed of the Sync byte, PID byte and EOP. 

Token Packets 

Host-sent token packets are composed of the PID followed by two bytes composed of a11-bit address and a 
5-bit cyclic redundancy check (CRC), as shown here: 

Sync PID 
11-bit 

Address 
5-bit 
CRC 

EOP 

OUT, IN and SETUP token packet organization 

Address zero is special and is for a device that has not been assigned an address at the beginning of the 
enumeration process. Later in the enumeration process, the host assigns a nonzero address to the device. 

All devices have an endpoint zero. Endpoint zero is special and is used for device control and status. Other 
device endpoints are for data sources and/or sinks. 

The host sends an OUT token to a device followed by data packets. The host sends an IN token to a device 
and expects to receive data packets or handshake packet such as NAK from the device. 

Data Packets 

Data packets contain a PID byte, data bytes and 16-bit CRC, as shown here: 

Sync PID Data 
16-bit 
CRC 

EOP 

Data Packets with the PID defining a DATA0 or DATA1 packet 

DATA0 and DATA1 packets have a 1-bit sequence number that is used in stop and wait automatic repeat-
request handshake. DATA0 and DATA1 packets alternate in error free transmission. Data packets are 
resent with the same sequence number when a transmission error occurs. 

An error free data transaction is when the host sends a DATA0 packet to the device, the device sends a 
handshake ACK packet, and then the host sends a DATA1 packet. 

If the host does not receive a handshake ACK packet, or receives a NAK from the device, it resends the 
DATA0 packet. If the device sent an ACK packet and receives the data packet with the same sequence 
number again, the device acknowledges the data packet but ignores the data as a duplicate. 

Start of Frame 

Start of Frame (SOF) packet is used to synchronize isochronous and polled data flows.  The 11-bit frame 
number is incremented by one in each consecutive SOF. 

Sync PID 
Frame 

Number 
5-bit 
CRC 

EOP 

Start of Frame Packet 
 

 

Lab Objectives 

- Obtain a basic understanding of the USB serial bus. 

- Learn how to use oscilloscopes to measure and decode USB. 

- Learn how to setup a decoded USB serial bus and trigger and search on USB packet content with 
an MSO/DPO5000 Series oscilloscope. 
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MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 USB bus is an industry standard and can be found in many 
embedded designs today. 

 Traditional manual decoding methods to decode USB 
buses with an oscilloscope are time-consuming. 

 With the SR-USB option installed, the MSO/DPO5000 
Series oscilloscope can trigger on, decode, and search 
USB bus traffic. 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the SR-USB: USB 
Serial Triggering and Analysis 
option is installed. 

 Press the OK button. 

Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has USB signals 
which we can use for this lab: 

 

DPO Demo Board Procedure: 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the green POWER LED is 
lit. 

 On this board, the three USB 
signals are differential signals and 
are available on pairs of square 
pins. The positive side of the 
differential signal is on pin 1 of the 
connector (identified by the 
silkscreen arrow and the square 
pad) and the negative side of the 
differential signal is on pin 2 of the 
connector. 
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Key Take Away Points 

(optional) Determining USB Data Rate 

 The data rate of USB signals for commonly-available USB 
computer mice and USB flash drives may be Low-speed 
(1.5 Mb/s), Full-speed (12 Mb/s), or High-speed (480 
Mb/s). In some cases, the devices may specify the speed 
at which they operate. However, in general, you may need 
to determine the data rate using this procedure. 

 The display should look about like this: 

 
 

Minimum Pulse 
Width 

USB Bit Rate USB Speed 

667 ns 1.5 Mb/s Low-speed 

83 ns 12 Mb/s Full-speed 

2.08 ns 480 Mb/s High-speed 
 

MSO/DPO5000 Series Procedure: 

 For this optional bit rate test only: 

 Attach a TPP0500 or TPP1000 
passive probe to the Channel 1 
input of the oscilloscope. 

 Connect the probe tip to the D+ 
signal on pin 1 of the USB_LS or 
USB_FS connector and the probe 
ground to GND. 

 Press Autoset. 

 Adjust the Horizontal Scale to 
clearly display individual cycles of 
the signal. 

 Press the front panel Cursors 
button once to turn on vertical bar 
cursors. 

 Using the Multipurpose controls, 
measure the width of the 
narrowest pulse, as shown in the 
screen shot at the left. 

 Read the bit rate (1/ time in the 
cursor readout) and write the 
value here:  ______ 
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Low-Speed USB Bus Setup and Decoding 

Key Take Away Points 

 NOTE: Low-speed USB triggering and analysis support is 
offered on all properly-equipped MSO/DPO5000 models. 
Both single-ended and differential probing of the USB 
signal is supported. For simplicity, this lab will use single-
ended probing with the standard passive probes. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 The Low-speed USB signal display should look about like 
this: 

 

MSO/DPO5000 Series Procedure: 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to pin 1 of the 
USB_LS connector on the demo 
board. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 2 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to pin 2 of the 
USB_LS connector on the demo 
board. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Press the front panel 2 button to 
turn on channel 2. 

 Set the Vertical Scale for 
channels 1 and 2 to 2V/div. 

 Use the Trigger Level control to 
adjust the trigger level to about 
1.4V. 

 Position the waveforms in the top 
half of the display as shown in the 
screen shot on the left. 

 Set the Horizontal Scale to 
10µs/div. 

 Press the front panel Single 
button. 
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Key Take Away Points 

 The USB Bus Setup control window looks like this: 

 

 Setting up a basic USB bus waveform display takes only a 
few simple steps with the MSO/DPO5000 Series. 

 Notice that any of the analog (single-ended or differential) 
or digital (single-ended) inputs or math signals can be used 
as a source for the USB bus. 

 The decoded USB bus should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the purple front panel Bus 
B button to display the Bus Setup 
menu. 

 Under Bus Type, select Serial. 

 Using the drop down menu, select 
USB. 

 Verify that the Speed is set to 
Low (1.5 Mbps). 

 Under Signal Type, select Single 
Ended. 

 For component D+, select Ch1. 

 For component D-, select Ch2. 

 Verify that the Threshold settings 
are about 1.4V. 

 Press the Bus 1 button to turn 
bus B1 On. 

 

 

 

 

 

 Press the Display tab at the left 
side of the control window. Notice 
the different display formats that 
are available. 

 Select Mixed Busform Decode. 
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Full-Speed USB Bus Setup and Decoding 

Key Take Away Points 

 NOTE: Full-speed USB support is offered on all properly-
equipped MSO/DPO5000 models. Both single-ended and 
differential probing of the USB signal is supported. For 
simplicity, this lab will use single-ended probing with the 
standard passive probes. 

 The Full-speed USB signal display should look about like 
this: 

 

MSO/DPO5000 Series Procedure: 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to pin 1 of the 
USB_FS connector on the demo 
board. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 2 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to pin 2 of the 
USB_FS connector on the demo 
board. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Press the front panel 2 button to 
turn on channel 2. 

 Set the Vertical Scale for 
channels 1 and 2 to 2V/div. 

 Use the Trigger Level control to 
adjust the trigger level to about 
1.4V. 

 Position the waveforms in the top 
half of the display as shown in the 
screen shot on the left. 

 Set the Horizontal Scale to 
10µs/div. 

 Press the front panel Single 
button. 

 Using the front panel Wave 
Inspector controls, zoom in on 
one of the USB packets. 
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Key Take Away Points 

 The USB Bus Setup control window looks like this: 

 

 Setting up a basic USB bus waveform display takes only a 
few simple steps with the MSO/DPO5000 Series. 

 Notice that any of the analog (single-ended or differential) 
or digital (single-ended) inputs or math signals can be used 
as a source for the USB bus. 

 When you zoom in on the decoded USB signals, you 
should see a display about like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the purple front panel Bus 
B button to display the Bus Setup 
menu. 

 Under Bus Type, select Serial. 

 Using the drop down menu, select 
USB. 

 Verify that the Speed is set to 
Full (12 Mbps). 

 Under Signal Type, select Single 
Ended. 

 For component D+, select Ch1. 

 For component D-, select Ch2. 

 Verify that the Threshold settings 
are about 1.4V. 

 Press the Bus 1 button to turn 
bus B1 On. 

 

 

 

 

 

 Press the Display tab at the left 
side of the control window. Notice 
the different display formats that 
are available. 

 Select Mixed Busform Decode. 
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High-Speed USB Bus Setup and Decoding 

Key Take Away Points 

 NOTE: High-speed USB support is only offered on the ≥1 
GHz MSO/DPO5204 and MSO/DPO5104 models, and 
requires differential probing of the USB signal. 

 The High-speed USB signal display should look about like 
this: 

 

MSO/DPO5000 Series Procedure: 

 Attach a TDP1000 probe to the 
Channel 1 input of the 
oscilloscope. Then connect the 
probe + input to pin 1 and the 
probe – input to pin 2 on the 
USB_HS connector. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Press the Menu button on the 
TDP1000. 

 Press the Range button on the 
probe to select 4.25V. 

 Set the Horizontal Scale to 
10µs/div. 

 Set the Vertical Scale for channel 
1 to 300 mV/div. 

 Use the Trigger Level control to 
adjust the trigger level to about  
-100 mV. 

 Position the waveform in the top 
half of the display as shown in the 
screen shot on the left. 

 Press Menu Off. 

 Press the front panel Single 
button. 

 Turn the inner portion of the Pan / 
Zoom control and adjust the zoom 
factor to about 1000X to get a 
single packet in the zoom 
window. 

 Turn the outer portion of the Pan / 
Zoom control to zoom in on the 
beginning of the packet. 
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Key Take Away Points 

 The USB signal Define Inputs menu looks like this: 

 

 Setting up a basic USB bus waveform display takes only a 
few simple steps with the MSO/DPO5000 Series. 

 Notice that any of the analog inputs or math signals (since 
they must be differential signals) can be used as a source 
for the USB bus. 

 When you zoom in on the decoded USB signals, you 
should see a display about like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Trigger 
Menu button and select 
Independent under Settings. Or, 
right-click on the trigger readout 
and select Settings-
>Independent. 

 Press the purple front panel Bus 
B button to display the Bus Setup 
menu. 

 Under Bus Type, select Serial. 

 Using the drop down menu, select 
USB. 

 Verify that the Speed is set to 
High (480Mbps). 

 Under Signal Type, select 
Differential. 

 For component D+/D-, select 
Ch1. 

 Using the Multipurpose a control, 
set the Threshold (H) level to 100 
mV. 

 Use the Multipurpose b control to 
set the Threshold (L) level to -100 
mV. 

 Press the Bus 1 button to turn 
bus B1 On. 

 Press the Display tab at the left 
side of the control window. Notice 
the different display formats that 
are available. 

 Select Mixed Busform Decode. 
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MSO/DPO5000 Series USB Bus Event Tables 

Key Take Away Points 

 Setting up a basic USB bus event table display takes only a 
few simple steps with the MSO/DPO5000 Series. 

 The USB bus event table display looks like this: 

 

 When you expand the Data packet display in the USB bus 
event table, the display looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the Protocol Decode 
Event Table button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 When you are done with the 
setup, press the Close button. 
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MSO/DPO5000 Series USB Bus Triggering 

Key Take Away Points 

 When debugging a system, you often want to capture the 
state of some key signals when a certain event occurs. 
One key event may be the transmission of specific content 
over the USB serial bus. 

 The MSO/DPO5000 Series can trigger on the following 
elements of a USB 2.0 bus: 

o Sync 
o Reset 
o Suspend 
o Resume 
o End of Packet 

o Token (address) Packet: Any token type, SOF, OUT, 

IN, SETUP; Address and End Point can be specified for 
Any Token, OUT, IN, and SETUP token types. 

o Data Packet: Any data type, DATA0, DATA1. 

o Handshake Packet: Any handshake type, ACK, NAK, 

STALL, NYET (HS only). 

o Special Packet: Any special type, PRE (FS only), ERR, 

SPLIT, PING, Reserved. 
o Error: PID check, CRC5 or CRC16, Bit stuffing (LS and 

FS only). 

 By following this simple procedure, you can easily trigger 
the oscilloscope on a specified serial pattern on an USB 
signal, capturing each occurrence. 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Trigger 
Menu button. 

 Touch the Trigger Type text box 
and select Bus triggering. 

 Verify that Bus B1 is selected. 

 Press the Mode tab and press the 
Normal Trigger Mode button. 

 Click on the Trigger On text box 
and select Sync. 

 Press the front panel Single 
button. 

 Press Menu Off. 

 Adjust the Wave Inspector pan 
and zoom controls as needed to 
view the USB packets. 
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MSO/DPO5000 Series USB Bus Searching 

Key Take Away Points 

 Once you have acquired a serial signal, you often want to 
find all occurrences of a certain event, such as the 
transmission of specific content over the USB serial bus. 

 The MSO/DPO5000 Series can search on the same 
elements of a USB 2.0 bus: 

o Sync 
o Reset 
o Suspend 
o Resume 
o End of Packet 

o Token (address) Packet: Any token type, SOF, OUT, 

IN, SETUP; Address and End Point can be specified for 

Any Token, OUT, IN, and SETUP token types. 
o Data Packet: Any data type, DATA0, DATA1. 

o Handshake Packet: Any handshake type, ACK, NAK, 

STALL, NYET (HS only). 

o Special Packet: Any special type, PRE (FS only), ERR, 

SPLIT, PING, Reserved. 

o Error: PID check, CRC5 or CRC16, Bit stuffing (LS and 

FS only). 

 By following this simple procedure, you can easily search 
an acquisition for a specified serial pattern on a USB 
signal, marking each occurrence. 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Search 
button. 

 Press the Bus button in the 
control window. 

 Press the Configure tab at the 
left side of the control window. 

 Verify that Bus B1 is selected. 

 Click on the Search For text box 
and select Sync. 

 Adjust the zoom window as 
needed to view the USB packets. 

 

 

 

 

 

 

 Using the front panel arrow 
buttons, navigate between search 
marks to see all occurrences of 
the USB Sync. 

 Press the Results tab at the left 
side of the control window to 
display the table of search results. 
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MSO5000/DPO5000 Series 
RS-232 / RS-422 / RS-485 / UART 
Triggering and Decoding Lab 

 

 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.4 and with the SR-COMP option installed 
One TPP0500 or TPP1000 passive probe 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this document were made with the DPO Demo board] 
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Understanding the RS-232 Bus 

RS-232 stands for Recommended Standard 232, a communication standard from the Electronic Industries 
Alliance (EIA), which was developed in the early 1960s for interconnection between teletype terminals and 
modems. The standard was updated to RS-232C in 1969 to specify electrical signal characteristics, 
mechanical interconnects, etc. 
 
RS-232 provides two single-ended signals for point-to-point, full-duplex communication (simultaneous 
transmitted and received data). The standard does not specify character encoding, data framing, or 
protocols. It was designed for short-distance, low-speed serial data communication. Although the maximum 
cable length is not specified, a distance of less than 15 meters is recommended. The maximum data rate is 
not also specified, but rates <20 kb/s are recommended. 
 
RS-232 data transmission is asynchronous, meaning that the clock is not transmitted and must be 
programmed in advance at both the transmitter and the receiver. Each character begins with a start bit, a 
high value which equates to a logic “0”. The character is comprised of 7 or 8 data bits, which must also be 
programmed. The data bits are transmitted in least-significant to most-significant bit order. The optional 
Parity bit is next. If not used, the bit is ignored. If used, the polarity must be programmed, and provides 
simple error detection by indicating whether there are an odd or even number of “1s” in the data word. 
Finally, the character is usually terminated in one to two stop bits. 
 

Start 
Data 

0 
Data 

1 
Data 

2 
Data 

 3 
Data 

4 
Data 

5 
Data 

6 

opt. 
Data 

7 

opt. 
Parity 

Stop 
opt. 
Stop 

1-bit 1-bit 1-bit 1-bit 1-bit 1-bit 1-bits 1-bit 1-bit 1-bit 1-bit 1-bit 

 
Each RS-232 character can be encoded in various formats, but ASCII format is most commonly used. 
ASCII, short for American Standard Code for Information Interchange, is a 7-bit code (a range from 0 to 127) 
which is used to represent characters. Of the 128 possible codes, 95 (numbered 32 to 126) represent 
printable characters. Many of the remaining non-printing characters are control characters which control how 
text is processed. (Examples of control characters include backspace, tab, carriage return, and line feed.) 
Since most computer memories are based on 8-bit bytes, the eighth bit of the stored ASCII character can be 
used for parity, a simple error-detection scheme. (An ASCII conversion chart is included later in this lab 
document.) 
 
The RS-232 standard does not specify how data content is framed or grouped, but a common technique is 
to end a data frame with a pre-determined termination character such as carriage return, line feed, or null. 
 

 
 

Lab Objectives 

- Obtain a basic understanding of the RS-232 serial bus. 

- Learn how to use oscilloscopes to measure and decode RS-232 signals. 

- Learn how to setup an RS-232 serial bus display and trigger and search on RS-232 packet content 
with an MSO/DPO5000 Series oscilloscope. 

 

Data Frame 

Termination 
Character 

Character 
0 

Character 
1 

Character 
2 

Character 
3 
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MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 RS-232 and related serial buses are industry standards 
and can be found in many embedded designs today. 

 Traditional manual decoding methods to decode these 
buses with an oscilloscope are time-consuming. 

 With the SR-COMP option installed, the MSO/DPO5000 
Series oscilloscope can trigger on, decode, and search RS-
232, RS-422, RS-485, and UART serial bus traffic. 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the SR-COMP: 
Computer Serial Triggering and 
Analysis option is installed. 

 Press the OK button. 
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Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has an RS-232 
signal which we can use for this lab: 

 

 The DPO Demo 2 board (020-2924-XX) also has RS-232 
and UART signals which we can use for this lab: 

 

DPO Demo Board Procedure: 

 Power up the DPO demo board. 

 Verify the green POWER LED is 
lit. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to the 
RS232_TX test point. 
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Manual RS-232 Bus Decoding 

Key Take Away Points 

 Notice that RS-232 signals are generally large signals, 
going positive and negative, with amplitudes from 3V to 
15V peak. These large amplitudes provide a very simple 
immunity from noise. 

 The display should look about like this: 

 

 Zoom in on one of the bursts of activity. This is a single RS-
232 character. The display should look something like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Set the channel 1 Vertical Scale 
to 5V/div. 

 Use the Trigger Level control to 
adjust the trigger level to the 
center of the waveform, about 0V. 

 Set the Horizontal Scale to 
1ms/div. This setting should 
allow a few bursts (RS-232 
characters) to be displayed on 
screen. 

 Press the front panel Single 
button. 

 

 

 Using the Wave Inspector pan 
and zoom controls, zoom in on 
one whole burst of signal. 
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Key Take Away Points 

 Notice the relatively long idle periods between signal bursts 
where the signal is low. 

 The RS-232 character begins with a positive pulse after the 
idle period. 

 The data bits come next, starting with the least-significant 
bit and ending with the most-significant bit. (In this case, we 
know that there are 8 data bits and no parity bit.) Low 
signals are digital 1s and high signals are digital 0s. 

 
 

 The binary message above, written in most- to least-
significant bit order is 01100010. This can also be written 
as 62 (hex) or ASCII “b”, as shown below. 

 Most engineers would prefer to use hexadecimal or “hex” 
notation, rather than binary. You can use the following 
chart to translate each group of 4 binary bits to a hex 
character: 

Binary Hex  Binary Hex 

0000 0  1000 8 

0001 1  1001 9 

0010 2  1010 A 

0011 3  1011 B 

0100 4  1100 C 

0101 5  1101 D 

0110 6  1110 E 

0111 7  1111 F 

 Since RS-232 is often used to transmit text characters, an 
even more popular code is ASCII. You can use the 
following chart to translate each hex character to a text 
character: 

MSO/DPO5000 Series Procedure: 

 

 

 Identify the start bit of the RS-232 
character. 

 Visually divide the rest of the 
character into 8 equal sections. 

 If the signal is low in any of the 8 
sections, write a “1” in the 
corresponding space below. If the 
signal is high in any of the 8 
sections, write a “0” in the 
corresponding space below. (See 
example at the left.) 

 

LSB                                          MSB 

___ ___ ___ ___  ___ ___ ___ ___ 

 

 Now, swap the order of the bits 
you wrote down, and divide the 8 
bits into two 4-bit groups 
(“nibbles”). This is the binary 
representation of the RS-232 
character. Write the binary 
character in the reverse order: 

 

MSB                                             LSB 

___ ___ ___ ___      ___ ___ ___ ___ 

 

 Now, using the table at the left, 
translate the character to hex and 
write the hex value below. 

 

___      ___ 

 

 Finally, using the hex-to-ASCII 
table, translate the character to 
hex and write the value below. 

 

___ 

Start bit 

LSB                        MSB 
    0   1   0   0   0   1   1   0 

Stop bit 
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Conclusion:  Manually decoding RS-232 data is a time-consuming process. Engineers are looking for a 
better and faster way to do this. 
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MSO/DPO5000 Series RS-232 Decoding Setup 

(optional) Determining RS-232 Bus Data Rate 

 The data rate of the RS-232 signal on both of the DPO 
demo boards is 9600 bits/second (also sometimes called 
“9600 baud”). However, in general, you may need to 
determine the data rate using this procedure. 

 In addition to the long list of preset bit rate values from 50 
bps to 10 Mbps, the custom bit rate control allows the user 
to set the bit rate to any value between 50 bps and 10 
Mbps in fine steps (which vary with the setting of the front 
panel Fine mode and also vary with the baud rate). 

 The display should look about like this: 

 

 Since the minimum pulse width is 104 s, the data rate is 
verified to be 9600 bits/second. This signal uses 8 data bits 
with no parity. The display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Using the Wave Inspector 
controls, zoom in on the 
narrowest pulse on the display. 

 Press the front panel Cursors 
button. 

 Using the Multipurpose controls, 
measure the width of the 
narrowest pulse by positioning 
the cursor cross-hairs near the 
center of the rising and falling 
edges of the pulse. 

 Read the bit rate (1/ time in the 
cursor readout) and write the 
value here:  ______ 

 Read the pulse width ( time in 
the cursor readout) and write the 
value here:  ______ 

 Using the Wave Inspector 
controls, zoom in on one whole 
burst of signal. 

 Using the Multipurpose controls, 
measure the width of the burst. 

 Read the burst width ( time in 
the cursor readout) and write the 
value here:  ______ 

 Divide this value by the pulse 
width value you recorded earlier, 
and subtract one (for the Start 
Bit). Assuming that there is no 
Parity bit being used, the result is 
the number of data bits (7 or 8). 
______ 

 Press the front panel Cursors 
button once to turn off cursors. 
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MSO/DPO5000 Series RS-232 Bus Decoding 

Key Take Away Points 

 As you personally experienced in the last part of the lab, 
manually decoding RS-232 signals can be a time-
consuming process. In this section, you will learn how to 
use the MSO/DPO5000 Series to automatically decode 
RS-232 packet content. 

 Setting up a basic RS-232 bus waveform display takes only 
a few simple steps with the MSO/DPO5000 Series. Notice 
that any of the analog or digital inputs or math signals can 
be used as a source for the RS-232 bus. 

 The display should now look about like this, with the 
hexadecimal decoded value shown in the bus waveform: 

 

 A lot simpler than manually decoding the data! 

 

MSO/DPO5000 Series Procedure: 

 Continue with same setup as 
previous lab. 

 Position the channel 1 waveform 
in the upper half of the display. 

 Press the purple front panel Bus 
B button to display the Bus Setup 
menu. 

 Under Bus Type, select Serial. 

 Using the drop down menu, select 
RS232. 

 Set the Data Components signal 
source to Ch1. 

 Double-click on the Threshold text 
box and set the value to 0V. 

 The default RS-232 bus values in 
the MSO/DPO5000 Series were 
chosen to match the signal on the 
DPO demo board, so many of the 
steps to the right have already 
been done for you. 

 For RS-232 transmitted signals 
which idle in the low-voltage 
state, select Normal Polarity 
(High = 0). For RS-422, RS-485, 
and UART signals, select 
Inverted Polarity (High = 1). 

 Using the Baud Rate drop down 
menu, select 9600 bps. 

 Using the Data Bits drop down 
menu, select 8 bits. 

 Using the Parity drop down 
menu, select None. 

 Press the Bus 1 button to turn 
bus B1 On. 

 Using the Bus 1 Position control, 
position the bus waveform as 
desired for easy viewing. 

 Press the Display tab at the left 
side of the control window. 

 Under Bus 1 Display, verify that 
Busform Style and Hex Decode 
are selected. 
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Key Take Away Points 

 Although the analog waveform display and the busform 
with hex values is familiar to most hardware engineers, 
there are another display formats that other engineers, 
such as software engineers, may find more useful. 

 The bus Waveform display shows the digital interpretation 
of the signal. This can be very useful for verifying that the 
threshold values are set appropriately. 

 In the case of RS-232 transmitted signals, ASCII is a 
common display format, especially when transmitting text 
messages. The display should now look something like 
this, with the ASCII decoded value shown in the bus 
waveform: 

 

 With this display, you can easily see the transmitted text 
message “Tektronix Enabling Innovation”: 

 

MSO/DPO5000 Series Procedure: 

 

 

 

 Select Both Bus Components. 

 

 

 Select the ASCII Bus 1 Display 
format. 

 

 

 

 

 

 

 

 

 

 

 

 

 Change the Horizontal Scale to 5 
ms/div. 

 Turn off zoom. 

 Press the front panel Single 
button. 
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Key Take Away Points 

 For some applications, it is more useful to be able to 
display the text strings that are transmitted. 

 With the packet view display, you can easily see the 
transmitted text message “Tektronix Enabling Innovation”: 

 

MSO/DPO5000 Series Procedure: 

 Change the Horizontal Scale to 
20 ms/div. 

 Press the front panel Single 
button. 

 Select Packet View. 

 Press the down arrow next to the 
End Of Packet text box. Notice 
the available packet termination 
characters. In this case, use the 
default 0Ah (LF) Line Feed 
character to terminate each 
packet. 
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MSO/DPO5000 Series RS-232 Bus Event Tables 

Key Take Away Points 

 Setting up a basic RS-232 bus event table display takes 
only a few simple steps with the MSO/DPO5000 Series. 

 The RS-232 bus Event Table display looks like this when 
the decode is set to Packet View: 

 

 The RS-232 bus Event Table display looks like this when 
the decode is set to ASCII character display: 

 

MSO/DPO5000 Series Procedure: 

 Press the Protocol Decode 
Event Table button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Press the Close button. 

 Deselect Packet View. 

 Press the Protocol Decode 
Event Table button. 

 Press the Export button. Notice 
that you can save the Event 
Table information to a file in.CSV 
format. When you are done, 
either Save the file or press 
Cancel. 

 

 

 

 

 When you are done with the 
setup, press the Close button. 
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MSO/DPO5000 Series RS-232 Bus Triggering 

Key Take Away Points 

 When debugging a system, you often want to capture the 
state of some key signals when a certain event occurs. 
One key event may be the transmission of specific content 
over the RS-232 serial bus. 

 

 The MSO/DPO5000 Series can trigger on the Start Bit, End 
of Packet, Data value, or Parity Error. 

 By following this simple procedure, you can easily trigger 
the oscilloscope on a specified serial pattern, capturing 
each occurrence. 

 

MSO/DPO5000 Series Procedure: 

 Draw a box around the packet at 
the trigger point and select Zoom 
1 On. 

 Press the front panel Trigger 
Menu button. 

 Using the Trigger Type drop down 
menu, select Bus triggering. 

 Using the Bus drop down menu, 
select B1. 

 Press the front panel Run/Stop 
button to re-start acquisitions. 

 Press the Mode tab and press the 
Normal Trigger Mode button. 

 Press the A Event tab. 

 

 

 

 

 

 Using the Trigger On drop down 
menu, select Data. 

 The easiest way to enter the 
address is with the Pattern Editor. 
Press the Edit button at the right. 

 Select Hex format. 

 Double click on the Data Value 
text box and set the ASCII data 
pattern to 0x54 to capture the ‘T’ 
character at the start of the 
“Tektronix” message. 

 When you are done, press OK. 

 Press the front panel Run/Stop 
button to re-start acquisitions. 

 Adjust the Wave Inspector Pan 
control as needed. 
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MSO/DPO5000 Series RS-232 Bus Searching 

Key Take Away Points 

 Once you have acquired a serial signal, you often want to 
find all occurrences of a certain event, such as the 
transmission of specific content over the RS-232 serial bus. 

 

 The MSO/DPO5000 Series can search on the Start Bit, 
End of Packet, Data value, or Parity Error. 

 By following this simple procedure, you can easily search 
an acquisition for a specified serial pattern on a RS-232 
signal, marking each occurrence. 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Search 
button. 

 Press the Bus Search button in 
the control window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Select the Configure tab at the 
left side of the control window. 

 Using the Search For drop down 
menu, select Data. 

 The easiest way to enter the 
address is with the Pattern Editor. 
Press the Edit button at the right. 

 Select Hex format. 

 Double click on the Data Value 
text box and set the ASCII data 
pattern to 0x54 to search for the 
‘T’ character at the start of the 
“Tektronix” message. 

 When you are done, press OK. 

 You can also do the same by 
pressing the Copy Settings 
button. 

 Press the front panel Run/Stop 
button to restart acquisitions. 

 Adjust the zoom window as 
needed to view the RS-232 
packets. 
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MSO/DPO5000 Series Support for RS-232-related Standards 

RS-232 is primarily focused on applications where these serial signals are transmitted between modules, 
over cables, and between products. RS-232 signals are transmitted single-ended, at relatively high voltage 
(up to ±15V), and inverted (so a digital 0 is a positive voltage and a 1 is a negative voltage). 

 

There are two other types of variants on the RS-232 family that are also addressed with the COMP option. 

The first is differential signaling, such as with the RS-422 and RS-485 standards. These standards specify 
transmission of a lower-voltage differential signal which is not inverted. Although one side of these 
differential signals can be probed with a passive probe, the TDP0500 and TDP1000 differential probes will 
provide better signal fidelity, especially in noisy environments. 

The second variant on RS-232 signals is the transmission of these serial signals between components on a 
single circuit board. This embedded system application, most commonly communication between a 
microcontroller and a Universal Asynchronous Receiver / Transmitter (UART) or RS-232 driver/receiver IC. 
These signals are single-ended and non-inverted, with standard logic levels. 

For both of these non-inverting RS-232 variants, you need to select Inverted Polarity in the Bus Setup 
control window. Otherwise, the signals are treated like RS-232 signals. 
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MSO5000/DPO5000 Series 
CAN Triggering and Decoding Lab 
 

 
 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.4 and with the SR-AUTO option installed 
One TPP0500 or TPP1000 passive probe 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this document were made with the DPO Demo 3 board] 
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Understanding the CAN Bus 

CAN (Controller Area Network) was developed by the Robert Bosch GmbH, in Germany, during the late 
1980’s. The need to specifically control and communicate with electronic control devices (ECUs) in 
electrically noisy environments was a driving force behind CAN. In 1992, Mercedes-Benz became the first 
automobile manufacturer to employ CAN in their higher end cars. Today almost every car manufacturer in 
the world employs CAN controllers and networks in systems such as windshield wiper motor controllers, rain 
sensors, airbags, door locks, engine timing controls, anti-lock braking systems, power train controls and 
electric windows, to name a few. CAN is rapidly expanding into other applications like industrial control, 
marine, medical, and aerospace. 

CAN is a two-wire, half-duplex, high-speed serial communications bus. It is a layered protocol where the 
transmission and physical layers are of primary interest here. Because CAN is an asynchronous the bus can 
be utilized as a differential balanced line similar to RS-232 but allows multiple masters on the same network. 
Data rates range from 10 Kbps (<6km) to 1Mbps (<40m) with a tradeoff between speed and bus length, 
decreasing the bit rate allows for longer bus lengths. Typically CAN is used for system-to-system 
communication between nodes (transceivers and receivers) which communicate on the bus by messages 
similar to Ethernet. 

There are a variety of CAN signals, as shown in the figure below. The transmitted data (Tx) and received 
data (Rx) signals are single-ended digital signals which are found at the inputs and outputs of devices such 
as CAN controllers and Electronic Control Units (ECUs). The messages transmitted between modules and 
products are carried on an inverted differential signal. The differential signal can be measured, or the 
individual signals (CAN_H and CAN_L) can be measured individually (if the signal-to-noise ratio is 
adequate). Because the signal amplitudes, polarities, and DC offsets vary between these different signals, 
you need to adjust your measurement setup and decoding method accordingly. 
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Identifiers, Arbitration and Frames 

CAN data messages are transmitted from any node by identifier (ID) not by address or data. Before a node 
sends a message out to another node it checks if the bus is busy - two nodes on the same network are not 
allowed to send messages at the same time – a node can detect if it has lost arbitration and stops 
transmitting, letting the other node, with the higher priority transmit uninterrupted. A CAN message is 
created using frames. The frames of interest are: Data Frames, Standard (11 bit ID) and Extended (29 bit 
ID). Both Data Frames can hold 0 to 8 bytes of data and are used when a node wants to transmit data on 
the network. Remote Frames are used to request information and the node having the information should 
then respond by sending it on the network. Error Frames are used to signal an error and can be transmitted 
by any node. Overloaded Frames are used to provide extra delay between data and remote frames when a 
node is busy. 

 

Bit stuffing 

In CAN frames a bit of opposite polarity is inserted after five consecutive bits of the same polarity. This 
practice is called bit stuffing, and is due to the Non-Return-to-Zero (NRZ) coding. The "stuffed" data frames 
are un-stuffed by the receiver. Since bit stuffing is used, six consecutive bits of the same type (111111 or 
000000) are considered an error. The bits in a CAN message are sent either high or low: high bits are 
recessive; low bits are dominant. 

Lab Objectives 

- Obtain a basic understanding of the CAN serial bus. 

- Learn how to use oscilloscopes to measure and decode CAN signals. 

- Learn how to setup a CAN serial bus display, and trigger and search on CAN bus content with an 
MSO/DPO5000 Series oscilloscope. 

 

MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 CAN serial buses are industry standards and can be found 
in many embedded designs today. 

 Traditional manual decoding methods to decode these 
buses with an oscilloscope are time-consuming. 

 With the SR-AUTO option installed, the MSO/DPO5000 
Series oscilloscope can trigger on, decode, and search 
CAN bus traffic. 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the SR-AUTO: 
Automotive Serial Triggering 
and Analysis 
(CAN/LIN/FlexRay) option is 
installed. 

 Press the OK button. 
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Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has CAN signals 
which we can use for this lab: 

 

 The DPO Demo 2 board (020-2924-XX) also has CAN 
signals which we can use for this lab: 

 

DPO Demo Board Procedure: 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the green POWER LED is 
lit. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to the CAN_H 
test point. 
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Manual CAN Bit Rate Measurement 

Key Take Away Points 

 On the DPO Demo 3 and DPO Demo 2 boards, the CAN 
bit rate is 500 kbps. 

 With the SR-AUTO option, the MSO/DPO5000 provides a 
list of common bit rate values to choose from, ranging from 
10 kbps to 1 Mbps. 

 However, in general, you may not know what the bit rate is. 
Because CAN is an asynchronous bus, you must 
accurately determine the bit rate before the bus can be 
properly decoded. This section of the lab explains how to 
measure the CAN bit rate. The display should look about 
like this: 

 

 The cursor measurement of the pulse width of the 
narrowest pulse indicates a 2 µs minimum pulse width. 
Compare this pulse width with the values in the following 
chart to determine the CAN bit rate: 

Minimum CAN Pulse Width CAN Bit Rate 

1 s 1 Mbps 

1.25 s 800 kbps 

2 s 500 kbps 

4 s 250 kbps 

8 s 125 kbps 

12 s 83.3 kbps 

16 s 62.5 kbps 

20 s 50 kbps 

30 s 33.3 kbps 

50 s 20 kbps 

100 s 10 kbps 

  

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Set channel 1 Vertical Scale to 
1V/div. 

 Set the Horizontal Scale to 
1ms/div. 

 Press the Trigger Level control to 
automatically adjust the trigger 
level to the center of the AC 
portion of the CAN signal, about 
3V. 

 Press the front panel Single 
button. 

 Using the mouse or the touch 
screen, draw a narrow zoom box 
around the trigger point at the 
center of the display and select 
Zoom 1 On. 

 If necessary, zoom again on the 
waveform to resize the zoom box 

 Press the front panel Cursors 
button once. 

 Using the Multipurpose a and b 
controls, position the cursors on 
the rising and falling edge of a 
narrow pulse to measure the 
pulse width. 

 When done, press the front panel 
Cursors button once. 
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MSO/DPO5000 Series CAN Bus Setup and Decoding 

Key Take Away Points 

 Setting up a basic CAN bus waveform display takes only a 
few simple steps with the MSO/DPO5000 Series. 

 Notice that any of the analog or digital inputs or math 
signals can be used as a source for the CAN bus. For 
example, you can probe CAN_H with a passive probe on 
channel 1 and CAN_L with a passive probe on channel 2 
and decode the differential math signal M1 = Ch1-Ch2. 

 The CAN Bus Setup menu looks like this: 

 

 The CAN bus Display menu looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the purple front panel Bus 
B button to display the Bus Setup 
menu. 

 Under Bus Type, select Serial. 

 Using the drop down menu, select 
CAN. 

 Verify that the CAN_H input 
signal is set to Ch1. 

 Verify that the Threshold settings 
are about 3V. 

 Press the Bus 1 button to turn 
bus B1 On. 

 

 

 

 

 

 Press the Display tab at the left 
side of the control window. 

 Under Bus 1 Display, verify that 
Busform Style is selected. 

 Select Hex Decode. 

 Adjust the zoom factor and 
position of the zoom window to 
view the decoded bus 
information. 

 The green bar symbol represents 
the start of packet. 

 ID packets are shown in yellow 
boxes. 

 Missing Acks are shown as red ‘!’ 
symbols. 

 Data packets are shown in cyan 
boxes. 

 DLCs and CRCs are shown in 
blue boxes. 

 Errors are shown in red boxes. 

 The red bar symbol represents 
the end of the CAN packet. 
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MSO/DPO5000 Series CAN Bus Event Tables 

Key Take Away Points 

 Setting up a basic CAN bus event table display takes only 
a few simple steps with the MSO/DPO5000 Series. 

 The CAN bus event table display looks like this: 

 

 The docked CAN bus event table display looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the Protocol Decode 
Event Table button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Press the Dock button. 

 Press the X in the upper right 
corner of the control window to 
close it. 

 Click on one of the rows in the 
Event Table and notice the zoom 
box is repositioned to correspond 
to the selected row. 

 

 

 

 

 

 

 When you are done with the 
event table, press the X in the 
upper right corner to close it. 
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MSO/DPO5000 Series CAN Bus Triggering 

Key Take Away Points 

 When debugging a system, you often want to capture the 
state of some key signals when a certain event occurs. 
One key event may be the transmission of specific content 
over the CAN serial bus. 

 NOTE: The trigger source must be an input channel. If you 
are decoding a bus based on a math signal, simply set up 
another bus based on an input channel and trigger on that 
bus. 

 The MSO/DPO5000 Series can trigger on Start of Frame, 
Type of Frame (Data, Remote, Error, Overload), Identifier, 
Data, Ident & Data, EOF, Missing Ack, and Bit Stuffing 
Error. 

 

 By following this simple procedure, you can easily trigger 
the oscilloscope on a specified serial pattern on a CAN 
signal, capturing each occurrence. 

 

MSO/DPO5000 Series Procedure: 

 Select Trig->Bus Setup…. 

 Using the Bus drop down menu, 
select B1. 

 Notice that, by default, Trigger On 
Start of Frame is selected. 

 Press the front panel Single 
button. 

 

 

 

 

 

 

 

 

 

 

 

 Using the Trigger On drop down 
menu, select Identifier. 

 Select Hex Standard format. 

 Press the Edit button. 

 Enter the identifier value 757 hex. 
As you enter the values, notice 
that the values in the other 
radices are also updated. 

 When you are done, press OK. 

 In the Direction section, select 
Read and Write. 

 Press the front panel Single 
button. 

 Adjust the MultiView Zoom pan 
and zoom controls as needed to 
view the CAN packets. 
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MSO/DPO5000 Series CAN Bus Searching 

Key Take Away Points 

 Once you have acquired a serial signal, you often want to 
find all occurrences of a certain event, such as the 
transmission of specific content over the CAN serial bus. 

 

 The MSO/DPO5000 Series can search on Start of Frame, 
Type of Frame (Data, Remote, Error, Overload), Identifier, 
Data, Ident & Data, EOF, Missing Ack, and Bit Stuffing 
Error. 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Search 
button. 

 Press the Bus button in the 
control window. 

 

 

 

 

 

 

 

 

 

 

 

 Press the Configure tab at the 
left side of the control window. 

 Notice that, by default, Search 
For Start of Frame is selected. 

 Using the front panel left and right 
arrows, navigate between search 
events. 
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Key Take Away Points 

 By following this simple procedure, you can easily search 
an acquisition for a specified serial pattern on a CAN 
signal, marking each occurrence. 

 

 The Results Table looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Using the Search For drop down 
menu, select Identifier. 

 Select Hex Standard format. 

 Press the Edit button. 

 Enter the identifier value 057 hex. 
As you enter the values, notice 
that the values in the other 
radices are also updated. 

 When you are done, press OK. 

 In the Direction section, select 
Read and Write. 

 Using the front panel left and right 
arrows, navigate between search 
events. 

 

 

 

 Press the Results tab at the left 
side of the control window to 
display the table of search results. 
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MSO5000/DPO5000 Series 
LIN Triggering and Decoding Lab 
 

 
 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.4 and with the SR-AUTO option installed 
One TPP0500 or TPP1000 passive probe 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this document were made with the DPO Demo 3 board] 
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Understanding the LIN Bus 

Local Interconnect Network (LIN) is one of the older low-speed serial standards for the automotive industry, 
developed by the LIN consortium in 1999 as a lower-cost alternative to the CAN bus for applications where 
CAN’s cost, versatility, and speed were overkill. LIN applications typically include communications between 
intelligent sensors and actuators such as window controls, door locks, rain sensors, windshield wiper 
controls, and climate control, to name a few. However, due to its electrical noise tolerance, error-detection 
capabilities, and high speed data transfer, CAN is still used today for engine timing controls, anti-lock 
braking systems, power train controls and more. 

The LIN bus is a low-cost, single-wire implementation based on the Enhanced ISO9141 standard. LIN 
networks have a single master and one or more slaves. LIN signals can be transmitted over distances up to 
40 meters. All messages are initiated by the master with only one slave responding to each message, so 
collision detection and arbitration capabilities are not needed as they are in CAN. Communication is based 
on UART/SCI with data being sent in eight-bit bytes along with a start bit, stop bit and no parity. Data rates 
range from 1kb/s to 20kb/s. While this may sound slow, it is suitable for the intended applications and 
minimizes EMI. 

LIN signal level are defined as follows: 
o Recessive (high) ≥0.6 * system supply voltage 
o Dominant (low) ≤0.4 * system supply voltage 
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The LIN bus is always in one of two states: active or sleep. When it’s active, all nodes on the bus are awake 
and listening for relevant bus commands.  Nodes on the bus can be put to sleep by either the Master issuing 
a Sleep Frame or the bus going inactive for longer than a predetermined amount of time. The bus is then 
awakened by any node requesting a wake up or by the master node issuing a break field. 

LIN frames consist of two main parts, the header and the response.  The header is sent by the master while 
the response is sent by the slave.  The LIN message frame looks like this: 

 
Header Components: 

 Sync Break – marks the beginning of the Message Frame. It activates and instructs all slave devices to 
listen to the remainder of the header. 

 Sync Field – an alternating bit pattern which is used by the slave nodes for determination of the baud 
rate being used by the master node and synchronize themselves accordingly. 

 Identifier Field –specifies which slave device is to take action. The ID Field contains four elements: 

 Message Identifier: identifies the sender, the receiver, the purpose, and data field length 6 Bit 

 4 classes of 2/4/8 data bytes 

 16 identifiers 

 2 parity bits 
 
Response Components: 

 Data – the specified slave device responds with one to eight bytes of data 

 Checksum – computed field used to detect errors in data transmission.  The LIN standard has evolved 
through several versions that have used two different forms of checksums.  Classic checksums are 
calculated only over the data bytes and are used in version 1.x LIN systems.  Enhanced checksums are 
calculated over the data bytes and the identifier field and are used in version 2.x LIN systems. 

 
The LIN bus transmits signals in three ways: 

 Unconditional: The most typical LIN frame where the bus master sends the frame header in a 
scheduled frame slot and the designated slave node fills the frame with data. 

 Event-triggered: Receives maximum information from slave nodes without overloading bus. Event 
Triggered Frames can be filled with data from multiple slave nodes. 

 Sporadic: Sent only from master when a signal is updated in a slave node. Usually the master fills the 
data bytes of the frame and slave nodes receive information. 

Lab Objectives 

- Obtain a basic understanding of the LIN serial bus. 

- Learn how to use oscilloscopes to measure and decode LIN signals. 

- Learn how to setup a LIN serial bus display and trigger and search on LIN bus content with an 
MSO/DPO5000 Series oscilloscope. 

 

Message Frame 

Inter-byte space 

Header Response 

Sync 
Break 

Sync 
Field 

ID 
Field 

Data 
Field 

Data 

Field 
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MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 The LIN bus is an industry standard and can be found in 
many automotive designs today. 

 Traditional manual LIN decoding methods are time-
consuming. 

 With the SR-AUTO option installed, the MSO/DPO5000 
Series oscilloscope can trigger on, decode, and search LIN 
bus traffic. 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the SR-AUTO: 
Automotive Serial Triggering 
and Analysis 
(CAN/LIN/FlexRay) option is 
installed. 

 Press the OK button. 
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Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has a LIN signal 
which we can use for this lab: 

 

 The DPO Demo 2 board (020-2924-XX) also has a LIN 
signal which we can use for this lab: 

 

DPO Demo Board Procedure: 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the green POWER LED is 
lit. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to the LIN test 
point. 
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Manual LIN Bit Rate Measurement 

Key Take Away Points 

 The data rate of the LIN signal on the DPO demo board is 
about 19200 bits/second and this is the default setting in 
the oscilloscope, as you will soon see. However, in general, 
you may need to determine the data rate using this 
procedure. 

 With the SR-AUTO option, the MSO/DPO5000 provides a 
list of common bit rate values to choose from 1.2 kb/s to 
19.2 kb/s in fixed steps, and custom bit rates from 800 b/s 
to 100 kb/s. 

 Since LIN slaves depend upon the average bit rate in the 
sync field, let’s measure that. The measurement below 
indicates that the average single bit width (428 µs / 8 bits) 
is about 53 µs, so the bit rate is verified to be about 
19.2kbps. 

 The display should look about like this: 

 

 Look up the data rate in this table: 

Average Sync 
Bit Width 

Data Rate (bits / 
sec) 

50 s 20000 

52.1 s 19200 

66.7 s 15000 

100 s 1000 

200 s 5000 

1 ms 1000 

2 ms 500 

  

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button. 

 Press the front panel Autoset 
button. 

 Set the Trigger Level control to 
about 3V. 

 Set the Horizontal Scale to 
200µs/div. 

 Trigger on the sync break by 
triggering on a relatively long 
negative pulse. 

 Select Trig -> Glitch 
Setup…. 

 Under Glitch Width, select 
Greater Than. 

 Press the Neg button in the 
Polarity section to trigger on 
negative pulses. 

 Double-click on the Width 
text box, type in 500µ, and 
press Enter. 

 Press the front panel Single 
button. 

 Press the front panel Cursors 
button once. 

 Using the Multipurpose controls, 
measure the width of the 8-bit 
sync field (01010101), starting 
with the negative edge, as shown 
in the screen shot at the left. 

 Read the sync field burst width ( 
time in the cursor readout) and 
write the value here:  ______ 

 Divide the burst width by 8 to get 
the average sync bit width and 
write the value here:  ______ 

 Look up the data rate in the table 
at the left and write the value 
here:  ______ 
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MSO/DPO5000 Series LIN Bus Setup and Decoding 

Key Take Away Points 

 Setting up a basic LIN bus waveform display takes only a 
few simple steps with the MSO/DPO5000 Series. 

 Notice that any of the analog or digital inputs or math 
signals can be used as a source for the LIN bus. The LIN 
Bus Setup menu looks like this: 

 

 The LIN bus Display menu looks like this: 

 

 The green bar symbol represents the start of packet and 
the red bar symbol represents the end of packet. 

 Break and Sync are shown in blue boxes, ID and Parity are 
shown in yellow boxes, Data packets are shown in cyan 
boxes, Checksum and Wakeup are shown in blue boxes, 
and errors are shown in red boxes. 

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup and Autoset buttons. 

 Set channel 1 Vertical Scale to 
2V/div. 

 Set the Trigger Level control to 
about 3V. 

 Set the Horizontal Scale to 
200ms/div. 

 Select Trig->Mode… and press 
the Norm button. 

 Select Horiz/Acq ->Roll Mode 
Auto to uncheck it. 

 Select Horiz/Acq ->Resolution 
control. 

 Double-click on the Sample Rate 
text box and use the Multipurpose 
a control to adjust the Sample 
Rate to 500 kS/s, setting the 
record length to 1.0M points. 

 Press the front panel Single 
button. 

 Press the purple front panel Bus 
B button. 

 Select Serial Bus Type, and then 
select LIN. 

 Verify that the Data signal is on 
Ch1, the Ch1 Threshold setting is 
about 1.4V, the LIN Standard is 
set to v2.x, the Bit Rate is set to 
19.2kb/s, and the Include Parity 
Bits with ID check box is not 
checked. 

 Press the Bus 1 button to turn 
bus B1 On. 

 Position the bus waveform below 
the LIN waveform as desired. 

 Press the Display tab at the left 
side of the control window. 

 Under Bus 1 Display, verify that 
Busform Style and Mixed 
Decode are selected. 
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MSO/DPO5000 Series LIN Bus Event Tables 

Key Take Away Points 

 Setting up a basic LIN bus event table display takes only a 
few simple steps with the MSO/DPO5000 Series. 

 The LIN bus event table display looks like this: 

 

 The docked LIN bus event table display looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the Protocol Decode 
Event Table button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Press the Dock button. 

 Press the X in the upper right 
corner of the control window to 
close it. 

 Click on one of the rows in the 
Event Table and notice the zoom 
box is repositioned to correspond 
to the selected row. 

 

 

 

 

 

 When you are done with the 
setup, press the X in the upper 
right corner of the control window 
to close it. 
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MSO/DPO5000 Series LIN Bus Triggering 

Key Take Away Points 

 When debugging a system, you often want to capture the 
state of some key signals when a certain event occurs. 
One key event may be the transmission of specific content 
over the LIN serial bus. 

 The MSO/DPO5000 Series can trigger on Sync, Identifier, 
Data, ID and Data, Wakeup Frame, Sleep Frame, and 
Error (Sync, ID Parity, Checksum). 

 

 By following this simple procedure, you can easily trigger 
the oscilloscope on a specified serial pattern on a LIN 
signal, capturing each occurrence. 

 

MSO/DPO5000 Series Procedure: 

 Select Trig->Bus Setup…. 

 Using the Bus drop down menu, 
select B1. 

 Notice that, by default, Trigger On 
Sync is selected. 

 Press the front panel Single 
button. 

 

 

 

 

 

 

 

 

 

 

 

 

 Using the Trigger On drop down 
menu, select Identifier. 

 Select Hex format. 

 Press the Edit button at the right. 

 Double click on the Identifier text 
box and enter the value 00 hex. 
As you enter the values, notice 
that the values in the other 
radices are also updated. 

 When you are done, press OK. 

 Press the front panel Single 
button. 

 Adjust the MultiView Zoom pan 
and zoom controls as needed to 
view the LIN packets. 
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MSO/DPO5000 Series LIN Bus Searching 

Key Take Away Points 

 Once you have acquired a serial signal, you often want to 
find all occurrences of a certain event, such as the 
transmission of specific content over the LIN serial bus. 

 

 The MSO/DPO5000 Series can search on Sync, Identifier, 
Data, ID and Data, Wakeup Frame, Sleep Frame, and 
Error (Sync, ID Parity, Checksum). 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Search 
button. 

 Press the Bus button in the 
control window. 

 

 

 

 

 

 

 

 

 

 

 

 Press the Configure tab at the 
left side of the control window. 

 Notice that, by default, Search 
For Sync is selected. 

 Using the front panel left and right 
arrows, navigate between search 
events. 
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Key Take Away Points 

 By following this simple procedure, you can easily search 
an acquisition for a specified serial pattern on a LIN signal, 
marking each occurrence. 

 

 The Event Table results table looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Using the Search For drop down 
menu, select Identifier. 

 Select Hex format. 

 Press the Edit button at the right. 

 Double click on the Identifier text 
box and enter the value 0X hex. 
As you enter the values, notice 
that the values in the other 
radices are also updated. 

 When you are done, press OK. 

 Using the front panel left and right 
arrows, navigate between search 
events. 

 

 

 

 Press the Results tab at the left 
side of the control window to 
display the table of search results. 
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MSO5000/DPO5000 Series 
FlexRay Triggering and Decoding Lab 
 

 
 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.4 and with the SR-AUTO option installed 
One TDP0500 or TDP1000 differential probe 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this document were made with the DPO Demo 3 board] 
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Understanding the FlexRay Bus 

FlexRay is the most significant of several emerging low-speed serial standards for the automotive industry. 
FlexRay is still being developed by a group of leading automotive companies and suppliers known as the 
FlexRay Consortium. As cars get smarter and electronics find their way into more and more automotive 
applications, manufacturers are finding that existing automotive serial standards such as CAN and LIN do 
not have the speed, reliability, or redundancy required to address X-by-wire applications such as brake-by-
wire or steer-by-wire. 

Today, these functions are dominated by mechanical and hydraulic systems. In the future they will be 
replaced by a network of sensors and highly reliable electronics that will not only lower the cost of the 
automobile, but also significantly increase passenger safety due to intelligent electronic-based features such 
as anticipatory braking, collision avoidance, adaptive cruise control, etc. 

The SR-AUTO application for the MSO/DPO5000 Series provides optional serial triggering and analysis for 
FlexRay. This lab will walk you through the most significant of the capabilities of the product. 

FlexRay is a differential automotive serial bus which transmits data at rates up to 10 Mbps. The FlexRay 
information is transmitted over unshielded twisted-pair (UTP) cables and shielded twisted-pair (STP) cables 
(for better EMC performance). This is significantly faster than LIN’s 20 kb/s or CAN’s 1 Mb/s rates. FlexRay 
uses a dual channel architecture which has two major benefits. First, the two channels can be configured to 
provide redundant communication in safety critical applications such as x-by-wire to ensure the message 
gets through. Second, the two channels can be configured to send unique information on each at 10 Mb/s, 
giving an overall bus transfer rate of 20 Mb/s in less safety critical applications. 

FlexRay uses a time-triggered protocol that incorporates the advantages of prior synchronous and 
asynchronous protocols via communication cycles that include both static and dynamic frames. Static 
frames are time slots of predetermined length allocated for each device on the bus to communicate during 
each cycle. Each device on the bus is also given a chance to communicate during each cycle via a Dynamic 
frame which can vary in length (and time). 
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The FlexRay frame is made up of three major recurring segments (Header, Payload, and Trailer), separated 
by idle periods. At the end of the idle period there is a: 

 TSS (Transmission Start Sequence): 3-15 bits, which initiates network connection setup 

 FSS (Frame Start Sequence): 1 bit which immediately follows TSS. 

Then Header Segment is 5 bytes long and contains: 

 Indicator Bits: 5 bits which provide Header Segment preamble information. The combination of 
the bits specify the type of frame: 

 Null / Normal / Payload 
 Sync / Startup 

 Frame Id (Frame Identifier): 11 bits which define the slot in which the frame is transmitted. 
Frame IDs range from 1 to 2047 with any individual frame ID being used no more than once on 
each channel in a communication cycle. 

 Payload Length: 7 bits which specify the number of data words being transferred in the frame. 

 Header CRC (Header Cyclic Redundancy Code): error-detection protection for part of the 
Header Segment, calculated over the sync frame indicator, the startup frame indicator, the 
frame ID and the payload length. 

 Cycle Count: the value of the current communication cycle, which can range from 0-63. This 
value is incremented at the start of each communication cycle. 

The Payload Segment contains the data transferred by the frame. The Payload Segment has a variable 
length, from 0 to a maximum payload length of 127 words (254 bytes). For frames transmitted in the static 
segment the first 0 to 12 bytes of the payload segment may optionally be used as a network management 
vector. The payload preamble indicator in the frame header indicates whether the payload segment contains 
the network management vector.  For frames transmitted in the dynamic segment the first two bytes of the 
payload segment may optionally be used as a message ID field, allowing receiving nodes to filter or steer 
data based on the contents of this field. The payload preamble indicator in the frame header indicates 
whether the payload segment contains the message ID. 

The Trailer Segment contains a single 24-bit CRC to provide error-detection protection for the Header and 
Payload segments. 

Each frame is delimited with a bus idle signal. 

 FES (End of Frame): 2 bits, immediately following the Trailer CRC. 

 DTS (Dynamic Trailing Sequence): follows a dynamic frame and prevents premature channel 
idle detection by the bus receivers. 

CID (Channel Idle Delimiter): minimum of 11 bits which indicate the beginning of the idle period. 
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Key Take Away Points 

 The FlexRay signals on the demo board look about like this, where the yellow channel 1 signal is 
the positive FLEX_RAY_BP and the cyan channel 2 signal is the negative FLEX_RAY_BM: 

 

 Notice that FlexRay signals are relatively large signals, with multiple voltage levels. 

 FlexRay signal levels are defined as follows: 

 

 BP (Bus Plus): the positive side of the differential FlexRay signal. 

 BM (Bus Minus): the negative side of the differential FlexRay signal. 

 Data_1: positive differential voltage between BP and BM. 

 Data_0: negative differential voltage between BP and BM. 

 Idle: biased to a mid-level voltage, BP=BM. 

 Idle_LP (Low Power): biased to ground. No current to BP or BM. 
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Lab Objectives 

- Obtain a basic understanding of the FlexRay serial bus. 

- Learn how to use oscilloscopes to measure and decode FlexRay signals. 

- Learn how to setup a FlexRay serial bus display and trigger and search on FlexRay bus 
content with an MSO/DPO5000 Series oscilloscope. 

 
 
 

MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 The FlexRay bus is an industry standard and can be found 
in many automotive designs today. 

 Traditional manual FlexRay decoding methods are time-
consuming. 

 With the SR-AUTO option installed, the MSO/DPO5000 
Series oscilloscope can trigger on, decode, and search 
FlexRay bus traffic. 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the SR-AUTO: 
Automotive Serial Triggering 
and Analysis 
(CAN/LIN/FlexRay) option is 
installed. 

 Press the OK button. 
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Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has a FlexRay 
signal which we can use for this lab: 

 

 The DPO Demo 2 board (020-2924-XX) also has a 
FlexRay signal which we can use for this lab: 

 

DPO Demo Board Procedure: 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the green POWER LED is 
lit. 

 Attach a TDP0500 or TDP1000 
differential probe to the Channel 1 
input of the oscilloscope. Then 
connect the probe’s + input to 
FLEX_RAY_BP and connect the 
probe’s - input to the 
FLEX_RAY_BM test point. 
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MSO/DPO5000 Series FlexRay Bus Setup and Decoding 

Key Take Away Points 

 Setting up a basic FlexRay bus waveform display takes 
only a few simple steps with the MSO/DPO5000 Series. 

 Notice that any of the analog or digital inputs or math 
signals can be used as a source for the FlexRay bus. 

 The MSO/DPO5000 Series can trigger and decode 
FlexRay signals at the preset bit rates of 2.5, 5, and 10 
Mbps, or at any user-selectable value from 1 Mbps to 10 
Mbps (in 10 kbps increments with the front panel Fine 
mode selected and 100 kbps increments with the Fine 
mode deselected). 

  The FlexRay Bus Setup menu looks like this: 

 

 The FlexRay bus Display menu looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Set channel 1 Vertical Scale to 
2V/div. 

 Use the Trigger Level control to 
adjust the trigger level below the 
center of the waveform, about 
-1V. 

 Set the Horizontal Scale to 
100μs/div. 

 Select Trig->Mode… and press 
the Norm button. 

 Press the front panel Single 
button. 

 Press the purple front panel Bus 
B button. 

 Select Serial Bus Type, and then 
select FLEXRAY. 

 Verify that the Signal Type is set 
to Bdiff or BP (Polarity Normal: 
High = 1) and the Input signal is 
on Ch1. 

 Set the Threshold (H) value to 
about +1.6V, the Threshold (L) 
value to about -1.6V, and the 
Channel Type is set to B. 

 Verify the Bit Rate is set to 
10 Mb/s. 

 Press the Bus 1 button to turn 
bus B1 On. 

 Position the bus waveform below 
the FlexRay waveform as desired. 

 Press the Display tab at the left 
side of the control window. 

 Under Bus 1 Display, verify that 
Busform Style and Mixed 
Busform Decode are selected. 

 Zoom in on the signal until you 
can read the individual decoded 
signal elements. 
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Key Take Away Points 

 The green bar symbol represents the start of packet and 
the red bar symbol represents the end of packet. 

 

 Notice that TSS appears in purple, followed by the green 
start of frame bar. The Header segment begins with the 
indicator bits in purple, followed by the frame ID in yellow, 
the payload length and header CRC in purple, and the 
cycle count in yellow. The data in the Payload segment are 
shown in cyan. Finally, the Trailer CRC, DTS, and CID are 
shown in purple and the end of frame bar is red. Errors are 
shown in red. 

 

MSO/DPO5000 Series Procedure: 

 Pan through the display to see 
what the decoded signal 
elements look like. 
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MSO/DPO5000 Series FlexRay Bus Event Tables 

Key Take Away Points 

 Setting up a basic FlexRay bus event table display takes 
only a few simple steps with the MSO/DPO5000 Series. 

 The FlexRay bus event table display looks like this: 

 

 The docked FlexRay bus event table display looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the Protocol Decode 
Event Table button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Press the Dock button. 

 Press the X in the upper right 
corner of the control window or 
press the front panel Menu Off 
button to close the control panel. 

 Click on one of the rows in the 
Event Table and notice the zoom 
box is repositioned to correspond 
to the selected row. 

 

 

 

 

 

 When you are done with the 
setup, press the X in the upper 
right corner of the control window 
to close it. 
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MSO/DPO5000 Series FlexRay Bus Triggering 

Key Take Away Points 

 When debugging a system, you often want to capture the 
state of some key signals when a certain event occurs. 
One key event may be the transmission of specific content 
over the FlexRay serial bus. 

 The MSO/DPO5000 Series can trigger on: 

o Start of Frame 
o Indicator Bits (Normal, Payload, Null, Sync, Startup) 
o Identifier (=, ≠, <, ≤, ≥, >) 
o Cycle Count (=, ≠, <, ≤, ≥, >) 
o Header Fields 
o Data (=, ≠, <, ≤, ≥, >) 
o ID & Data (=, ≠, <, ≤, ≥, >) 
o End of Frame (All, Static Frame, Dynamic Frame) 
o Error (Header CRC, Trailer CRC, Null Frame(Static), 

Null Frame (Dynamic), Sync Frame in Dynamic, 
Startup Frame(No Sync)) 

 By following this simple procedure, you can easily trigger 
the oscilloscope on a specified serial pattern on a FlexRay 
signal, capturing each occurrence. 

 

MSO/DPO5000 Series Procedure: 

 Select Trig->Bus Setup…. 

 Using the Bus drop down menu, 
select B1. 

 Notice that, by default, Trigger On 
Start of Frame is selected. 

 Using the Trigger On drop down 
menu, select Identifier. 

 Select Hex format. 

 Press the Edit button at the right. 

 Double click on the Identifier text 
box and enter the value 004 hex. 
As you enter the values, notice 
that the values in the other 
radices are also updated. 

 When you are done, press OK. 

 Press the front panel Single 
button. 

 Adjust the MultiView Zoom pan 
and zoom controls as needed to 
view the FlexRay packets. 
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MSO/DPO5000 Series FlexRay Bus Searching 

Key Take Away Points 

 Once you have acquired a serial signal, you often want to 
find all occurrences of a certain event, such as the 
transmission of specific content over the FlexRay serial 
bus. 

 

 The MSO/DPO5000 Series can search on Start of Frame, 
Indicator Bits, Identifier, Cycle Count, Header Fields, Data, 
Ident & Data, End of Frame, and Error. 

 By following this simple procedure, you can easily search 
an acquisition for a specified serial pattern on a FlexRay 
signal, marking each occurrence: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Search 
button. 

 Press the Bus button in the 
control window. 

 

 

 

 

 

 

 

 

 

 

 

 Press the Configure tab at the 
left side of the control window. 

 Notice that, by default, Search 
For Start of Frame is selected. 

 Under Trigger On, select 
Identifier. 

 Select Binary format. 

 Press the Edit button at the right. 

 Double click on the binary text 
box and enter the binary value 
000 0000 XXX1. As you enter the 
values, notice that the values in 
the other radices are also 
updated. 

 When you are done, press OK. 

 Using the front panel left and right 
arrows, navigate between search 
events. 
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Key Take Away Points 

 The search results can also be displayed in tabular format. 
The Event Table results table looks like this: 

 

 When you select a row in the results table, the display 
looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the Results tab at the left 
side of the control window to 
display the table of search results. 

 

 

 

 

 

 

 

 

 

 

 

 Click on one of the rows in the 
Event Table and notice the zoom 
box is repositioned to correspond 
to the selected row. 
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MSO5000/DPO5000 Series 
MIL-STD-1553 Triggering 
and Decoding Lab 
 

 
 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.4 and with the SR-AERO option installed 
One TDP0500 or TDP1000 differential probe 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

a MIL-STD-1553 reference waveform 
[Note: screen shots in this document were made with the DPO Demo 3 board] 
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Understanding the MIL-STD-1553 Bus 

Similar to the computer industry’s LAN, MIL-STD-1553 is a military standard that defines the electrical and 
protocol characteristics of a serial bus initially designed for data communication in avionics applications. 

MIL-STD-1553 began with the development of the A2-K draft standard by the Society of Automotive Engineers 
(SAE) in 1970. After government and military reviews and revisions, it was released as MIL-STD-1553 (USAF) in 
1973. MIL-STD-1553A was released in 1975 to support all of the branches of the military, and the SAE then 
released and froze the MIL-STD-1553B standard to enable component manufacturers to build compliant products. 
The most recent changes, documented as Notice 2, was released in 1986 to provide a common set of operational 
characteristics. The standard is now overseen by SAE as commercial document AS15531. 

Although the standard was widely used in US military applications, it has also been used commercially in mass-
transportation, spacecraft, and manufacturing applications, and has been accepted and implemented by NATO 
and many other governments. 

The SR-AERO application for the MSO/DPO5000 Series provides optional serial triggering and analysis for 
MIL-STD-1553. This lab will walk you through the most significant of the capabilities of the product. 

MIL-STD-1553 asynchronously transmits messages of up to thirty-two 16-bit data words at bit rates of up to 10 
Mb/s over shielded twisted-pair and twinax cabling. A 1553 network uses time-division multiplexed half-duplex 
communication to transmit data over a single cable. For safety-critical applications, dual redundant buses are 
commonly used to provide higher-reliability communications. Manchester II bi-phase encoding is used to allow 
direct or transformer coupling. Manchester encoding is self-clocking, independent of the bit sequence, and is DC-
balanced. Because the information in Manchester coded signals is actually contained in the polarity and timing of 
the zero-crossings, the 1553 bus is tolerant of large variations in signal levels. 

MIL-STD-1553 defines three distinct word types: Command words, Data words, and Status words. All are twenty-
bit structures, with a 3-bit synchronization field, a 16-bit information field, and finally an odd parity bit for simple 
error detection. The sync field is an invalid Manchester signal, with a single transition in the middle of the second 
bit time. A command/status sync has a negative transition in the middle, while a data sync has a positive 
transition. 

Command words, sent by the active bus controller, specify the function that a remote terminal is to perform. The 
16-bit information field contains a 5-bit terminal address which uniquely identifies the terminal, a transmit/receive 
bit, 5 bits of sub-address or mode, and 5 bits of word count or mode code. 

 

Data words, transmitted by either a bus controller or remote terminal, are sent with the most-significant-bit first. 

 

Status words are returned by remote terminals in response to a valid message from the controller to acknowledge 
receipt of a message or to convey the remote terminal status. The first 5 bits of the 16-bit information field are the 
terminal address. The remaining bits represent specific status information, including Message Error, 
Instrumentation Bit, Service Request, Broadcast Command Received, Busy, Subsystem Flag, Dynamic Bus 
Acceptance, and Terminal Flag. 
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Key Take Away Points 

 The MIL-STD-1553 signals on the demo board look about like this, where the yellow channel 1 
signal is the positive MIL1553+ and the cyan channel 2 signal is the negative MIL1553-: 

 

 Notice that the individual MIL-STD-1553 signals are relatively large signals, about ±2.5Vpk-pk, with 
multiple voltage levels. 

 These MIL-STD-1553 signals transmit information differentially, and the SR-AERO decoder is 
designed to work with a single differential signal, so the remainder of this lab will focus on the 
differential signal, captured with a differential probe, as shown below: 
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Lab Objectives 

- Obtain a basic understanding of the MIL-STD-1553 serial bus. 

- Learn how to use oscilloscopes to measure and decode MIL-STD-1553 signals. 

- Learn how to setup a MIL-STD-1553 serial bus display and trigger and search on MIL-
STD-1553 bus content with an MSO/DPO5000 Series oscilloscope. 

 

MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 The MIL-STD-1553 bus is an industry standard and can 
be found in many aerospace designs today. 

 Traditional manual MIL-STD-1553 decoding methods are 
time-consuming. 

 With the SR-AERO option installed, the MSO/DPO5000 
Series oscilloscope can trigger on, decode, and search 

MIL-STD-1553 bus traffic. 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the SR-AERO: MIL-
STD-1553 Serial Triggering and 
Analysis option is installed. 

 Press the OK button.  

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has a MIL-STD-
1553 signal which we can use for this lab: 

 

 You can also load a MIL-STD-1553 signal into a reference 
memory (and define a math waveform to equal that 
reference waveform) for use in this lab to demonstrate 
decoding and searching. However, the rest of this lab 
assumes a live signal. 

DPO Demo Board Procedure: 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the green POWER LED is 
lit. 

 Attach a TDP0500 or TDP1000 
differential probe to the Channel 1 
input of the oscilloscope. Then 
connect the probe’s + input to 
MIL1553+ and connect the 
probe’s - input to the MIL1553- 
test point. 

 For your reference, to load a 
reference waveform for decoding, 
after setting up the scope: 

 Select File->Recall…. 

 Enter file name and press 
Recall button. 

 Press the Display Off button. 

 Select Math-Math Setup…. 

 Set Math 1 = Ref1. 
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MSO/DPO5000 Series MIL-STD-1553 Bus Setup and Decoding 

Key Take Away Points 

 Setting up a basic MIL-STD-1553 bus waveform display 
takes only a few simple steps with the MSO/DPO5000 
Series. 

 Notice that any of the analog or math signals can be used 

as a source for the MIL-STD-1553 bus. 

 The MIL-STD-1553 Bus Setup menu looks like this: 

 

 The MIL-STD-1553 bus Display menu looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Set channel 1 Vertical Scale to 
2V/div. 

 Use the Trigger Level control to 
adjust the trigger level below the 
center of the waveform, about 
-1V. 

 Set the Horizontal Scale to 
200μs/div. 

 With Horizontal Delay mode Off, 
turn the Horizontal Position 
control counter-clockwise until the 
orange trigger position marker is 
aligned with the first graticule line 
at the left side of the display. 

 Press the front panel Single 
button. 

 Press the purple front panel Bus 
B button. 

 Select Serial Bus Type, and then 
select MIL-1553. 

 Verify that the Data Input signal 
is set to Ch1. 

 Set the Threshold (H) value to 
about +500mV, the Threshold 
(L) value to about -500 mV, and 
the Polarity is set to Normal. 

 Press the Bus 1 button to turn 
bus B1 On. 

 Click on the Bus 1 Position text 
box and position the bus 
waveform below the MIL-STD-
1553 waveform as desired. 

 Press the Display tab at the left 
side of the control window. 

 Under Bus 1 Display, verify that 
Busform Bus Components and 
Mixed Busform Decode are 
selected. 

 Zoom in on the signal until you 
can read the individual decoded 
signal elements. 

 Press the X in the upper right 
corner of the lower control 
window or press the front panel 
Menu Off button. 
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Key Take Away Points 

 The green bar symbol represents the start of packet and 
the red bar symbol represents the end of packet. 

 

 Notice that the Sync Word Type, R/T bit, Word Count, 
Status Bits, and Parity appear in purple. Address bits 
appear in yellow. Data values are shown in cyan. Errors 
are shown in red. 

 

MSO/DPO5000 Series Procedure: 

 Pan through the display to see 
what the decoded signal 
elements look like. 
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MSO/DPO5000 Series MIL-STD-1553 Bus Event Tables 

Key Take Away Points 

 Setting up a basic MIL-STD-1553 bus event table display 
takes only a few simple steps with the MSO/DPO5000 
Series. 

 The MIL-STD-1553 bus event table display looks like this: 

 

 The docked MIL-STD-1553 bus event table display looks 
like this: 

 

MSO/DPO5000 Series Procedure: 

 Select Vertical->Bus Setup…. 

 Press the Protocol Decode 
Event Table button. 

 

 

 

 

 

 

 

 

 

 

 

 

 Press the Dock button. 

 Press the X in the upper right 
corner of the lower control 
window or press the front panel 
Menu Off button to close the 
control panel. 

 Click on one of the rows in the 
Event Table and notice the zoom 
box is repositioned to correspond 
to the selected row. 

 

 

 

 

 

 When you are done with the 
setup, press the X in the upper 
right corner of the Event Table 
control window to close it. 
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MSO/DPO5000 Series MIL-STD-1553 Bus Triggering 

Key Take Away Points 

 When debugging a system, you often want to capture the 
state of some key signals when a certain event occurs. 
One key event may be the transmission of specific content 
over the MIL-STD-1553 serial bus. 

 The MSO/DPO5000 Series can trigger on: 

o Sync 
o Command Word (set RT Address (=, ≠, <, >, ≤, ≥), T/R, 

Sub-address/Mode, Data Word Count/Mode Code, and 
Parity individually) 

o Status Word (set RT Address (=, ≠, <, >, ≤, ≥), 
Message Error, Instrumentation, Service Request Bit, 
Broadcast Command Received, Busy, Subsystem 
Flag, Dynamic Bus Control Acceptance (DBCA), 
Terminal Flag, and Parity individually) 

o Data (user-specified 16-bit data and parity values) 
o Idle Time (< Minimum, > Maximum, Inside Range, 

Outside Range) 
o Error (Parity Error, Sync Error, Manchester Error, Non-

Contiguous Data) 

 NOTE: Trigger selection of Command Word will trigger on 
Command and ambiguous Command/Status words. 
Trigger selection of Status Word will trigger on Status and 
ambiguous Command/Status words. 

 By following this simple procedure, you can easily trigger 
the oscilloscope on a specified serial pattern on a MIL-
STD-1553 signal, capturing each occurrence. 

 

MSO/DPO5000 Series Procedure: 

 Select Trig->Mode… and press 
the Norm button. 

 Select Trig->Bus Setup…. 

 Using the Bus drop down menu, 
select B1. 

 Notice that, by default, Trigger On 
Sync is selected. 

 Using the Trigger On drop down 
menu, select Data. 

 Select Hex format. 

 Press the Edit button at the right. 

 Double click on the Identifier text 
box and enter the value 0000 
hex. As you enter the values, 
notice that the values in the other 
radices are also updated. 

 When you are done, press OK. 

 Press the front panel Single 
button. 

 Adjust the MultiView Zoom pan 
and zoom controls as needed to 
view the MIL-STD-1553 packets 
at the trigger point. 
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MSO/DPO5000 Series MIL-STD-1553 Bus Searching 

Key Take Away Points 

 Once you have acquired a serial signal, you often want to 
find all occurrences of a certain event, such as the 
transmission of specific content over the MIL-STD-1553 
serial bus. 

 

 The MSO/DPO5000 Series can search on Sync, Command 
Word, Status Word, Data, Idle Time, and Error. 

 By following this simple procedure, you can easily search 
an acquisition for a specified serial pattern on a MIL-STD-
1553 signal, marking each occurrence: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Search 
button. 

 Press the Bus button in the 
control window. 

 

 

 

 

 

 

 

 

 

 

 

 

 Press the Configure tab at the 
left side of the control window. 

 Notice that, by default, Search 
For Sync is selected. 

 Under Search For, select Status 
Word. 

 Select Binary format. 

 Press the Edit button at the right. 

 Double click on the binary text 
box and enter the binary value  
X XXX1. As you enter the values, 
notice that the values in the other 
radices are also updated. 

 When you are done, press OK. 

 Using the front panel left and right 
arrows, navigate between search 
events. 
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Key Take Away Points 

 The search results can also be displayed in tabular format. 
The Event Table results table looks like this: 

 

 When you select a row in the results table, the display 
looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the Results tab at the left 
side of the control window to 
display the table of search results. 

 

 

 

 

 

 

 

 

 

 

 

 Click on one of the rows in the 
Event Table and notice the zoom 
box is repositioned to correspond 
to the selected row. 
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MSO5000/DPO5000 Series 
8b/10b Decoding Lab 

 

 

 
Equipment List 
One MSO/DPO5204 Series oscilloscope with software version ≥6.4 and with the SR-810B option installed 
One SMA-to-BNC cable 
Optional USB keyboard and mouse 
TB3 demo board and power adapter 
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Understanding 8b/10b Encoding 

8b/10b is an encoding method used in many computer and communications applications which replaces 8-
bit data values with 10-bit symbols. In exchange for the 25% overhead, 8b/10b encoding provides a signal 
with no DC content, limited low-frequency content, limited “disparity”, and enough signal transitions to 
enable good clock recovery. The resulting bit stream never has more than five 1s or 0s in a row, and the 
difference between the number of 1s and 0s in any string of at least 20 bits is less than or equal to two. 
These characteristics combine to allow the signal to be easily transmitted over an AC-coupled channel, 
ensures that the duty cycle of lasers used in optical transmission is maintained at 50% for optimal 
performance and power dissipation, and minimizes the sensitivity of receivers to variations in accumulated 
DC offsets. Another benefit of this overhead is the ability to detect single-bit transmission errors (more 
effective error-detection than traditional parity). 

8b10b line coding was developed and patented by IBM in 1984, but, since the patent expired, it has been 
used in a variety of communications standards, including Common Public Radio Interface (CPRI), Digital 
Audio Tape, DisplayPort, DVB Asynchronous Serial Interface (ASI), DVI, Fibre Channel, Gigabit Ethernet, 
HDMI, HyperTransport, IEEE 1394b, InfiniBand, PCI Express (< v3.0), Serial ATA, Serial RapidIO, Serial 
Storage Architecture (SSA), USB 3.0, and XAUI. 

Because the encoding and decoding is normally done in hardware at the link layer, 8b/10b is used for a wide 
range of standard and custom applications, and the upper layers of the OSI software stack do not need to 
be aware that the link layer is using this code. 

How it works 

The 8 data bits are transmitted as a 10-bit symbol, composed of two groups of bits. The 5 least-significant 
data bits are encoded into a 6-bit group (“5b/6b”) and the 3 most-significant data bits are encoded into a 4-
bit group (“3b/4b”) and then concatenated. The data symbols are often referred to as “D.x.y”, where “x” 
represents the least-significant 5 bits (with a value of 0–31) and “y” represents the most-significant 3 bits 
(with a value of 0–7). 

Communication standards may define up to 12 control characters (special symbols) which can replace data 
symbols to represent start-of-frame, end-of-frame, idle, skip, and similar link-level conditions. Symbol 
framing is done with a special "comma" symbol which defines the alignment of the 10 bit symbols. The 
control characters are often referred to as “K.x.y” and are distinguished from any of the “D.x.y” symbols by 
the use of different encodings. 

Since 8b/10b encoding uses 10-bit symbols to encode 8-bit words, there are many possible bit combinations 
which are not used. Of the possible 1024 (2

10
) 10-bit codes, the “D.x.y” symbols are chosen to uniquely 

represent the 256 (2
8
) data values, to provide a run-length limit of 5 consecutive 1s or 0s, and to limit the 

“disparity” (the difference of the count of 0s and 1s across two or more symbols) is no more than 2. 

Encoding tables 

For the following sections, we will represent the bits in the 8-bit data word with the string of capitalized 
characters “HGFEDCBA”, where A is the least-significant bit and H is the most-significant bit. We will also 
represent these data bits in lower case when they are part of the encoded symbol, and will include two extra 
bits, i and j. The bits are sent least-significant to most-significant order, with the extra bits inserted as 
follows: a, b, c, d, e, i, f, g, h, and j. You can also think of this series as the 5b/6b code followed by the 3b/4b 
code. 

Each 6-bit code can contain equal numbers of 0s and 1s (a disparity of 0), or comes in a pair of forms, one 
with two more 1s than 0s (four 1s and two 0s) and one with two less 1s than 0s (two 1s and four 0s). 
Likewise, each 4-bit code can contain equal numbers of 0s and 1s (a disparity of 0), or comes in a pair of 
forms, one with two more 1s than 0s (three 1s and one 0) and one with two less 1s than 0s (one 1 and three 
0s). 

 

http://en.wikipedia.org/wiki/Least_significant_bit
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The encoder needs to keep track of the difference between the number of transmitted 1s and 0s. This 
residual count is known as the running disparity (“RD”). By limiting the difference within each code to the 
range of ±2 and an RD alternating between ±1 at the end of each symbol, the long-term ratio of 1s and 0s is 
50% and 8b/10b coding is DC-free. 

When a 5b/6b and 3b/4b code has a non-zero disparity, there are two valid bit patterns that can be used to 
represent the data values, one with a disparity value of +1 and one with a disparity value of -1. As shown in 
the table below, the value of the running disparity and the disparity value for the code word specify the 
disparity encoding to be chosen to toggle the running disparity. (If the code word has a zero disparity, there 
is only one valid bit pattern to use and the disparity would be unchanged.) 

 

Rules for Running Disparity 

Previous RD Disparity of code word Disparity chosen Next RD 

−1  0  0 −1 

−1 ±2 +2 +1 

+1  0  0 +1 

+1 ±2 −2 −1 

 
The following (simplified) tables show the coding for the 5b/6b and 3b/4b groups: 

 

5b/6b Code 

nput RD = −1 RD = +1 

 

Input RD = −1 RD = +1 

 
EDCBA abcdei 

 
EDCBA abcdei 

D.00 00000 100111 011000 D.16 0000 011011 100100 

D.01 00001 011101 100010 D.17 10001 100011 

D.02 00010 101101 010010 D.18 10010 010011 

D.03 00011 110001 D.19 10011 110010 

.0
4 

00100 110101 001010 D.20 10100 001011 

D.05 00101 101001 D.21 10101 101010 

D.06 00110 011001 D.22 10110 011010 

D.07 00111 111000 000111 D.23 10111 111010 000101 

D.08 01000 111001 000110 D.24 11000 110011 001100 

D.09 01001 100101 D.25 11001 100110 

D.10 01010 010101 D.26 11010 010110 

D.11 01011 110100 D.27 11011 110110 001001 

D.12 01100 001101 D.28 11100 001110 

D.13 01101 101100 D.29 11101 101110 010001 

D.14 01110 011100 D.30 11110 011110 100001 

D.15 01111 010111 101000 D.31 11111 101011 010100 

 
K.28 11100 001111 110000 
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3b/4b Code 

Input RD = −1 RD = +1 

 

Input RD = −1 RD = +1 

 
HG fghj 

 
HGF fghj 

D.x.0 000 1011 0100 K.x.0 000 1011 0100 

D.x.1 001 1001 K.x.1 001 0110 1001 

D.x.2 010 0101 K.x.2 010 1010 0101 

D.x.3 011 1100 011 K.x.3 011 1100 0011 

D.x.4 100 1101 0010 K.x.4 100 1101 0010 

D.x.5 101 1010 K.x.5 101 0101 1010 

D.x.6 110 0110 K.x.6 110 1001 0110 

D.x.P7 111 1110 0001 
 

D.x.A7 111 0111 1000 K.x.7 111 0111 1000 

Control symbols 

“K.x.y” 8b/10b control symbols are valid 10-bit sequences (no more than six 1s or 0s) that do not have a 
corresponding 8-bit data value. Control symbols are used by communication standards to perform low-level 
control functions. The transmitted codes for control symbols are also affected by the running disparity. Here 
are the following 12 control symbols: 

 

Control Symbols 

Input RD = −1 RD= +1 

 
DEC HGF EDCBA abcdei fghj abcdei fghj 

K.28.0 28 000 11100 001111 0100 110000 1011 

K.28.1 60 001 11100 001111 1001 110000 0110 

K.28.2 92 01011100 001111 0101 110000 1010 

K.28.3 124 011 11100 001111 0011 110000 1100 

K.28.4 156 100 11100 001111 0010 110000 1101 

K.28.5 188 101 11100 001111 1010 110000 0101 

K.28.6 220 110 11100 001111 0110 110000 1001 

K.28.7 252 111 11100 001111 1000 110000 0111 

K.23.7 247 111 10111 111010 1000 000101 0111 

K.27.7 251 111 11011 110110 1000 001001 0111 

K.29.7 253 111 11101 101110 1000 010001 0111 

K.30.7 254 111 11110 011110 1000 100001 0111 

  
 

Lab Objectives 

- Obtain a basic understanding of 8b/10b encoding. 

- Learn how to setup an 8b/10b-encoded serial bus display and decode and search on data 
patterns with an MSO/DPO5000 Series oscilloscope. 
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MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 8b/10b-encoded serial buses are industry standards and 
can be found in many designs today. 

 With the SR-810B option installed on an MSO/DPO5000 
Series oscilloscope can automatically decode and search 
8b/10b-encoded serial bus traffic. 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the SR-810B: 8B10B 
Serial Analysis option is 
installed. 

 Press the OK button. 

 

Key Take Away Points 

 The TB3 demo board has an 8b/10b-encoded 2.5 Gb/s 
signal which we can use for this lab: 

 

TB3 Demo Board Procedure: 

 Connect the power adapter to 
J2890 on the demo board and 
connect the adapter to the mains 
power. 

 Move power switch S2780 to the 
ON position. 

 Verify the power LEDs are lit. 

 Attach the BNC connector of an 
SMA-to-BNC cable to the 
Channel 1 input of the 
oscilloscope and the SMA 
connector to J11 on the demo 
board. 

 Press the DEMO switch S2 until 
mode 0 is displayed on the DEMO 
LED. 

 Press the STEP switch S1 until 
mode 1 is displayed on the STEP 
LED. 
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MSO/DPO5000 Series 8b/10b Bus Setup and Decoding 

Key Take Away Points 

 In this section, you will learn how to use the 
MSO/DPO5000 Series to automatically decode 8b/10b-
encoded serial bus traffic. 

 Setting up a basic 8b/10b bus waveform display takes only 
a few simple steps with the MSO/DPO5000 Series. Notice 
that any of the analog or digital inputs or math signals can 
be used as a source for the 8b/10b bus. 

 The display should now look about like this, with the 8b10b 
character decoded values shown in the bus waveform: 

 

 The data values can also be displayed in Binary, Hex, 
Character, or Symbol format: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Select Vertical->Termination… 
and select 50 Ω. 

 Select Horiz/Acq-
>Horizontal/Acquisition 
Setup…. 

 Set the Horizontal Scale to 100 
ns/div. 

 Set the Sample Rate to 10.0 
GS/s. 

 Select Vertical->Bus Setup…. 

 Select Serial Bus Type and then 
select 8B10B. 

 Select 2.5 Gb/s Data Rate. 

 Set the Threshold to 0.0V. 

 Turn Bus 1 on. 

 Position the bus waveform in the 
lower half of the display. 

 Press the front panel Single 
button. 

 Using the inner Wave Inspector 
control, turn on Zoom and zoom 
in until you can see the decoded 
values clearly. 

 Press the Display tab at the left 
side of the control window. 
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MSO/DPO5000 Series 8b/10b Bus Event Tables 

Key Take Away Points 

 Setting up a basic 8b/10b bus event table display takes 
only a few simple steps with the MSO/DPO5000 Series. 

 The Protocol Decode Event Table pop-up display looks like 
this when it is first enabled: 

 

 The Event Table display can be sized and positioned on 
the screen, and the cursor position in the table is 
synchronized with the zoom box in the waveform display: 

 

MSO/DPO5000 Series Procedure: 

 Press the Protocol Decode 
Event Table button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 The Event Table can be 
positioned by left-clicking on the 
top of the pop-up table and 
dragging it around on the display. 

 The Event Table can also be 
sized by left-clicking on the lower 
right corner and dragging it to 
chance the size and shape of the 
table. 

 Using the mouse or touchscreen, 
select lines in the table and show 
how the zoomed waveform 
corresponds to the selected line 
in the Event Table. 
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Key Take Away Points 

 The Protocol Decode Event Table display can also be 
docked: 

 

 Selected portions of the decoded information in the Event 
Table can be copied to the Windows clipboard and can be 
saved to a file in CSV format: 

 

MSO/DPO5000 Series Procedure: 

 Press the Protocol Decode 
Event Table button. 

 Press the Dock button. 

 Close the Bus Setup control 
window using the X in the upper 
right corner of the control window. 

 

 

 

 

 

 

 

 

 

 Press the Export button in the 
Event Table. Notice that you can 
select which portions of the 
decoded data to copy or save. 

 Press the Export button in the 
pop-up window. Notice that you 
can save the Event Table 
information to a file in .CSV 
format. When you are done, 
either Save the file or press 
Cancel. 
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MSO/DPO5000 Series 8b/10b Bus Searching 

Key Take Away Points 

 Once you have acquired a serial signal, you often want to 
find all occurrences of a certain event, such as the 
transmission of specific values over the 8b/10b-encoded 
serial bus. 

 

 The MSO/DPO5000 Series can search on a serial Pattern, 
a specific Character/Symbol, an Error, or Any Control 
Character. 

 By following this simple procedure, you can easily search 
an acquisition for a specified serial pattern, marking each 
occurrence. In this case, search finds the only occurrence 
of the character “D29.6” in the acquisition: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Search 
button. 

 Press the Bus Search button in 
the control window. 

 

 

 

 

 

 

 

 

 

 

 

 

 Select the Configure tab at the 
left side of the control window. 

 Using the Search For drop down 
menu, select Character/Symbol. 

 The easiest way to enter the 
value is with the 8b/10b Character 
Keypad. Double-click on the 
Character text box. 

 Using the pop-up keypad, enter 
“D29.6”. 

 When you are done, press OK. 

 If the character “D29.6” occurs in 
the current acquisition, one or 
more purple triangles will appear 
at the top of the display. 

 If the character “D29.6” does not 
occur in the current acquisition, 
press the front panel Single 
button one or more times until 
triangles appear at the top of the 
display. Or you can simply skip to 
the next section to find a more 
reliable way to find an event. 
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MSO/DPO5000 Series 8b/10b Bus Software Triggering 

Key Take Away Points 

 Although the MSO/DPO5000 Series oscilloscopes do not 
have an 8b/10b hardware trigger, the 8b/10b bus search 
gives you similar capability for some applications. By 
programming search to stop acquisitions when it finds the 
specified data pattern, search provides a software trigger 
capability. 

 

 Although the performance of software triggering may not be 
as effective as hardware triggering in some applications, 
you can follow this simple search procedure to acquire 
specified serial patterns. 

MSO/DPO5000 Series Procedure: 

 Select the Mode tab at the left 
side of the control window. 

 Check the Stop Acquisition if 
event found check box. 

 Press the front panel Run/Stop 
button to re-start acquisitions. 

 Press the <Prev or Next> buttons, 
either in the control window or on 
the front panel, to jump between 
search events. 
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MSO5000/DPO5000 Series 
Custom Serial Bus Decoding Lab 

 

 

 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.4 and with the SR-CUST option installed 
Custom decoder file 
Custom signal source or custom signal waveforms 
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Understanding Custom Serial Bus Decoding 

Custom serial buses are used in many designs in industry today. In many cases, these custom buses are 
similar to other industry-standard buses, but have been adapted for a specific purpose. For example, a 
custom bus may be an industry-standard bus at the physical layer that has a unique number of bits per field. 
Or it may be a bus that has unique bit encoding. 

Although the details of the bus may be different, the basic customer need is often similar: debugging a 
complex electronic system with industry-standard tools like the time-correlated, multi-domain displays of an 
oscilloscope. 

How it works 

Using proprietary programming tools, a Tektronix application engineer builds a custom serial bus decoder 
definition, delivered as a Windows .DLL file. Working from a bus specification, the AE defines the inputs and 
characteristics of the bus, much like the Tektronix software engineers did when they built the standard serial 
bus decoders. The SR-CUST option uses this definition file to implement the bus decoding and search 
capabilities on the oscilloscope. 

The look and feel of the custom decoder will be similar to the standard serial bus decoders and will be 
familiar to the users. However, the exact layout of the displayed bus waveform and the fields will be specific 
to the custom bus. 

 

Lab Objectives 

- Obtain a basic understanding of the optional custom serial bus decoding and search 
capabilities of SR-CUST. 

- Learn how to use SR-CUST to set up a custom serial bus display and decode and search 
on data patterns with an MSO/DPO5000 Series oscilloscope. 
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MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 The SR-CUST option, in conjunction with a custom serial 
decoder designed by a Tektronix Application Engineer, and 
an MSO/DPO5000 Series oscilloscope can automatically 
decode and search custom serial bus traffic. 

 The custom decoder DLL file must be loaded on the 
oscilloscope in the 
C:\Program Files\Tektronix\TekScope\SYSTEM folder. 

 If you select Custom Serial Bus Setup and no custom 
decoder DLL files are properly loaded, you will see the 
following message displayed: 

 

 The customer decoder files are recognized as the 
oscilloscope application starts up, so the oscilloscope 
application must be restarted after loading the custom 
decoder DLL file. 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the SR-CUST: 
Custom Serial Analysis option is 
installed. 

 Press the OK button. 

 

 

 

 

 

 

 Load the custom decoder DLL file 
onto the oscilloscope in the 
C:\Program Files\Tektronix\ 
TekScope\SYSTEM folder. 

 Press the X in the upper left 
corner of the oscilloscope 
application or select File->Exit, 
and then press the Yes button. 

 Double-click on the TekScope 
icon on the Windows desktop to 
restart the oscilloscope 
application. 
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MSO/DPO5000 Series Custom Bus Setup and Decoding 

Key Take Away Points 

 In this section, you will learn how to use the 
MSO/DPO5000 Series to automatically decode custom 
serial bus traffic. 

 Setting up a basic custom bus waveform display takes only 
a few simple steps with the MSO/DPO5000 Series, as with 
any of the standard serial buses. Notice that any of the 
analog or digital inputs or math signals can be used as a 
source for the custom bus. 

 This is an example display of the setup control window for 
a custom SVID serial bus: 

 

 The supported data display formats can be selected in the 
Display tab. For example, the custom SVID decoder can 
display data in Binary, Hex, or Mixed format: 

 

 The decoded information in the bus waveform will be color-
coded in a similar manner to the displays from the standard 
serial bus decoders. 

 The decoded information can also be displayed in a tabular 
format with the Event Table. The Event Table display can 
be sized and positioned on the screen, and the cursor 
position in the table is synchronized with the zoom box in 
the waveform display. 

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Connect the custom serial signal 
to the oscilloscope and adjust the 
vertical and horizontal scales and 
triggering to get a stable display 
of one or more packets of serial 
data. 

 Press the blue front panel Bus B 
button or select Vertical->Bus 
Setup…. 

 Select Serial Bus Type and then 
select Custom. 

 Select the desired custom 
decoder from the Custom 
Decoder drop-down box. 

 Set the Threshold values 
appropriately for each of the 
custom serial bus signals. 

 Turn Bus 1 on. 

 Position the bus waveform as 
desired on the display. 

 Press the front panel Single 
button. 

 Using the inner Wave Inspector 
control, turn on Zoom and zoom 
in until you can see the decoded 
values clearly. 

 Press the Display tab at the left 
side of the control window. 

 Press the Protocol Decode 
Event Table button. 

 The Event Table can be 
positioned and sized with the 
mouse, or docked below the 
display graticule. 

 Using the mouse or touchscreen, 
select lines in the table and show 
how the zoomed waveform 
corresponds to the selected line 
in the Event Table. 
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MSO/DPO5000 Series Custom Bus Searching 

Key Take Away Points 

 Once you have acquired a serial signal, you often want to 
find all occurrences of a certain event, such as the 
transmission of specific values over the custom serial bus. 

 

 The MSO/DPO5000 Series can search on any serial data 
value, pattern, or error defined in the custom decoder. 

 By following this simple procedure, you can easily search 
an acquisition for a specified serial pattern, and mark each 
occurrence. 

MSO/DPO5000 Series Procedure: 

 Press the front panel Search 
button. 

 Press the Bus Search button in 
the control window. 

 Select the Configure tab at the 
left side of the control window. 

 Using the Search For drop down 
menu, select the desired bus 
field. 

 The easiest way to enter the 
value for the selected field is with 
the on-screen keypad. Double-
click on the selected field’s text 
box. 

 Using the pop-up keypad, enter 
the desired value. 

 When you are done, press OK. 

 If the specified value occurs in the 
current acquisition, one or more 
purple triangles will appear at the 
top of the display. 

 If the value does not occur in the 
current acquisition, press the front 
panel Single button one or more 
times until triangles appear at the 
top of the display. Or you can 
simply skip to the next section to 
find a more reliable way to find an 
event. 
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MSO/DPO5000 Series Custom Bus Software Triggering 

Key Take Away Points 

 Although the MSO/DPO5000 Series oscilloscopes do not 
have a custom serial bus hardware trigger, the custom 
serial bus search gives you similar capability for some 
applications. By programming search to stop acquisitions 
when it finds the specified data pattern, search provides a 
software trigger capability.  

 

 Although the performance of software triggering may not be 
as effective as hardware triggering in some applications, 
you can follow this simple search procedure to acquire 
specified serial patterns. 

MSO/DPO5000 Series Procedure: 

 Select the Mode tab at the left 
side of the control window. 

 Check the Stop Acquisition if 
event found check box. 

 Press the front panel Run/Stop 
button to re-start acquisitions. 

 Press the <Prev or Next> buttons, 
either in the control window or on 
the front panel, to jump between 
search events. 

  



 

MSO5000 / DPO5000 Lab Exercise Book 

Version 1.1   5/11/2012 48W-26279-3   164 of 394 

 

MSO5000/DPO5000 Series 
Parallel Bus Triggering 
and Decoding Lab 

 

 

 
Equipment List 
One MSO5000 Series oscilloscope with software version ≥6.4 or 

one DPO5000 Series oscilloscope with software version ≥6.4 and with the MSOE option installed 
One TPP0500 or TPP1000 passive probe 
One P6616 MSO probe 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this document were made with the DPO Demo 3 board] 
 
 
 

Lab Objectives 

- Learn how to set up a parallel serial bus display and trigger and search on parallel bus content with 
an MSO5000 Series mixed-signal oscilloscope. 

- Learn how to use setup & hold triggering to identify timing errors in synchronous buses. 

- Learn how to use the MagniVu acquisition mode to maximize measurement timing resolution. 
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MSO5000 Series Lab Setup 

Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has a parallel bus 
signal which we can use for this lab: 

 

 The DPO Demo 2 board (020-2924-XX) also has a parallel 
bus signal which we can use for this lab: 

 

DPO Demo Board Procedure 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the power LED is lit. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. Then connect 
the probe ground to GND and 
connect the probe to the 
I2C_CLK (clock) test point. 

 Attach a P6616 MSO probe to the 
D15-D0 input on the front of the 
oscilloscope. 

 On Group 1 of the MSO probe, 
connect the D0 input to the 
CNT_OUT0 square pin, with the 
probe ground on the ground pin 
on the left side of the connector. 
Similarly, connect inputs D1 
through D6 to the CNT_OUT1 
through CNT_OUT6 signals. 

 Connect the D7 input to the 
CNT_CLK pin. 
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Key Take Away Points 

 The display should look about like this: 

 

 There are several key next-generation digital display 
characteristics to notice in the display. When digital signals 
are low, the waveforms are colored blue. When the 
signals are high, the waveforms are colored green. 

 Digital channels can be displayed in several sizes, from 
extra small (8 channels occupy about 2 divisions on the 
display) to large (where 8 channels fill the display). 

 As the number of signals on the display increases, it 
becomes increasingly valuable to be able to attach text 
labels to the waveforms. There are two ways to add labels: 

 Enter the label, character by character, by double-
clicking on the label text box and typing in the label with 
the popup keyboard using the touch screen or mouse. 

 Enter the label by clicking on the label text box and 
typing in the label with an attached USB keyboard. 

 

MSO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Press the front panel 1 button to 
turn off channel 1. 

 Press the blue front panel D15-D0 
button to display the Digital Setup 
control window. 

 Press the Turn D7-D0 On button. 

 

 

 

 

 

 

 

 

 Using the Size drop down menu, 
select Large display size. 

 Set the Horizontal Scale to 
1µs/div. 

 If you have a USB keyboard 
connected to the oscilloscope, 
click on the label text box below 
each of the channel On buttons. 
Type in a unique label for each 
channel. 

 If you do not have a USB 
keyboard connected to the 
oscilloscope, double-click on the 
label text box below each of the 
channel On buttons, type in a 
unique label, and press the Enter 
button. 
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Key Take Away Points 

 Many digital and mixed signal designs also contain multiple 
logic families. The signal on each input to the digital logic 
probe is compared with a threshold value to determine if 
the input signal is high or low. 

 Most MSO products only allow the user to set a single logic 
threshold per group of 8 channels. If the application has 
multiple logic families, this would require using channels 
from each group to acquire the waveform. If more than two 
logic families are needed another instrument would be 
needed. The MSO5000 series allows the user to set a 
unique logic threshold for every digital channel. 

 There are various ways to enter a threshold value for each 
digital channel: 

 Touch the Threshold text box and adjust the value 
using the Multipurpose controls. 

 Click on the Threshold text box and edit the threshold 
value with a USB keyboard. 

 Double-click on the Threshold text box and edit the 
threshold value with the popup keyboard using the 
touch screen or mouse. 

 Double-click on the Threshold text box and select one 
of the preset threshold values (TTL, ECL, or USER) 
with the popup keyboard using the touch screen or 
mouse. 

 The display should look about like this: 

 

 You can also easily set the threshold value for all of the 
digital channels with a single action using the Global 
Threshold control. 

MSO5000 Series Procedure: 

 If you have a USB keyboard 
connected to the oscilloscope, 
click on the Threshold text box for 
channel D0 and edit the threshold 
value to be 2.4V. 

 If you do not have a USB 
keyboard connected to the 
oscilloscope, double-click on the 
Threshold text box for channel D0 
and edit the threshold value to be 
2.4V. 

 Double-click on the Threshold text 
box for channel D1 and edit the 
threshold value to be 2.0V. 

 Double-click on the Threshold text 
box for channel D2 and set the 
threshold value to TTL (1.4V). 

 Click on the Threshold text box 
for channel D3 and use the 
Multipurpose a control to set the 
threshold value to 1.8V. 

 

 

 

 

 

 

 

 

 

 

 

 

 Double-click on the Global 
Threshold text box. 

 Using the popup keyboard, set 
the threshold value to 1.5V. 

 Press the Apply button and verify 
that the Threshold value for all of 
the digital channels changes to 
1.5V. 
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MSO5000 Series Parallel Bus Decoding Setup 

Key Take Away Points 

 Setting up a basic parallel bus waveform display takes only 
a few simple steps with the MSO5000 Series. 

 Notice that any of the analog or digital inputs or math 
signals can be used as a source for the parallel bus. To 
keep this demo simple, we will only use one group of 8 
digital signals. 

 Zoom in on one of the bus transitions. You may notice that 
there are some intermediate states on an unclocked bus: 

 

 Since the clock is on channel D7, we can use it to create a 
clocked bus, which only transitions when the clock edge 
occurs. The clocked bus display should now look about like 
this, with the decoded values shown in the bus waveform: 

 

MSO5000 Series Procedure: 

 Press the front panel B button or 
select Digital -> Bus Setup…. 

 Verify that the Parallel Bus Type 
is selected and that Clocked is 
not checked. 

 Press the Add Sources Select 
button. 

 Add digital channels 7 (MSB) 
through 0 (LSB) to the parallel 
bus by pressing the D7, D6, D5, 
D4, D3, D2, D1, and D0 buttons, 
in that order, and press OK. 

 Press the Bus 1 button to turn the 
parallel bus On. 

 Using the Multipurpose a control, 
position the bus near the top of 
the display. 

 Using the Wave Inspector 
controls, zoom in on the decoded 
data values. 

 

 

 Find and select D7 in the Bus 1 
Contains list and press the 
Remove button. 

 Check the Clocked check box 
control. 

 Touch the Clock Source text box, 
select D0-D7, and select D7. 

 Verify that the Clock Polarity is 
set to Rising. 

 

 

 

 

 

 

 When you are done, deselect the 
Clocked check box control and 
turn off Zoom. 
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MSO/DPO5000 Series Parallel Bus Symbol Tables 

Key Take Away Points 

 The MSO/DPO5000 Series also can display decoded 
parallel bus information symbolically, based on a 
translation table called a Symbol File. 

 The symbol file uses a specific format called TLA Symbol 
Format (TSF) and has a .tsf file extension. Symbol files can 
be created and edited with any text editor. 

 The header line for the file begins with the “#+” characters 
and specifies the file format version, the word “PATTERN”, 
and the numeric radices used to specify the symbol values 
for display and for interpreting the values in the file. Valid 
radix values are “HEX”, “OCT”, “DEC”, and “BIN”. 

 Except for lines which begin with the special “#+” pattern, 
any characters after a ‘#’ character are interpreted as 
comments. 

 The remaining lines in the file are used to specify the 
symbols and values. An ‘X’ can be used to specify a “don’t 
care” value. The symbol values need to be valid for the 
radix specified. (For example, only ‘0’, ‘1’, and ‘X’ are valid 
for BIN format.) Spaces or tabs are used to separate the 
fields on a line. 

 For example, try this symbol file: 

# ParallelTest.tsf   Symbol File Test for Parallel 
# 
#+ version 2.1.0 PATTERN BIN BIN 
# 
# Symbol    Pattern    Comments 
# 
STATE0   XXXXX00 
STATE1   XXXXX01 
STATE2   XXXXX10 
STATE3   XXXXX11 

 Note: The order of the symbols in the file is important. The 
instrument scans the list of pattern symbols starting at the 
top of the file and displays the first symbol that matches the 
bits with numeric values (not Xs). If the instrument cannot 
find a match, there is no symbol and the numeric value is 
displayed instead. 

PC Procedure: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Open a text editor and create a 
TSF file with symbols and 
numeric values, as shown at the 
left. 

 Save the file in text format and 
name it ParallelTest.tsf. 
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Key Take Away Points 

 The Symbol File display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Copy the ParallelTest.tsf file to 
the 
C:\TekScope\BusDecodeTables 
directory on the instrument. 

 From the Bus Setup window, 
select the Display tab and 
appropriate bus to decode using 
the symbol file. 

 Select the Hex number base to 
match the Display radix defined in 
the file. 

 Click the Use Symbol File check 
box. 

 Click the Symbol File box and 
enter the path to the file with the 
keyboard or press the Browse 
button to locate the file. 

 
 
 

MSO/DPO5000 Series Parallel Bus Event Tables 

Key Take Away Points 

 Setting up a basic parallel bus event table display takes 
only a few simple steps with the MSO/DPO5000 Series. 

 The parallel bus Event Table display looks like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the Protocol Decode 
Event Table button. 

 

 

 

 

 

 

 

 

 Press the Export button. Notice 
that you can save the Event 
Table information to a file in .CSV 
format. When you are done, 
either Save the file or press 
Cancel.  

 Press the Close button. 

 Uncheck the Use Symbol check 
box. 
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MSO5000 Series Parallel Bus Triggering 

Key Take Away Points 

 When debugging a system, you often want to capture the 
state of some key signals when a certain event occurs. 
One key event may be the data value on the parallel bus. 

 You can use Logic triggering, setting up the desired digital 
trigger pattern bit-by-bit. However, since the parallel bus is 
already set up, it is much easier to use parallel bus 
triggering. 

 By following this simple procedure, you can easily trigger 
the oscilloscope on a specified serial pattern on a parallel 
bus signal, capturing each occurrence. 

 

 Notice that, in this case, the trigger point is positioned at 
the end of the 0X bus value. 

MSO5000 Series Procedure: 

 Press the front panel Trigger 
Menu button. 

 Using the Trigger Type drop 
down menu, select Bus 
triggering. 

 Using the Bus drop down menu, 
select Bus B1. 

 Press the Edit button. 

 Select Hex, enter the pattern 0X, 
and press OK. 

 Click on the Pattern text box and 
select >. 

 Double click on the Time text box 
and type in 100 ns. 

 Press the front panel Single 
button. 
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MSO/DPO5000 Series Parallel Bus Searching 

Key Take Away Points 

 Once you have acquired a serial signal, you often want to 
find all occurrences of a certain event, such as the 
transmission of specific content over the parallel bus. In 
this case, notice the locations of all data values matching 
the XX11 pattern in the acquisition. 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Search 
button. 

 Press the Bus search button in 
the control window. 

 Select the Configure tab at the 
left side of the control window. 

 The easiest way to enter the 
address is with the Pattern Editor. 
Press the Edit button at the right. 

 Select Binary format. 

 Double click on the Data Value 
text box and set the pattern to 
XXX XX11. 

 When you are done, press OK. 

 Press the front panel Run/Stop 
button to restart acquisitions. 
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MSO5000 Series MagniVu Acquisition 

Key Take Away Points 

 The normal sample rate for the MSO5000 digital channels 
is 500 MS/s per channel (2 ns timing resolution) over the 
full record length. This sample rate provides adequate 
sample rate for most applications involving widely-spaced 
digital signals. 

 Notice the digital timing resolution (displayed at the bottom 
of the screen): 

 

MSO5000 Series Procedure: 

 Set the horizontal Scale to 5 
ns/div. As you change the scale, 
notice that the digital sample rate 
reaches a maximum 500 MS/s 
(2.0ns/pt timing resolution, 
indicated in the readout at the 
bottom of the display). 

 Press the front panel Single 
button. 

 Press the front panel B button. 

 Press the Add Sources Select 
button, press the D7 button, and 
press OK to add channel D7 back 
into the parallel bus. 

 To restore it to the MSB position 
in the bus, click on the D7 entry in 
the Bus 1 Contains graphic and 
repeatedly press the up arrow 
next to it until D7 appears at the 
top of the list. 

 Notice that intermediate decoded 
bus values may appear on the 
display, and the bus transitions 
occur where the data bit values 
change, not just on the clock 
edges. You can use zoom to look 
at these intermediate values in 
more detail. 

 Press the Cursors front panel 
button once to turn on vertical bar 
cursors. 

 Using the Multipurpose controls, 
place the a and b cursors on 
events of interest. 

 Notice that we are displaying the 
time delay between the edges, 
with single-pixel timing resolution. 
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Key Take Away Points 

 For high-resolution timing measurements between timing 
events that are close together, such as setup & hold time or 
propagation delay measurements, MagniVu acquisition 
mode provides the highest timing resolution available in a 
mixed signal oscilloscope. MagniVu provides up to 16.5 
GS/s sample rate (60.6 ps timing resolution) over a 10k 
record length centered around the trigger point. 

 With the higher MagniVu timing resolution, you can now 
accurately measure the timing differences between edges 
that occur within a single 2 ns digital sample period. 

 

 And, because normal and MagniVu acquisitions are always 
taken at the same time, you can switch back and forth 
between acquisition modes, even after acquisitions are 
stopped. 

MSO5000 Series Procedure: 

 Press the front panel Single 
button. 

 Select Digital -> MagniVu to 
select it. 

 Notice the 60.6 ps/pt digital timing 
resolution in the readout at the 
bottom of the display. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Select Digital -> MagniVu to 
toggle between normal and 
MagniVu modes. 
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MSO5000/DPO5000 Series 
Visual Trigger Lab 

 

 
 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.4 and with option VET installed 
Two TPP0500 or TPP1000 passive probes 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this document were made with the DPO Demo 3 board] 
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Overview of Visual Trigger 

Finding the right characteristic of a complex signal can require hours of collecting and sorting through 
thousands of acquisitions for the event of interest. Defining a trigger that isolates the desired event and 
shows data only when the event occurs speeds up this process. The optional Visual Trigger makes the 
identification of the desired waveform events quick and easy by scanning through all waveform acquisitions 
and comparing them to on-screen areas (geometric shapes). 

The visual trigger option adds an additional dimension to the standard trigger system that provides an 
intuitive method of triggering based on shapes in the oscilloscope's graticule. It enables the user to define 
shapes on the oscilloscope's display that qualify trigger events for the incoming signals. Visual trigger can 
qualify any trigger setup, simple or complex. Areas can be created using a variety of shapes including 
triangles, rectangles, hexagons or trapezoids to fit the area to the particular trigger behavior desired. Once 
shapes are created on the oscilloscope's display, they can be positioned and/or re-sized dynamically while 
the oscilloscope is in run mode to create ideal trigger conditions. Visual triggers can be combined with the 
standard triggers and act as a Boolean logic qualifier for the "A" and “B” events. 

More specifically, Visual Trigger is a software post-process that graphically compares acquired analog input 
waveform(s) to the areas you draw on the display. The process always begins with setting up the 
oscilloscope’s hardware trigger system to acquire the waveforms. The trigger can be as simple as an edge 
trigger or as complex as a multi-state trigger, or parallel, serial, or video trigger. For predictable operation, 
the scope should always be in Normal trigger mode. The maximum possible waveform capture rate is 
determined by this hardware trigger rate. The actual waveform capture rate will be reduced by the software 
processing time and the percentage of waveforms that do not meet the visual trigger criteria. 

Each of the visual trigger areas is associated with a specific input channel. By default, the areas are 
rectangular and are associated with the “selected channel” when created. You can then change the shape 
of the area, the associated channel, and whether the signal must go inside or stay outside of the area. 
Finally, you can write a logical equation to describe how Visual Trigger will use the various areas to 
determine which waveforms are displayed and which are discarded. 

Visual triggers can speed up complex debugging situations for high speed serial signaling by creating a 
series of ones and zeros using up to 8 shapes that simulate a serial pattern trigger. For DDR debugging 
situations, Visual Trigger can be helpful for accurately capturing bursty read/write traffic. It also can detect 
patterns in the memory data buses using the dynamic shaping of Visual Trigger to localize the cause of 
reduced setup and hold margins. Using Visual Trigger, hours of waiting to capture the right signal can be 
reduced to seconds or minutes. 

 

Lab Objectives 

- Obtain a basic understanding of Visual Trigger capabilities. 

- Learn how to graphically set up and demonstrate a simple Visual Trigger. 

- Learn how to set up a complex Visual Trigger using the equation editor. 

- Learn how to use the Save on Event feature to save the results of each trigger event. 

- Learn how to use the Mark All Trigger Events in Record feature. 
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MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has I
2
C digital 

clock and data signals which we can use for this lab: 

 

 The DPO Demo 2 board (020-2924-XX) also has I
2
C digital 

clock and data signals which we can use for this lab: 

 

DPO Demo Board Procedure 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
DPO Demo 3 board. 

 Verify the power LED is lit. 

 Attach TPP1000 or TPP0500 
probes to the Channel 1 and 
Channel 2 inputs of the 
oscilloscope. 

 Attach the probe grounds to the 
GND test point on the test board. 

 Connect the channel 1 probe tip 
to the I2C_CLK test point on the 
test board. 

 Connect the channel 2 probe tip 
to the I2C_DATA test point on the 
test board. 

 Press the Default Setup button to 
set the oscilloscope into a known 
state. 

 Press the RESET button. 

Key Take Away Points 

 With option VET installed, the MSO/DPO5000 Series 
oscilloscope allows you to refine the oscilloscope’s 
hardware-based triggering with a graphical definition of the 
desired trigger signal. 

MSO/DPO5000 Series Procedure 

 Select Help -> About 
TekScope…. 

 Verify that option VET: Visual 
Trigger and Search is installed. 

 Press the OK button. 



 

MSO5000 / DPO5000 Lab Exercise Book 

Version 1.1   5/11/2012 48W-26279-3   178 of 394 

 

Simple Waveform Triggering 

Key Take Away Points 

 Let’s start by examining an I
2
C clock signal. This signal 

consists of bursts of digital pulses, with various lengths of 
bursts. As such, it is difficult to get a stable display using 
standard triggering techniques. 

 

 Remember that, in normal acquisition mode, the 
oscilloscope only acquires signals when a valid trigger 
occurs. Once the oscilloscope has acquired a waveform, 
the oscilloscope can then process the signal. Normally this 
would be a measurement or display. But it can also be 
further refinement of the trigger criteria using Visual 
Trigger. 

 Notice the orange circle around the channel 1 icon at the 
left side of the display. This indicates that channel 1 is the 
“selected channel”. (Since there is only one signal on the 
display, this should not be a surprise.) The concept of 
“selected channel” is important to Visual Trigger and will 
become clearer as you move through the lab. 

MSO/DPO5000 Series Procedure: 

 Set the channel 1 Vertical Scale 
to about 700 mV/div and center 
the position of the waveform 
vertically on the display. 

 Set the Horizontal Scale to 20 
µs/div. 

 Press the Trigger Level control 
to automatically set the trigger 
level to 50%. 

 Select Trig->Edge Setup…. 

 Press the Options tab at the left 
side of the control window. 

 Press the Normal Trigger Mode 
button. This step is very 
important. If you leave the scope 
in Auto Trigger Mode, you may be 
very confused by the behavior of 
visual trigger. 

 Notice that the display is similar to 
the screen shot at the left, and is 
fairly stable, but there are a few 
different patterns which meet this 
trigger criterion. 

 Just to prove the point, press the 
purple front-panel DPX button. 

 When you are done, press the 
DPX button again to return to 
normal acquisitions. 
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Simple Visual Trigger Setup 

Key Take Away Points 

 The optional Visual Trigger allows you to graphically 
specify areas on the display through which the signal must 
or must not cross. 

 

 Notice that the Visual Trigger was automatically turned on 
and the specified Visual Trigger area is now displayed: 

 

 The readouts on the A1 area display indicate that the 
Visual Trigger area is operating on channel C1 (the 
“selected channel”), and the X indicates that the signal 
must be outside the area. 

 The equation readouts at the top of the display and in the 
Visual Trigger control window indicate the current setup of 
the Visual Trigger. 

MSO/DPO5000 Series Procedure: 

 Press the Visual Trigger tab at 
the left side of the control window. 

 Press the left mouse button and 
draw a rectangle below the 
waveform at the left side of the 
display, as shown at the left, and 
select Visual Trigger->Add 
Visual Trig Area. 

 Notice that the visual trigger area 
A1 appears. The check-mark and 
C1 readout in the upper right 
corner of the area indicates that, 
by default, Visual Trigger is 
requiring the channel 1 (“selected 
channel”) signal to cross through 
the area. 

 

 

 

 Right-click on this shape and 
select Visual Trigger Area 1 -> 
Must be outside -> C1. This 
specifies that the Channel 1 
signal must stay outside of this 
area. Notice that the signal no 
longer occurs in this area and the 
area readout now shows “X C1”. 
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Key Take Away Points 

 After enabling two Visual Trigger areas, the display should 
look about like this: 

 

 Notice the Visual Trigger equation at the top of the display: 
“((C1 OUT A1) & (C1 OUT A2))”. This would be interpreted 
as the (channel 1 is OUTside area A1) AND (channel 1 is 
OUTside area A2). This equation looks a lot like Boolean 
math in the oscilloscope’s math equation editor! 

 This is an example of using to Visual Trigger to simply and 
graphically setting up the trigger system to capture a 
specific burst width on a complex signal. 

MSO/DPO5000 Series Procedure: 

 Press the left mouse button and 
draw a rectangle below the 
waveform at the right quarter of 
the display, as shown at the left, 
and select Visual Trigger->Add 
Visual Trigger Area. 

 Right-click on this shape and 
select Visual Trigger Area 2 -> 
Must be outside -> C1. This 
specifies that the Channel 1 
signal must stay outside of this 
area. Notice that the signal no 
longer occurs in this area. 

 Right-click on this shape again 
and notice that this pop-up menu 
provides a way to show or hide 
the trigger expression (shown at 
the top left corner of the display), 
show or hide the visual trigger 
areas, and show or hide the area 
settings in these visual trigger 
areas. 
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Key Take Away Points 

 In addition to graphical definition with the mouse or 
touchscreen, the Visual Trigger areas can be edited with 
the Visual Qualification Setup control window: 

 

 From this control window, you can change the size and 
position of the area, as well as add and delete vertices to 
create your own shape! 

 Finally, you can make the areas’ colors match the source 
waveform for easy recognition. This can be especially 
helpful when the Visual Trigger specification includes 
multiple channels. 

 

MSO/DPO5000 Series Procedure: 

 Right-click on area 1 and select 
Visual Trigger Area 1 -> Visual 
Setup…. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Click on the Edit Logic tab at the 
left side of the control window. 

 Click on the Inherit Source 
Colors radio button in the lower 
right corner of the control window. 

 

 

 

 

 

 

 

 

 

 When you are done, right-click on 
area A1 and select Visual 
Trigger Area 1->Delete All 
Areas. 
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More Complex Visual Trigger Setup 

Key Take Away Points 

 Now let’s look at a more random signal – the I
2
C Data 

signal. 

 Since we need a stable trigger signal to work with Visual 
Trigger, we’ll continue to use the I

2
C clock on channel 1 as 

the trigger source (even though we’re not going to display 
it). 

 

 Again, we’ll start with a Visual Trigger area and we’ll 
specify that the channel 2 signal must stay outside of it: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Ch 1 button 
to turn it off. 

 Press the front panel Ch 2 button 
to turn it on. 

 Notice the orange circle around 
the channel 2 icon at the left side 
of the display. This indicates that 
channel 2 is now the “selected 
channel”. 

 Set the channel 2 Vertical Scale 
to about 700 mV/div and center 
the position of the waveform 
vertically on the display. 

 Set the Horizontal Scale to 1 
µs/div. 

 Select Trig->Visual Trigger 
Setup…. 

 

 

 

 Press the left mouse button and 
draw a rectangle in the blank area 
near the left side of the display, 
as shown at the left, and select 
Add Visual Trigger Area. 

 Notice that the visual trigger area 
A1 appears. The check-mark and 
C2 readout in the upper right 
corner of the area indicates that, 
by default, Visual Trigger is 
requiring the channel 2 (“selected 
channel”) signal to cross through 
the area. 

 Right-click on this shape and 
select Visual Trigger Area 1 -> 
Must be outside -> C2. This 
specifies that the Channel 2 
signal must stay outside of this 
area. The area readout now 
shows “X C2”. 
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Key Take Away Points 

 Then we’ll add a second area and specify that the C2 
signal must remain outside it: 

 

 We have some choices about the shapes of the Visual 
Trigger areas, including rectangles, triangles, hexagons, 
and trapezoids. To provide a little margin for variations in 
risetimes, let’s change area A2 to a hexagon: 

 

MSO/DPO5000 Series Procedure: 

 Right-click on Visual Trigger area 
A1 and select Visual Trigger 
Area 1 -> Duplicate Area. This 
places a copy of the area on the 
display. 

 Left-click on area A2 and drag it 
near to the center of the display, 
as shown at the left. 

 Notice that, while you are moving 
the area, the coordinates of the 
area become time and voltage 
readouts. The vertical scale and 
position for the area are related to 
the channel associated with the 
area. (If you were to associate the 
area with a different channel, the 
position and/or the size of the 
area would change accordingly.) 

 

 

 Right-click on area A2 and select 
Visual Trigger Area 2 -> Edit 
Shape -> Hexagon. This 
changes the shape from a 
rectangle to a hexagon. 

 From the same right-click menu, 
you can also flip the shape 
horizontally or vertically. 

 Using the left mouse button, click 
and drag the squares (“handles”) 
on the sides and corners of area 
A2 to resize it horizontally and 
vertically, and to adjust the 
position of area A2. 

 You can also click on any of the 
vertices and adjust the position of 
just that vertex, as shown at the 
left. 
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Key Take Away Points 

 Visual Trigger can be used to graphically specify where 
signals must occur, as well as where they must not occur. 
Area A3 is defined to be an area in which the signal must 
occur, with either a rising or a falling edge occurring within 
the rectangle. 

 

 Notice the signals to the right of area A2. Some of the 
signals have very fast risetimes, while others are slower. 
We can use Visual Trigger to manually select the signals of 
interest: 

 

 You can also add more areas to the display (up to 8 areas) 
to further refine the trigger definition. 

 Also, Visual Trigger allows you to save and recall the setup 
of the Visual Trigger areas and other settings without 
having to save the entire oscilloscope setup. The setups 
are text files and can be saved on the oscilloscope or on an 
external drive such as a USB flash drive. 

MSO/DPO5000 Series Procedure: 

 Notice that the signal is appearing 
between areas A1 and A2. Draw 
a rectangle between A1 and A2, 
and select Add Visual Trigger 
Area. Notice that, by default, this 
area is specifying that the signal 
“Must be inside”, as indicated by 
the check mark. 

 

 

 

 

 

 

 

 

 

 Press the left mouse button and 
draw a rectangle in the blank area 
near the right side of the display, 
as shown at the left, and select 
Add Visual Trigger Area. 

 Right-click on area A4 and select 
Visual Trigger Area 4 -> Edit 
Shape -> Triangle. The triangular 
shape is especially useful for 
manually selecting details of 
signals. 

 Press the left mouse button and 
drag the triangular area A4 to 
select specific signals, such as 
those with slow risetimes, as 
shown at the left. 

 Notice that you can use a Visual 
Trigger region, especially a 
triangle, to interactively 
investigate the characteristics of a 
complex signal. 
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Key Take Away Points 

 As noted earlier, the coordinates of the areas are based on 
the oscilloscope horizontal and vertical scales and units, 
not merely screen position. 

 For example, the Visual Triggers are scaled horizontally 
when you adjust the Horizontal Scale control: 

 

 Changing scales can also force the Visual Trigger areas 
off-screen. When the regions are off-screen, you can click 
on the triangular icons and drag them back onto the display 
with the mouse. 

 

MSO/DPO5000 Series Procedure: 

 Turn the Horizontal Scale control 
counter-clockwise and notice that 
the Visual Trigger areas are 
scaled along with the waveforms 
on the display. 

 

 

 

 

 

 

 

 

 

 

 

 

 Turn the Horizontal Scale control 
clockwise and notice that the 
Visual Trigger areas are scaled 
along with the waveforms on the 
display. Some of the areas are 
eventually pushed off of the 
screen and are displayed as small 
triangles. You can use the mouse 
to drag these areas back onto the 
display. 

 Return the Horizontal Scale 
control to 1 µs/div. 

 

 

 

 When you are done, right-click on 
area A1 and select Visual 
Trigger Area 1->Delete All 
Areas. 
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Editing Visual Trigger Expressions 

Key Take Away Points 

 As a final step to this Visual Trigger lab, let’s use Visual 
Trigger to program the oscilloscope to trigger when the 
digital signal starts high AND then goes low OR where the 
signal starts low AND then goes high. 

 To do this, we need to define four Visual Trigger areas: 

 

 And edit the equation to implement the appropriate logic: 

 

 As you can see in the editor control window, you can build 
an equation using any of the four analog channels, the In or 
Out operands, the logical AND, OR, and XOR operands, 
and any of the eight areas. 

MSO/DPO5000 Series Procedure: 

 Using the mouse or touchscreen, 
define four Visual Trigger areas, 
approximately as shown at the 
left, to specify the high and low 
digital signal levels at the left side 
of the display and near the middle 
of the display. 

 As you add these areas, the 
triggering will stop. This is 
expected, since you’ve just asked 
the trigger system to find digital 
signals that are simultaneously 
“low” and “high” at the same time, 
as indicated by the default visual 
trigger equation. 

 Let's now edit the visual trigger 
expression to implement the 
desired logic. 

 

 

 Press the Edit button to launch 
the Qualification Expression 
Editor control window. 

 Either clear the equation and 
enter it, or simply edit the 
equation to achieve the desired 
logical expression. 

 Assuming you entered the four 
areas in the same order as 
shown, the equation triggers the 
scope when the digital signal 
starts high AND then goes low 
OR where the signal starts low 
AND then goes high: 

(((C2 IN A1) & (C2 IN A2)) |  
 ((C2 IN A3) & (C2 IN A4))). 

 When you are done, press Apply 
and OK. 
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Debugging Visual Trigger Setups 

Key Take Away Points 

 Perhaps it would be useful to review a few key points about 
Visual Trigger and use this knowledge to help debug 
common Visual Trigger setup issues. 

 First of all, Visual Trigger is a software post-process 
operating on a properly triggered acquisition. 

o Verify the trigger is in Normal mode. 

o Verify the oscilloscope is triggering, by temporarily 
disabling Visual Trigger. This can be done by 
enabling FastAcq mode or by turning Visual 
Trigger off, either through the Visual Trigger Setup 
control window or through the right-click menu. If 
the oscilloscope is not triggering, debug your setup 
as you normally would. Then, turn Visual Trigger 
back on. 

o Make sure the overall setup is as expected. You 
can do this by examining the graphical 
representation in the Visual Trigger Setup control 
window. 

 Second, the logic must make sense. For example, if you 
are edge triggering on the signal as shown below and you 
draw the boxes as shown below, you will never get a visual 
trigger unless you specify (C1 OUT A1) and (C1 IN A2) and 
(C1 OUT A3). If you specify (C1 IN A1) or (C1 OUT A2) or 
(C1 IN A3), you create a condition that is never true. 

o If all else fails, simplify the Visual Trigger setup by 
removing areas one at a time. You can do this via 
the right-click menu or by removing areas from the 
Visual Trigger equation with the equation editor. 

 A working setup might look something like this: 

 

MSO/DPO5000 Series Procedure: 

 Verify trigger readout shows 
“Normal”. 

 Temporarily turn off Visual Trigger 
to check the signal and setup: 

 Press the front panel 
FastAcq button, or 

 Select Trig->Visual Trigger 
Setup… and press Visual 
Trigger Off, or 

 Right-click on a visual trigger 
area and select Visual 
Trigger Area -> Visual 
Trigger Off. 

 Verify the instrument is triggering. 
The waveform should be updating 
and the trigger readout shows 
“Triggered”. 

 Turn Visual Trigger back on: 

 Press the front panel 
FastAcq button again, or 

 Select Trig->Visual Trigger 
Setup… and press Visual 
Trigger On, or 

 Right-click on a visual trigger 
area and select Visual 
Trigger Area -> Visual 
Trigger On. 

 Select Trig->Visual Trigger 
Setup… and verify that the 
Trigger only if matches this 
condition graphic is as you 
expect. 

 Finally, examine the setup for 
each of the areas and examine 
the visual trigger expression to 
verify you have implemented the 
desired logic. 

 If necessary, delete areas one at 
a time until the logic starts to 
work. 

 Finally, if you want to save a 
waveform captured by Visual 
Trigger, use Single Sequence 
and then save the file. 
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“Save On Trigger” Setup 

Key Take Away Points 

 Now, let’s take a look at a related and very useful feature – 
Action on Event. Action On Event allows you to program 
the oscilloscope to save or email specific information (such 
as screen shots or waveform data) each time a specific 
event (such as a Trigger, Limit Test violation, or Mask Test 
violation) occurs. For this example, we will save screen 
shots of a series of 10 Visual Trigger events. 

 

 The Save on Event Setup control window allows you full 
control of the actions to take when the specified event 
occurs: 

. 

MSO/DPO5000 Series Procedure: 

 If the front panel Run/Stop button 
is green, press it to stop 
acquisitions. 

 Select File->Action On Event… 
and verify that Trigger is selected 
in the On the event of text box, 
or select Trig->A Event (Main) 
Trigger Setup… and select the 
Save on Trigger check box. 

 Press the Setup button next to 
the Save check box. 

 Press the Browse button next to 
the Save Location text box and 
select the desired file path. 

 Verify that Screen Capture is 
selected under Files to Save. To 
verify or change the file 
properties, press the Settings 
button next to Screen Capture. 

 Under File Name, verify that Use 
Date and Timestamp is selected. 
If you prefer to give the files a 
specific name (such as 
“SaveOnTrigger”) with the event 
number appended to it, select 
Custom Base Filename and type 
in the desired base file name. 

 Verify that the Limit value under 
Event Limits is set to 10. 

 Check the Save On Trigger 
Event check box. 

 Press the front panel Run/Stop 
button to restart acquisitions. 

 You can watch the Current 
Count readout to monitor 
progress. When the limit is 
reached, the Save on check box 
will be automatically cleared. 

 Finally, minimize the scope 
application and navigate through 
the Windows file system to find 
and verify that the screen shots 
were saved as expected. 
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“Mark All Trigger Events in Record” Setup 

Key Take Away Points 

 After autosetting the I
2
C clock signal, notice that the 

oscilloscope is triggering on a positive edge and has 
positioned this edge and the orange triangle (at the top of 
the display) halfway across the display. This is not the only 
edge in the waveform; it is just the one that the 
oscilloscope is triggering on. 

 

 Notice that each event (in this case, positive edges) is 
marked with a green triangle at the top of the display: 

. 

MSO/DPO5000 Series Procedure: 

 Press the Default Setup and 
Autoset buttons to get a stable 
display. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Set the Horizontal Scale to 500 
µs/div. 

 Select Trig->A Event (Main) 
Trigger Setup…. 

 Press the Options tab at the left 
side of the control window. 

 Press the Normal Trigger Mode 
button. 

 Press the front panel Single 
button. 

 Press the A Event tab at the left 
side of the control window. 

 Check the Mark All Trigger 
Events in Record check box. 

 Zoom in on the center of the 
display at the trigger point. 
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Key Take Away Points 

 Using Visual Trigger, set up the oscilloscope to keep only 
acquisitions that are high for an extended amount of time 
followed by a positive edge, like this: 

 

 Notice that the green bar now starts with the left edge of 
the Visual Trigger area and ends with the edge trigger point 
in the screen shot above. 

 Notice that all of the other composite trigger events (in this 
case, a Visual Trigger followed by a positive edge) is 
marked with a green bar with triangles on each end. This is 
what the green bar to the right of the trigger point looks like: 

 

 In general, the green bar will start at the left-most side of 
the composite trigger definition and will end at the right-
most side of the composite trigger definition, whether the 
composite trigger definition is just hardware triggering or if 
it includes Visual Triggering. And, the regions can overlap, 
since there is no sense of trigger holdoff in this mode. 

MSO/DPO5000 Series Procedure: 

 In the zoom window, draw a box, 
as shown in the screen shot on 
the left, and select Visual 
Trigger-> Add Visual Trigger 
Area. 

 Right click on the box and select 
Visual Trigger Area 1->Must be 
outside->C1. 

 Press the front panel Run/Stop 
button. 

 Verify that this Visual Trigger 
setup is indeed allowing you to 
isolate the first positive edge in 
each burst of clock pulses. 

 Press the front panel Single 
button. 

 

 

 

 

 Press the front panel Search right 
arrow button once. 

 Notice that the Mark All Trigger 
Events in Record feature is 
integrated with Visual Trigger. 
The blue Visual Trigger box and 
the orange hardware trigger 
indicator are shown only at the 
center of the screen, the Mark All 
Trigger Events in Record feature 
has marked all matching events 
with the green bars at the top of 
the display. 
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MSO5000 Series 
Mixed Signal Demo Lab 

 

 
 
Equipment List 
One MSO5000 Series oscilloscope with software version ≥6.1.1 and the SR-EMBD option installed or 
      one DPO5000 Series oscilloscope with software version ≥6.1.1 
      and the MSOE and SR-EMBD options installed 
Four TPP0500 or TPP1000 passive probes 
One P6616 MSO probe 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this lab were made with the DPO Demo 3 board] 
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A Mixed-Signal Application Circuit 

The DPO Demo 3 and DPO Demo 2 boards have a circuit which enables you to do a demo of a complete, 
fairly typical embedded mixed-signal application. 

The system microcontroller generates digital waveform values and sends them out over the SPI serial bus. 
The port expander translates the serial information from the SPI bus to its parallel bus representation. The 
parallel bus drives the inputs to a Digital-to-Analog Converter (DAC), which generates an analog 
representation of the digital values. 

The block diagram for the circuit is shown below: 

 
By using a Mixed-Signal Oscilloscope, you can trace the signal path from start to finish to verify the circuit 
operation and, if necessary, debug the circuit. 

MSO5000 Series Lab Setup 

Key Take Away Points 

 Parallel and serial buses are often combined with analog 
circuitry in many mixed-signal, embedded designs. An 
MSO provides unique insight into the operation of these 
systems. 

 With the MSOE option installed, the MSO5000 or 
DPO5000 Series oscilloscope can trigger on, decode, and 
search parallel bus traffic. 

 With the SR-EMBD option installed, the MSO5000 Series 
oscilloscope can trigger on, decode, and search SPI bus 
traffic. 

MSO5000 Series Procedure 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the MSOE: 16-
Channel MSO option is installed. 

 Verify that the SR-EMBD: I2C/SPI 
Serial Triggering and Analysis 
option is installed. 

 Press the OK button. 
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Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has a complete 
mixed-signal application circuit which we can use for this 
lab: 

 

 The DPO Demo 2 board (020-2924-XX) also has a 
complete mixed-signal application circuit which we can use 
for this lab: 

 

DPO Demo Board Procedure 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the power LED is lit. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. Connect the 
probe ground to the GND test 
point and the probe tip to the 
SPI_SCLK test point on the test 
board. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 2 input of 
the oscilloscope. Connect the 
probe ground to the GND test 
point and the probe tip to the 
SPI_SS test point on the test 
board. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 3 input of 
the oscilloscope. Connect the 
probe ground to the GND test 
point and the probe tip to the 
SPI_MOSI test point on the test 
board. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 4 input of 
the oscilloscope. Connect the 
probe ground to the GND test 
point and the probe tip to the 
DAC_OUT test point on the test 
board. 

 Attach a P6616 MSO probe to the 
front of the MSO. 

 Connect probe Bit 0 to DAC_IN0, 
probe Bit 1 to DAC_IN1, and so 
on, up to Bit 7 to DAC_IN7. 

 If the probe inputs have the 
ground extenders attached, make 
sure that the probe ground pins 
are all connected to the 
connector’s GND pins on the left 
side of the connector. If the probe 
inputs do not have ground 
extenders attached, connect a 
ground wire from the automotive 
spade on the side of the probe to 
a GND test point on the board. 
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Key Take Away Points 

 The display should look about like this: 

 

 Here you can see many SPI serial signals (channels 1-3), 
and analog sine wave (channel 4), and some digital signals 
(D7-D0). However, it is difficult to interpret the meaning of 
the digital data, especially the serial data, from this display. 

 Let’s look at an easy way to interpret the serial data. 

MSO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Turn on all of the analog channels 
by pressing the front panel 2, 3, 
and 4 buttons. 

 Set the Vertical Scale for 
channels 1, 2, 3, and 4 to 5V/div. 

 Position channels 1, 2, 3, and 4 in 
the upper half of the display. 

 Press the front panel Trigger 
Level control to set the trigger 
level to 50%. 

 Press the front panel D15-D0 
button. 

 Press the Turn D7-D0 On button. 

 Using the Size drop down menu, 
select Medium display size. 

 Press the X in the upper right 
corner of the control window to 
close it. 

 Set the Horizontal Scale to 10 
ms/div to display a couple of 
cycles of the sine wave on 
channel 4. 

 Press the front panel Single 
button. 
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MSO5000 Series SPI Bus Decoding 

Key Take Away Points 

 The MSO5000 Series can automatically decode SPI bus 
data. Setting up a basic SPI bus waveform display takes 
only a few simple steps. 

 The decoded serial bus (B1) is shown at the center of the 
display: 

 

 When you use Wave Inspector to zoom in on the serial bus 
details, you can see the individual decoded data bytes: 

 

MSO5000 Series Procedure: 

 Press the purple front panel Bus 
B button to display the Bus Setup 
menu. 

 Under Bus Type, select Serial. 

 Using the drop down menu, select 
SPI. 

 Verify that the SCLK signal is on 
Ch1, SS is on Ch2, and MOSI 
Data is on Ch3. 

 Verify that the Threshold settings 
are all about 1.4V. 

 Verify that SCLK is set to Rising 
edge, SS is set to Active Low, 
and MOSI Data is set to Active 
High. 

 Set the Word Size (the number of 
bits in the packet) to 8. 

 Verify that MSB First is the 
selected Bit Order. 

 Press the Bus 1 button to turn 
bus B1 On. 

 Press the X in the upper right 
corner of the control window to 
close it. 

 Using the Wave Inspector pan 
and zoom controls, zoom in on 
one word of the decoded serial 
signal. 
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MSO5000 Series Parallel Bus Decoding 

Key Take Away Points 

 The MSO5000 Series can automatically decode parallel 
buses, too. Setting up a basic parallel bus waveform 
display takes only a few simple steps. 

 The decoded parallel bus (B2) is shown just below the 
center of the display. When you use Wave Inspector to 
zoom in on the decoded values on the serial and parallel 
buses, you can see the individual decoded data bytes: 

 

 

 

MSO5000 Series Procedure: 

 Press the purple front panel Bus 
B button to display the Bus Setup 
menu. 

 Select Bus B2 at the left side of 
the control window. 

 Verify that Parallel is selected 
and Clocked is not checked. 

 Press the Add Sources Select 
button. 

 Add digital channels 7 (MSB) 
through 0 (LSB) to the parallel 
bus by pressing the D7, D6, D5, 
D4, D3, D2, D1, and D0 buttons, 
in that order, and press OK. 

 Press the Bus 2 button to turn the 
parallel bus On. 

 Press the Display tab at the left 
side of the control window. 

 Notice that the data can be 
displayed in Hex, Binary, or 
Decimal. 

 Press the X in the upper right 
corner of the control window to 
close it. 

 Position Bus B2 below Bus B1. 

 Using the Wave Inspector pan 
and zoom controls, zoom in on 
one word of the decoded serial 
signal and notice the relationship 
to the decoded values on the 
parallel bus. 

 When you are done with zoom, 
press the Wave Inspector zoom 
button or turn the inner zoom 
control fully counter-clockwise to 
turn off zoom. 
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MSO5000 Series Mixed-Signal Triggering 

Key Take Away Points 

 What serial or parallel data values relate to the positive 
peak on the analog waveform? You can easily find out by 
triggering on the analog waveform and examining the 
decoded bus data, as shown below: 

 

 Zooming in, we see that the digital value of 01 hex 
corresponds to the positive peak of the DAC output 
voltage: 

 

MSO5000 Series Procedure: 

 Press the front panel Run/Stop 
button. 

 Press the front panel Trigger 
Menu button. 

 Press the Source Select button, 
press Ch4, and press OK. 

 Press the Mode tab and press the 
Normal Trigger Mode button. 

 Press the X in the upper right 
corner of the control window to 
close it. 

 Using the front panel Trigger 
Level control, set the trigger level 
at the top edge of the green 
channel 4 waveform. 

 Press the front panel Single 
button. 

 

 

 Adjust the Wave Inspector pan 
and zoom controls as needed to 
view the decoded data values at 
the time of the trigger event. 
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Key Take Away Points 

 What does the analog waveform look like when many of 
the digital inputs to the DAC are transitioning 
simultaneously? 

 Many DACs generate glitches on their analog outputs when 
multiple digital inputs change at the same time. This is 
especially critical at mid-scale, where the 8-bit digital data 
values might be transitioning from 7F hex (0111 1111 
binary) to 80 hex (1000 0000) binary. 

 You can easily find out by triggering on the decoded digital 
values (in this case, either on the serial or parallel bus) and 
examining the analog waveform, as shown below: 

 

 In this case, the DAC circuit is well-designed and there is 
no large mid-scale glitch on the analog output. 

 

MSO5000 Series Procedure: 

 Press the front panel Trigger 
Menu button. 

 Press the Trigger Type Select 
button and press the Bus button. 

 Using the Bus drop down menu, 
select Bus B1 as the trigger 
source. 

 Using the Trigger On drop down 
menu, select Data. 

 Press the Data Value Edit button. 

 Select Hex format and set the 
trigger data value to 8X hex. (It 
turns out that the exact values of 
7F and 80 hex do not occur in this 
design.) 

 Press OK. 

 

 

 

 

 

 

 

 

 

 Press the X in the upper right 
corner of the control window to 
close it. 

 Press the front panel Single 
button. 

 Adjust the Wave Inspector pan 
and zoom controls as needed to 
view the decoded bus values and 
the corresponding analog 
waveform. 
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MSO5000/DPO5000 Series 
LXI Class C Compliant 
Web Interface Lab 

 

 

 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.1.1 
One TPP1000 or TPP0500 passive probe 
One PC with Internet browser installed 
One standard or cross-over Ethernet cable to connect the oscilloscope directly to the PC, 
 or two standard Ethernet cables to connect both PC and oscilloscope to LAN 
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Overview of MSO/DPO5000 Web Interface 

Increasingly, companies are finding that distributed design teams are an efficient way to bring the right 
resources together for a design project. Engineers around the world need to share design details at the 
outset, and evaluation and measurement results as the project progresses. 

The MSO/DPO5000 Series can be connected to the Internet via the LAN port and a standard web browser. 
This LXI Class-C-compliant web interface enables control of network configuration. 

 

Overview of LXI Class C Compliance 

LXI (which stands for LAN eXtensions for Instrumentation) defines the communications protocols for 
instrumentation and data acquisition systems using Ethernet. LXI is a standard developed by the LXI 
Consortium, who maintain the LXI specification, promote the use of LXI, and ensure interoperability. 

LXI-compliant devices can also interoperate with devices that are not LXI-compliant, as well as instruments 
that employ other remote interfaces such as GPIB, VXI, and PXI. To simplify communication with non-LXI 
instruments, every LXI instrument must have an Interchangeable Virtual Instrument (IVI) driver. The IVI 
Foundation defines a standard driver Application Programming Interface (API). There are two IVI driver 
formats in use in the industry: IVI-COM for working with COM-based (usually Windows) development 
environments and IVI-C for working in traditional programming languages and many industry-standard 
analysis tools. 

LXI Class C is the baseline standard which provides LAN capabilities, a web interface, and IVI drivers. 
(Class B adds expanded triggering and communication capabilities. Class A devices build upon Class B 
devices by adding a wired trigger bus for precision triggering.) The MSO/DPO5000 Series interface is LXI 
Class C compliant. 

 

Objectives 

- Obtain an overview of LXI Class C compliance 

- Learn how to connect an oscilloscope to a PC via Ethernet. 

- Obtain a basic understanding of the web interface connectivity. 
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MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 

 

 

 

 

 

 

 

 You can connect to the MSO/DPO5000 Series via Ethernet 
connection through a standard PC web browser by simply 
entering the oscilloscope's IP address in the address bar of 
the browser. 

 There are two ways to physically connect the oscilloscope 
and PC via Ethernet: through an existing IP network or 
directly (“peer-to-peer”). 

 Either way, the next step in connecting an oscilloscope to a 
PC via Ethernet is to obtain the Internet Protocol (IP) 
address of the oscilloscope. 

 NOTE: You should always discuss plans for network 
connections with the network administrator. If Dynamic 
Host Configuration Protocol (DHCP) is available to 
automatically supply the IP address, the network 
administrator can tell you. If you need a static IP address, 
you should get it from the network administrator. 

 The next few step require access to the Windows desktop, 
so minimize the TekScope application: 

 

MSO/DPO5000 Series Procedure: 

 Connect the TPP0500 or 
TPP1000 probe to channel 1. 

 Connect the probe tip to the 
PROBE COMP signal on the 
lower right corner of the 
oscilloscope. 

 Connect the probe ground to the 
ground connection just above the 
PROBE COMP signal. 

 For an IP network connection: 

 Connect a standard Ethernet 
cable between the network 
connection and the Ethernet 
connector on the 
oscilloscope’s rear panel. 

 For direct connection to your PC: 

 Connect a standard or cross-
over Ethernet cable between 
the PC’s Ethernet connector 
and the Ethernet connector on 
the oscilloscope’s rear panel. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 
Note that this operation does not 
affect the Ethernet connection 
settings. 

 Press the front panel Autoset 
button to get a stable display. 

 Minimize the TekScope 
application by clicking on the 
minimize icon in the upper right 
corner of the display. 

 The TekScope icon will then 
appear at the bottom of the 
Windows display: 
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Key Take Away Points 

 The next step is to verify the LXI status. 

 

 Display the LXI LAN status indicator 

 

 and verify that the status is green and find the IP address: 

 

MSO/DPO5000 Series Procedure: 

 Click on the Show hidden icons 
up arrow at the bottom of the 
display. 

 

 

 

 

 

 Right click on the LAN Status 
Indicator icon. 

 

 

 

 

 

 Select Show LAN Status 
Indicator. 

 

 

 

 

 

 

 

 Notice that this window displays 
the same IPv4 address as if you 
selected Start -> Control Panel -
> Network and Internet -> View 
network status and tasks -> 
Local Area Connection -> 
Details. 

 Write down the IP address. 

 Close the status window by 
clicking on the X in the upper right 
corner. 
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LXI-enabled Instrument Control 

Key Take Away Points 

 When you enter the oscilloscope’s IP address into the 
browser’s address box, you should see the Instrument 
Welcome Page for the oscilloscope: 

 

 The LXI Network Configuration page should look about like 
this: 

 

 Notice that the LXI Status Indicator is displayed on the 
oscilloscope and that the green status indicator is flashing: 

 

PC Procedure: 

 Launch your Internet browser 
(e.g. Microsoft Internet Explorer) 
program on the PC. 

 Type the oscilloscope’s IP 
address into the web browser’s 
address box. For example: 
 
http://134.62.69.178 
 

 The oscilloscope’s LXI web page 
is displayed in your browser. 

 

 Notice the oscilloscope’s Host 
Name is also shown. Once you 
know this name, you can enter it 
into the web browser’s address 
box instead of the IP address. For 
example: 
 
http://MSO5204CQ18 
 

 

 Click on the Network 
Configuration link at the left side 
of the web page. 

 

 From this web page, you can 
change the host settings, such as 
the Host Name, Description, or IP 
address. When you have made 
the change, press the Submit 
button at the bottom of the page. 

 

 Click on the LXI Identification on 
Instrument On radio button to 
remotely turn on the LXI status 
display on the oscilloscope. 
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MSO5000/DPO5000 Series 
OpenChoice Connectivity Lab 
 

 

 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.1.1 
One TPP1000 or TPP0500 passive probe 
One PC with TekVISA installed (software is available for free download from www.tek.com) 
One USB cable (174-4401-00) 
 

file:///C:/Documents%20and%20Settings/scottd/My%20Documents/Marketing/FlagShip/Route66B/Training/Catalina/Calico/www.tek.com
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Overview of OpenChoice PC Connectivity Tools 

For oscilloscope / PC connectivity, the OpenChoice Instrument Manager programs provide many low-level 
features that most users are looking for when verifying and debugging simple test programs. With just a few 
clicks of a mouse, the free OpenChoice Call Monitor and Talker/Listener programs provide easy methods to 
remotely control the oscilloscope, test small programs, and monitor the results on a PC. 

Objectives 

- Learn how to launch OpenChoice Instrument Manager applications and connect an oscilloscope to 
a PC. 

- Learn how to remotely control an oscilloscope using Talker/Listener scripts. 

 
 
 

MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 For this lab, set up a simple display, such as the PROBE 
COMP signal: 

 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Connect the TPP1000 or 
TPP0500 probe to channel 1. 

 Connect the probe tip to the 
PROBE COMP signal on the front 
of the oscilloscope. 

 Connect the probe ground to the 
ground connection next to the 
PROBE COMP signal. 

 Press the front panel Autoset 
button. 
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Key Take Away Points 

 After you connect the USB cable between the oscilloscope 
and the PC, the USB plug-n-play driver should launch a 
Test and Measurement Device window like this: 

 

 Press the Cancel button. The OpenChoice Desktop 
program does not support the MSO/DPO5000 Series. 

 Click on the yellow VISA Resource Manager icon: 

 

 and you should see the following pop-up: 

 

 This is the OpenChoice Instrument Manager screen: 

 

PC Procedure: 

 Connect the rectangular end of 
the USB cable to a USB Host port 
on the PC and connect the ‘D’ 
shaped connector to the USB 
Device port on the back of the 
oscilloscope. 

 

 

 

 

 

 

 

 Click on the Cancel button. 

 Click on the yellow VISA 
Resource Manager icon in the 
Windows taskbar in the lower 
right corner of the display. 

 

 

 

 

 

 

 Select Instrument Manager…. 

 

 

 

 Notice that the instrument you 
connected (and maybe others) is 
shown in the list at the left. 
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Call Monitor and Talker / Listener Lab 

Key Take Away Points 

 The OpenChoice Instrument Manager program provides 
two applications, the Call Monitor and the Talker Listener. 

 

 The first application is the OpenChoice Call Monitor. This 
program monitors the communications between the 
oscilloscope and the PC: 

 

 The call monitor can be used to capture, time, and log the 
low-level communications. For example, the screen shot 
above captures all of the steps when the “*IDN?” query is 
sent to the oscilloscope. (You’ll see how to send the 
“*IDN?” query in the next section.) 

PC Procedure: 

 In the Instrument Manager 
program, click on the 
OpenChoice Call Monitor entry 
to highlight it and click on the 
Start Application or Utility 
button. 
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Key Take Away Points 

 Now, let’s go back to the OpenChoice Instrument Manager 
screen and start the Talker Listener application: 

 

 This is the OpenChoice Talker Listener screen. From this 
screen, you can directly control the oscilloscope by typing 
in commands and queries (found in the Programmer’s 
Manual). 

 

 By default, the “*IDN?” query is loaded into the text box at 
the top of the screen. 

 As shown in the bottom section of the display, the query 
opens a VISA session (first line), sends the command to 
the oscilloscope (second line), and reads back the 
oscilloscope’s response (third line). 

PC Procedure: 

 In the Instrument Manager 
program, click on the 
OpenChoice Talker Listener 
entry to highlight it and click on 
the Start Application or Utility 
button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Click on the Query button to send 
the “*IDN?” query to the 
oscilloscope. 

 Notice the commands and 
responses as they appear at the 
bottom of this screen. 

 Also, notice the lower level of 
detail that appears in the 
OpenChoice Call Monitor window 
(shown on the previous page of 
this lab). 
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Key Take Away Points 

 The second application is the OpenChoice Talker Listener 
which allows you to interact with the oscilloscope using the 
programmable interface. For details, see the 
MSO/DPO5000 Programmer’s Manual. 

 You can type other commands and queries, one at a time, 
into the text box at the top. Click on the Write button if it is 
a command or the Query button if it is a query. 

 

 The commands are logged in the Command / Script History 
window. To repeat any of those commands, simply click on 
them to copy them into the text box at the top and then 
click on the Write or Query button. 

PC Procedure: 

 

 

 

 

 

 Type “FACtory” into the text box 
at the top of the screen and click 
on the Write button. 

 

 

 

 Type “SET?” into the text box at 
the top of the screen and click on 
the Query button. 

 

 

 

 

 

 

 Click on “FACtory” in the 
Command / Script History window 
in the center of the screen and 
click on the Write button. 
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Key Take Away Points 

 If you have repetitive or complex tasks, you may find it 
easier to save the commands into a script file and reload 
them from the file. 

 Here is a simple example program which extracts the 
middle 101 samples out of a 1000 point acquisition: 

 

 You can read and execute a command script with just a 
few clicks of the mouse: 

 

 Now, go back and look at the OpenChoice Call Monitor. 
Notice it has logged all of the communications between the 
oscilloscope and the PC: 

 

PC Procedure: 

 Click on the Tools menu at the 
top of the screen, select 
Options…, check the AutoQuery 
box, and click OK. 

 Using a simple text editor like 
Windows Notepad, create a text 
file called “StartStop.txt” with the 
following contents: 
 
Talker Listener Script: 
<<Script2>> 
FACtory 
HORizontal:RECOrdlength 1000 
AUTOset EXECute 
Data:Source CH1 
Data:Start 450 
Data:Stop 550 
Data:Encdg ASCII 
Curve? 

 

 

 Click on the File menu at the top 
of the screen, click on Open 
Script…, navigate to and select 
the file you just created, and click 
on the Open button. 

 Notice that the script file text has 
been loaded into the center 
Command / Script History window 
on the display. 

 Press the Run button to run the 
script. 

 

 

 In the OpenChoice Call Monitor 
program, click on File, click on 
Save…, type in a file path and file 
name, and click Save to save the 
log file. 
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MSO5000/DPO5000 Series 
TekXL and TekW Toolbars Lab 

 

 

 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.1.1 
One TPP1000 or TPP0500 passive probe 
One PC with Microsoft Office, TekXL and TekW toolbars, and TekVISA installed 
    (This Tektronix software is available for free download from www.tek.com) 
One USB cable (174-4401-00) 
 

file:///C:/Documents%20and%20Settings/scottd/My%20Documents/Marketing/FlagShip/AnalogKid/Training/LabNotebook/www.tek.com
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Overview of PC Connectivity with TekXL and TekW Toolbars 

For simple connectivity between an oscilloscope and Microsoft Word and Excel applications on the PC, the 
TekW and TekXL toolbars provide most of the features that most users are looking for. With just a few clicks 
of a mouse, the free toolbars easily transfer screen shots, waveform data, measurements, and setup files to 
the PC and insert them directly into Word documents and Excel spreadsheets. 

The TekW Word toolbar allows you to: 

 Connect the oscilloscope to the PC over USB. 

 Get oscilloscope settings from the oscilloscope, save them to a file, and send them back to the 
oscilloscope, all from within Word. 

 Capture an acquired waveform, graph the data values, and insert the graph into the document. 

 Capture automatic measurement values at regular time intervals and insert a table of values into the 
document. 

 Capture triggered waveforms, graph the data, and insert the graph into the document. 

 Capture triggered automatic measurement data and insert a table of values into the document. 

 Capture the oscilloscope’s screen image and insert it into the document. 

The TekXL Excel toolbar allows you to: 

 Connect the oscilloscope to the PC over USB. 

 Get oscilloscope settings from the oscilloscope, save them to a file or workbook, and send them 
back to the oscilloscope, all from within Excel. 

 Capture an acquired waveform, insert the data values into the spreadsheet, and optionally graph the 
data. 

 Capture automatic measurement values at regular time intervals, insert a table of values into the 
spreadsheet, and optionally graph the measurement data. 

 Capture triggered waveforms and insert the data values into columns in the spreadsheet. 

 Capture triggered automatic measurements and insert the data values into the spreadsheet. 

 Capture the oscilloscope’s screen image and insert it into the spreadsheet. 

Objectives 

- Learn how to install the Tek toolbars into the Microsoft Office applications and connect the 
oscilloscope to the PC via USB. 

- Learn how to transfer oscilloscope screen shots, waveform data, and automatic measurement 
results directly into a Word document on a PC. 

- Learn how to transfer oscilloscope waveform data, timed measurements, triggered waveform 
captures, and screen shots directly into an Excel spreadsheet on a PC. 
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MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 For this lab, set up a simple display, such as the PROBE 
COMP signal: 

 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Connect the TPP1000 or 
TPP0500 probe to channel 1. 

 Connect the probe tip to the 
PROBE COMP signal on the front 
of the oscilloscope. 

 Connect the probe ground to the 
ground connection next to the 
PROBE COMP signal. 

 Press the front panel Autoset 
button. 
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Key Take Away Points 

 After you connect the USB cable between the oscilloscope 
and the PC, the USB plug-n-play driver may launch a Test 
and Measurement Device window like this on the PC 
display: 

 

 When you installed the toolbars on your PC, the following 
icon was probably installed on your PC desktop: 

 

 From this configuration window you can specify whether or 
not the toolbars will be launched automatically or manually 
(through the Tools->Templates and Add-ins list): 

 

PC Procedure: 

 Connect the rectangular end of 
the USB cable to a USB Host port 
on the PC and connect the ‘D’ 
shaped connector to the USB 
Device port on the back of the 
oscilloscope. 

 If the Test and Measurement 
Device popup appears, click on 
the Cancel button. 

 

 

 

 Double-click on the Tektronix 
Toolbar Startup icon. 

 

 

 

 

 

 

 

 

 When you are done, click on the 
OK button. 
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TekW Toolbar Lab 

Key Take Away Points 

 If you need to add the TekWToolbar template add-in, you 
should see the following popup: 

 

 

 

 

 

 

 

 

 

 Then you may see a security warning that macros have 
been disabled. If this happens, click on the Enable button: 

 

 Finally, you may see this popup: 

 

 When the TekWToolbar is properly installed, you should 
see it appear at the top of the display: 

 

PC Procedure: 

 Launch Microsoft Word. 

 If the TekW toolbar does not 
appear near the top of the Word 
window: 

 The interface varies between 
versions of Word, but for 
Word 2002: 
 Click on Tools and then 

click on Templates and 
Add-ins…. 

 Check the box next to 
TekWToolbar.Dot. 

 Click on OK. 
 Right click in the menu 

area at the top of the 
Word window and click on 
TekWToolbar to display 
the toolbar. 

 For Word 2007: 
 Click on the Office 

Button and Word 
Options. 

 Select Add-Ins. 
 Select Templates in the 

Manage text box and 
press Go…. 

 Check the box next to 
TekWToolbar.Dot. 

 Click on OK. 
 Click on the new Add-Ins 

tab at the top of the 
screen. 

 For Word 2010: 
 Select File-> Options-> 

Add-Ins. 
 Select Word Add-ins in 

the Manage text box and 
press Go…. 

 Check the box next to 
TekWToolbar.Dot. 

 Click on OK. 
 Click on the new Add-Ins 

tab at the top of the 
screen. 

 If you see a warning popup about 
macros, click on the Enable 
Macros button. 

 If you see a warning popup about 
initializing ActiveX controls, click 
on the OK button. 
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Key Take Away Points 

 Work from left to right across the TekWToolbar to set up 
and use the toolbar features: 

 

 The first step is to connect to the oscilloscope. Simply 
select it from the list of connected devices: 

 

 For documentation tasks in Word, the most useful feature 
will likely be the TekW Screen Capture button: 

 

 When you click on the TekW Screen Capture button, the 
oscilloscope screen image will be inserted into the Word 
document at the cursor, much more easily than saving the 
image to a flash drive and copying it into the document: 

 

PC Procedure: 

 Mouse over each of the buttons in 
the TekWToolbar to discover their 
functions. 

 Click on the left-most button in the 
TekWToolbar. A mouse-over will 
identify it as TekW Connection. 

 

 

 Highlight the oscilloscope in the 
list and click on the OK button. 

 

 

 

 

 

 

 

 

 Place your cursor in your Word 
document at the location where 
you would like to insert an 
oscilloscope screen image. 

 Click on the sixth button from the 
left in the TekWToolbar. A mouse-
over will identify it as TekW 
Screen Capture. 
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Key Take Away Points 

 You can also graph the waveform data with the TekW 
Waveforms feature: 

 

 

 
 The other very useful TekW feature for most 

documentation tasks is to quickly and remotely capture 
waveform measurements using the TekW Measurements 
button: 

 

 Select up to 14 automatic measurements from the list: 

 

 When you click Start, you will automatically insert a table of 
measurement values at the cursor: 

CH1 
Amplitude 

CH1 Frequency CH1 Period CH1 Positive 
Duty 

2.52 1075.37722217 0.00092990625 49.99474235935 
 

PC Procedure: 

 Click on the third button from the 
left in the TekWToolbar. A mouse-
over will identify it as TekW 
Waveforms. 

 Click on the Capture button to 
capture the selected waveform 
data, graph it, and insert it into the 
document at the cursor. 

 

 

 

 

 

 

 

 

 When you are done, click on the 
Close button. 

 

 

 Click on the fourth button from the 
left in the TekWToolbar. A mouse-
over will identify it as TekW 
Measurements. 

 

 

 Click on the Single Capture radio 
button at the top of the window. 

 You select and deselect 
measurements from the list by 
clicking on them. Amplitude is 
already highlighted. Click on the 
Frequency, Period, and Positive 
Duty measurements in the list at 
the right side of the screen. 

 Click on the Start button to insert 
the measurement table. 

 

 

 

 Click on the Close button when 
you are done. 
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TekXL Toolbar Lab 

Key Take Away Points 

 If you need to add the TekXLToolbar add-in, you should 
see the following popup: 

 

 

 

 

 

 

 

 

 

 When the TekXLToolbar is properly installed, you should 
see it appear at the top of the display. Work from left to 
right across the TekXLToolbar to set up and use the toolbar 
features: 

 

 The first step is to connect to the oscilloscope. Simply 
select it from the list of connected devices: 

 

PC Procedure: 

 Launch Microsoft Excel. 

 If the TekXL toolbar does not 
appear near the top of the Word 
window: 

 The interface varies between 
versions of Excel, but for 
Excel 2002: 
 Click on Tools and then 

click on Add-ins…. 
 Check the box next to 

Tekxltoolbar. 
 Click on OK. 

 For Excel 2007: 
 Click on the Office 

Button and Excel 
Options. 

 Select Add-Ins. 
 Select Excel Add-ins in 

the Manage text box and 
press Go…. 

 Check the box next to 
Tekxltoolbar. 

 Click on OK. 
 Click on the new Add-Ins 

tab at the top of the 
screen. 

 

 Mouse over each of the buttons in 
the TekXLToolbar to discover 
their functions. 

 Click on the left-most button in the 
TekXLToolbar. A mouse-over will 
identify it as TekXL Connection. 

 

 Highlight the oscilloscope in the 
list and click on the OK button. 
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Key Take Away Points 

 For analysis tasks in Excel, one of the most useful features 
will be the TekXL Waveforms button: 

 

 

 By default, the TekXL Waveforms feature will insert the 
data values in the active Excel tab and automatically 
generate a graph of the data values, starting at the 
specified column and row coordinates: 

 

PC Procedure: 

 Click on the third button from the 
left in the TekXLToolbar. A 
mouse-over will identify it as 
TekXL Waveforms. 

 

 

 Click on the Capture button to 
capture the selected waveform 
data, graph it, and insert it into the 
document at the cursor. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 When you are done, click on the 
Close button. 
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Key Take Away Points 

 Another very useful TekXL feature for analysis tasks is to 
automatically log regularly-scheduled waveform 
measurements using the TekXL Measurements button: 

 

 Select up to 14 automatic measurements from the list: 

 

 On the Timing tab, you can select how many 
measurements to make, how often, and when to start the 
measurements. By default, you will get 50 measurements, 
taken once a second, starting as soon as you click on the 
Start button: 

 

PC Procedure: 

 Click on the fourth button from the 
left in the TekXLToolbar. A 
mouse-over will identify it as 
TekXL Measurements. 

 

 

 On the Selection tab, click on the 
Repeated Timed Captures radio 
button at the top of the window. 

 You select and deselect 
measurements from the list by 
clicking on them. Amplitude is 
already highlighted. Click on the 
Frequency measurement in the 
list at the right side of the screen. 

 

 

 

 

 Click on the Timing tab at the top 
of the window. 
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Key Take Away Points 

 On the Charting tab, you can select whether or not you 
automatically generate a graph of the measurement values: 

 

 By default, the TekXL Measurements feature will insert the 
measurement values in the active Excel tab and 
automatically generate a graph of the values, starting at the 
specified column and row coordinates (specified on the 
Selection tab): 

 

PC Procedure: 

 Click on the Charting tab at the 
top of the window. 

 Click on the Upon Completion 
radio button to specify that the 
graph will be generated after all of 
the measurement values are 
acquired. 

 

 

 

 

 

 Click on the Start button to insert 
the measurement table. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 Click on the Close button when 

you are done. 
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Key Take Away Points 

 If you want to intermittently capture waveform or 
measurement data only when the oscilloscope triggers, you 
will find the TekXL Triggered Captures feature to be useful: 

 

 The TekXL Triggered Captures feature allows you to select 
among the active waveforms or among the list of automatic 
measurements. You can specify how many triggered sets 
of data you want to log: 

 

 By default, the TekXL Triggered Captures feature will insert 
the measurement values in the active Excel tab and 
automatically generate a graph of the values, starting at the 
specified column and row coordinates: 

 

 Finally, just like with TekW toolbars, you can insert an 
oscilloscope screen shot into the document with the TekXL 
Screen Capture button: 

 

PC Procedure: 

 Click on the fifth button from the 
left in the TekXLToolbar. A 
mouse-over will identify it as 
TekXL Triggered Captures. 

 

 

 Click on the Waveform radio 
button at the top of the window. 

 Set the Number of Captures to 
10. 

 

 

 

 

 

 Click on the Start button to insert 
the triggered waveform data table. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Click on the Close button when 
you are done. 

 

 Click on the sixth button from the 
left in the TekXLToolbar. A 
mouse-over will identify it as 
TekXL Screen Capture. 
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MSO5000/DPO5000 Series 
Acquisition Lab 

 

 
 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.1.1 
Two TPP0500 or TPP1000 passive probes 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this lab were made with the DPO Demo 3 board] 
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Understanding the MSO/DPO5000 Series Acquisition Modes 

You are probably familiar with the analog (hardware) bandwidth-limit filters on the inputs of most 
oscilloscopes. The MSO/DPO5000 Series has such bandwidth filters in the analog channel menu (20 MHz, 
250 MHz, and 500 MHz low-pass filters) which can be used to remove high-frequency noise from a signal. 
For example, the 20 MHz filter can be very useful to eliminate stray RF signals from low-frequency circuits 
like power supplies. 

However, the MSO/DPO5000 Series also provides several more powerful acquisition tools that enable you 
to control the acquisition of a complex signal. This lab goes through some of these features step-by-step to 
allow you to see the capabilities. 

Lab Objectives 

- Obtain a basic understanding of MSO/DPO5000 Series acquisition mode controls. 

- Learn how to apply peak detect to reliably capture signal spikes. 

- Learn how to apply averaging techniques to remove noise from signals. 

- Learn about the FastFrame segmented memory acquisition mode. 
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MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has a DAC_OUT 
signal which we can use for this lab: 

 

 The DPO Demo 2 board (020-2924-XX) also has NOISY 
SINE and DAC_OUT signals which we will use for this lab: 

 

DPO Demo Board Procedure 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the power LED is lit. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. 

 Attach the probe ground to the 
GND test point on the test board. 

 Connect the probe tip to the 
NOISY SINE (or DAC_OUT) test 
point on the test board.  

 NOTE: The instructions in this lab 
were written around the NOISY 
SINE signal. If you use the 
DAC_OUT signal, you will need to 
adjust the vertical controls a little 
differently. 
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Key Take Away Points 

 Notice the readouts of sample rate and record length at the 
bottom of the display. The NOISY SINE signal should look 
about like this: 

 

 

 

 Let’s take a quick look at the signals parameters. From the 
Measurement Snapshot, we can see that the signal is a 
~20 Hz sine wave. 

 

 At first glance, this may look like a reasonable setup. We 
are sampling the 20Hz sine wave at 10 kS/s, which is 
plenty fast to represent the sine wave accurately. 

 However, if you watch the display carefully, you will 
occasionally see relatively large, fast spikes at various 
locations on the waveform. 

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Set the channel 1 vertical scale to 
500 mV/div. 

 Set the horizontal scale to 10 
ms/div. 

 With the channel 1 Vertical 
Position control, center the 
waveform on the display. 

 Press the Trigger Menu button. 

 Press the Mode tab and press the 
Normal button. 

 Using the Trigger Level control, 
adjust the trigger level to the top 
of the waveform, about 2.5V, to 
stabilize the waveform display. 

 Press the front panel Acquire 
button. 

 Touch the Sample Rate text box 
to attach the Multipurpose a 
control to Sample Rate. 

 Using the Multipurpose a control, 
reduce the Sample Rate to 
10.0kS/s. Notice that this has the 
side effect of reducing the record 
length to 1k samples. 

 Press the front panel Measure 
button to display the 
Measurement Setup menu. 

 Press the Snapshot button. 

 When finished, press the X in the 
upper right corner of the 
measurement window to close it. 
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MSO/DPO5000 Series Peak Detect 

Key Take Away Points 

 One way to see more horizontal detail is to increase the 
record length. This also has the effect of raising the sample 
rate, which in turn raises the single-shot bandwidth. By 
selecting 1M record length, notice that we have also 
increased the sample rate to 10 MS/s. With the increased 
record length, you can now see a more realistic view of the 
noisy signal: 

 

 You can see that the displayed trace is now quite thick, and 
there are some stationary spikes on it. To investigate these 
spikes more closely, we can use Peak Detect, which 
assures that we capture and display all of the peaks of the 
signal. With Peak Detect, the display should now look 
about like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Acquire 
button. 

 Touch the Sample Rate text box 
to attach the Multipurpose a 
control to Sample Rate. 

 Using the Multipurpose a control, 
increase the Sample Rate to 
10.0MS/s. Notice that this has the 
side effect of increasing the 
record length to 1M samples. 

 

 

 

 

 

 

 

 

 

 Touch the Acquisition tab. 

 Press the Pk Detect button. 

 This digital peak detect captures 
and displays peaks at the 
maximum sample rate of the 
product, capturing pulses as 
narrow as 1/(sample rate). 

 

 

 

 

 

 

 You can also try Envelope 
acquisition mode, which provides 
a similar display, but accumulates 
the peaks between a specified 
number of acquisitions, as if Peak 
Detect and infinite persistence 
were turned on. 
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MSO/DPO5000 Series FastAcq 

Key Take Away Points 

 By using high sample rate and peak detect, you could see 
that there were a few random noise spikes on the signal. 
By carefully watching the flashes on the display, you can 
infer that the noise spikes are infrequent. But the 
oscilloscope is only capturing a few waveforms every 
second, so you may not be seeing all of the infrequent 
occurrences. 

 The MSO/DPO5000 products have a special acquisition 
mode called FastAcq which can capture up to hundreds of 
thousands of waveforms every second. 

 And, by color-grading the display, you can easily judge the 
relative frequency-of-occurrence of the waveform 
characteristics. In the screen shot below, notice that the 
frequently-occurring sine wave is displayed in red, while the 
infrequent noise spikes are shown in yellow. 

 

 You can alter the color mapping by adjusting the display 
intensity control. For example, if you turn down the 
intensity, the infrequent spikes can be displayed in blue, 
the more frequent random noise in green and yellow, and 
the most frequent sine wave in red. 

 Other display formats are also available in the Display -> 
Colors… control window. 

MSO/DPO5000 Series Procedure: 

 Press the purple front panel 
FastAcq button or the FastAcq 
button in the Acquisition control 
window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Press the front panel Intensity 
button. 

 Turn the Multipurpose b control 
counterclockwise to reduce the 
display intensity. This will have 
the effect of changing the 
mapping of the frequency-of-
occurrence information to the 
different colors used in the 
display. 

 Press the front panel Intensity 
button to turn off the intensity 
control. 

 

 

 

 When you are done, press the 
purple front panel FastAcq button 
or the FastAcq button in the 
Acquisition control window to turn 
off FastAcq mode. 
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MSO/DPO5000 Series Averaging 

Key Take Away Points 

 Because this signal appears to be repetitive, we can use 
averaging (which averages successive acquisitions 
together, point by point, and displays the result). 

 

 Notice how averaging removes random variations between 
acquired waveforms and preserves the stationary events 
such as the sine wave and the spikes. In this display, we 
can see the discrete voltage steps on the output of the 
circuit. 

 If you want to see the result of exactly 64 averages, you 
can use Single sequence to acquire only that many 
waveforms. This takes a few seconds to complete. 

 

MSO/DPO5000 Series Procedure: 

 If necessary, press the front panel 
Acquire button to display the 
Horizontal/Acquisition menu. 

 Press the Acquisition tab. 

 Press the Average acquisition 
button. 

 Touch the # of Wfms text box to 
attach the Multipurpose a control 
to the number of averages 
control. 

 Using the Multipurpose a control, 
set the number of averages to 64. 

 

 

 

 

 

 

 

 

 

 

 Press the front panel Single 
button. 

 Notice the acquisition counter in 
the lower right corner readout as 
the 64 acquisitions are made. 
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MSO/DPO5000 Series Hi Res Acquisition 

Key Take Away Points 

 Because averaging mode averages samples between 
acquisitions, a repetitive signal is required. However, it 
does retain the full bandwidth of the signal, as long as you 
substantially over-sample the signal. 

 Another type of averaging, called Hi Res or “box-car 
averaging” averages groups of samples within a single 
acquisition and replaces them with the higher-vertical-
resolution mean value. The tradeoff is that the bandwidth of 
the signal is reduced. However, this method does work on 
single-shot acquisitions. 

 

 We can control the bandwidth of Hi Res by adjusting the 
sample rate and record length. Here, the bandwidth has 
been limited to about 4.4 kHz: 

 

MSO/DPO5000 Series Procedure: 

 Select Hi Res acquisition mode. 

 Press the front panel Run / Stop 
button to start the acquisitions. 

 Press the Horizontal tab. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Use the arrow buttons to reduce 
the Sample Rate to 10 kS/s. 

 From the equation on the next 
page, we can calculate the Hi Res 
bandwidth as 0.44 * 10kS/s = 
4.400 kHz. 

 

 

 Slowly increase the Sample Rate 
(and therefore the Record 
Length) and notice the increasing 
bandwidth, as indicated by the 
increased noise on the signal. 
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The bandwidth limiting and the increase in vertical resolution due to Hi Res varies with the maximum sample 
rate and the actual sample rate of the instrument. The actual sample rate is displayed near the bottom of the 
screen. 

The resulting -3 dB bandwidth is 0.44 * sample rate and the increase in bits of vertical resolution is 
0.5 log2 (maximum sample rate / actual sample rate). 

For example, when all analog channels of the MSO/DPO5000 series are in use, the maximum sample rate 
is 5 GS/s, and Hi Res provides the following performance: 

Sample Rate Bits of  
Vertical Resolution 

3 dB Bandwidth Limit 
(0.44 x Sample Rate) 

2.5 GS/s 8.5 bits 1.1 GHz * 

1 GS/s 9 bits 440 MHz* 

250 MS/s 10 bits 110 MHz 

50 MS/s 11 bits 22 MHz 

10 MS/s 12 bits 4.4 MHz 

2.5 MS/s 13 bits 1.1 MHz 

1 MS/s 14 bits 440 KHz 

250 KS/s 15 bits 110 KHz 

25 KS/s >15 bits 11 KHz 

250 S/s >15 bits 110 Hz 

25 S/s >15 bits 11 Hz 

2.5 S/s >15 bits 1.1 Hz 

* The maximum Hi Res bandwidth may be further limited by the analog bandwidth. 
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MSO/DPO5000 Series XY Display 

Key Take Away Points 

 Most oscilloscope displays show voltages on the vertical 
(“Y”) axis and time on the horizontal (“X”) axis, since the 
user is most often interested in signal behavior over time. 
This type of display is often called a “YT” display. 

 However, sometimes the relative behavior of two signals is 
more critical. Examples are measuring relative frequency or 
phase between two signals. The XY display allows the user 
to plot one signal on the vertical axis and the second on the 
horizontal axis. 

 In this first setup, the same signal is plotted on the X and Y 
axes, so the resulting display is a straight line at 45 
degrees. 

 The XY display provides a unique set of waveform cursor 
measurements, including readouts in both rectangular and 
polar coordinates on the XY display, as well as matching 
cursor indications on the YT waveforms at the top of the 
screen: 

 

MSO/DPO5000 Series Procedure: 

 Attach a TPP0500 or TPP1000 
probe to the Channel 2 input of 
the oscilloscope. Connect the 
probe ground to the GND test 
point and the probe tip to the 
NOISY SINE (or DAC_OUT) test 
point on the test board. 

 Press the front panel 2 button to 
turn on channel 2. 

 Set the channel 2 vertical scale to 
500 mV/div. 

 With the channel 1 and 2 Vertical 
Position controls, center the 
waveforms on the display. 

 Select Display -> Display 
Format -> XY. 

 Press the front panel Single 
button. 

 Press the front panel Cursors 
button. 

 Using the Multipurpose controls, 
notice how the waveform cursors 
move around on the XY display. 
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Key Take Away Points 

 There are also screen-based cursor measurements: 

 

MSO/DPO5000 Series Procedure: 

 Press the Setup button. 

 Press the Screen Cursor Type 
button. 

 Because there are four screen 
cursor lines to control, you use 
the text boxes in the Cursor Setup 
control window to select which 
cursor is controlled by the 
Multipurpose controls. 

 Touch the H Position text box in 
the Cursor 1 section. 

 Using the Multipurpose controls, 
adjust the position of cursor 1. 

 Touch the H Position text box in 
the Cursor 2 section. 

 Using the Multipurpose controls 
or the mouse, notice how the 
screen cursors move around on 
the XY display. 

 When you are done, press the 
Cursors button to turn off the 
cursor display. 
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Key Take Away Points 

 If we display two different signals, we get a more 
interesting XY display. In this example, we are displaying 
two sinusoidal signals with different fundamental 
frequencies. Because the frequencies are not integer 
multiples of one another, the relative phases of the signals 
are constantly moving, and the XY display is also moving: 

 

 Because the XY display is simply a different way of 
displaying pairs of waveforms, the underlying data values 
are still available for measurements, as well as for saving 
for off-line analysis. Waveforms can be saved individually 
in binary or spreadsheet (CSV) format, or all active 
waveforms can be saved in a single CSV file: 

 

 Since there are two waveform files, they will be saved as 
XY_Ch1.csv and XY_Ch2.csv. 

MSO/DPO5000 Series Procedure: 

 Move the Channel 2 probe tip to 
the DAC Out (or a different 
signal) test point on the test 
board. 

 Press the front panel Vertical 
Menu button to display the 
Vertical Setup menu and press 
the Chan 2 tab to display the 
channel 2 controls. 

 Press the front panel Run/Stop 
button. 

 

 

 

 

 

 

 

 

 There are several ways to do 
save all of the waveform data: 

 Press the Save/Recall Menu 
button below the display and 
then press the Waveform 
button. 

 Select File -> Save As -> 
Waveform. 

 Select File -> Save All 
Waveforms…. 

 Select Displayed Analog as the 
Source. 

 Select the file location for Save 
In:. 

 Type in the file Name: as “XY” 
and select Save As Type: 
Waveform CSV files (*.csv). 

 If you are going to do this 
repetitively, check the Set Front 
Panel Print Button to Save 
check box. 

 Press the Save button. 

 When you are done, select 
Display -> Display Format -> YT 
display format. 
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MSO/DPO5000 Series Bandwidth Limit 

Key Take Away Points 

 Each of the vertical channels has bandwidth limit filters 
available. These filters limit the range of frequencies that 
the oscilloscope can acquire and display accurately with 
less than 3 dB of attenuation. 

 Some filters are implemented in hardware (labeled with 
“HW”) and will limit the input signal bandwidth at any 
oscilloscope setting. 

 NOTE: The bandwidth readout will display the probe tip 
bandwidth if the probe is limiting the bandwidth of the 
selected channel. 

 

 Other filters use Digital Signal Processing (DSP) to filter the 
signal. The bandwidth readout displays in reverse video if 
the bandwidth is not what you selected. If you want the 
bandwidth to be what you selected, make sure that the 
sample rate is high enough to enable DSP filters (DSP). 

MSO/DPO5000 Series Procedure: 

 Move the Channel 1 and 2 probe 
tips to the 40 MHz test point on 
the test board. 

 Set the Channel 1 and 2 Vertical 
Scales to 500 mV/div. 

 Press the Trigger Level control to 
set the trigger level to 50%. 

 Set the Horizontal Scale to 
100ns/div. Notice that the sample 
rate in the readout in the lower 
right corner of the display. 

 Click on the Vertical menu and 
select Bandwidth Limit…. 

 Press the Channels 2 button. 

 Click on the down arrow next to 
the Bandwidth text box and notice 
the available bandwidth limit 
choices. 

 Select 20.0 MHz (HW) from the 
Bandwidth drop down menu. 
Notice how the channel 2 signal 
is attenuated. 

 

 

 Slowly rotate the Horizontal Scale 
control counter-clockwise while 
watching the bandwidth readouts 
in the lower left corner of the 
display. When you reduce the 
sample rate below the maximum 
value, notice that the bandwidth 
readout displays the value in 
reverse video, indicating 
insufficient sample rate for the 
DSP filtering (which is the 
default). 

 Click on the Vertical menu and 
select Vertical Setup…. 

 Check Force Constant Sample 
Rate to ensure DSP filtering. 

 Select Analog Only to ensure 
only hardware filtering is used. 
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Key Take Away Points 

 When 1M termination is used, the input amplifier limits 
the signal bandwidth to a maximum of 500 MHz. However, 

when 50 termination is used, the input amplifier limits the 
signal bandwidth to the bandwidth of the oscilloscope. 

 On this 2 GHz MSO5204, notice that the maximum 

bandwidth setting in the 50 mode is 2.0 GHz: 

 

 In the vertical readout section, notice that the choice of 
input termination has also set the channel’s bandwidth. 

MSO/DPO5000 Series Procedure: 

 Remove the probes from 
channels 1 and 2. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Select Vertical -> Vertical 
Setup…. 

 Press the Chan 2 tab on the left 
side of the control window. 

 Select 1M Termination. 

 Click on the down arrow next to 
the Bandwidth text box and notice 
that the highest available 
bandwidth is 500 MHz. 

 Press the Chan 1 tab on the left 
side of the control window. 

 Select 50 Termination. 

 Click on the down arrow next to 
the Bandwidth text box and notice 
that the highest available 
bandwidth is now the same as the 
bandwidth of the oscilloscope. 

 Reconnect the probes to 
channels 1 and 2. 
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MSO/DPO5000 Series FastFrame Acquisition Mode 

Key Take Away Points 

 FastFrame is a segmented-memory acquisition mode 
which provides high-resolution capture of a series of 
intermittent, triggered events while ignoring the dead-time 
between the events. FastFrame can acquire over 310,000 
waveforms per second. 

 The setup can be very simple. Just set up the oscilloscope 
to capture one event and then specify the number of 
frames. 

 

 After the frames have all been acquired, you can easily 
examine them one by one: 

 

 You can also specify that an average or envelope 
waveform appear in the final frame. 

MSO/DPO5000 Series Procedure: 

 Connect the Channel 1 probe tip 
to the RNDM_BURST test point 
on the test board. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Set the channel 1 vertical scale to 
500 mV/div. 

 Set the Horizontal Scale to 2 
µs/div. 

 With the channel 1 Vertical 
Position control, center the 
waveform on the display. 

 Press the Trigger Level control to 
automatically set the trigger level 
to the center of the waveform. 

 Press the Trigger Menu button. 

 Press the Mode tab and press the 
Normal button. 

 Press the front panel Measure 
button. 

 Click on the Time tab and select 
the Pos Width measurement. 

 Press the front panel Acquire 
button. 

 Press the Acquisition tab. 

 Press the FastFrame button. 

 Double-click on the # of 
Events/Frames text box and 
select 10 Frames. 

 Press the FastFrame button to 
turn it On. 

 Press the front panel Single 
button to acquire 10 frames. 

 Touch the View tab and touch the 
Display Selected Frame text box 
to attach the Multipurpose a 
control to the frame selection. 

 As you turn the Multipurpose a 
control, notice that the pulse 
width measurement of the first 
pulse is made on each frame. 
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Key Take Away Points 

 One of the capabilities of FastFrame is the ability to overlay 
all of the acquired waveforms in one display for a quick 
comparison. For example, in this display, you can see that 
the pulse widths of all of the initial pulses are the same: 

 

 In this display, you can see that the widths of the first 
pulses are not all the same: 

 

MSO/DPO5000 Series Procedure: 

 Set the Horizontal Scale to 100 
ns/div. 

 Notice that the scope doesn’t 
always trigger on the first rising 
edge on the screen. To assure 
that it does, we need to increase 
the trigger holdoff. 

 Select Trigger -> Holdoff…. 

 Press the Holdoff Time button. 

 Double-click on the Trig Holdoff 
text box, enter 7.5 µs, and press 
Enter. For this signal, this should 
assure that the first edge appears 
at the trigger point. 

 Select Horiz/Acq -> Fast Frame 
Setup…. 

 Press the View tab on the left 
side of the control window. 

 In the View Multiple Frames 
section, select Overlay Only. 

 Click on the Start Frame text box 
to attach the Multipurpose 
controls. 

 Using the Multipurpose a control, 
set the Start Frame to 1. 

 Using the Multipurpose b control, 
set the Number of Frames to 10. 

 Press the front panel Single 
button to acquire 10 frames. If 
necessary, press Single again to 
get a display of various overlaid 
waveforms that do not all match. 
This might take a few tries. 

 When you are done, press the 
front panel Measure button and 
press the Display button to turn 
off the display of measurements. 
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Key Take Away Points 

 There are two unique analysis tools provided with 
FastFrame, a Frame Delta Calculator and a Frame Finder. 

 The Frame Delta Calculator calculates the time difference 
between two specified frames in the acquisition. This can 
be very useful for verifying repetition rates of infrequent 
events. Notice the readout of the time between the first and 
last frames in this acquisition:  

 

 The Frame Finder uses a binary search algorithm to guide 
you through the frames. In this case, the pulse width of 
some of the initial pulses in the bursts are approximately 
100 ns, while some of the other initial pulses are wider. 
After you press Start, the Frame Finder presents an overlay 
display of a subset of the frames and asks if you see the 
anomaly. Simply answer Yes or No. When the algorithm 
has guided you to the first frame with an anomaly, it stops. 
Here, frame 2 had the wider pulse width: 

 

MSO/DPO5000 Series Procedure: 

 Select Horiz/Acq -> Fast Frame 
Setup…. 

 Press the Analyze tab on the left 
side of the control window. 

 In the Frame Delta Calculator 
To: section, click on the Selected 
Frame text box and set the value 
to 10. 

 Notice the time readout at the 
bottom of the Frame Delta 
Calculator section. 

 

 

 

 

 

 

 

 

 

 In the Frame Finder section, set 
the From Frame # to 1 and the 
To Frame # to 10. 

 Press the Start button. 

 Follow the on-screen instructions, 
pressing the Yes and No buttons, 
to do a binary search for frames 
that are different from the 
Reference Frame. 
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MSO5000/DPO5000 Series 
Limit and Mask Testing Lab 

 

 
 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.1.1 and with options LT and MTM installed 
One TPP0500 or TPP1000 passive probe 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this lab were made with the DPO Demo 3 board] 
Quick Start 7 demo board or other comm. signal generator 
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Introduction 

This lab contains simple demos of the optional limit testing and mask testing applications of the 
MSO/DPO5000 Series. 

In the cases of both limit testing and mask testing, the tests actually are remarkably complex. The graphical 
comparison of a live waveform to a template or mask requires the signal be triggered, and that the 
amplitude, rise-time, fall-time, delay, and the jitter measurements all be made simultaneously and that the 
results fall within the specified tolerances. 

Limit Testing compares a live waveform to a “template” waveform, where the template is specified by a 
single Y-T waveform and horizontal and vertical tolerances around the waveform. Limit testing is commonly 
used in manufacturing and engineering for unattended monitoring circuit behavior over variations of time 
(like over the weekend) and temperature (as you vary the circuit’s ambient temperature from 0 to 50 
Celsius). Although Limit Testing is simple to set up, it is limited to working with single-valued Y-T waveforms, 
so it does not work with eye diagrams. 

Mask Testing is generally used to verify compliance to industry standards, most commonly used with 
communication signals. As you will see, many industry-standard masks are provided, but you can also 
specify your own to match your application. 

 

MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 With option LT installed, the MSO/DPO5000 Series 
oscilloscope can provide waveform limit testing. 

 With option MTM installed, the MSO/DPO5000 Series 
oscilloscope can provide mask testing. 

MSO/DPO5000 Series Procedure 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that option LT: Limit Test 
is installed. 

 Verify that option MTM: Serial 
Mask Testing is installed. 

 Press the OK button. 

MSO/DPO5000 Series Setup Procedure 

 For this lab, use the DPO Demo 2 board. Verify the USB cable is plugged into the MSO/DPO5000 
Series oscilloscope and the demo board. 

 Verify the power LED is lit. 

 Connect a TPP0500 or TPP1000 10x passive probe to channel 1. 

 Connect the probe ground to GND. 

 Connect the channel 1 probe to the FREQ_ANOM test point. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 

 Press the front panel Autoset button. 
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Limit Testing in the MSO/DPO5000 Series 

Key Take Away Points 

 The MSO/DPO5000 Series’ Limit Test provides automated 
monitoring and capture of signals which vary outside a 
predetermined tolerance from a standard or “template” 
waveform. The signal under test is typically one of the 
analog channels, although math and reference signals can 
be used. The template waveform is typically stored in a 
reference, but it can also be stored in a file. 

 In the MSO/DPO5000, limit testing is done on a waveform 
sample-by-sample basis, not display pixel-by-pixel, as is 
done in some other oscilloscopes. 

 For simplicity, this lab uses a template based on a single 
waveform acquired in sample mode. For a smoother 
template, you might want to base the template on an 
averaged waveform. However, if you want to build a 
template that accommodates some noise on a signal with 
overshoots, you might want to base the template on an 
envelope waveform. 

 After creating a limit test template and storing it in 
Reference 1, the Limit Test application begins comparing 
the live Channel 1 waveform with the template: 

 

 While the Limit Test is running, the test status is indicated 
in the text box in the control window. As you can see in the 
screen shot above, the limit test is initially “Passing”. 

MSO/DPO5000 Series Procedure 

 Set the Horizontal Scale to 10 
ns/div. 

 Select Mask -> Limit Test 
Setup…. 

 In the Create Template section, 
verify that the Source is set to Ch 
1 and the Destination is set to 
Ref 1. 

 The next step in creating a 
template is to specify a vertical 
and horizontal tolerance band 
around the template. 

 In the Tolerances section, touch 
the Vertical text box to attach the 
Multipurpose controls to the 
tolerances. 

 Using the Multipurpose a and b 
controls, set the vertical and 
horizontal tolerances to 200mdiv, 
or two tenths of a division around 
the waveform. 

 Press the Template Save button. 
Notice the white reference 
waveform appears on the display, 
showing the limit test template. 

 Press the Channel 1 button twice 
to turn it off and back on. This has 
the side-effect of bringing this 
waveform to the foreground, in 
front of the white limit test 
template waveform. 

 In the Compare section, verify 
that the Source waveform is set 
to Ch 1. 

 Select Ref 1 in the Template 
drop-down menu. 

 In the Test Options section, 
verify that Lock Template to 
Waveform and Highlight Hits 
are both On. 

 Press the Limit Test button to 
turn on limit testing. 
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Key Take Away Points 

 Although you can watch limit test run, the true power of a 
limit test is to automatically take specified actions whenever 
a failure is detected. For example, let’s stop the 
acquisitions as soon as an error is detected. That way, 
even in unattended operation, you will be sure to capture 
any violations when they occur. 

 

 When a limit test failure does occur, the acquisitions stop 
and you can see where the violation occurred: 

 

MSO/DPO5000 Series Procedure 

 Press the Failure Notification 
tab at the left side of the control 
windows. 

 Notice all of the choices of actions 
when the limit test fails. 

 Press the Stop Acq button. 

 

 

 

 

 

 

 

 

 

 

 

 

 Press the Setup tab at the left 
side of the control windows. 

 Press the Reset button to restart 
the limit test. 

 

 

 

 After a limit test violation occurs 
and the acquisition is stopped, 
you have the acquired waveform 
with the violation. 

 Select File->Reference 
Waveform Controls…, and press 
the Display On button to turn off 
the template. 

 You can now analyze or store the 
waveform. 
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 Mask Testing in the MSO/DPO5000 Series 

MSO/DPO5000 Series Setup Procedure 

 For this lab, there are few appropriate signals available on easily-accessible demo. For this lab, we will 
use the USB High-speed signal on the DPO Demo 3 board. If another communication signal source is 
used, adapt the instructions accordingly. 

 Attach the two host connectors on the USB cable to the oscilloscope and then connect the device 
connector on the cable to the demo board. 

 Connect a TDP0500 or TDP1000 differential probe to channel 1. 

 Connect the probe’s + input to pin1 and the – input to pin 2 of the USB_HS connector on the demo 
board. 

 

Key Take Away Points 

 The USB High-speed signal on the demo board should look 
about like this after a Default Setup: 

 

 When you select a standard mask, the oscilloscope will 
automatically adjust the oscilloscope for a standard signal, 
so there is no need to adjust the controls at this time. 

MSO/DPO5000 Series Procedure 

 Press the front panel Default 
Setup button to set the 
oscilloscope to a known state. 
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Key Take Away Points 

 The USB High-speed signal and appropriate standard 
mask should look about like this after manually adjusting 
the vertical scale and trigger level: 

 

 Notice that the WfmDB acquisition mode has been turned 
on, providing a color-graded waveform display. (FastAcq is 
not supported in Mask Testing.) 

 Although you can manually view the mask test results, the 
real power of mask testing is automated pass/fail testing. 
By default, the automated test will compare 100,000 
samples to the mask and consider the test a failure if there 
is even 1 failure. 

 

MSO/DPO5000 Series Procedure 

 Select Mask -> Mask Setup….. 

 Press the More button to select 
the second page of standards. 

 Press the USB 1.1/2.0 button. 

 Press the down arrow by the 
drop-down menu in the middle of 
the control window and notice the 
selection of standard USB masks 
available. 

 Select HS: T6 (480Mb/s) from the 
drop-down menu. (This is the 
least-demanding USB HS mask 
and therefore the easiest to use 
for a demonstration.) 

 Press the Lock Mask to Wfm 
button to turn it off. 

 Set the Trigger Level to about 
-100 mV. 

 Because the signal on the demo 
board is not terminated, the 
amplitude of the signal does not 
match the mask, so you need to 
adjust the amplitude to match the 
mask. 

 Set the Vertical Scale to 200 
mV/div. 

 Press the front panel Clear button 
(under the display) to clean up 
the display. 

 

 

 

 Press the Pass/Fail Setup tab on 
the left side of the control window. 

 Set the Number of Samples to 
1,000,000. 

 Verify the Fail Threshold is set to 
1. 

 In the Test Fail Notifications 
section, press the Stop Acq 
button to turn it on. 
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Key Take Away Points 

 The Pass/Fail Results control window shows the details of 
the mask test results: 

 

 Before we leave this test setup, let’s see how the mask test 
setup automatically configured the communication trigger 
to capture the USB High-speed signal: 

 

MSO/DPO5000 Series Procedure 

 Press the Pass/Fail Results tab 
on the left side of the control 
window. 

 Press the Pass/Fail Test button 
in the middle of the control 
window. 

 After 1,000,000 samples are 
compared to the mask, notice that 
the acquisitions stop. 

 

 

 

 

 

 

 

 Select Trig -> A Event (Main) 
Trigger Setup…. 
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MSO5000/DPO5000 Series 
Math Application Lab 

 

 
 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.1.1 
Four TPP0500 or TPP1000 passive probes 
One TDP0500 or TDP1000 high-voltage differential probe 
One TCP0030 current probe 
Optional USB keyboard and mouse 
One 878-0544-XX or 3PQS power demo board and 12VAC power adapter 
One video generator, 75 Ohm cable, and 75 Ohm feed-through terminator 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this lab were made with the DPO Demo 3 board] 
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Introduction 

This lab contains a few waveform analysis applications of the MSO5000 / DPO5000 Series highlighting the 
capabilities of the math system. Step-by-step instructions and a few application hints are provided. Although 
the setup information for each application is fairly complete, the labs do build on previous setups, so reading 
through the document may help. Some screen shots are provided to help you if you are unable to get the 
equipment to actually complete a lab experiment. 
 
The math system has three separate sections, Predefined Math Functions, Spectral Analysis, and Equation 
Editor. Each has different capabilities, and these labs will cover some highlights from each. 

 
 
 

Predefined Math Functions in the MSO/DPO5000 Series 

 
Many basic waveform math requirements can be addressed with the basic math capabilities found under the 
Predefined Functions in the Math menu. Basically, these capabilities include subtraction of paired channels, 
multiplication of paired channels, and spectral analysis. 
 
In this section, we will start with some of the most common applications for dual waveform math: pseudo-
floating and instantaneous power measurements. 
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Pseudo-Floating Measurements 

All voltage measurements are differential measurements. That is, the measurements are always comparing 
the voltage of one point to another (reference) point. Often, the reference point is ground, and most 
oscilloscope probes connect their reference or ground lead to the power line ground through the 
oscilloscope. 
 
However, in some applications, you need to measure the voltage difference between two points where 
neither point is at ground. This is sometimes called a “floating” measurement. The highest performance 
solution is to use an active differential probe, especially for high-speed and high-voltage signals. These 
probe inputs are carefully matched for high-frequency response and loading, and may be capable of safely 
measuring much higher voltages than passive probes. But active differential probes are more expensive 
than the standard passive probes, and you may not have any available. 
 
Within certain limits, such as low frequencies (less than a few MHz) and small ratios between common-
mode and differential signal amplitudes (less than 10 or so), you can make good differential voltage 
measurements with two passive probes and math subtraction. By calculating the difference between two 
ground-referenced signals, the oscilloscope can calculate the floating voltage difference. 
 

MSO/DPO5000 Series Setup Procedure 

 For this lab, use the DPO Demo 3 or DPO Demo 2 board. Attach the two host connectors on the USB 
cable to the oscilloscope and then connect the device connector on the cable to the demo board. 

 Verify the power LED is lit. 

 Connect TPP0500 or TPP1000 10x passive probes to channels 1 and 2. 

 Connect the probe grounds to GND. 

 Connect the channel 1 probe to the CNT_CLK test point. 

 Connect the channel 2 probe to the CNT_CLK test point. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 

 Press the front panel 2 button to turn on channel 2. 

 Press the front panel Autoset button. 

 In this case, the signals on channel 1 and channel 2 are very similar. Using the front panel vertical scale 
and position controls, scale the signals so they occupy about half of the screen vertically, and position 
them so they overlap. 
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Key Take Away Points 

 The MSO/DPO5000 Series’ Predefined Functions provide 
simple waveform math capabilities with just a few controls 
in this one simple menu. The display should look 
something like this: 

 

 Notice that when you compare two similar signals, located 
across the circuit board from one another, the amplitude is 
slightly different (as indicated by the square wave 
component of the difference signal) and the timing of the 
edges are slightly different (as indicated by the positive and 
negative spikes on the difference signal). The display 
should look something like this: 

 

 As expected, the math difference waveform represents the 
instantaneous voltage differences between the two input 
signals. 

MSO/DPO5000 Series Procedure 

 Press the red front panel Math 
button. 

 Select the Ch1-Ch2 Predefined 
Function. 

 Notice that the difference 
between the two probes is nearly 
zero when the probes are 
connected to the same signal, as 
expected. 

 However, notice that the 
mathematical difference 
waveform provides a very 
sensitive measure of the voltage 
differences between these two 
logic signals. 

 Select Math -> Position/Scale…. 

 Using the Multipurpose b control, 
set the math vertical Scale to 
match the channel vertical scale 
settings. 

 

 

 

 Move the channel 2 probe to the 
FAST_FF_CLK test point. 

 Notice that the math difference 
waveform makes even small 
amplitude and/or timing 
differences very apparent. 
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Instantaneous Power Measurements 

Another common oscilloscope measurement which requires simple math is measurement of instantaneous 
power. One specific measurement is the power dissipation in the switching device in a switch-mode power 
supply. 
 
In this lab, you will measure the power dissipated in an Insulated Gate Bipolar 
Transistor (IGBT) or MOSFET switching device. The instantaneous power is the 
product of the current flowing through the device (the Collector or Drain current, 
IC or ID) and the voltage across the device (the Collector voltage relative to the 
Emitter, VCE, or the Drain voltage relative to the Source, VDS). 
 
When the switching device on turned on, the voltage across the device is very 
small and the current is large. When the device is turned off, the voltage across 
the device is large and the current is very small. 
 

MSO/DPO5000 Series Setup Procedure 

 For this lab, use the power demo board. Attach the two host connectors on the USB cable to the 
oscilloscope and then connect the device connector on the cable to the demo board. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 

 Connect a TDP0500 or TDP1000 differential probe to channel 1. 

 Connect the + and – inputs together. Make sure that the Range is set to 42.0 V. 

 Press the Menu button on the probe’s comp box, and press the AutoZero button on the display. 

 Connect the + input of the differential probe to the Collector or Drain test point. 

 Connect the - input of the differential probe to the Emitter or Source test point. 

 Connect a TCP0030 current probe to channel 2. 

 Make sure that the current probe’s jaw is closed. Press the Degauss AutoZero button on the probe. 

 Connect the current probe around the Collector Current or Drain Current loop and close the jaws. 

 Set the channel 1 positive edge trigger level to about 15V. 

 Press the front panel 2 button to turn on channel 2. 

 In this case, the voltage and current waveforms are square waves, 180 degrees out of phase. If the 
channel 2 signal is in phase with the channel 1 signal, remove the current probe, turn it over, and 
reconnect it. 

 Using the front panel horizontal and vertical scale and position controls, scale the signals so they occupy 
about half of the screen vertically, and position them so they overlap. 
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Key Take Away Points 

 The instantaneous power waveform should look something 
like this: 

 

 Notice that, because the voltage and current are out of 
phase (one waveform has a value of zero, so the product of 
waveforms is zero), the instantaneous power is very small 
except during the turn-on and turn-off transitions. 

MSO/DPO5000 Series Procedure 

 Press the front panel Acquire 
button. 

 Press the Acquisition tab at the 
left side of the control window. 

 Select Hi Res Acquisition Mode. 

 Press the red front panel Math 
button. 

 Press the Ch1*Ch2 Predefined 
Functions button. 

 Use the Multipurpose a control to 
select adjust the math waveform 
vertical position and the 
Multipurpose b control to adjust 
the vertical scale. 
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Spectral Analysis in the MSO/DPO5000 Series 

Introduction 

The MSO/DPO5000 Series provides a frequency-domain or spectral analysis display of any analog channel 
or internal reference waveform. Simple spectral analysis, calculated using a Fast Fourier Transform (FFT), is 
found under the Spectral Mag Predefined Function button in the Math menu. 
 
The MSO/DPO5000’s FFT function provides eight different window functions. The windows are listed in the 
order of their ability to resolve frequencies (resolution bandwidth).Here is a general guideline for choosing 
between the most common of the windows: 

 Rectangular: This is the best type of window for resolving frequencies that are very close to the same 
value but worst for accurately measuring the amplitude of those frequencies. It is the best type for 
measuring the frequency spectrum of non-repetitive signals and measuring frequency components near 
DC. Use Rectangular for measuring transients or bursts where the signal levels before and after the 
event are nearly equal. Also, use this window for equal-amplitude sine waves with frequencies that are 
very close and for broadband random noise with a relatively slow varying spectrum. 

 Hamming: This is a very good window for resolving frequencies that are very close to the same value 

with somewhat improved amplitude accuracy over the rectangular window. It has a slightly better 
frequency resolution than the Hanning. Use Hamming for measuring sine, periodic, and narrow band 
random noise. This window works on transients or bursts where the signal levels before and after the 
event are significantly different. 

 Hanning: This is a very good window for measuring amplitude accuracy but less so for resolving 
frequencies. Use Hanning for measuring sine, periodic, and narrow band random noise. This window 
works on transients or bursts where the signal levels before and after the event are significantly different. 

 Blackman-Harris: This is the best window for measuring the amplitude of frequencies but worst at 

resolving frequencies. Use Blackman-Harris for measuring predominantly single frequency waveforms to 
look for higher order harmonics. 

Simple Spectral Display of a Square Wave 

If you want to display the frequency domain representation of a square wave, the FFT function can calculate 
and display the spectrum. This display will include a representation of all of the signal components, including 
the desired square wave as well as the noise and amplitude modulation of the signal. 

MSO/DPO5000 Series Setup Procedure 

 For this lab, use the DPO Demo 3 or DPO Demo 2 board. 

 Attach the two host connectors on the USB cable to the oscilloscope and then connect the device 
connector on the cable to the demo board. 

 Verify the power LED is lit. 

 Connect a TPP0500 or TPP1000 10x passive probe to channel 1. 

 Connect the probe ground to GND on the demo board. 

 Connect the channel 1 probe to the CNT_CLK signal on the demo board. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 

 Press the front panel Autoset button to automatically set up a stable display. 
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Key Take Away Points 

 The peak at the left side of the display represents the DC 
(0 Hz) content of the signal. The next FFT peak, about 1/8 
of a division from the left side of the display, is the 
“fundamental” frequency of the input square wave signal. 
Since the math horizontal scale is 10 MHz/div, the 
fundamental frequency is about 1.25 MHz. Since the 
remaining major peaks are at odd integer multiples of this 
frequency (“odd harmonics”), from Fourier analysis theory 
we know that this input signal is indeed a square wave. 

 

 The FFT’s frequency resolution can be dramatically 
improved by increasing the amount of input data. This is 
done by increasing the record length. With a 10X increase 
in record length, notice that the FFT peaks are much 
sharper and better defined: 

 

MSO/DPO5000 Series Procedure 

 Press the red front panel Math 
button. 

 Press the Basic Spectral to 
display the spectral analysis 
control window. 

 Select Magnitude to enable the 
spectral magnitude display. 

 Touch the Scale text box in the 
Vertical Controls section to allow 
the Multipurpose b control to 
adjust the Vertical Scale. 

 Using the Multipurpose b control, 
adjust the Spectral Vertical Scale 
to 10 dB/div. 

 Touch the Level text box in the 
Vertical Controls section to allow 
the Multipurpose a control to 
adjust the Reference Level. 

 Using the Multipurpose a control, 
adjust the vertical position of the 
spectral display, setting the 
Reference Level to about 50 dB. 

 Notice that the Resolution BW 
displayed in the center of the 
control window is 400 kHz. 

 In the horizontal readout in the 
lower right corner of the display, 
notice that the horizontal scale is 
500 ns/div and the record length 
is 1.0k points. 

 Adjust the Horizontal Scale 
control until the horizontal scale is 
5.0 µs/div. 

 Notice that the Record Length has 
increased to 10.0k and the 
Resolution BW displayed in the 
center of the control window has 
decreased to 40 kHz. 

 Select Horiz/Acq->Resolution…. 

 Double-click on the Sample Rate 
text box and set the value to 50 
MS/s. 

 Notice that the Spectral Horizontal 
Scale is now 2.5 MHz/div. 
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Key Take Away Points 

 The increased FFT frequency resolution helps identify the 
exact harmonic frequencies, but it also accentuates the 
appearance of some of the noise. Although the vertical 
scale is logarithmic (10 dB/div), it is possible to reduce the 
random noise in the FFT display. One way is to average 
the input signal. With 512 averages, the noise is much less 
noticeable. 

 

 Cursors can be used to measure the amplitudes and 
frequencies of the harmonics in the FFT display: 

 

MSO/DPO5000 Series Procedure 

 Press the front panel Acquire 
button. 

 Press the Acquisition tab at the 
left side of the control window. 

 Press the Average button. 

 Double-click on the # of Wfms text 
box and select 512 averages. 

 

 

 

 

 

 

 

 Press the front panel Cursors 
button once. 

 Set the Cursor 1 and Cursor 2 
Sources to Math 1. 

 Using the Multipurpose controls or 
the mouse, position the cursors 
on the fundamental and third 
harmonics, as shown at the left. 

 Select the Waveform Cursor 
Type. 

 Notice the cursor readouts in the 
lower right corner of the display, 
showing the absolute and relative 
frequencies and amplitudes. 
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FFT of a Complex Waveform 

The MSO/DPO5000 Series FFT calculates the frequency domain representation of the entire input signal. If 
you want to display the frequency domain representation of a portion of a very complex waveform, you need 
to first adjust the acquisition to capture only that portion of the signal. 
 
For this lab, you need to verify the spectrum of the positive sin(x)/x video test signal. This sin(x)/x pulse 
occurs on only half of a video line, and you do not want to include the rest of the video signal, such as the 
video’s horizontal and vertical intervals, in the FFT analysis. 

MSO/DPO5000 Series Setup Procedure 

 For this lab, use a standard analog video generator that can provide a frequency response signal. For 
this example, a Sin(x)/x pulse was used, but a multiburst signal could be used instead. To demonstrate 
the math, connect the video generator directly to the MSO/DPO5000 Series oscilloscope through a 75 
Ohm cable and 75 Ohm feed-through terminator on channel 1. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 
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Key Take Away Points 

 For this lab, we’re using a sin(x)/x video signal, Theory 
predicts that a sin(x)/x time-domain pulse has a flat 
frequency response across the entire baseband video 
bandwidth. This is what the signal looks like: 

 

 By default, the MSO/DPO5000 Series FFT calculates the 
frequency domain representation of the entire acquired 
waveform. We want to examine the spectral magnitude of 
only the sin(x)/x pulse, so we gate the waveform using the 
acquisition controls. In this case, the FFT analysis is run on 
only the positive sin(x)/x video signal. As theory would 
predict, a sin(x)/x time-domain pulse has a flat frequency 
response across the entire baseband video bandwidth, as 
shown below: 

 

MSO/DPO5000 Series Procedure 

 Press the front panel Trigger 
Menu button. 

 Press the Select button and the 
Video button. 

 In the Autoset section, press the 
Lines button. 

 In the Trigger On drop-down 
menu, select Line #. 

 Touch the Line No text box to 
attach the Multipurpose a control. 

 Using the Multipurpose a control, 
select line 31. 

 Set the Horizontal Scale to 5 
µs/div. 

 Press the front panel Acquire 
button. 

 Set the Sample Rate to 20 MS/s. 
This will also set the record length 
to 1000 points. 

 Press the Acquisition tab on the 
left side of the control window. 

 Press the Average button. 

 Double-click on the # of Wfms 
text box, enter 512, and press 
Enter. 

 Press the red front panel Math 
button. 

 In the Spectral Analysis section, 
press the Advanced button. 

 Press the Magnitude, Channels 
1, and Apply buttons to enable 
the spectral magnitude display. 

 Press the Vert Axis tab on the left 
side of the control window. 

 Double-click the Level text box 
and set it to about 0 dB. 

 Double-click the Scale text box 
and set it to 10 dB/div. 

 Touch the Gate Duration text 
box. 

 Using the Multipurpose b control, 
use the gating indicators to select 
just the Sin(x)/x pulse, as shown 
at the left. 



 

MSO5000 / DPO5000 Lab Exercise Book 

Version 1.1   5/11/2012 48W-26279-3   258 of 394 

 

Advanced Math in the MSO/DPO5000 Series 

Introduction 

In addition to the basic waveform math and spectral analysis capabilities, the MSO/DPO5000 Series 
provides Advanced Math, which allows the user much more flexibility in specifying the mathematical 
function. 
 
In this section, we will look at several common applications for advanced waveform math: 

 comparison of a signal to a reference 

 scaling and offsetting transducer signals 

 instantaneous power measurements using pseudo-floating voltage measurements 

 video linearity testing 

 logarithms 

 integration 

 creating digital signals 

 FFTs of idealized digital signals 

 binary math with digital signals 

Hints for Using Math with Reference Waveforms 

Reference waveforms and live channel waveforms act a little differently in math. Here are a few hints for 
applying math with references: 
 

 Math is always calculated point-by-point, starting at the left of the waveforms. Even if the reference 
waveform is displayed with a different horizontal scale and/or position (which can be adjusted in the 
Reference waveform menu), the math is calculated point-by-point. 

 Because math always starts at the left side of the waveform, trigger points are ignored. 

 Because math is done on points only, time/div and sample rate differences are ignored. 

 Because math is done point-by-point, if the input waveform record lengths are different, the math 
system will point-replicate to interpolate values so it can operate on equal-length waveforms. (For 
example, if you are adding a 1k record to a 10k record, each sample in the 1k record will be 
repeated 10 times.) 

 So, to minimize confusion, it is recommended that you acquire reference waveforms exactly the way 
you plan to acquire the live waveforms, with the same record length, time/div, and trigger setup and 
position. 

If you are going to save or post-process the math waveform, there are a few other details which could be 
important. Each waveform has a “header” which contains information about the way the waveform was 
acquired and how it should be displayed (such as vertical and horizontal scales, record length, trigger 
position, and acquisition mode). Since the math waveform header must contain "something reasonable" 
under all circumstances, a simple algorithm to select the "main source" is performed by the MSO/DPO5000 
Series oscilloscope before each math calculation that goes like this: 
 

 If all source waveforms are live, set main source to the lowest numerical channel, 

 else, if one source is live, set main source to that channel, 

 else, set main source to the non-live source with the fastest timebase. 
 
Then the math waveform header is formed using information from the main source waveform header, as 
well as the math parameters. 
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Comparison of a Signal to a Reference 

Another common use of waveform math is to compare a live waveform to a stored reference. Although a 
simple comparison can be done with Dual Wfm Math, this lab shows how a comparison can be done with 
Advanced Math. As well as a simple introduction to the use of Advanced Math, this technique also opens up 
possibilities such as comparing pseudo-floating voltage measurements to references. 
 

MSO/DPO5000 Series Setup Procedure 

 For this lab, use the DPO Demo 3 or DPO Demo 2 board. 

 Attach the two host connectors on the USB cable to the oscilloscope and then connect the device 
connector on the cable to the demo board. 

 Verify the power LED is lit. 

 Connect a TPP0500 or TPP1000 10x passive probe to channel 1. 

 Connect the probe ground to GND on the demo board. 

 Connect the channel 1 probe to the XTALK1 signal on the demo board. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 
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Key Take Away Points 

 The MSO/DPO5000 Series’ Advanced Math editor allows 
you to build the math expression out of simple operators 
and waveforms with the on-screen user interface. The 
display should look about like this: 

 

 Notice how the math comparison of the live waveform to a 
reference highlights the positive and negative glitches on 
the waveform, as shown below: 

 

MSO/DPO5000 Series Procedure 

 Press the front panel Autoset 
button to automatically get a 
stable display. 

 Press the front panel Save/Recall 
Menu button. 

 Press the Waveform button. 

 Select Ref1 icon. 

 Press the Save button. If you see 
the popup warning “Do you want 
to overwrite Ref1?”, press the Yes 
button. 

 Press the white front panel R 
button to display the reference 
menu. 

 Press the Display button until On 
is selected. Notice that a white 
reference waveform is displayed. 

 Press the red front panel M 
button. 

 Press the Editor button. 

 Enter the math expression “Ch1-
Ref1”: 

 Select Channels 1. 

 Select the minus sign. 

 Touch the Ref tab and select 
References 1. 

 Press OK. 

 Press the Single button a few 
times, noticing the resulting math 
difference waveforms. 
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Scaling and Offsetting Transducer Signals 

Transducers are electronic devices which output a voltage that represents some physical quantity. 
Examples include thermocouples, pressure sensors, tachometers, and accelerometers. The output voltages 
of these devices are often at vertical scale factors or DC offsets which do not provide the desired display on 
the oscilloscope. Advanced Math provides a simple way to correct the vertical scale and/or offset, often 
more practical than adjusting the oscilloscope controls or external signal conditioning accessories. 

MSO/DPO5000 Series Setup Procedure 

 For this lab, use the DPO Demo 3 or DPO Demo 2 board. 

 Attach the two host connectors on the USB cable to the oscilloscope and then connect the device 
connector on the cable to the demo board. 

 Verify the power LED is lit. 

 Connect a TPP0500 or TPP1000 10x passive probe to channel 1. 

 Connect the probe ground to GND on the demo board. 

 Connect the channel 1 probe to the NOISY SINE (or DAC_OUT) signal on the demo board. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 
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Key Take Away Points 

 The MSO/DPO5000 Series’ Advanced Math editor allows 
you to easily scale and offset a channel waveform. The 
NOISY SINE signal display should look about like this: 

 

 Notice how the VAR1 and VAR2 controls can be used to 
provide simple control of numeric factors at high resolution, 
over a very wide dynamic range. 

MSO/DPO5000 Series Procedure 

 Press the front panel Autoset 
button to automatically get a 
stable display. 

 Set the Horizontal Scale to 10 
ms/div. 

 Press the red front panel M 
button. 

 Press the Editor button. 

 Press the Var tab in the Primitive 
section. 

 Enter the math expression 
“Var1 * ch1 + Var2”: 

 Press the Clear button. 

 Press the Var1 button. 

 Press the * (multiply) button. 

 Press the Channels 1 button. 

 Press the + (addition) button. 

 Press the Var2 button. 

 Touch the Var1 text box to 
attach the Multipurpose 
controls to Var1 and Var2. 

 Press the OK button. 

 Notice that the Multipurpose 
controls remain attached to the 
variables. 

 Double-click on the Var1 readout 
in the upper right corner of the 
display. With the keypad, type 2 
and press the Enter button. 

 Press the Multipurpose a control 
until the Fine LED next to the 
control is lighted. 

 With the Multipurpose a control, 
change VAR1 to 3.0. 

 Press the Multipurpose b control 
until the Fine LED next to the 
control is off. 

 With the Multipurpose b control, 
set VAR2 to -4.0. 
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Instantaneous Power Measurements Using Pseudo-floating Voltage Measurements 

Another common oscilloscope measurement which requires simple math is 
measurement of instantaneous power. One specific measurement is the power 
dissipation in the switching device in a switch-mode power supply, as shown in 
the diagram at the right, an Insulated Gate Bipolar Transistor (IGBT). 
Measurements on a MOSFET would be similar, but the upper terminal is called 
the Drain and the lower terminal is called the Source. 
 
As with many other power supply signals, the signals you are looking at are not 
referenced to ground. In fact, there is no ground reference on this power demo 
board. Therefore, you will be making “floating” measurements. But because you 
will be using math to measure these floating voltages, the measurements are 
sometimes called “pseudo-floating” or “A-B” measurements. 
 
Although VCE is usually best measured with an active differential probe and IC is 
usually best measured with a current probe, you don’t always have these 
probes available. Advanced Math provides another way to make this 
instantaneous power measurement with standard passive voltage probes, using the Pseudo-floating 
technique described in an earlier lab. 

MSO/DPO5000 Series Setup Procedure 

 For this lab, use the power demo board. Attach the two host connectors on the USB cable to the 
oscilloscope and then connect the device connector on the cable to the demo board. 

 Connect a TPP0500 or TPP1000 passive probe to each of the four analog channel inputs. 

 To measure the floating voltage across the switching device, you will subtract channel 2 from channel 1 
to calculate the voltage: 

 Connect the channel 1 probe to the Collector or Drain test point. 

 Connect the channel 2 probe to the Emitter or Source test point. 

 Connect each of the probe grounds to the Neutral test points. 

 To measure the current flowing through the switching device (which equals the current flowing through 
the 300 Ohm load), you will measure the voltage across the load (again, a floating measurement) and 
divide by the load resistance (according to Ohm’s Law). 

 Connect the channel 3 probe to the high side of the load (+DC test point). 

 Connect the channel 4 probe to the low side of the load (Collector or Drain test point). 

 Connect each of the probe grounds to the Neutral test points. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 

 Press the front panel 2, 3, and 4 buttons to turn on channels 2, 3, and 4. 

 Using the front panel vertical Position controls, place the ground references for all four analog channels 
near the center of the display. 

 Using the front panel vertical scale controls, scale the signals so they occupy at least half of the screen 
vertically, and position them so they overlap. 

 Using the front panel vertical scale and position controls, scale the signals so they occupy about half of 
the screen vertically, keeping all of the scale factors set to the same values. 
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Key Take Away Points 

 Advanced math allows simple instantaneous power 
measurements to be made, using only passive probes, as 
shown below: 

 

 In this case, the differential voltage across the switching 
device is multiplied by the current flowing through it. The 
current is measured by dividing the differential voltage 

across the load by the 300 load resistance. 

 As previously noted, the performance of the pseudo-
floating measurements is limited, but for many debug 
applications it is adequate and convenient.) 

MSO/DPO5000 Series Procedure 

 Press the front panel Acquire 
button. 

 Press the Acquisition tab and 
select the Hi Res Acquisition 
Mode. 

 Press the red front panel MATH 
button. 

 Select the math Editor. 

 Enter the math expression 
“(Ch1 – Ch2) * ((Ch3 - Ch4) / 
300)””: 

 Press the Clear button. 

 Press the left parenthesis 
button. 

 Press the Channels 1 button. 

 Press the minus button. 

 Press the Channels 2 button. 

 Press the left parenthesis 
button. 

 Press the * (multiply) button. 

 Press the left parenthesis 
button twice. 

 Press the Channels 3 button. 

 Press the minus button. 

 Press the Channels 4 button. 

 Press the left parenthesis 
button. 

 Press the / (divide) button. 

 Type in “300”. 

 Press the left parenthesis 
button. 

 Press the OK button. 
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Video Linearity Testing 

A common video test is to drive a piece of video equipment with a staircase or linear ramp test signal and 
differentiate the output signal to identify any linearity distortion in the equipment. These distortions might be 
analog in nature, such as clipping in an amplifier, or quantization errors or calculation errors in digital video 
processing equipment. 

Because differentiation is done by subtracting adjacent samples (output[n] = input[n-1] – input[n]), it is 
usually best to lower the number of samples so the differences stand out above the noise. In this case, we 
set the record length to 1000 points and average the signal to minimize random noise so the signal 
characteristics will be more visible. 

MSO/DPO5000 Series Setup Procedure 

 For this lab, use a standard analog video generator that can provide a linearity signal. For this 
example, a 5-step linearity staircase signal was used, but a 10-step staircase or luminance ramp 
signal could be used instead. To demonstrate the math, connect the video generator directly to the 
MSO/DPO5000 Series oscilloscope through a 75 Ohm cable and 75 Ohm feed-through terminator 
on channel 1. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 
 

Key Take Away Points 

 Notice how the math waveform allows you to see very 
minor differences in the heights of each step, often caused 
by non-linearities in video equipment: 

 

MSO/DPO5000 Series Procedure 

 Press the front panel Trigger 
Menu button. 

 Press the Select button and the 
Video button. 

 In the Autoset section, press the 
Lines button. 

 In the Trigger On drop-down 
menu, select Line #. 

 Touch the Line No text box to 
attach the Multipurpose a control. 

 Using the Multipurpose a control, 
select line 31. 

 Set the Horizontal Scale to 5 
µs/div. 

 Press the front panel Acquire 
button. 

 Set the Sample Rate to 20 MS/s. 
This will also set the record length 
to 1000 points. 

 Press the Acquisition tab on the 
left side of the control window. 

 Press the Average button. 

 Double-click on the # of Wfms 
text box, enter 512, and press 
Enter. 
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Key Take Away Points 

 Notice how the math waveform allows you to see very 
minor differences in the heights of each step, often caused 
by non-linearities in video equipment: 

 

MSO/DPO5000 Series Procedure 

 Press the red front panel Math 
button. 

 Press the Editor button. 

 Press the Derivative dy/dt 
button, the Channels 1 button, the 
right parenthesis button, and the 
OK button. 

 Adjust the Math 1 Position and 
Scale controls so the spikes of 
the derivative expression fill most 
of the display, as shown at the 
left. 

 Notice how sensitive this math 
function is to slight differences in 
the heights of the steps. 
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Integration without Accumulating Offsets 

Integration is a mathematical technique to find the area under a curve. The integration function always starts 
at a zero value, and calculates the integral by adding new input data points to the current value of the 
integral (output[n] = output[n-1] + input[n]). 

One common application is to calculate energy delivered by a signal by integrating the instantaneous power 
waveform over time. However, over time, any offsets in the signal are accumulated. In some cases, the user 
would like to be able to ignore these offsets. 

The Advanced Math system allows the use of waveform measurements to be used as scalar arguments. 
One such use is with integration, where you can use an equation like Integral(ch1 – mean(ch1)). 

MSO/DPO5000 Series Setup Procedure 

 For this lab, use the DPO Demo 3 or DPO Demo 2 board. 

 Attach the two host connectors on the USB cable to the oscilloscope and then connect the device 
connector on the cable to the demo board. 

 Verify the power LED is lit. 

 Connect a TPP0500 or TPP1000 10x passive probe to channel 1. 

 Connect the probe ground to GND on the demo board. 

 Connect the channel 1 probe to the CNT_OUT0 signal on the demo board. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 

 Press the front panel Autoset button to automatically get a stable display. 
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Key Take Away Points 

 Notice how the integral continues to accumulate the offsets 
in the input signal across the display (because the input 
signal has a DC offset): 

 

 Although there are other ways to remove the offset, 
advanced math can use the automatic measurement 
system to calculate the value for each waveform and 
subtract it out: 

 

MSO/DPO5000 Series Procedure 

 Press the front panel Measure 
button. 

 Press the More and the Mean 
measurement buttons. 

 Press the red front panel MATH 
button. 

 Press the Editor button. 

 Enter the math expression 
“INTG(Ch1 – Meas1)”. 

 Press the Clear button. 

 Press the Integral button. 

 Press the Channels 1 button. 

 Press the - (minus) button. 

 Click on the Meas tab in the 
Primitive section. 

 Press the 1 (Mean(Ch1) 
button. 

 Press the left parenthesis 
button. 

 Press the OK button. 
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Creating Digital Signals – The Logic of Greater Than (or Less Than) 

When working with digital signals, you sometimes want to see all of the analog characteristics. But when you 
don’t, Advanced Math allows you to transform them into ideal binary waveforms for further analysis. 

The Advanced Math system relational operators are >, <, >=, and <=. These operators compare a waveform 
to a scalar value (a fixed number, a variable value you specify, or a measurement value) and output a digital 
signal which is a digital high when the equation is true and a digital low when the equation is false. The 
simplest is a digital comparator such as “ch1 > 2” which creates a digital high signal whenever channel 1 
exceeds 2.0 V. 

MSO/DPO5000 Series Setup Procedure 

 For this lab, use the DPO Demo 3 or DPO Demo 2 board. 

 Attach the two host connectors on the USB cable to the oscilloscope and then connect the device 
connector on the cable to the demo board. 

 Connect a TPP0500 or TPP1000 10x passive probe to channel 1. 

 Connect the probe ground to GND on the demo board. 

 Connect the channel 1 probe to the XTALK1 signal on the demo board. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 

 Adjust the Vertical and Horizontal Scale and Position and Trigger Level to get a stable display. 

Key Take Away Points 

 Notice that the math waveform is the digital representation 
of the analog channel 1 signal. In this example, the glitch 
crosses through the threshold value and is interpreted as a 
transition in the digital signal, as it would in the hardware 
receiver in the circuit: 

 

MSO/DPO5000 Series Procedure 

 Press the front panel MATH 
button. 

 Select the math Editor. 

 Enter the math expression 
“Ch1 > VAR1”. 

 Press the Clear button. 

 Press the Channels 1 button. 

 Press the > (greater than) 
button. 

 Click on the Var tab in the 
Primitive section. 

 Press the Var1 button. 

 Touch the Var1 text box to 
attach the Multipurpose a 
control to this variable. 

 Press the OK button. 

 With the Multipurpose a control, 

set VAR1 to the desired digital 
threshold value, such as 2V (2.0). 

 Vary the threshold value and 
notice how the glitches on the 
signal are interpreted as different 
logic threshold levels. 
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FFTs of Idealized Digital Signals 

FFTs provide the frequency domain representation of the input signal. In the case of a real square wave, the 
FFT display includes the spectral representation of all of the signal components, both the desired square 
wave as well as the noise and amplitude modulation of the signal. In some cases, this is desirable, but in 
others you are really most interested in the spectrum of the idealized square wave. 

The standard math FFT allows you to display the spectral representation of any of the analog channels or 
reference waveforms. The FFT function in advanced math allows an arbitrarily complex argument. 
(However, the FFT function itself cannot be part of an argument, so it must be the outer-most function in a 
complex math equation.) 

As seen in the last lab, the Advanced Math system allows the creation of idealized digital waveforms. These 
waveforms can also be analyzed by the FFT function. 

MSO/DPO5000 Series Setup Procedure 

 For this lab, use the DPO Demo 3 or DPO Demo 2 board. 

 Attach the two host connectors on the USB cable to the oscilloscope and then connect the device 
connector on the cable to the demo board. 

 Connect a TPP0500 or TPP1000 10x passive probe to channel 1. 

 Connect the probe ground to GND on the demo board. 

 Connect the channel 1 probe to the CNT_CLK signal on the demo board. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 

 Press the front panel Autoset button to automatically get a stable display. 
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Key Take Away Points 

 This is the FFT of the real square wave, from earlier in the 
lab: 

 

 Notice how much “cleaner” the FFT display of the idealized 
square wave is: 

 

MSO/DPO5000 Series Procedure 

 Adjust the Horizontal Scale to 5 
µs/div. 

 Select Horiz/Acq->Resolution…. 

 Double-click on the Sample Rate 
text box and set the value to 50 
MS/s. 

 Press the front panel MATH 
button. 

 Select the math Editor. 

 Enter the first math expression 
“Ch1 > VAR1”. 

 Press the Channels 1 button. 

 Press the > (greater than) 
button. 

 Click on the Var tab in the 
Primitive section. 

 Press the Var1 button. 

 Double-click on the Var1 text 
box and type in “2” and Enter 
to set the threshold value to 
2V and to attach the 
Multipurpose a control to this 
variable. 

 Press the OK button. 

 Set the Math1 Vertical Scale to 1 
unit/div. 

 Click on the Math2 tab at the left 
of the control window. 

 Select the math Editor. 

 Enter the second math expression 
“SpectralMag(Math1)”. 

 Set the Math2 Vertical Scale to 
10 dB/div and position the Math2 
waveform on the display. 

 



 

MSO5000 / DPO5000 Lab Exercise Book 

Version 1.1   5/11/2012 48W-26279-3   272 of 394 

 

Binary Math with Digital Signals 

Advanced Math provides other operators that work with idealized digital waveforms, allowing you to do other 
analysis. The Advanced Math system binary operators are !, ==, ≠, ||, and &&. 
 

 The !() operator inverts the logic of the expression in the parentheses. For example, !(ch1 > 1.6) 
inverts the idealized digital waveform with a 1.6V digital threshold. 

 The || operator provides the logical OR function on the preceding and following arguments. For 
example, (ch1 < 0) || (ch1 > 5) provides a high output whenever the channel 1 signal is outside the 
range of 0V to 5V. 

 The && operator provides the logical AND function on the preceding and following arguments. For 
example, (ch1 >= 1) && (ch1 <= 2) provides a high output whenever the channel 1 signal is between 
1.0V and 2.0V. 

 

MSO/DPO5000 Series Setup Procedure 

 For this lab, use the DPO Demo 3 or DPO Demo 2 board. 

 Attach the two host connectors on the USB cable to the oscilloscope and then connect the device 
connector on the cable to the demo board. 

 Verify the power LED is lit. 

 Connect TPP0500 or TPP1000 10x passive probes to channels 1 and 2. 

 Connect the channel 1 probe to the CNT_OUT0 signal on the demo board. 

 Connect the probe ground to GND on the demo board. 

 Connect the channel 2 probe to the CNT_OUT1 signal on the demo board. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 

 Press the front panel channel 2 button to turn on channel 2. 

 Press the front panel Autoset button to automatically get a stable display. 
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Key Take Away Points 

 Notice that the math waveform is the logical AND of the 
digital representations of the analog channel 1 and 2 
signals: 

 

 Now that you have a math waveform, you can make 
measurements on it. For example, you can measure the 
resulting duty cycle: 

 

MSO/DPO5000 Series Procedure 

 Press the front panel MATH 
button. 

 Double-click on the Math 1 = text 
box. 

 Enter the math expression 
“(Ch1 > VAR1) && (Ch2 > 
VAR2)”. 

 Press the Apply button to 
complete the equation and 
calculate the result. 

 Position and scale the math 
waveform on the display for easy 
viewing. 

 Select the math Editor, click on 
the Var tab in the Primitive 
section, and click on the Var1 text 
box to attach the Multipurpose 
controls to the variables. 

 With the Multipurpose controls, 
set the digital threshold values to 
about 2V. 

 Then, press the front panel 
Measure button. 

 Press the Time tab at the left side 
of the control window. 

 Press the + Duty Cycle button. 
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User-defined Arbitrary Filters 

Advanced Math also provides the ability to digitally filter a signal with a user-defined arbitrary FIR filter. 

The oscilloscope comes with a library of standard filters, found in the 
C:\Users\[Username]\Tektronix\TekScope\Math Arbitrary Filters\<filename> directory. The filename of 
each filter identifies its type as low-pass, high-pass, etc., and also identifies its normalized cutoff frequency 
(relative to the real-time sample rate) or other identifying factors. The precise magnitude characteristics of 
these filters are shown in the following graphs. These are all linear phase filters. 

Low Pass Filters 

The following graphs show the available set of low pass filters. Their normalized frequency response is 
shown from 0 to ½ the sample rate. These filters will operate at any sample rate with cutoff frequency scaled 
as shown below on the graphs. The filters have normalized cutoff frequencies of 0.05, 0.1, 0.15, 0.20, 0.25, 
0.3, 0.35, 0.40, and 0.45. Stop band rejection is typically between –50 and –60 dB. 

 
Frequency response of the available low-pass filters 

 
High Pass Filters 

The following graphs show the available set of high pass filters. Their normalized frequency response is 
shown from 0 to ½ the sample rate. These filters will operate at any sample rate with cutoff frequency scaled 
as shown below on the graphs. The filters have normalized cutoff frequencies of 0.05, 0.1, 0.15, 0.20, 0.25, 
0.3, 0.35, 0.40, and 0.45. Stop band rejection is typically between –50 and –60 dB. 

 
Frequency response of the available high-pass filters 
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Band Pass Filters 

Each filter has a bandwidth of 0.05 times the sample rate. They will operate at any sample rate. The 
available center frequencies are 0.05, 0.10, 0.15, 0.20, 0.25, 0.30, 0.35, 0.40, and 0.45. Stop band 
attenuation is approximately -60 dB and pass band ripple is around 1dB. 

 
Frequency response of the available band-pass filters 

 

Band Stop Filters 

Each filter has a bandwidth of 0.1 times the sample rate. They will operate at any sample rate. The available 
center frequencies are 0.10, 0.15, 0.20, 0.25, 0.30, 0.35, and 0.40. Stop band attenuation is approximately  
-110 dB, however, the noise floor of the oscilloscope will not allow for that depth. With an FFT and long 
record length, and averaging turned on, one can approach noise floors in the -110 dB range on an 8-bit 
oscilloscope. However, the oscilloscope will have some spurious signals above that floor. This is possible 
because the FFT is an average calculation internally and the averaging function increases the vertical bits of 
resolution. 

 
Frequency response of the available band-stop filters 
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Smoothing Filters 

These are sometimes called box-car filters. They simply average together adjacent samples along the time 
record. The filter coefficients for these filters are all equal to 1/ M where M is the length of the filter. The 
name of the files indicates the length of the smoothing filter. 

Smoothing filters are low pass filters with a somewhat less than optimal stop band characteristic. However, 
they are commonly used to remove high frequency noise from a displayed trace. Take care in using to 
insure that the pass band of the signal you are filtering is well within the pass band of the filter you choose. 
That will insure that only noise is removed. Lengths of 3, 5, 10, 20, 50, 100, and 200 are provided in the 
library. The red trace is for filter length 3, followed by blue trace at 5, followed by magenta trace for 10, and 
so on. 

 
Frequency response of the available smoothing filters 

 

Hilbert Transform Filter 

The ideal Hilbert transform filter has a gain of one at all frequencies and shifts the phase of all frequencies 
by 90 degrees. This type of filter is one of the types that may be specified in the Remez Exchange algorithm. 
This filter departs from its desired behavior in the frequency range of 0 to 0.025 times the sample rate and 
also in the range of about 0.475 to 0.5 times the sample rate. This type of filter can be used to create 
quadrature signals over a wide frequency range. The filename for this filter is 
HilbertTransform90PhaseShift.flt. 

 
Frequency response of the Hilbert Transform filter 
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Differentiator 

The ideal differentiator is a high pass filter that shifts phase by 90 degrees and its frequency response would 
be linear from DC to 0.5. Since this is not easily realized, the filter provided in the library makes a good 
differentiator for the frequency range of DC to 0.45. 

 
Frequency response of the differentiator filter 

 

Filter File Format 

Filters are defined in text files on the oscilloscope, where a single file format allows the user to specify a 
different set of coefficients for each sample rate that the filter operates at. If the desired sample rate is not in 
the file list, then the filter will not be applied to the data. Comments are preceded by # symbol. The file 
format also allows the user to specify that the set of filter coefficients is normalized. This allows the same set 
of filter coefficients to operate at all sample rates. The ASCII file format is specified as follows: 

< sampleRate > coef1, coef2, …. coefN 

Each set of filter coefficients in a file are specified in one row preceded by the sample rate value at which 
that set will operate. If the user specifies the @ symbol for the sample rate then the filter will operate at all 
sample rates. If the @ symbol is specified then there should only be one set of filter coefficients in the file. 
However, the user may have other rows with sample rates specified and they will be ignored. There will be a 
separate row for each sample rate the filter is to operate at. Each row may have a different number of 
coefficients with a maximum of 1000. The file may contain up to 20 rows. 

An example of file content for a normalized filter is the smooth5.flt file: 

@ 0.2, 0.2, 0.2, 0.2, 0.2 

An example of a filter that is setup to operate at a specific sample rate is given as follows. This is the 
contents of a file named 200MHz_mult_sample_rates.flt that is included in the library directory on the 
oscilloscope. 

#This is a 4th order Bessel-Thompson low pass filter. 
#200MHz bandwidth, will operate at any of the following sample rates: 
# 40 GS/s, 20 GS/s, 10 GS/s, 5 GS/s, 2.5 GS/s, 1 GS/s, 500 MS/s 
5e8; 1.968e-007,1.008,-0.00978,0.002267,-0.0002208,1.643e-005,-1.397e-006,1.434e-007 
1e9; 9.524e-008,0.3899,0.4877,0.1304,-0.004733,-0.004566,…………………………. 
2.5e9; 3.868e-008,0.01885,0.1081,0.1982,0.2284,0.1981,……………………… 
5e9; 1.935e008,0.0007332, 0.009428, 0.02874, 0.05408, 0.07921, ………………………. 
1e10; 9.673e-009,3.445e-006,0.0003666,0.001831,0.004714,0.008978,0.01437,0………………. 
2e10; 4.837e-009, 1.657e-008, 1.723e-006, 4.274e-005, 0.00018334-009, ………………. 
4e10; 2.418e-009, -3.524e-009, 8.284e-009, -1.795e-008,8.613e-007, ………………. 
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MSO/DPO5000 Series Setup Procedure 

 For this lab, use the DPO Demo 3 board. 

 Attach the two host connectors on the USB cable to the oscilloscope and then connect the device 
connector on the cable to the DPO Demo 3 board and verify the power LED is lit. 

 Connect a TPP1000 or TPP0500 10x passive probe to channel 1. 

 Connect the channel 1 probe to the SS_CLOCK signal on the demo board. 

 Connect the probe ground to GND on the demo board. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 

 Press the front panel Autoset button to automatically get a stable display and press OK. 

 Adjust the Vertical Scale and Position controls until the clock signal fills most of the screen vertically. 
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Key Take Away Points 

 The 100 MHz spread-spectrum clock signal SS_CLOCK 
should look about like this: 

 

 The harmonics on the 100 MHz clock signal (primarily the 
3

rd
 and 5

th
 harmonics, at 300 and 500 MHz, respectively) 

distort the shape of the fundamental 100 MHz sine wave. 
One way to view just the fundamental signal is to low-pass 
filter the signal and remove the harmonic content. 

 You can use the math equation editor to build a math 
waveform based on the standard arbitrary filters included 
with the oscilloscope. In this case, we are going to use a 
low-pass FIR filter with a corner frequency at 10% of the 
sample rate to remove the harmonics from the clock signal: 

 

MSO/DPO5000 Series Procedure 

 Set the Horizontal Scale to 100 
ns/div. 

 Select Horizontal->Horizontal 
Modes->Real Time Only. 

 Turn on zoom and select a Zoom 
Factor of about 10-20 so you can 
clearly see a few cycles of the 
clock signal. 

 

 

 

 

 

 

 

 

 

 

 

 Select Math -> Math Setup…. 

 Press the Editor button. 

 Click on the Filter tab. 

 Click on the Load button at the 
top of the User-defined Arbitrary 
Filters table. 

 Double-click on the LowPass-
Norm folder and select the 
lowpass_0.1bw.flt filter file. This 
selects a low-pass FIR filter that 
has a corner frequency at 10% of 
the sample rate. 

 Press the Flt1 button to define 
the math expression as this filter 
applied to the channel 1 signal. 

 Press the green Apply button. 

 Press the OK button to close the 
equation editor control window. 

 Set the Math1 Scale to match the 
channel 1 Vertical Scale setting. 

 Click on the white X in the upper 
right corner of the control window 
to close it. 
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Key Take Away Points 

 Here is the user-defined arbitrary filter math waveform. The 
corner frequency of the low-pass filter is 10% of the sample 
rate. In the following example, the filter bandwidth is 1 GHz 
(so the system bandwidth is actually being limited by the 
analog bandwidth of the probe and oscilloscope, in this 
case). The orange math signal looks about the same as the 
yellow channel 1 signal, like this: 

 

 When the sample rate is reduced to 2.5 GS/s, the 
bandwidth of the FIR filter is reduced to 250 MHz. This 
corner frequency is below the frequency of the 3

rd
 harmonic 

but above the 100 MHz fundamental frequency of the clock 
signal: 

 

MSO/DPO5000 Series Procedure 

 Select Horiz/Acq->Resolution…. 

 Click on the Sample Rate text box 
to attach the Multipurpose a 
control. 

 Turn the Multipurpose a control 
fully clockwise to select the 
maximum real-time sample rate. 

 Notice that the shape of the math 
waveform is the same as the 
clock signal. 

 

 

 

 

 

 

 

 

 

 

 Gradually turn the Multipurpose a 
control counter-clockwise until the 
sample rate has been reduced to 
about 2.5 GS/s. 

 Notice that the filtered signal now 
looks sinusoidal, and yet the 
amplitudes of the waveforms are 
about the same. 

 



 

MSO5000 / DPO5000 Lab Exercise Book 

Version 1.1   5/11/2012 48W-26279-3   281 of 394 

 

Key Take Away Points 

 When the sample rate is further reduced to 1 GS/s, the 
bandwidth of the FIR filter is reduced to 100 MHz. 
Remember that the corner frequency is the frequency at 
which the signal is attenuated by 3 dB, or about 30%. 
When the 100 MHz fundamental frequency of the clock 
signal is aligned with the corner frequency of the FIR filter, 
notice that the amplitude has been reduced: 

 

 But for a signal like this, a band-pass filter would also be an 
appropriate choice to remove harmonics, as well as noise 
and DC offset from the clock signal. 

 At a sample rate of 1 GS/s, the band-pass filter is centered 
on the 100 MHz clock fundamental. Notice that the 
harmonics have been removed, but also notice that the DC 
offset of the signal has been removed (the signal is now 
centered around the ground reference point): 

 

MSO/DPO5000 Series Procedure 

 Turn the Resolution control 
counter-clockwise until the 
sample rate has been reduced to 
1 GS/s. 

 Notice that the filtered signal still 
looks sinusoidal, but the 
amplitude of the filtered waveform 
is now substantially reduced. 

 

 

 

 

 

 

 

 

 Select Math -> Math Setup…. 

 Press the Editor button. 

 Press the Clear button. 

 Click on the Filter tab. 

 Click on the Load button at the 
top of the User-defined Arbitrary 
Filters table. 

 Navigate to the BandPass-Norm 
folder and select the 
bandpass_0.05bw_0.1Center.flt 
filter file. This selects a band-pass 
FIR filter that has a center 
frequency at 10% of the sample 
rate and a bandwidth of 5% of the 
sample rate. 

 Press the Flt1 button to define 
the math expression as this filter 
applied to the channel 1 signal. 

 Press the green Apply button. 

 Press the OK button to close the 
equation editor control window. 

 Set the Math1 Scale to match the 
channel 1 Vertical Scale setting. 

 Click on the white X in the upper 
right corner of the control window 
to close it. 
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MSO5000/DPO5000 Series 
Waveform Histograms Lab 

 

 

 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.1.1 
One TPP0500 or TPP1000 Passive Probe 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: screen shots in this lab were made with the DPO Demo 3 board] 
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Overview of Waveform Histograms 

A histogram is a graphical display which shows the density or relative proportions of cases of a varying 
quantity falling into each of several bins or categories. For example, in a Digital Phosphor Oscilloscope, the 
waveform intensity at each picture element (or pixel) on the display represents the relative frequency-of-
occurrence. In this way, the brightness of the pixels is a statistical representation of a time-varying signal. 

Waveform histograms show the density of the waveform samples in a row or column of pixels (“hits”) in a 
specified area on the oscilloscope display. The user specifies the portion of the displayed waveform to be 
analyzed by positioning a rectangle or box on the display. 

A vertical histogram shows the number of waveform samples which occur at each of the 252 digitizer levels 
on the display. The box specifies the waveform samples that are analyzed. 

A horizontal histogram shows the number of waveform samples which occur in each of the 1000 pixel 
columns on the display. The box specifies the waveform samples that are analyzed. 

In either case, the waveform histogram data is normalized such that the display of the bin with the highest 
number of hits is scaled to a specified number of divisions tall. The default scaling is 2 divisions, but the 
scale can vary from 0.1 to 10 divisions. The default display format scales the histogram data linearly, but a 
logarithmic display format is also available which can improve visibility of details of bins with few hits. 

In addition to the waveform histogram display, automatic measurements on the histogram data are 
available: 

Wfm Ct: Displays the number of waveforms that contributed to the histogram. 

Hts in Box: The number of samples or hits within the histogram box or on its boundaries. 

Peak Hits: The number of samples in the bin that contains the most hits. 

Median: The middle histogram data value, where half of all histogram data points are less than this value 
and half are greater than this value. 

Max: The voltage of the highest nonzero bin in vertical histograms or the time of the right-most nonzero bin 
in horizontal histograms. 

Min: The voltage of the lowest nonzero bin in vertical histograms or the time of the left-most nonzero bin in 
horizontal histograms. 

Pk-to-pk: Vertical histograms display the voltage of the highest nonzero bin minus the voltage of the lowest 
nonzero bin. Horizontal histograms display the time of the right-most nonzero bin minus the time of the left-
most nonzero bin. 

Mean: The average of all histogram data points within or on the histogram box. 

Std Dev: The standard deviation (Root Mean Square deviation) of all histogram data points within or on the 
histogram box. 

µ±1: The % of the hits in the histogram that are within one standard deviation of the histogram mean. 

µ±2: The % of the hits in the histogram that are within two standard deviations of the histogram mean. 

µ±3: The % of the hits in the histogram that are within three standard deviations of the histogram mean. 

Objectives 

- Obtain a basic understanding of waveform histogram displays and automatic measurements on 
histogram data. 

- Learn how to set up and demonstrate waveform histograms with an MSO/DPO5000 Series 
oscilloscope. 
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MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has a 
FAST_FF_CLK signal which we will use for this lab. This is 
a 1.25 MHz signal with a slow variation in duty cycle. (The 
timing of the falling edges vary at about a 1 Hz rate.) 

 

 The DPO Demo 2 board (020-2924-XX) also has a 
FAST_FF_CLK signal: 

 

 

Demo Board Procedure 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the power LED is lit. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. 

 Attach the probe ground to the 
GND test point on the test board. 

 Connect the probe tip to the 
FAST_FF_CLK test point on the 
test board. 

FAST_FF_CLK 
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Vertical Waveform Histograms 

Key Take Away Points 

 Vertical waveform histograms allow you to evaluate the 
distribution of voltage values on a signal over time. For 
example, on this digital signal, the “high” voltage is 
approximately 4V, but there is some noise superimposed 
on the signal, as shown below: 

 

 The vertical histogram display provides a way to measure 
and characterize this noise over a region on the waveform 
over many acquisitions, specified by the graphical box. The 
noise can be displayed as a linear or logarithmic histogram, 
shown at the left side of the display, aligned with the box. 
Notice that the noise histogram appears to be a fairly bell-
shaped curve: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Set the Vertical Scale to 
500mV/div and center the 
position of the waveform vertically 
on the display. 

 Press the Trigger Level control 
to automatically set the trigger 
level to 50%. 

 Set the Horizontal Scale to 
10ns/div. 

 Press the front panel Measure 
button. 

 Press the Histogram button. 

 Press the Vert histogram mode 
button. 

 Double-click on the Left Limit 
text box and set the value to 20 
ns. 

 Double-click on the Right Limit 
text box and set the value to 40 
ns. 

 Double-click on the Top Limit 
text box and set the value to 
about 4.3 V. 

 Double-click on the Bottom Limit 
text box and set the value to 
about 3.3 V. 

 Another way to define the 
histogram box is to use the 
mouse or touchscreen to 
graphically define the box. Using 
either the mouse or touchscreen, 
draw a box around a portion of 
the waveform and select 
Histogram Vertical. 
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Horizontal Waveform Histograms 

Key Take Away Points 

 Horizontal waveform histograms allow you to evaluate the 
changes in position of a signal over time. In many cases, 
this is referred to as “jitter”. For example, on this digital 
signal, the falling edge is varying back and forth by over 20 
ns: 

 

 The horizontal histogram display below shows the jitter on 
the falling edge of the FAST_FF_CLK signal. The 
histogram is positioned at the top of the display and is 
aligned with the box. The histogram is always scaled such 
that the peak value is 2 divisions high. 

 

 Notice that the histogram is not at all bell-shaped, 
suggesting that the edge jitter is not due to random noise. 

MSO/DPO5000 Series Procedure: 

 NOTE: This section of the lab 
continues with the oscilloscope 
setup from the previous section. 

 Press the front panel Acquisition 
button. 

 Press the Delay Mode button to 
turn it On. 

 Turn the horizontal Position 
control clockwise until the falling 
edge of the signal is centered on 
the display. The trigger delay 
readout should indicate about 400 
ns, shown at the bottom of the 
display. 

 Set the Vertical Scale to 1 V/div. 

 Select Display->Display 
Persistence->Infinite 
Persistence. 

 Press the front panel Measure 
button. 

 Press the Histogram button. 

 Press the Horiz histogram mode 
button. 

 Double-click on the Left Limit 
text box and set the value to 380 
ns. 

 Double-click on the Right Limit 
text box and set the value to 420 
ns. 

 Double-click on the Top Limit 
text box and set the value to 
about 2.0 V. 

 Double-click on the Bottom Limit 
text box and set the value to 
about 1.5 V. 

 Watch the histogram build as the 
position of the falling edge of the 
signal varies. 
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Automatic Measurements on Histogram Data 

Key Take Away Points 

 In addition to graphing the waveform histogram data, the 
oscilloscope can make automatic measurements on the 
data. 

 When the histogram data is selected as the source for the 
measurements, the list of appropriate measurement types 
appears: 

 

 The measurements on the histogram data appear at the 
bottom of the screen, in the same color as the histogram 
display: 

 

 In this case, the peak-to-peak and RMS jitter 
measurements on the edge are made automatically. 

MSO/DPO5000 Series Procedure: 

 NOTE: This section of the lab 
continues with the oscilloscope 
setup from the previous section. 

 In the Waveform Histogram Setup 
window, press the Measurement 
Setup button. 

 Click on the Histog tab in the 
Measurements section. 

 Press the Peak-to-peak button. 

 Press the More button. 

 Press the Std Dev button. 

 

 

 

 

 

 

 

 

 To indicate where the Peak-to-
peak measurement is made on 
the waveform histogram, select 1 
– Pk-Pk from the Annotation 
drop down menu or select 
Measure->Annotation->Peak to 
Peak. 

 To indicate where the Peak-to-
peak measurement is made on 
the waveform histogram, select 2 
– Std Dev from the Annotation 
drop down menu or select 
Measure->Annotation-
>Standard Deviation. 
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MSO5000/DPO5000 Series 
DPOJET Lab 
 

 
 
Equipment List 
One MSO5000 Series oscilloscope with software version ≥6.4 or 

one DPO5000 Series oscilloscope with software version ≥6.4 and with the MSOE option installed 
DPOJET application (version ≥3.6.0) installed on the oscilloscope 
One TPP0500 or TPP1000 Passive Probe 
One P6616 MSO Probe 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) or 

DPO Demo 2 board and USB cable (020-2924-XX and 174-4401-00) 
[Note: most of the screen shots in this lab were made with the DPO Demo 3 board] 
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Introduction to Jitter and Timing Measurements 

Timing jitter is the unwelcome companion of all electrical systems that use voltage transitions to represent 
timing information. Historically, electrical systems have lessened the ill effects of timing jitter (or, simply 
“jitter”) by employing relatively low signaling rates. As a consequence, jitter-induced errors have been small 
when compared with the time intervals that they corrupt. The timing margins associated with today’s high-
speed digital designs and high-speed serial buses and data links reveal that a tighter control of jitter is 
needed throughout the system design. 

The simple definition of jitter is the deviation of timing edges from their “correct” locations. In a timing-based 
system, timing jitter is the most obvious and direct form of non-idealness. As a form of noise, jitter must be 
treated as a random process and characterized in terms of its statistics. 

Before a digital signal’s deviations from ideal positions can be measured, those ideal positions must be 
identified. For a clock-like signal (alternating 1’s and 0’s), the ideal positions conceptually correspond to a 
jitter-free clock with the same mean frequency and phase as the measured one. More care must be used for 
a data signal, since no event (transition) occurs when the same bit repeats two or more times in a row. 
Clock Recovery is the name given to the process of establishing the timing of the reference clock. 

There are several ways in which jitter may be measured on a single waveform. These are period jitter, 
cycle-cycle jitter, and time interval error (TIE). It is important to understand how these measurements relate 
to each other and what they reveal. 

 

This figure shows a clock-like signal with timing jitter. The dotted lines show the ideal edge locations, 
corresponding to a jitter-free version of the clock. 

The period jitter, indicated by the measurements P1, P2 and P3, simply measures the period of each clock 
cycle in the waveform. This is the easiest and most direct measurement to make. Its peak-to-peak value 
may be estimated by adjusting an oscilloscope to display a little more than one complete clock cycle with 
the display set for infinite persistence. If the scope triggers on the first edge, the period jitter can be seen on 
the second edge. 

The cycle-cycle jitter, indicated by C2 and C3, measures how much the clock period changes between any 
two adjacent cycles. As shown, the cycle-cycle jitter is simply the difference operation between adjacent 
period jitter measurements. 
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The time interval error is shown by the measurements TIE1 through TIE4. The TIE measures how far each active 
edge of the clock varies from its ideal position. For this measurement to be performed, the ideal edges must be 
known or estimated. For this reason, it is difficult to observe TIE directly with an oscilloscope, unless some means 
of clock recovery or post-processing is available. The TIE may also be obtained by integrating the period jitter, 
after first subtracting the nominal (ideal) clock period from each measured period. TIE is important because it 
shows the cumulative effect that even a small amount of period jitter can have over time. 

Since all known signals contain jitter that has a random component, statistical measures are required to properly 
characterize the jitter. Some of the commonly used measures are: 

 Mean: The arithmetic mean, or average, value of a clock period is the nominal period. This is the 
reciprocal of the frequency that a frequency counter would measure. 

 Standard Deviation: The standard deviation, represented by the Greek character sigma (), is the 
average amount by which a measurement varies from its mean value. 

 Maximum, Minimum and Peak-Peak Values: The Max and Min values generally refer to values actually 
observed during a measurement interval, and the Peak-Peak value is simply the Max minus the Min. 

 Population: The population is the number of individual observations included in a statistical data set. For 
a random process, a high population intuitively gives greater confidence that the measurement results 
are repeatable. 

Because the measurements are describing a statistical quantity, a histogram of the measurement values can be a 
helpful way to display the measurement values. A histogram is a diagram that plots the measurement values in a 
data set against the frequency of occurrence of the measurements. If the number of measurements in the data set 
is large, the histogram provides a good estimate of the probability density function (pdf) of the set. 

 

Since the jitter histogram doesn’t show the time-order in which the measurement observations occur, it cannot 
reveal repeating patterns that might indicate a modulation or other periodic component. A plot of jitter values 
versus time can make such a pattern obvious. For example, a time trend of jitter measurements can make a 
pattern of jitter variation becomes apparent, and its correlation with one of several possible sources of coupled 
noise might become clear. 

Since the jitter measurements can be plotted versus time, an obvious extension is to apply a Fourier 
transform to these measurements and display the results in the frequency domain. This results in a jitter 
spectrum, with the modulation frequency displayed on the horizontal axis and the amplitude of modulation 
shown on the vertical axis. One of the benefits of spectral analysis is that periodic components that 
otherwise might be hidden by wideband noise can often be clearly distinguished. 
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Introduction to Eye Diagrams 

All of the methods discussed so far rely on edge locations only. These locations are extracted from a 
waveform by detecting when the waveform crosses one or more amplitude thresholds. The eye diagram is a 
more general tool, since it gives insight into the amplitude behavior of the waveform as well as the timing 
behavior. 

An eye diagram is created when many short segments of a waveform are superimposed such that the 
nominal edge locations and voltage levels are aligned, as shown below. Usually, a horizontal span of two 
unit intervals is shown. The waveform segments may be adjacent ones, as shown in the figure, or may be 
taken from more widely spaced samples of the signal. If the waveform is repetitive, an oscilloscope can use 
equivalent time sampling to build an eye diagram from individual samples taken at random delays on many 
waveforms. 

 

Eye diagrams usually use either intensity-graded monochrome displays or color-graded displays to indicate 
the density of waveform samples at any given point on the display. The eye diagram below shows such a 
color density display for a waveform that exhibits several types of noise. 

 

In this diagram, white arrows are used to show the vertical and horizontal extent of the eye opening. As the 
noise on a signal increases, the eye becomes less open, either horizontally, vertically or both. The eye is 
said to be closed when no open area remains in the center of the diagram. 
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Introduction to Jitter Analysis 

Jitter separation, or jitter decomposition, is an analysis technique that uses timing measurements to model 
and predict system behavior. The most commonly used jitter model is based on a hierarchy where the total 
jitter (TJ) is separated into random jitter (RJ) and deterministic jitter (DJ). 

Random Jitter: Random jitter is timing noise that cannot be predicted, because it has no discernable 
pattern. Random jitter is usually assumed to have a Gaussian distribution. One reason for this is that the 
primary source of random noise in many electrical circuits is thermal noise, which has a Gaussian 
distribution. Another, more fundamental reason is that the composite effect of many uncorrelated noise 
sources, no matter what the distributions of the individual sources, approaches a Gaussian distribution 
according, to the central limit theorem. 

Although most samples of a random variable are clustered around its mean value, the peak value that it 
might attain is infinite. The more samples one takes of such a distribution, the larger the measured peak-to-
peak value will be. For this reason, a better approach is to fit the measured values to the assumed Gaussian 

distribution and describe it in terms of its mean and standard deviation. The Gaussian distribution, also known 
as the normal distribution, has a PDF that is described by the familiar bell curve, as shown below. 

 

If you display an eye diagram of a signal affected only by random jitter, you will see a display similar to this: 

 

If you plot the position of the waveform samples in the red box at the left side of the eye diagram above, you 
will create the horizontal histogram shown at the bottom of the figure. Notice how the shape of the histogram 
approximates a normal or bell curve. 

Deterministic Jitter: Deterministic jitter is timing jitter that is repeatable and predictable. Because of this, the 
peak-to-peak value of this jitter is bounded, and the bounds can usually be observed or predicted with high 
confidence based on a reasonably low number of observations. This category of jitter is further subdivided in the 
paragraphs that follow, based both on the characteristics of the jitter and the root causes. 

Deterministic jitter is further subdivided into several categories: periodic jitter (PJ), duty-cycle dependent 
jitter (DCD), and data-dependent jitter (DDJ, also known as inter-symbol interference, ISI). 
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Periodic Jitter: Jitter that repeats in a cyclic fashion is called periodic (or sinusoidal) jitter. Periodic jitter is 
typically caused by external deterministic noise sources coupling into a system, such as switching power-
supply noise or a strong local RF carrier. It may also be caused by an unstable clock-recovery PLL. Periodic 
jitter may also be intentionally designed into a system, such as a spread-spectrum clock, to spread RF 
energy across a frequency band. 

 

Data-Dependent Jitter: Any jitter that is correlated with the bit sequence in a data stream is termed Data-
Dependent Jitter, or DDJ. DDJ is often caused by the frequency response of a cable or device. Consider the 
following data sequence where the waveform doesn’t reach a full HIGH or LOW state unless there are 
several bits in a row of the same polarity. This has the effect of shifting the timing of the signal crossing 
through the threshold. 

 

Since this timing shift is predictable and is related to the particular data values preceding the transition, it is 
an example of DDJ. Another common name is Inter-Symbol Interference, or ISI. The eye diagram of a signal 
with 0.2 unit intervals of DDJ, together with the associated TIE histogram, is shown below: 
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Duty-Cycle Dependent Jitter: Jitter that may be predicted based on whether the associated edge is rising 
or falling is called Duty-Cycle Dependent Jitter (DCD). There are two common causes of DCD: 

1. The slew rate for the rising edges differs from that of the falling edges. 

2. The decision threshold for a waveform is higher or lower than it should be. 

The screen shot below is an eye diagram demonstrating the first case. Here, the decision threshold is at the 
50% amplitude point but the slow rise time of the waveform causes the rising edges to cross the threshold 
later than the falling edges. As a result, the histogram of an edge crossing (gray) shows two distinct 
groupings. (This eye diagram also shows some Gaussian noise in addition to the duty-cycle jitter.) 

 

The screen shot below illustrates the second case, in which the waveform has balanced rise and fall times 
but the decision threshold is not set at the 50% amplitude point. However, the edge-crossing histogram 
would look very much like that shown above. 
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Introduction to Bit Error Rates and Bathtub Curves 

Earlier in this document, we discussed the concepts of eye diagrams and eye openings. The Gaussian 
probability distribution, with its theoretically unbounded peak-to-peak value, was also covered. Considering 
these two topics together leads to an interesting thought: 

For any signal that contains some Gaussian jitter, the eye diagram should close completely if you 
accumulate samples for a long enough time. This would render the concept of eye opening useless as a 
basis for comparison. Fortunately, the usefulness of the eye diagram is restored if a confidence level is 
applied to the eye opening. 

Consider the figure below, in which a green ruler 0.5 unit intervals long has been placed horizontally in the 
center of the eye. Suppose that it is regarded a failure if any waveforms cross this ruler, either rising or 
falling. In the figure, it appears that this ruler has not been crossed by any waveforms yet, but such a 
crossing is inevitable if waveform samples continue to accumulate and the signal contains some Gaussian 
jitter. 

 

Now suppose instead that the test was considered successful if no more than one waveform out of every 
1000 waveforms crossed over the ruler. It would no longer matter how long the test ran. If 50,000 
waveforms were allowed to accumulate and 50 or less crossed over the ruler, the test would have passed. 
One could say that, aside from one waveform in 10

3
, the eye was 50% open. Since each crossing is 

assumed to represent a bit error, this would be a bit error rate (BER) of 10
-3

. 

If the same signal were tested with a shorter ruler, say, 0.25 unit intervals long, then the ruler would certainly 
be crossed less frequently. Perhaps only one waveform out of every 100,000 waveforms, on average, would 
cross this shorter ruler. One could say that, aside from one waveform in 10

5
, the eye was 25% open. 

Continuing along these lines and using a series of rulers, one could fully characterize the eye opening 
versus the bit error rate. (Note that each ruler should be allowed to slide left or right to obtain the best 
possible fit.) If the rulers are all plotted against their corresponding bit error rates on a single chart, with the 
ends of the rulers connected, a plot something like this results: 
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A plot like this is called a Bathtub Plot, since the pink lines can be imagined to look like a bathtub. Using 
such a figure, one can tell what horizontal portion of the eye will remain completely free of signal transitions, 
for a given confidence level. 

Finally, note that it can take a long time to accumulate enough data to directly measure the eye openings 
near the bottom of the chart. For this reason, the mathematical model for total jitter, based on the individual 
jitter component measurements, can be used to predict performance on the basis of a much smaller sample 
set. 

 

Lab Objectives 

- Learn how to make simple timing measurements, along with measurement trend plots and 
measurement histograms, with the DPOJET application. 

- Learn how to do basic jitter analysis with the DPOJET wizards. 

- Learn how to use advanced jitter measurements can be used to identify signal characteristics. 

For further reference: 

- See the on-line help material: Help -> Help on Jitter And Eye Analysis 

- See related materials on http://www.tek.com/applications/computing/jitter.html, especially the 
following: 

o Tektronix Jitter Primer “Understanding and Characterizing Timing Jitter” (55W-16146) 

o DPOJET Data Sheet (61W-21170) 

 

 
 
 

MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 With the optional DPOJET application installed, the 
MSO/DPO5000 Series oscilloscopes can make a variety of 
automatic jitter and timing measurements. 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the optional DJA: 
Jitter and Eye Diagram Tools - 
Advanced application is installed. 

 Press the OK button. 

  

http://www.tek.com/applications/computing/jitter.html
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Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has several clock 
signals which we can use for this lab: 

 

 The DPO Demo 2 board (020-2924-XX) also has several 
clock signals which we can use for this lab: 

 

DPO Demo Board Procedure: 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the green POWER LED is 
lit. 

 Attach a TPP0500 or TPP1000 
probe to the Channel 1 input of 
the oscilloscope. 

 Attach the probe ground to the 
GND test point on the test board. 

 Connect the probe tip to the 
CNT_CLK test point on the test 
board. 

 NOTE: The signals on each demo 
board may be slightly different, so 
the exact measurement details 
may differ. However, the concepts 
should still be valid. 
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Key Take Away Points 

 We need to get a stable display of the signal on the 
oscilloscope. Then we need to adjust the acquisition 
system so there are many cycles in each acquisition. 

 The oscilloscope display should look about like this: 

 

 Next, you’re going to measure the frequency of every cycle 
in the acquisition with a few clicks of the mouse! 

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Press the front panel Autoset 
button. 

 Set the Vertical Scale to 500 
mV/div. 

 Using the Vertical Position 
control, center the waveform on 
the display. 

 Set the Horizontal Scale to 100 
µs/div. 
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Making Automatic Frequency Measurements 

Key Take Away Points 

 When you run the automatic measurement, notice the 
measurement results with measurement statistics. With 
adequate sample rate and record length, you can easily 
make a very accurate measurement. Over time, the 
measurement statistics enable you to build up a fairly high-
resolution (Mean) frequency measurement value: 

 

 However, it is important to note that there is only one 
frequency measurement made on each acquired 
waveform. Notice the annotation market at the left side of 
the display. 

 The statistics are building up across acquisitions, adding a 
single measurement value with each acquisition. 

 If you look carefully at this screen shot, you will realize that 
the oscilloscope is not optimally set up to make automatic 
measurements. While it is true that the sample rate is 
indeed much higher than the frequency you are measuring, 
the time window and therefore the record length are 
unnecessarily long, providing no advantage for this 
measurement. 

 Let’s zoom in to see what is really happening. 

MSO/DPO5000 Series Procedure: 

 Turn on the automatic frequency 
measurement by selecting 
Measure -> Time -> Frequency. 
You can also do this with the 
keyboard shortcuts Alt-S, Alt-T, 
Alt-Q. 
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Key Take Away Points 

 When you zoom in on the first cycle of the acquisition, you 
can clearly see where the automatic measurement. Notice 
that indeed the frequency measurement is being made on 
the first full cycle of the waveform and that the 
measurement reference level is at about half of the signal 
amplitude: 

 

 With all of the cycles in this acquisition, wouldn’t it be great 
to be able to measure the frequency of all of them? 

 Wouldn’t it be great to use measurement statistics to 
describe the variations in the measurements within the 
acquisition, and average the measurement values to get a 
higher-resolution result? 

 Wouldn’t it be great to be able to plot the trend of the 
measurement values over time to see how the frequency is 
changing? 

 These are some of the basic capabilities of the DPOJET 
Essentials application, which is standard with the 
MSO/DPO5000 Series oscilloscopes. 

 DPOJET Advanced is an option to the instruments which 
adds significant jitter measurement capabilities. 

MSO/DPO5000 Series Procedure: 

 Press the Single button. 

 Notice that a single acquisition is 
made (shown in the status box in 
the lower right corner of the 
display) and that a single 
measurement has been made 
(Value = Mean = Min \ Max, and 
Count = 1). 

 Zoom in on the left edge of the 
display. If necessary, you can do 
a zoom-on-zoom to get adequate 
magnification to display the first 
cycle of the acquisition. 

 

 

 

 

 When you are done, right click on 
the measurement readout area 
and select Remove. 

 Turn off zoom. 

 Press the Run/Stop button. 

 



 

MSO5000 / DPO5000 Lab Exercise Book 

Version 1.1   5/11/2012 48W-26279-3   301 of 394 

 

Making Frequency Measurements with DPOJET 

Key Take Away Points 

 When you run the measurement, notice the measurement 
results with measurement statistics. With this test setup, 
notice that a population of 1248 frequency measurements 
are made on the acquired waveform: 

 

 Notice that the measurement readout provides the rich 
measurement statistics data, even in Single acquisition 
mode, since the measurements are based on all of the full 
cycles of the waveform within the acquisition. 

 Each time you press the DPOJET Single button, you 
accumulate the results of 1248 more frequency 
measurements. 

 When you display the plots, you can see the variation of 
the measurement values over time (measurement trending) 
in the left plot, and the distribution of measurement values 
(measurement histograms) in the right plot: 

 

MSO/DPO5000 Series Procedure: 

 Launch the DPOJET application 
by selecting Analyze -> Jitter 
and Eye Analysis -> Select…. 
You can also do this with the 
keyboard shortcuts Alt-A, Alt-J, 
Alt-S. 

 With the Select button at the left 
side of the control window 
selected, press the Freq button to 
select the Frequency 
measurement. 

 Press the Plots button at the left 
side of the control window. 

 Press the Time Trend button to 
display the graph of frequency 
measurements over time. 

 Press the Histogram button to 
display the histogram display of 
the frequency measurements. 

 Press the Single button at the 
right side of the control window. 

 

 

 

 Press the Single button again 
and notice that the number of 
measurements (population) 
doubles. 
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Using the DPOJET One-Touch Jitter Wizard 

Key Take Away Points 

 You can use the One-Touch Jitter Wizard to automatically 
perform a repeatable, complex jitter analysis with a single 
menu selection. The process selects a waveform source, 
sets the horizontal and vertical scales, chooses 
measurements, generates statistical results, and creates 
summary plots. 

 Simply get a stable signal and launch the wizard: 

 

 Notice that six measurements are selected, the signal is 
Autoset to optimize the measurements, and the 
measurement results are tabulated and plotted: 

 

MSO/DPO5000 Series Procedure: 

 Move the probe tip to the 40 MHZ 
test point on the test board. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Press the front panel Autoset 
button. 

 Launch the DPOJET One-Touch 
Jitter Wizard application by 
selecting Analyze -> Jitter and 
Eye Analysis (DPOJET) -> 
Wizard -> One Touch Jitter. You 
can also do this with the keyboard 
shortcuts Alt-A, Alt-J, Alt-J. 
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Key Take Away Points 

 The automatically-generated plots at the top of the display 
look about like this: 

 

 The first automatic measurement in the measurement table 
is Time Interval Error (TIE). TIE is the difference in time 
between an edge in the waveform and the corresponding 
edge of a reference clock, (usually determined by a clock 
recovery process). In other words, TIE indicates how much 
the frequency of each single cycle is varying from the ideal 
frequency value. One way to easily visualize this variation 
is to plot the values as a histogram, as shown in the upper 
right plot. 

 

 The lower left plot is the spectrum of the TIE 
measurements: 

 

 The broad spectrum of values in this plot would indicate 
that some of the variation in frequency is fairly random 
(also suggested by the general bell-shaped histogram), but 
that there is a strong 10 MHz component to the frequency 
variation, too. In a debug situation, this might suggest that 
there is a cross-talk issue between this signal and a 10 
MHz signal that needs to be resolved. 

MSO/DPO5000 Series Procedure: 

 

 

 

 

 

 You can find more details about 
these measurements in the Help 
system. Select Help -> Help on 
Jitter and Eye Analysis, or Alt-H 
and Alt-T, and looking under the 
Algorithms topic. 
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Key Take Away Points 

 The upper left plot is the Eye Diagram. This display shows 
the eye opening for the signal. The pink dots indicate the 
location of the recovered clock signal. Since we are 
measuring a rising-edge clock signal, it is reassuring to find 
that the recovered clock is aligned with the rising edges of 
the waveform: 

 

 The second measurement in the measurement table is Eye 
Height. Eye Height is the measured minimum vertical eye 
opening at the center of the Unit Interval (UI). 

 The third measurement is called TJ@BER which stands for 
the Total Jitter at a specified Bit Error Rate. This value is a 
prediction of the total jitter on a signal based on the bathtub 
curve (shown in the lower right plot on the display), and 
may differ from the actual jitter measurement for a single 
acquisition. 

 

 The fourth and fifth measurements are Random Jitter (RJ) 
and Deterministic Jitter (DJ). These RJ and DJ values are 
determined for each acquisition. Since this signal is 
repetitive, the jitter analysis is based on the spectral 
analysis of the measurements. 

 Random Jitter is the RMS magnitude of all timing errors not 
exhibiting deterministic behavior. Random jitter shows up 
as the noise floor in the spectral display of timing 
measurements, as you saw in the TIE spectrum display 
above. 

 Deterministic Jitter is the peak-to-peak amplitude of all 
timing errors that follow deterministic behavior. An example 
of this is the 10 MHz component in the TIE spectrum 
display above, where that component clearly rose above 
the noise floor of the spectrum display. 

MSO/DPO5000 Series Procedure: 
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Key Take Away Points 

 The last lab section used a low-jitter clock signal, and the 
jitter measurements were not very dramatic. 

 If you do the same experiment with a modulated clock, you 
will find that the histogram of the TIE measurement is much 
more interesting: 

 

 As described in the introduction, this display clearly 
indicates Periodic Jitter, especially the histogram display. 

 You can zoom in on the individual graphs for further 
analysis, such as with the cursors: 

 

MSO/DPO5000 Series Procedure: 

 Move the probe tip to the 
FAST_FF_CLK test point on the 
test board. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Press the front panel Autoset 
button. 

 Launch the DPOJET One-Touch 
Jitter Wizard application by 
selecting Analyze -> Jitter and 
Eye Analysis (DPOJET) -> 
Wizard -> One Touch Jitter. You 
can also do this with the keyboard 
shortcuts Alt-A, Alt-J, Alt-J. 

 During the wizard’s Autoset 
process, it will increase the record 
length to increase the number of 
edges to measure. It is possible 
that it will continue to increase the 
record length until it hits the 
maximum value. If this happens, 
you will see a warning pop up. 
Don’t worry about it. It will go 
away and the routine will work 
correctly. 

 On certain signals, especially 
those with a lot of overshoot or 
ringing, it is also possible that the 
Autoset routine will not vertically 
scale the signal correctly and you 
will get an error message about 
the signal clipping and the 
accuracy of the jitter 
measurements may be 
compromised. 

 Click on the + sign next to the plot 
in the upper left corner of the 
display to expand it. 

 Click on the toolbar button with 
the red vertical cursors to make 
measurements on the plot. 

 When you are done, click on the - 
sign next to the plot to restore the 
display. 
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Key Take Away Points 

 You can also document the test results in a compliance 
report. Save and open the report. In the report, you will see 
details about the test setup, measurement results, and the 
plots of the measurements. 

 You can examine the details in the report, or you can 
examine the individual plots on the display in more detail. 

 

MSO/DPO5000 Series Procedure: 

 Press the Reports button at the 
left side of the control window. 

 Press the Save As button, 
navigate to the desired file 
location, and press the Save 
button. 
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Using the DPOJET Serial Data / Jitter Wizard 

Key Take Away Points 

 DPOJET provides a second wizard which gives the user 
more control of the testing, but still guides them through the 
few the steps necessary to make valid jitter and timing 
measurements.  

 The Serial Data / Jitter Wizard uses some basic information 
and then prompts you to assemble information about your 
signal, optimizes the horizontal and vertical settings, then 
defines a number of common measurements and plots. 

 Depending on how much you need to enter, you can select 
Next to move down to the next configuration detail; or press 
Finish to move forward and begin measurements. 

 Once the setups are complete, DPOJET sequences the 
scope acquisition system and analyzes the signal, 
displaying the results in statistical and graphical form.  

 The value is that the process is nearly automatic and 
requires very little jitter and measurement expertise, 
especially of complex topics like RJ/DJ, allowing better use 
of technical lab resources. 

 For the first usage of the Serial Data / Jitter Wizard, we’ll 
just use the default settings. The wizard interface looks like 
this: 

 

MSO/DPO5000 Series Procedure: 

 Move the probe tip to the 40 MHZ 
test point on the test board. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Press the front panel Autoset 
button. 

 Launch the DPOJET Serial Data / 
Jitter Wizard application by 
selecting Analyze -> Jitter and 
Eye Analysis (DPOJET) -> 
Serial Data/Jitter Wizard…. You 
can also do this with the keyboard 
shortcuts Alt-A, Alt-J, Alt-W. 

 

 

 

 

 

 

 Verify that Period and 
Frequency is selected. 

 Press the Next > button. 
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Key Take Away Points 

 By default, the analysis will be done on channel 1: 

 

 By default, the application will Autoset on the signal, and 
then automatically set the measurement reference levels: 

 

MSO/DPO5000 Series Procedure: 

 Because the measurements have 
already been selected, the 
interface jumps to the third 
selection, Select Source(s). 

 Verify that Channel 1 is selected. 

 Press the Next > button. 

 

 

 

 

 

 

 

 

 

 

 Press the Next > button. 
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Key Take Away Points 

 For the selected measurements, a default set of plots are 
selected: 

 

 By using all of the default settings, we easily get a 
consistent set of timing jitter measurements: 

 

 As expected, the time trend at the left and the histogram at 
the right both indicate that the period is consistently around 
25 ns (which is the period of a 40 MHz signal). 

 But we also notice that the measurements are moving a 
little, because the time trend is not a flat horizontal line and 
the histogram is not a single vertical line. 

MSO/DPO5000 Series Procedure: 

 By default, the application will plot 
the Time Trend, Spectrum, and 
Histogram of the Period 
measurement. 

 Press the Finish button. 
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Key Take Away Points 

 Let’s use the Serial Data / Jitter Wizard to analyze the 
signal with the TIE measurement: 

 

 As the histogram of the Time Interval Error (TIE) analysis 
fills in, notice that two clear bell curves have appeared: 

 

 This looks a lot like the Duty Cycle Dependent Jitter we 
discussed in the introduction. Let’s use DPOJET to verify 
our conclusions. 

MSO/DPO5000 Series Procedure: 

 Launch the DPOJET Serial Data / 
Jitter Wizard application again by 
selecting Analyze -> Jitter and 
Eye Analysis -> Serial 
Data/Jitter Wizard…. You can 
also do this with the keyboard 
shortcuts Alt-A, Alt-J, Alt-W. 

 Select Time Interval Error (TIE). 

 For simplicity, since we don’t plan 
to change any other settings for 
this simple demo, press the 
Finish button. 

 

 

 

 

 

 To accumulate the measurement 
results over multiple acquisitions, 
press the Run button. 

 Watch as the population of TIE 
measurements grows and the 
plots fill in. 
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Key Take Away Points 

 Let’s use DPOJET to measure the rise- and fall-times of 
the signal to see if we can verify that differences in the 
edge speeds is indeed contributing to the jitter. 

 

 Here is what the histograms of the rise- and fall-time 
measurements look like: 

 

 Notice that there is indeed a significant difference in the 
mean of the rise- and fall-time measurements on this 
signal. Although these timing differences would be difficult 
to easily or repeatably measure with standard oscilloscope 
measurement techniques, we were able to do them with 
only a few clicks of the mouse when using DPOJET. 

MSO/DPO5000 Series Procedure: 

 Press the Select button at the left 
side of the control window to 
select different measurements. 

 Press the Clear All button. 

 Press the Time tab to select the 
time-related measurements. 

 Press the Rise Time and Fall 
Time buttons to select them. 

 Press the Plots button to select 
the plots. 

 Click on the Rise Time1 
measurement in the table at the 
left of the control window. 

 Press the Histogram button. 

 Click on the Fall Time1 
measurement in the table at the 
left of the control window. 

 Press the Histogram button. 

 Press the Run button. 

 Watch as the population of rise- 
and fall-time measurements 
grows and the plots fill in. 
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Spread Spectrum Clock Verification with the DPOJET Serial Data / Jitter Wizard 

Key Take Away Points 

 A great application of the DPOJET Serial Data / Jitter 
Wizard is a simple measurement demo on the spread 
spectrum clock on the DPO Demo 3 board. The clock 
frequency is around 100 MHz, but is being purposely 
modulated to spread the spectral energy around – a 
popular design technique to improve electromagnetic 
compatibility. 

 

 After the application does a specialized autoset, it 
measures the period and frequency of every cycle in a 
single waveform: 

 

 The left graph shows that the period of the signal is 
ramping up and down at a very controlled rate, about 30 
kHz. The histogram in the graph at the right indicates that 
the period is consistently around 10 to 10.3 ns (which is the 
period of a 97 to 100 MHz signal). 

MSO/DPO5000 Series Procedure: 

 Move the probe tip to the 
SS_CLOCK test point on the 
DPO Demo 3 board. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Press the front panel Autoset 
button. 

 Launch the DPOJET Serial Data 
Jitter Wizard application by 
selecting Analyze -> Jitter and 
Eye Analysis (DPOJET) -> 
Serial Data/Jitter Wizard…. You 
can also do this with the keyboard 
shortcuts Alt-A, Alt-J, Alt-W. 

 For this analysis, we’re going to 
use all of the default settings for 
the wizard, so simply press the 
Finish button. 

 

 

 Notice the measurement values in 
the table in the lower half of the 
display. 

 With a single acquisition, 
DPOJET has made period and 
frequency measurements across 
thousands of cycles of the 
waveform, and provided all of the 
statistics for those 
measurements. 
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Digital Channel Parametric Measurements with DPOJET 

Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has many 
interesting digital clock and data signals which we can use 
for this lab. One of the most predictable groups of signals is 
the 7-bit counter output on J1006: 

 

 The DPO Demo 2 board (020-2924-XX) also has many 
interesting digital clock and data signals which we can use 
for this lab. One of the most predictable groups of signals is 
the 7-bit counter output on J924: 

 

DPO Demo Board Procedure: 

 Attach the P6616 digital probe to 
the input on the front of the 
oscilloscope. 

 Connect digital channel D0 (on 
probe Group 1) to the 
CNT_OUT_0 signal, being careful 
to attach the ground side of the 
digital probe to the adjacent GND 
pin on the connector. 

 Connect D1 to the CNT_OUT_1. 

 Connect D2 to the CNT_OUT_2. 

 Connect D3 to the CNT_OUT_3. 

 Connect D4 to the CNT_OUT_4. 

 Connect D5 to the CNT_OUT_5. 

 Connect D6 to the CNT_OUT_6. 

 Connect D7 to the CNT_CLK. 
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Key Take Away Points 

 The current version of the DPOJET application also 
supports advanced timing measurements on the digital 
channels of the MSO5000 Series. 

 

 The DPOJET application can measure the frequency (or 
any of the other timing parameters shown) of every cycle in 
a waveform: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Press the yellow channel 1 button 
to turn off channel 1. 

 Press the blue front panel D15-D0 
button. 

 Press the Turn D7-D0 On button. 

 Press the Trigger Menu button. 

 In the Source selector box, select 
D0-D7->D6. 

 Press the X in the upper right 
corner of the control window to 
close it. 

 Set the Horizontal Scale to  
10 µs/div. 

 Press the front panel Single 
button. 

 

 

 Launch the DPOJET application 
by selecting Analyze -> Jitter 
and Eye Analysis (DPOJET) -> 
Select…. You can also do this 
with the keyboard shortcuts Alt-A, 
Alt-J, Alt-S. 

 Press the Freq button to add the 
Freq1 frequency measurement. 

 Click on the Source button, click 
on the Digital tab of the selector, 
press the D0 button, and press 
the Close button. 
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Key Take Away Points 

 DPOJET can also make measurements on multiple signals: 

 

 With the press of the Single button, the application 
measures the frequency of every cycle in each of the 
selected waveforms: 

 

MSO/DPO5000 Series Procedure: 

 Press the Freq button to add the 
Freq2 frequency measurement. 

 Click on the Freq2 Source button, 
press the D1 button, and press 
the Close button. 

 Press the Freq button to add the 
Freq3 frequency measurement. 

 Click on the Freq3 Source button, 
press the D2 button, and press 
the Close button. 

 Press the Freq button to add the 
Freq4 frequency measurement. 

 Click on the Freq4 Source button, 
press the D3 button, and press 
the Close button. 

 Press the green Single button at 
the right side of the control 
window. 

 

 

 Notice the measurement values in 
the table in the lower half of the 
display. 

 With a single acquisition, 
DPOJET has made frequency 
measurements across many 
cycles of the four selected 
waveforms, and provided all of 
the statistics for those 
measurements. 
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MSO5000/DPO5000 Series 
SignalVu Lab 
 

 
 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.1.3 

and with SignalVu application (version ≥2.5.0089) installed 
One TPP0500 or TPP1000 Passive Probe 
Optional USB keyboard and mouse 
DPO Demo 3 board and dual-A-to-single-B USB cable (679-6506-XX and 174-5959-00) 
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Overview of Wideband Vector Signal Analysis 

SignalVu vector signal analysis software helps you easily validate wideband designs and characterize 
wideband spectral events. By combining the signal analysis software of the RSA Real-Time Spectrum 
Analyzer with that of the industry’s widest bandwidth digital oscilloscopes, designers can now evaluate 
complex signals without an external down converter. You get the functionality of a vector signal analyzer 
and spectrum analyzer combined with the powerful trigger capabilities of a digital oscilloscope — all in a 
single package. Whether your design validation needs include wideband radar, high data rate satellite links 
or frequency hopping communications, SignalVu vector signal analysis software can speed your time-to-
insight by showing you the time variant behavior of these wideband signals. 

Objectives 

- Obtain a basic understanding of SignalVu spectrum analysis. 

- Learn how to set up and demonstrate marker measurements on a spectrum analyzer display of a 
clock signal. 

- Learn how to easily make magnitude vs. frequency and frequency vs. time measurements on a 
spread spectrum clock signal. 
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MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 The DPO Demo 3 board (679-6506-XX) has a 40 MHz 
clock and a 100 MHz spread-spectrum SS_CLK signal 
which we will use for this lab. 

 

Demo Board Procedure 

 Attach the two host connectors on 
the USB cable to the oscilloscope 
and then connect the device 
connector on the cable to the 
demo board. 

 Verify the power LED is lit. 

 Attach a passive probe to the 
Channel 1 input of the 
oscilloscope. 

 Attach the probe ground to the 
GND test point on the test board. 

 Connect the probe tip to the 
40_MHz test point on the test 
board. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

Key Take Away Points 

 The SignalVu application provides vector signal analysis 
software and spectrum analysis capabilities for Windows-
based real-time oscilloscopes such as the MSO/DPO5000 
Series. 

 SignalVu Essentials provides the basic RF measurement 
capabilities. Additional wideband RF analysis tools are also 
available, such as SVM Modulation Analysis, SVP Pulse 
Measurements, and SVT Setting Time Measurements. 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the SVE: SignalVu 
Essentials option is installed. 

 See if options SVM, SVP, and 
SVT are also installed. 

 Press the OK button. 
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One-Time SignalVu Setup for Oscilloscopes 

Key Take Away Points 

 First, as a one-time setup activity, we need to disable 
SignalVu from over-riding the oscilloscope settings. 
SignalVu’s defaults are optimized for RF signals at 50Ω 
impedance levels, not general-purpose scope settings and 
high-impedance probes. 

 

 Now we need to optimize the oscilloscope’s acquisition of 
the signal. To get the best signal-to-noise ratio 
performance, you want to scale and position the signal so it 
fills most of the screen vertically. Signal Vu has already set 
the sample rate to the maximum real-time sample rate of 
the oscilloscope. To improve the time-resolution (and 
therefore the frequency resolution), increase the record 
length significantly: 

 

MSO/DPO5000 Series Procedure: 

 Select Analyze->SignalVu 
Vector Signal Analysis 
Software to launch the SignalVu 
application. 

 Press the blue Preset button at 
the top of the display to restore 
the SignalVu application to a 
known starting point. 

 Select Setup->Acquire or press 
the Acquire button. 

 

 Click on the Scope settings tab 
and remove the check marks next 
to Sample Rate, Other 
acquisition/horizontal settings 
and Vertical settings, and 
Trigger Position. 

 Minimize the SignalVu 
application. 

 Adjust the Vertical Scale and 
Position so the signal fills about 
80% of the display. 

 Notice that SignalVu has already 
set the Sample Rate to 10 GS/s. 

 Set the Horizontal Scale to 
10µs/div. Notice that this also 
sets the Record Length to 1 
Mpoints. 
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SignalVu Spectrum Analysis Measurements 

Key Take Away Points 

 We know that the signal is nominally a 40 MHz clock, so 
we set the center frequency to 100 MHz so we can easily 
see the 40 MHz fundamental and the first few harmonics: 

 

 Notice the horizontal Center Frequency and Span readouts 
just below the display. 

 Also notice the vertical Scale, Position, and Resolution 
Bandwidth readouts at the upper left side of the display: 

 

MSO/DPO5000 Series Procedure: 

 Maximize the SignalVu 
application. One way to do this is 
to use the keyboard’s Alt-Tab to 
select the application. 

 Select Setup->Settings 

. 

 Click on the Freq & Span tab. 

 Click on the Center: text box and 
set the value to 100 MHz. You 
can also edit this value directly in 
the CF text box at the lower left 
corner of the graticule. 

 Press the Autoscale button at the 
left side of the display to 
automatically scale the display 
vertically. 

 Click on the Scale tab. 

 Notice that the Vertical Scale is 
set to 100.00 dB. This 
corresponds to 10 dB/div. You 
can also edit this value directly in 
the dB/div text box at the upper 
left corner of the graticule. 

 

 

 

 

 

 

 

 Click on the red X in the upper 
right corner of the control window. 
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Key Take Away Points 

 We can easily make magnitude and frequency 
measurements on the SignalVu spectrum display by 
turning on markers: 

 

 By turning on a pair of markers, we can make relative 
magnitude and frequency between the two markers: 

 

MSO/DPO5000 Series Procedure: 

 Right click on the graticule and 
select Marker to peak. Notice 
that a square reference marker 
(MR) is positioned on the highest 
peak of the spectrum, probably at 
the left side of the display (DC). 

 Left click on the marker and drag 
it horizontally. Position the marker 
on the first peak to the right of DC 
(the clock’s fundamental 
frequency at about 40 MHz). 

 Also, notice that the Markers 
control window is displayed at the 
bottom of the display. 

 Press the Define button. 

 Click on the Define Peaks tab. 

 Set the Peak Threshold value to 
-30 dBm. This defines peaks as 
those signals which exceed the  
-30 dBm level. 

 Verify that the Minimum 
Excursion value is 6 dB. This 
specifies how much the signal 
must decrease and then increase 
before another peak can be 
declared. 

 Press the Add button at the left 
side of the control window to add 
a second marker. 

 Click the right and left arrow 
buttons to automatically move the 
second marker (M1) between 
peaks. 

 Notice the readout in the upper 
right corner of the graticule which 
shows the relative magnitude and 
frequency between the two 
markers. 
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Key Take Away Points 

 SignalVu also provides a tabular display of marker 
measurements: 

 

 The table display can be used to show multiple absolute 
and relative magnitude and frequency measurements: 

 

MSO/DPO5000 Series Procedure: 

 Press the Table button at the 
bottom of the display. 

 

 

 

 

 

 

 

 

 

 

 

 

 Right click on the graticule and 
select Add marker. Notice that a 
square marker (M2) has been 
added at the center of the display. 

 Using the right and left arrow 
buttons, position marker M2 on 
another peak. 

 Notice the absolute and relative 
magnitude and frequency readout 
in the table. 

 Also notice the readout in the 
upper right corner of the graticule. 
Since marker M2 is the selected 
marker, the readout shows the 
relative magnitude and frequency 
between markers M2 and MR. 

 

 

 When you are done, right click on 
the graticule and select All 
markers off. 

 Click on the red X in the upper 
right corner of the control window. 
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Analyzing Spread Spectrum Clock Signal 

Key Take Away Points 

 This is the SignalVu spectrum analyzer display of the 100 
MHz spread spectrum clock signal: 

 

 The side-to-side motion of the spectrum indicates that the 
spectrum length may be less than the period of the 
frequency modulation. 

 By increasing the spectrum length, we see the flat 
spectrum we saw in the DPOJET lab, indicating that the 
frequency is being swept between about 97 and 100 MHz: 

 

MSO/DPO5000 Series Procedure: 

 Minimize the SignalVu 
application. 

 Move the probe tip to the 
SS_CLOCK test point on the test 
board. 

 Adjust the Vertical Scale and 
Position so the signal fills about 
80% of the display. 

 Set the Horizontal Scale to 
50µs/div. Notice that this also 
sets the Record Length to 5 
Mpoints. 

 Press the keyboard’s Alt-Tab to 
maximize the SignalVu 
application. 

 Click on the Span readout in the 
lower right corner of the display 
and type in “10M” to set the span 
to 10 MHz. 

 Click on Setup->Analysis. 

 

 Click on the Spectrum Time tab. 

 Notice that the Spectrum Length 
is only about 22 µs of time. The 
side-to-side motion of the 
spectrum indicates that the 
spectrum length may be less than 
the period of the frequency 
modulation. 

 Deselect the Auto check box next 
to Spectrum Length. 

 Double-click on the Spectrum 
Length text box and set the value 
to 200.000 us. 

 Press the AutoScale button at 
the left side of the display. 
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Key Take Away Points 

 Notice how the SignalVu displays of Frequency vs. Time 
and Magnitude vs. Frequency: 

 

 Compare these to the corresponding plots in the DPOJET 
lab: 

 

 In this lab section, we easily analyzed the spread spectrum 
clock signal and verified that this is the same triangular 
modulation we saw in the DPOJET lab. (Note that the 
default histogram plot in DPOJET is of period 
measurements, the reciprocal of the frequency displayed 
with SignalVu, but the shapes are similar.) 

MSO/DPO5000 Series Procedure: 

 Click on Setup->Displays. 

 

 Double-click on the Frequency 
vs Time icon and press OK. 

 Click on Setup->Analysis. 

 

 Click on the Analysis Time tab. 

 Notice that the Freq vs Time 
display is showing only about 5 
µs of time. 

 Deselect the Auto check box next 
to Analysis Length. 

 Set the Analysis Length to 
200.000 us. 

 Press the AutoScale button in 
the Frequency vs Time display. 
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TEK-DPG 
Deskew Pulse Generator 
Application Lab 

Minimizing Skew in Power Measurements 
 

 
 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.1.1 
One TEK-DPG Deskew Pulse Generator 
One 067-1686-00 Power Measurement Deskew and Calibration Fixture 
One TDP0500 or TDP1000 Differential Probe 
One TCP0030 Current Probe 
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The Importance of Probe Deskew for Power Measurements 

Introduction 

When engineers are making critical high-speed timing measurements between channels, they usually 
recognize the need to carefully match the delays through their probes. This may be simplified by using the 
same kind of probes whenever possible. The actual skew can be verified by connecting all of the probes to a 
common signal source, even the PROBE COMP signal on the front of the oscilloscope and verifying that the 
timing of all of the waveforms is matched. 

But why is probe skew a concern for low-speed applications such as power measurements? First, even if 
the power supply’s switching frequency is below 1 MHz, the rise-times of the switching waveforms may be 
on the order of 1 ns. Second, the phase relationships between voltages and currents in a switching device 
are very critical in determining the amount of power instantaneously dissipated in the switching device. 

The 067-1686-00 Power Measurement Deskew and 
Calibration Fixture 

The 067-1686-00 fixture converts a pulse signal into a set of 
test point connections. These connections provide you with a 
convenient way to compensate for timing differences between 
voltage and current probes and the signal paths within the 
oscilloscope. 

This fixture can be used with a variety of passive, active, 
differential, and current probes. In this lab, we will concentrate 
on some of the most common power probes used with the 
DPO5000 and MSO5000 Series products. Please refer to the 
067-1686-00 Instructions on www.tek.com for more 
information about other supported probes. 

 

The TEK-DPG Deskew Pulse Generator 

The TEK-DPG Deskew Pulse Generator is a signal-generating accessory for select Tektronix oscilloscopes 
that feature the TekVPI interface. 

 

- In this lab, we will use the TEK-DPG and the 067-1686-00 to manually optimize power probe 
deskew. We will also demonstrate the measurement errors that can occur because of probe skew. 

http://www.tek.com/
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Manual Deskew Procedure for Power Probes with the MSO/DPO5000 Series 

Oscilloscope Setup Procedure: 

 Plug in and turn on the oscilloscope. 

 Press the front panel Default Setup button to set the oscilloscope to a known state. 

 Connect the TDP1000 or TDP0500 differential probe to channel 1. 

 Press the front panel 2 button to display channel 2. 

 Connect the TCP0030 current probe to channel 2. (Notice that the vertical readout automatically shows 
the correct units of Amperes.) 

 Connect the TEK-DPG to channel 3. 

 Press the front panel 3 button to display the trigger signal on channel 3. 

 Connect the TEK-DPG’s BNC connector to Port A on the deskew fixture. 

 NOTE: For best results, warm up the equipment for 20 minutes before making critical adjustments. 
 

Key Take Away Points 

 TDP0500 / TDP1000 and TCP0030 connections: 

 

Test Procedure: 

 Short the TDP0500 or TDP1000 
probe tips together. 

 Press the Menu button on the 
TDP probe. 

 Make sure that the Range is set 
to 4.25 V. If necessary, change 
the mode to Manual. 

 Press the AutoZero side bezel 
button to remove any DC offsets 
from the probe and channel input. 

 Connect the TDP probe to the 
long square pins on the deskew 
fixture as shown at the left, with 
the – input to ground. 

 Press the Menu button on the 
TCP0030 current probe. 

 Select the 5A range, either by 
pressing the Range button on the 
probe or the side bezel button on 
the oscilloscope until the 5A 
range is selected. 

 Make sure that the current 
probe’s jaw is closed. 

 Press the Degauss AutoZero 
button on the probe. 

 Connect the TCP0030 probe to 
the deskew fixture as shown at 
the left. 
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Key Take Away Points 

 To more precisely set the propagation delays, let’s see how 
to use the TEK-DPG and deskew fixture with these probes. 

 Controls and readouts on the TEK-DPG: 

 

Test Procedure: 

 Notice the interface of the TEK-
DPG. 

 The Status LED glows amber at 
power-on to indicate the 
generator is on and the output at 
the BNC cable is not enabled. 

 Press the Mode button until the 
3

rd
 green Mode LED (±1Vpk-pk 1 

MHz signal with <1 ns risetime) is 
lit. 

 Press the Output Enable button 
and notice that the Status LED is 
now green. If the LED glows red, 
disconnect and reconnect the 
generator to clear the fault that 
may have occurred. 

Key Take Away Points 

 The TEK-DPG and deskew test fixture provide a very 
simple and convenient way to provide a timing signal to 
multiple probes at a time: 

 

 Notice that the skew between channels in the screen shot 
above is about 10 ns. 

MSO/DPO5000 Series Procedure: 

 Set the channel 1 Vertical Scale 
to about 500 mV/div. 

 Set the channel 2 Vertical Scale 
to about 50 mA/div. 

 Set the channel 3 Vertical Scale 
to about 1 V/div. 

 Set the Horizontal Scale to 10 
ns/div. 

 Select Trig->Edge Setup…. 

 Since the signal from the TEK-
DPG is the timing reference for 
deskewing the probes, we will 
select it as the trigger source. 
Press the right arrow in the 
Source selection text box and 
select Ch3. 

 Set the Trigger Level to about 1V. 
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Key Take Away Points 

 For some low-frequency applications, adequate 
measurement performance can be achieved simply by 
ignoring the differing propagation delays of the probes. 

 And, the propagation delays between probes tend to be 
fairly small, when all of the probes are the same model. 

 However, for most high-speed applications and whenever 
you use a combination of different probes, it is very 
important to correctly account for these timing differences. 

 Using the TEK-DPG signal as the timing reference, and 
deskew test fixture provide a very simple and convenient 
way to manually remove skew between channels. First, we 
align channel 1 to the signal source: 

 

 Next we align channel 2 to the signal source: 

 

MSO/DPO5000 Series Procedure: 

 

 

 

 

 

 

 

 

 Select Vertical->Deskew…. 

 Click on the Ch1 Deskew Time 
text box to attach the 
Multipurpose a control. 

 Adjust the Multipurpose a control 
until the falling edge of the 
channel 1 signal is centered in the 
graticule. 

 Notice that the DS icon appears 
next to the channel 1 vertical 
readout, indicating that deskew is 
in use. 

 

 

 

 

 Press the Channels 2 button in 
the control window. 

 Adjust the Multipurpose a control 
until the falling edge of the 
channel 2 signal is centered in the 
graticule. 

 Notice that the DS icon also 
appears next to the channel 2 
vertical readout, indicating that 
deskew is in use. 
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Key Take Away Points 

 So why is proper deskew important for low-frequency 
power measurements? 

 Consider that a typical power measurement is made by 
measuring the voltage across a power switching device 
(like with the differential probe on channel 1) and the 
current flowing through the switching device (like with the 
current probe on channel 2) and multiplying the waveforms 
together to get the instantaneous power, as shown below. 

 The voltage across and the current flowing through a 
typical switching device are square waves that are 180 
degrees out of phase. To simulate this, we will use the 
higher-frequency deskew pulse signal and invert the 
channel 1 signal. 

 With properly deskewed probes, when the math multiply 
waveform is calculated, we would expect that a positive 
signal times a negative signal would result in a negative 
product, which it does in the display below. 

 Notice that the math product of the two waveforms is zero 
at the point where the two signals are both crossing 
through zero volts: 

 

Test Procedure: 

 Reverse the TDP0500 / TDP1000 
connection on the deskew test 
fixture, such that the + input is 
connected to ground and the – 
input is connected to the signal. 

 Select Math->Ch1 * Ch2. 
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Key Take Away Points 

 However, when the probes are not properly deskewed, 
notice that the product becomes positive during the 
transitions when the signals are both negative: 

 

 Notice that the product also becomes positive during the 
transitions when the signals are both positive: 

 

 Notice the substantial change in shape and amplitude of 
the math waveform. As you can see from this very simple 
example, it is critical to properly deskew your probes to 
make accurate timing measurements, or measurements 
such as power which are very sensitive to timing errors. 

 Also, remember that timing errors in YT displays 
correspond to phase errors in XY displays. For example, 
when looking at a 10 MHz signal, a deskew error of only 1 
ns results in a 3.6 degree error. 

Test Procedure: 

 Select Vertical->Deskew…. 

 Press the Channels 2 button in 
the control window. 

 Click on the Ch2 Deskew Time 
text box to attach the 
Multipurpose a control. 

 Turn the Multipurpose a control 
clockwise to increase the value of 
the channel 2 deskew. 

 Notice that the peak value of the 
math product becomes positive as 
the signals cross at a negative 
voltage. 

 

 

 

 

 Turn the Multipurpose a control 
counter-clockwise to decrease the 
value of the channel 2 deskew. 

 Notice that the peak value of the 
math product also becomes 
positive as the signals cross at a 
positive voltage. 

 

 

 

 

 

 

 

 

 Double-click on the Ch2 Deskew 
Time text box to display the pop-
up keypad. 

 Click on the Max button and then 
click on the Min button. Notice 
that the total available deskew 
range is ±75 ns. 
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MSO5000/DPO5000 Series 
Power Measurements Lab 

 

 

 
Equipment List 
One MSO/DPO5000 Series oscilloscope with software version ≥6.1.1 

and with the DPOPWR application (version ≥1.0.10) installed 
Optional USB keyboard and mouse 
One TPP0500 or TPP1000 Passive Probe 
One TDP0500 or TDP1000 Differential Probe 
One TCP0030 Current Probe 
One 878-0544-XX power demo board or 3PQS power demo board, and 12VAC power adapter 
[Note: screen shots in this document were made with 878-0544-XX demo board] 
 
For the optional power efficiency section, the following additional equipment is needed: 

Another TDP0500 or TDP1000 Differential Probe 
Another TCP0030 Current Probe 
An external power supply accessory (Tek Part Number 119-7465-xx). 
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Overview of Automatic Power Measurements 

The DPOPWR application module enables consistent, automatic measurements of most common power 
supply measurements, including: 

 Power Device Measurements 
o Switching Loss, which provides a table of measurements and measurement statistics for the 

losses across each acquired waveform, including: 
 Turn-on, Turn-off, and Total Power Loss 
 Turn-on, Turn-off, and Total Energy Loss 

o Hi-Power Finder 
o Safe Operating Area (SOA), which includes: 

 an X-Y display of the switching device voltage and current 
 mask testing of the signals relative to a graphical description of the device 

specification limits 
o dv/dt and di/dt Measurements, 

 a slew rate measurement, added to the cursor readout, between the cursors on the 
selected waveform 

o RDS(on) 
o Modulation Analysis, which generates a graphical display of the specified measurement 

values across the acquired waveform, showing the variations in the modulated switching 
signal 

 Pulse Width 
 Duty Cycle 
 Period 
 Frequency 

 Magnetics Measurements 
o Inductance 
o Magnetic Property 
o Magnetic Loss 
o I vs. ∫V 

 Report Generator 
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 Input/Output Analysis 
o Power Quality, which provides a single table of measurements and measurement statistics 

for the AC input section of a power conversion circuit, including: 
 the RMS voltage and current 
 true power (P), the actual power delivered 

to the resistive part of the load, measured in 
Watts. It is also VRMS * IRMS * cos(φ) 

 apparent power (S), the product of the RMS 
voltage and current (mathematically, the 
absolute value of the vector sum of the true 
and reactive power), measured in Volt-
Amperes or VA 

 voltage and current crest factors, which are 
the peak-to-RMS ratios for the signals 

 frequency 
 power factor, the ratio of true power to 

apparent power. (If the signals are pure sine 
waves, the power factor is the cosine of the phase angle between the current and 
voltage waveforms.) 

 NOTE: reactive power and phase angle are not explicitly measured and displayed 
by DPOPWR, but can be easily derived from the other measurement results. 

 reactive power (Q), the power delivered to and temporarily stored in the 
reactive (inductive or capacitive) elements of the load, measured in Volt-
Amperes Reactive or VAR 

 phase angle (φ), which is the angle between the real and apparent power 
vectors, equal to the impedance phase angle 

o Current Harmonics, which provide a frequency-domain view of the AC input and pre-
compliance to the following standards: 

 IEC 61000-3-2 
 IEC 61000-3-2 with AM14 
 MIL-STD-1399 

o Total Power Quality, which provides Power Quality and Current Harmonics measurements 
in a single display. 

o Line Ripple 
o Switching Ripple 
o Spectral Analysis 
o Turn On Time 

In this lab, we will go through each of these measurement areas, starting with the input circuitry, going 
through the switching circuit, and finally measuring the output circuitry. This lab is based on the 878-0544-
XX power demo board. However, similar steps can be used to make these measurements on another power 
demo board or a power supply circuit. (Be sure to use probes with appropriate maximum ratings.) 

There is a lot of information about the DPOPWR application available through the MSO/DPO5000 Help 
system. Select Help -> Help on Power Analysis. 

 

Objectives 

- Obtain a basic understanding of power measurements. 

- Learn how to use oscilloscopes to measure power supply parameters. 

- Learn how to set up and demonstrate power supply measurements with an MSO/DPO5000 Series 
oscilloscope. 

Apparent 

power (S) 

True power (P) 

Reactive 

power (Q) 

Phase  

angle (φ) 
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MSO/DPO5000 Series Lab Setup 

Key Take Away Points 

 With the optional DPOPWR application installed, the 
MSO/DPO5000 Series oscilloscope can make a variety of 
automatic power measurements. 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Select Help -> About 
TekScope…. 

 Verify that the optional DPOPWR: 
Power Measurement and 
Analysis Software application is 
installed. 

 Press the OK button. 

 

Key Take Away Points 

 The 3PQS Power Demo board has a variety of power 
signals which we can use for this lab. However, this demo 
board does not support some measurements such as the 
magnetics measurements. 

 

 

 The switching device on the 3PQS Power Demo board is 
an Insulated Gate Bipolar Transistor (IGBT) and has a 
VCEsat of about 1.8V. 

3PQS Power Demo Board 
Procedure: 

 Connect the 12VAC power 
adapter to the demo board and 
plug it in. NOTE: This must be an 
AC-output adapter. A normal DC-
output adapter will not work. 

 NOTE: Most voltages on this 
power demo board are not 
referenced to ground. Do not use 
standard passive probes and do 
not connect probe grounds on this 
board. Instead, use the 
recommended differential and 
current probes. 

 NOTE: No voltage potential on 
the board exceeds 30 Volts. 
However, some of the 
components on this board do get 
very warm. 
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Key Take Away Points 

 The 878-0544-XX Power Demo board is the preferred 
demo took and has a variety of power signals which we can 
use for this lab: 

 

878-0544-XX Power Demo Board 
Procedure: 

 Connect the 12VAC power 
adapter to the demo board and 
plug it in. NOTE: This must be an 
AC-output adapter. A normal DC-
output adapter will not work. 

 NOTE: Most voltages on this 
power demo board are not 
referenced to ground. Do not use 
standard passive probes and do 
not connect probe grounds on this 
board. Instead, use the 
recommended differential and 
current probes. 

 NOTE: No voltage potential on 
the board exceeds 30 Volts. 
However, some of the 
components on this board do get 
very warm. 
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Key Take Away Points 

 The 878-0544-XX Power Demo board combines most of 
the features of two previous power demo boards, the 3PQS 
board (which was introduced with the TPS2000 Series 
oscilloscopes) and the PQS board (which was introduced 
with the TDSPWR power measurement application. 

 When SW1 is in the left position, the board functions much 
like the 3PQS board. The simplified schematic looks like 
this: 

 

 The switching device on the 878-0544-XX Power Demo 

board is a MOSFET and has an RDSon of about 26m. 

 When SW1 is in the right position, the board functions 
much like the PQS board. The simplified schematic looks 
like this: 

 

878-0544-XX Power Demo Board 
Procedure: 
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Key Take Away Points 

 To demonstrate power quality measurements, this section 
of the lab measures the input voltage and current to the 
demo board. 

 

 The display should look about like this: 

 

 For simple and good quality high-voltage and current 
measurements, let the oscilloscope automatically choose 
the probe attenuation ranges. However, to optimize the 
performance (such as improving signal-to-noise ratio of the 
current measurement, in this case), it is better to choose 
manual probe range selection and set the range so the 
signal fills most of the probe range. For example, in this 
case, the current is less than 1 Amp, so the measurement 
quality in the 5 Amp range will be better than if the 30 Amp 
range is used. 

MSO/DPO5000 Series Procedure: 

 On the demo board, move SW1 
to the left position. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Connect a TDP0500 or TDP1000 
differential probe to channel 1 of 
the oscilloscope. 

 Press the Menu button on the 
probe’s comp box. 

 In the Range section of the 
control window, select Manual. 

 Make sure that the Range is set 
to 42V. 

 Connect the + and – inputs. 

 Press the AutoZero button. 

 Connect the - input of the 
differential probe to the GND test 
point. 

 Connect the + input of the 
differential probe to the AC High 
test point. 

 Set the Horizontal Scale to 
5ms/div. 

 Press the front panel 2 button to 
turn on channel 2. 

 Connect a TCP0030 current 
probe to channel 2 on the 
oscilloscope. 

 Press the Menu button on the 
probe’s comp box. 

 In the Range section of the 
control window, select Manual. 

 Set the Range to 5A. 

 Make sure that the current 
probe’s jaw is closed. Press the 
Degauss AutoZero button on the 
probe. 

 Connect the current probe around 
the AC_CURRENT current loop 
and close the probe jaws. 

 Scale and position the signals as 
shown at the left. 
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Key Take Away Points 

 The display should look about like this: 

 
 

MSO/DPO5000 Series Procedure: 

 In this case, the voltage and 
current waveforms are in phase. If 
the phase of channel 2 signal is 
opposite of the channel 1 signal, 
remove the current probe, turn it 
over, and reconnect it. 

 Select Horiz/Acq->Resolution… 
or Horiz/Acq-
>Horizontal/Acquisition 
Setup…. 

 Set the Sample Rate to 20 MS/s. 
This will set the record length to 
1M points. 
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Power Probe Deskew 

Key Take Away Points 

 To make accurate power measurements, it is important to 
deskew the probes. This operation matching the 
propagation delays of the signals through the power 
probes. For most power measurements, it is adequate to 
use nominal deskew values, which can be manually 
selected from a long list of supported probes: 

 

 For this lab, the display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Select Analyze -> Power 
Analysis -> Deskew. 

 Press the Static tab near the left 
side of the control window. 

 In the From section of the control 
window, press the down arrow on 
the Probe drop-down box and 
select the appropriate probe (for 
example, TDP1000). 

 In the To section of the control 
window, press the down arrow on 
the Probe drop-down box and 
select the appropriate probe (for 
example, TCP0030). 

 Press the Single button at the 
right side of the control window to 
set the static deskew values. 

 Notice that the vertical readout 
section indicates that the deskew 
operation has been completed. 
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Power Quality Measurements 

Key Take Away Points 

 With the Power Quality measurements enabled, the display 
should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Select Analyze -> Power 
Analysis -> Select. 

 Press the Input/Output Analysis 
tab near the left side of the 
control window. 

 Press the Power Quality button. 

 Notice that the Sources text box 
shows that the voltage is on 
channel 1 and the current is on 
channel 2. 

 Press the Configure button on 
the left side of the control window. 

 Notice that the power waveform 
will appear in Math 1 and the 
energy waveform will appear in 
Math 2. 

 Press the Single button on the 
right side of the control window. 
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Current Harmonics Measurements 

The DPOPWR application makes current harmonics pre-compliance measurements according to three 
standards: IEC 61000-3-2, IEC 61000-3-2 with AM14, and MIL-STD-1399. 

IEC-61000-3-2 Pre-compliance 

IEC 61000-3-2 is a standard that defines permitted harmonic-current limits. It categorizes equipment into 
four classes (A, B, C and D) and imposes different harmonic-current limits on each class. It also defines 
cases where no limits apply. The standard was initially released in 1995, and then substantially revised in 
2000, and again in 2006. 

Equipment Examples: 
Class A: 

 Balanced 3-phase equipment 

 Household appliances (not in Class D) 

 Non-portable tools 

 Dimmers 

 Audio equipment 
Class B: 

 Portable Tools 

 Arc Welding 
Class C: 

 Lighting 

 Incandescent lighting with dimmers (Power > 25 W) use Table1 

 Lighting equipment (Power > 25 W) use Table2 

 Lighting ≤ 25 W use Table3 
Class D: (Input power P ≤ 600 W) 

 PC 

 Monitors 

 TV Receivers 

Input current harmonic levels are checked using both the average and maximum values over the whole test 
interval. Any harmonic is allowed to fluctuate up to a maximum of 150% of its limit, provided that its average 
value is below 100% of the limit. 

In addition, some trade-off between harmonics is allowed for odd harmonics ranging from 21 to 39, based 
on a value called the Partial Odd Harmonic Current (POHC), which is the RMS sum of all the odd harmonics 
between 21 and 39. This RMS sum is compared to the Partial Odd Harmonic Limit (POHL), which is the 
RMS sum of the limits for the same set of harmonics. If the actual POHC is less than the POHL, then the 
average value of any individual harmonic in this group may exceed 100% of its limit, again provided that no 
individual measurement exceeds 150% of the limit throughout the test. Obviously one or more of the other 
harmonics must be correspondingly less than 100% of its limit - otherwise the POHC will not be less than 
100% of the POHL. 
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Key Take Away Points 

 To demonstrate harmonics measurements, this section of 
the lab measures the input voltage and current to the demo 
board, as with the power quality measurements. 

 The current harmonics can be measured according to three 
different industry standards. For simplicity in this demo, we 
will use the default IEC 61000-3-2 standard. 

 

 With the Harmonics measurements enabled, the graphical 
display should look about like this: 

 

 The harmonics can also be displayed in table format. 

MSO/DPO5000 Series Procedure: 

 NOTE: This section of the lab 
continues with the oscilloscope 
setup from the previous section. 

 Press the Select tab on the left 
side of the control window. 

 Press the Current Harmonics 
button. 

 Press the Configure tab on the 
left side of the control window. 

 Verify that the 61000-3-2 
Standard Type is selected. 

 In the Line Frequency section, 
press the appropriate button for 
the local AC power. 

 Press the Single button on the 
right side of the control window. 

 

 

 

 

 

 You can display the current 
harmonic measurements in table 
or graph form. Press the Graph 
button. 
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MIL-STD-1399 Pre-compliance 

MIL-STD-1399 establishes electrical interface characteristics for shipboard equipment utilizing AC electric 
power to ensure compatibility between user equipment and the electric power system. The main types of 
shipboard electric power to be supplied from the electric power system are as follows: 

 Type I – 440V or 115V, 60 Hz ungrounded (the standard shipboard electric power source). 

 Type II – 440V or 115V, 400 Hz ungrounded (limited application). 

 Type III – 440V or 115V, 400 Hz ungrounded, with tighter tolerances than types I and II (restricted 
use). 

The input current waveform for all types must not cause single harmonic line currents to be generated that 
are greater than 3% of the unit's full rated load fundamental current between the 2

nd
 and 32

nd
 harmonic. 



 

MSO5000 / DPO5000 Lab Exercise Book 

Version 1.1   5/11/2012 48W-26279-3   345 of 394 

 

Key Take Away Points 

 The MIL-STD-1399 harmonics measurements enabled, the 
display should look about like this: 

 

 The harmonics measurements can also be displayed in 
table format: 

 

 In this case, notice that the third harmonic violates the limit 
for that frequency and is clearly shown in red. 

MSO/DPO5000 Series Procedure: 

 NOTE: This section of the lab 
continues with the oscilloscope 
setup from the previous section. 

 Press the Configure tab on the 
left side of the control window. 

 Select the MIL 1399 Standard 
Type. 

 In the Line Frequency section, 
press the appropriate button for 
the local AC power. 

 The next control to the right 
allows you to analyze either 50 or 
100 harmonics. For simplicity, you 
can use the default value of 50. 

 Press the Single button on the 
right side of the control window. 

 

 

 You can display the current 
harmonic measurements in table 
or graph form. Press the Graph 
button. 

 



 

MSO5000 / DPO5000 Lab Exercise Book 

Version 1.1   5/11/2012 48W-26279-3   346 of 394 

 

Total Power Quality Measurements 

Key Take Away Points 

 The DPOPWR application also provides a single 
measurement set which includes input power 
measurements and current harmonics results in a single 
display. Again, for simplicity in this demo, we will use the 
default IEC 61000-3-2 standard for the harmonics 
measurements: 

 

 The graphical display of the harmonics in the Total Power 
Quality measurements should look about like this: 

 

 The harmonics can also be displayed in table format. 

MSO/DPO5000 Series Procedure: 

 NOTE: This section of the lab 
continues with the oscilloscope 
setup from the previous section. 

 Press the Select tab on the left 
side of the control window. 

 Press the Total Power Quality 
button. 

 Press the Configure tab on the 
left side of the control window. 

 Verify that the 61000-3-2 
Standard Type is selected. 

 In the Line Frequency section, 
press the appropriate button for 
the local AC power. 

 Press the Single button on the 
right side of the control window. 

 

 

 

 

 

 Notice that the power quality 
measurements have been added 
to the table in the upper right 
corner of the display. 

 You can display the current 
harmonic measurements in table 
or graph form. Press the Graph 
button. 

 

 

 

 

 

 

 When you are done, press the X 
in the upper right corner to close 
the results display. 
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DPOPWR Report Generator 

Key Take Away Points 

 The DPOPWR application also provides a built-in report 
generator for documenting your test results. As an example 
of its use, you will use the report generator to document the 
Total Power Quality measurements you just made. 

 The Define Test Template control window looks like this: 

 

 The Define Report Layout control window looks like this 

 

MSO/DPO5000 Series Procedure: 

 NOTE: This section of the lab 
continues with the oscilloscope 
setup from the previous section. 

 Press the Report tab on the left 
side of the control window. 

 The first tab in the control window 
is the Define Test Template. 
This tab allows you to specify the 
document template, including the 
screen shots and measurement 
values you want to include in your 
report. You can view the template 
by pressing the Edit Template 
button. Click on the X in the upper 
right corner when you are done. 

 

 

 

 

 

 

 Press the Define Report Layout 
tab near the left side of the 
control window. This tab allows 
you to specify the document 
layout template. Each page of the 
report is assigned a title and a 
test template file. You can view 
the template by pressing the Edit 
Layout button. Click on the X in 
the upper right corner when you 
are done. 
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Key Take Away Points 

 The first page of the Total Power Quality report should look 
about like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the Generate Report tab 
near the left side of the control 
window. This tab allows you to 
generate, view, and print the 
report. 

 Press the Generat… button. 

 In the case of the Total Power 
Quality measurement, there are 
four pages in the default report. In 
this case, the summary is on 
page 1, so select it. Double-click 
on Total_Power_Quality_Page1. 

 From this control window, you can 
save or print this file, or export it 
in RTF format. 
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Inrush Current and I
2
t Measurements 

Key Take Away Points 

 Before leaving the topic of power measurements on the 
input section of a power supply, we should mention inrush 
current measurements. Although these measurements are 
not made with features of the power application, some 
engineers will want to make the measurements. 

 The instantaneous peak inrush current can be easily 
measured with the standard automatic measurements such 
as Max, as shown at the lower left side of the display: 

 

 The instantaneous inrush current is often measured to 
verify that the power supply’s input capacitor’s charging 
current does not exceed the maximum current rating for the 
capacitor or any other components in the input path. This 
high initial current is the result of the capacitor appearing 
as a short circuit when the power is first applied. This 
current is often much greater than the steady-state current 
drawn by the power supply. 

MSO/DPO5000 Series Procedure: 

 NOTE: This section of the lab 
continues with the oscilloscope 
setup from the previous section. 

 Close the DPOPWR power 
application by clicking on the X in 
the upper right corner of the 
control window. 

 Right-click on the M1 icon at the 
left of the display and select Turn 
Math 1 Off. 

 Right-click on the M2 icon at the 
left of the display and select Turn 
Math 2 Off. 

 Reduce the channel 2 vertical 
sensitivity to 1 A/div. 

 Set the horizontal scale to 20 
ms/div. 

 Move the Trigger Level to about 
5V. 

 Select Trig->Mode…. 

 Press the Normal Trigger Mode 
button. 

 Remove the power from the demo 
board. 

 Press the front panel Single 
button. 

 Apply power to the demo board. 

 Select Measure -> Measurement 
Setup…. 

 Press the Channels 2 button. 

 Press the Max, Min, and Pk-Pk 
buttons. 

 Click on the X in the upper right 
corner of the control window. 
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Key Take Away Points 

 For other applications, such as determining whether or not 
the inrush current will open the line fuse or circuit breaker, 
the peak inrush current may be defined as the RMS current 
over a specified time period, such as the first 100 ms after 
power is applied. For example, this time period may be 
chosen to model the thermal time-constant of the critical 
device. Such a device will not respond to very short pulses, 
but rather the IRMS

2
*R heating. 

 This measurement is most easily measured with gated 
automatic measurements, as shown at the lower left side of 
the display: 

 

 

 

 

 

 

 

 

 

 

 

 Other vendors, such as Littlefuse, in their Introduction to 
Circuit Protection 
http://www.littelfuse.com/data/en/Product_Catalogs/Chapte
r1IntroductiontoCircuitProtection.pdf, 
recommend that the peak energy pulse measurement be 
used instead. 

MSO/DPO5000 Series Procedure: 

 Select Measure -> Measurement 
Setup…. 

 Press the Clear All button. 

 Press the AC RMS button. 

 Press the Gating button. 

 Press the Cursor button. 

 Using the Multipurpose a control, 
place the a cursor just to the left 
of the first cycle of current. 

 Using the Multipurpose b control, 
place the b cursor near the right 
edge of the display where the 
cursor delta time readout 
indicates a time delta of 100 ms. 

 

 

 

 

 

 

 

 

 When you are done, select 
Measure -> Measurement 
Setup…. 

 Press the Clear All button. 

 Press the Gating button. 

 Press the Off button. 

 Click on the X in the upper right 
corner of the control window. 

 Press the front panel Cursors 
button to remove the cursors. 

 

http://www.littelfuse.com/data/en/Product_Catalogs/Chapter1IntroductiontoCircuitProtection.pdf
http://www.littelfuse.com/data/en/Product_Catalogs/Chapter1IntroductiontoCircuitProtection.pdf
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Key Take Away Points 

 Nominal melting I
2
t is a measure of the energy required to 

melt the fusing element and is expressed as “Ampere 
Squared Seconds” (A

2
 Sec.). This nominal melting I

2
t, and 

the energy it represents (within a time duration of 8 
milliseconds or less for circuit-board-mounted fuses and 1 
millisecond or less for thin film fuses), is a value that is 
constant for each different fusing element. 

 For trouble-free, long-life fuse protection, it is good design 
practice to select a fuse such that the I

2
t of the waveform is 

no more than 20% of the nominal melting I
2
t rating of the 

fuse in use. 

 The I
2
 math function should look about like this: 

 

 This gated automatic area measurement of the squared 
current shows a value of approximately 38 mA

2
s at the 

lower left side of the display: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel Run/Stop 
button to start acquisitions. 

 Set the horizontal scale to 2 
ms/div. 

 Select Math -> Math Setup…. 

 Press the Editor button to enter 
the equation. 

 Press the Channels 2 button, the 
* multiply button, the Channels 2 
button, and the OK button. 

 Set the Math Vertical Scale to 
about 1.5 A

2
. 

 Remove the power from the demo 
board. 

 Press the front panel Single 
button. 

 Apply power to the demo board. 

 Select Measure -> Measurement 
Setup…. 

 Press the More tab at the left side 
of the control window. 

 Press the Area button. 

 Press the Gating button. 

 Press the Cursor button. 

 Using the Multipurpose a control, 
place the a cursor just to the left 
of the first major peak of the 
current. 

 Using the Multipurpose b control, 
place the b cursor 8 ms to the 
right of the a cursor, 
approximately at the end of the 
first peak of the current. The 
cursor delta time readout should 
indicate a time delta of 8 ms. 

 The resulting energy value should 
be compared to the rating of the 
fuse to be sure that the fuse 
rating is at least 5 times the 
measured I

2
t value. 
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Switching Loss Measurements 

Key Take Away Points 

 Switching loss is one of the most critical measurements for 
optimizing the efficiency of a power supply. Although an 
ideal switching device is loss-less, a real switching device 
has losses, especially during the transitions from off to on 
and from on to off. 

 To demonstrate switching loss measurements, this section 
of the lab measures the voltage across the switching 
device and current flowing through the switching device. 

 

 Typical voltage and current switching waveforms look 
about like this: 

 

 When the switching device is off, there should be no 
current flowing through the device, so there should be no 
power dissipation. In practice, this is generally accurate. 

MSO/DPO5000 Series Procedure: 

 Press Default Setup. 

 On the demo board, move SW1 
to the left position. 

 Connect the - input of the 
differential probe to the 
FET_SOURCE test point. 

 Connect the + input of the 
differential probe to the 
FET_DRAIN test point. 

 Connect the current probe around 
the FET_CURRENT current loop 
and close the probe jaws. 

 Press the front panel 2 button to 
turn on channel 2. 

 Press Autoset. 

 The voltage and current 
waveforms should be out of 
phase. If they are in phase, 
remove the current probe, turn it 
over, and re-connect it. 

 Scale and position the signals as 
shown at the left. 

 Select Horiz/Acq -> 
Horizontal/Acquisition Setup…. 

 Select Automatic Mode. 

 Set the Horizontal Scale to 10 
ms/div. 

 Adjust the Sample Rate to 20 
MS/s to achieve a record length 
of 2M. 
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Key Take Away Points 

 When the switching device is conducting, there should only 
be a small voltage drop across the device. However, the 
current through the device can be large, so the “conduction 
loss” can be sizeable. 

 The largest losses occur during the switching transitions, 
when there may be a considerable voltage drop across the 
device while there is considerable current flowing through 
the device. These “turn-on” and “turn-off” losses typically 
make up much of the total power dissipation in the 
switching device. 

 One of the critical parameters for accurate switching loss 
measurements is the calculation of the switching device’s 
behavior during conduction. There are three ways to 
determine the correct values: 

o Provide the RDS(on) value (best model for 
MOSFETs) based on the device data sheet. This 
value is the expected on-resistance between the 
drain and source of the device when it is 
conducting. 

o Provide the VCE(sat) value (best model for BJTs and 
IGBTs) based on the device data sheet. This is the 
expected saturation voltage from the collector to 
the emitter of the device when it is saturated. 

o You can also measure the actual RDS(on) or VCE(sat) 
value for the switching device during conduction. 

 With the Switching Loss measurements enabled, the 
display should look about like this: 

 

 Notice that the switching loss measurements are made on 
each individual complete cycle within the selected region of 
the acquisition (the entire waveform, by default) and the 
statistics of those measurements are accumulated across 
the acquisition, but not between acquisitions. 

MSO/DPO5000 Series Procedure: 

 Select Analyze -> Power 
Analysis -> Select. 

 Press the Switching Loss 
button. 

 Press the Configure tab on the 
left side of the control window. 

 Verify that the Voltage is on 
channel 1 and the Current is on 
Channel 2. 

 Verify that the PWM Type is set 
to Fixed and the Cursor Gating 
is Off. 

 For simplicity in this demo, you 
may leave the Device set to 
Auto. This will select a MOSFET 
switching device with an 

RDS(ON) value of 20 m. (You 
can also measure this actual 
value, or look it up on the 
component data sheet, and then 
select User and enter the value 
manually.) 

 If you would like to make other 
manual adjustments to the setup, 
press the On-Off Level tab and 
make the changes in this control 
window. 

 Verify that the Math Destination 
is set to Math1. 

 Press the Utility Deskew button. 

 Press the Deskew button. 

 Press the Static tab. This will 
allow you to select the default 
static propagation delay values 
for the probes you are using. 

 In the From section, select the 
appropriate differential probe from 
the drop-down menu. 

 In the To section, select the 
appropriate current probe from 
the drop-down menu. 

 Press the Back button. 

 Press the Single button at the 
right side of the control window. 
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Hi-Power Finder 

Key Take Away Points 

 DPOPWR includes the Hi-Power Finder tool that 
automatically searches through and identifies the peaks in 
the switching loss power waveform. The Hi-Power Finder 
results display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 NOTE: This section of the lab 
continues with the oscilloscope 
setup from the previous section. 

 Press the Select tab on the left 
side of the control window. 

 Press the Hi-Power Finder 
button. 

 Press the Configure tab on the 
left side of the control window. 

 Verify that the Voltage is on 
channel 1 and the Current is on 
Channel 2. 

 Verify that the PWM Type is set 
to Fixed. 

 Verify that the Math Destination 
is set to Math1. 

 Press the Single button at the 
right side of the control window. 

 You can use the Prev and Next 
buttons to navigate between peak 
values listed in the table. 
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Safe Operating Area Analysis 

The Safe Operating Area (SOA) display provides a very simple graphical method for monitoring the 
interactions between voltage and current. If you exceed the maximum limits (defined by maximum 
instantaneous current, maximum instantaneous voltage, and maximum instantaneous power) for the device, 
it will fail. Typically these specifications are provided in the component’s data sheet. For example, the key 
maximum specifications for the MOSFET on the 878-0544-XX power demo board are: 

o VDSSmax = 60 V 
o IDmax = 45 A, with peaks to 150A 
o PDmax = 125 W 

The resulting SOA graph from the MOSFET’s data sheet is: 

  

 

IDmax 

VDSSmax 

PDmax 
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Key Take Away Points 

 To demonstrate Safe Operating Area (SOA) 
measurements, this section of the lab displays the voltage 
across the MOSFET versus the current flowing through the 
MOSFET. 

 The SOA display should look about like this: 

 

 NOTE: Especially for this complex display, the demo may 
be more effective if you increase the waveform intensity. 

 X-Y cursors can be used to identify specific points in the 
waveform, such as those that violate the SOA mask. 

 There is also an XY display mode for SOA. The SOA XY 
display looks like this: 

 

 Although both of these display modes for SOA can be 
useful for visual analysis, the real power in the SOA XY 
display is with mask testing. 

MSO/DPO5000 Series Procedure: 

 NOTE: This section of the lab 
continues with the oscilloscope 
setup from the previous section. 

 Press the Select tab on the left 
side of the control window. 

 Press the SOA button. 

 Press the Configure tab on the 
left side of the control window. 

 Verify that the Voltage is on 
channel 1 and the Current is on 
Channel 2. 

 Verify that the Cursor Gating is 
set to Off. 

 Notice that you can also specify 
an SOA mask from this control 
window. 

 Press the Single button at the 
right side of the control window. 

 

 

 

 

 

 Press the Select tab on the left 
side of the control window. 

 Press the SOA XY button. 

 Press the Single button at the 
right side of the control window. 

 

 

 

 

 

 

 

 When you are done, press the 
Stop button at the right side of 
the control window. 
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Key Take Away Points 

 Based on the component specifications, the horizontal top 
of the SOA mask is set at the IDmax value of 45 A, from 10 
mV to about 3V (where the power hits the PDmax value of 
125 W). 

 The vertical side of the SOA mask is set at the VDSSmax 
value of 60 V, from 10 mA to about 2A (where the power 
hits the PDmax value of 125 W). 

 The angled side of the SOA mask is drawn where the 
power equals the PDmax value of 125 W. 

 The SOA mask test log display should look about like this: 

 

 Clearly in this case, as in many cases in embedded system 
power applications, the design is not pushing the limits of 
the device. As long as the maximum voltage and current do 
not exceed half of the maximum values, a careful analysis 
of the SOA display is probably not necessary. 

MSO/DPO5000 Series Procedure: 

 Press the Select tab on the left 
side of the control window. 

 Press the SOA button. 

 Press the Configure tab on the 
left side of the control window. 

 In the Mask section, click the 
Enable check box. 

 Press the Mask Editor button. 

 In the Mask Grid Scale section, 
press the Log button. 

 First, set the outer dimensions of 
the display: 

 Double-click on the X-Max 
text box and enter 100 V. 

 Double-click on the Y-Max 
text box and enter 50 A. 

 Then, define the mask area: 

 Click on the Y axis at the 
IDmax point of 45 A. (You can 
see the coordinates in the 
readout in the upper right 
corner.) 

 Click at the point of 45A and 
3V. 

 Click at the point of 2A and 
60V. 

 Click at the VDSSmax point of 
60V on the X axis. 

 Press the Apply button. 

 Press the Save Mask button, 
enter a filename, and press the 
Save button. 

 Press the X in the upper right 
corner of the control window. 

 Press the Single button at the 
right side of the control window. 

 Press the Full Screen button. 

 Press the Log Plot Scale button. 

 When you are done, press the X 
in the upper right corner of the 
control window. 
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dv/dt and di/dt Measurements 

Key Take Away Points 

 This section of the lab demonstrates dv/dt and di/dt 
measurements, also known as voltage and current slew 
rate measurements, on the switching loss waveforms from 
the previous lab. 

 These measurements indicate how quickly the switching 
device is turning on and off. 

 The dv/dt display should look about like this: 

 

 The di/dt display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 NOTE: This section of the lab 
continues with the oscilloscope 
setup from the previous section. 

 Press the Select tab on the left 
side of the control window. 

 Press the dv/dt button. 

 Notice that the channel 1 voltage 
waveform has been selected as 
the source. 

 Press the Single button at the 
right side of the control window. 

 

 

 

 

 

 

 

 

 

 Press the Select tab on the left 
side of the control window. 

 Press the di/dt button. 

 Notice that the channel 2 current 
waveform has been selected as 
the source. 

 Press the Single button at the 
right side of the control window. 

 



 

MSO5000 / DPO5000 Lab Exercise Book 

Version 1.1   5/11/2012 48W-26279-3   359 of 394 

 

RDSon Measurements 

Key Take Away Points 

 This section of the lab demonstrates the measurement of 
the dynamic on-resistance or RDSon of a MOSFET switching 
device. This is the effective resistance of the MOSFET 
during the conduction cycle. Because the value changes 
with the current flowing through the device, this 
measurement is made at the actual drain current (unlike 
the data sheet spec, which is only valid at one specific 
current level). The RDS(on) display should look about like 
this: 

 

MSO/DPO5000 Series Procedure: 

 NOTE: This section of the lab 
continues with the oscilloscope 
setup from the previous section. 

 Select Horiz/Acq -> 
Horizontal/Acquisition Setup…. 

 Select Automatic Mode. 

 Set the Horizontal Scale to 1 
ms/div. 

 Adjust the Sample Rate to 20 
MS/s to achieve a record length 
of 2M. 

 Press the Select tab on the left 
side of the control window. 

 Press the RDS(on) button. 

 Notice that the Voltage is on 
channel 1 and the Current is on 
Channel 2. 

 Press the Single button at the 
right side of the control window. 

 With the mouse, drag the cursors 
over to the conduction region 
(where the cyan drain current is 
high and the yellow voltage drop 
is low) to define the measurement 
region. 

 Press the Cursor button and 
press Yes in the popup message 
dialog. 
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Modulation Analysis with Measurement Trends 

Key Take Away Points 

 To demonstrate modulation measurements, this section of 
the lab characterizes the switching frequency of the 
MOSFET. The frequency modulation analysis display 
should look about like this: 

 

 The remaining reference waveform on the display is the 
trend of the frequency measurement. Because it is a 
waveform, you can make automatic and cursor 
measurements on it. Notice that the readouts indicate the 
proper units: 

 

MSO/DPO5000 Series Procedure: 

 NOTE: This section of the lab 
continues with the oscilloscope 
setup from the previous section. 

 Set the Horizontal Scale to 100 
ms/div. 

 Adjust the Sample Rate to 2 
MS/s to achieve a record length 
of 2M. 

 Press the Select tab on the left 
side of the control window. 

 In the Modulation Analysis 
section, press the Frequency 
button. 

 Notice that the Voltage is on 
channel 1. 

 Press the Single button at the 
right side of the control window. 

 

 

 

 Press the channel 1 and 2 
buttons to turn off the display of 
channels 1 and 2. 

 Press the front panel Cursor 
button twice to re-attach the 
Multipurpose controls to the 
cursors. 

 Using the Multipurpose controls, 
measure the peak-to-peak 
variation in frequency. 

 

 

 

 When you are done, press the 
channel 1 and 2 buttons to turn 
on the display of channels 1 and 
2. 

 Click on the white arrow to return 
to the power application. 
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Key Take Away Points 

 Modulation analysis is most useful when analyzing the 
power supply’s control loop during power-up, the response 
to a change in input voltage (“line regulation”), or the 
response to a change in load (“load regulation”). 

 To view the variations in the frequency during power-up, 
start the measurement and then power up the demo board: 

 

 If you zoom in on the startup transient, you can see that the 
peak-to-peak variations in frequency are much higher 
during startup than during stead-state operation. The 
display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Disconnect the power from the 
demo board. 

 Press the Single button at the 
right side of the control window. 

 Re-connect the power to the 
demo board. 

 

 

 

 

 

 

 

 

 

 

 

 Press the channel 1 and 2 
buttons to turn off the display of 
channels 1 and 2. 

 Draw a box around the start-up 
transient and select Zoom 1 On. 

 Press the front panel Cursor 
button twice to re-attach the 
Multipurpose controls to the 
cursors. 

 Using the Multipurpose controls, 
measure the peak-to-peak 
variation in frequency. 

 

 

 When you are done, press the 
channel 1 and 2 buttons to turn 
on the display of channels 1 and 
2. 

 Click on the white arrow to return 
to the power application. 
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Line and Switching Ripple Measurements 

Key Take Away Points 

 To demonstrate ripple measurements, this section of the 
lab measures the voltage across the DC output section of 
the demo board. 

 

 The line ripple measurement display should look about like 
this: 

 

MSO/DPO5000 Series Procedure: 

 NOTE: This section of the lab 
continues with the oscilloscope 
setup from the previous section. 

 On the demo board, move SW1 
to the left position. 

 Connect the - input of the 
differential probe to the DC LOW 
test point. 

 Connect + input of the differential 
probe on channel 1 to the DC 
HIGH test point. 

 Press the front panel 2 button to 
turn off channel 2. 

 Press the Select tab on the left 
side of the control window. 

 Press the Input/Output Analysis 
tab near the left side of the 
control window. 

 Press the Line Ripple button. 

 Press the Configure tab on the 
left side of the control window. 

 Verify that AC Coupling, 20 MHz 
Bandwidth, and HiRes 
Acquisition Mode are selected. 

 In the Ripple Frequency section, 
press the appropriate button for 
the local AC power. 

 Press the Single button on the 
right side of the control window. 
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Key Take Away Points 

 If, instead, we measure the Switching Ripple, we see the 
ripple on the output that is related to the switching 
frequency (of about 150 kHz, in this case): 

 

MSO/DPO5000 Series Procedure: 

 Press the Select tab on the left 
side of the control window. 

 Press the Switching Ripple 
button. 

 Press the Configure tab on the 
left side of the control window. 

 Verify that AC Coupling, 20 MHz 
Bandwidth, and HiRes 
Acquisition Mode are selected. 

 In the Switching Frequency text 
box, press the appropriate 
switching frequency. 

 Press the Single button on the 
right side of the control window. 
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Output Spectral Analysis 

Key Take Away Points 

 To demonstrate the spectral measurement on the output 
signal, set up the span and resolution to cover the 
spectrum of the frequencies of interest. In this case, we’re 
going to look at the harmonics of the line frequency on the 
output signal: 

 

 The output spectral analysis display should look about like 
this: 

 

MSO/DPO5000 Series Procedure: 

 Press the Select tab on the left 
side of the control window. 

 Press the Select tab near the left 
side of the control window. 

 Press the Spectral Analysis 
button. 

 Press the Configure tab on the 
left side of the control window. 

 Verify that 50 Hz Start 
Frequency, Rectangular 
Window Type, and Auto Setup 
are selected. 

 Set the Stop Frequency to 500 
Hz. 

 Select a Res BW (Hz) value of 
about 1 Hz. 

 In the Ripple Frequency section, 
press the appropriate button for 
the local AC power. 

 Press the Single button on the 
right side of the control window. 

 If you see the message “RBW not 
updated, set maximum available 
RBW and continue 
measurement?”, press the Yes 
button. 
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Key Take Away Points 

 You can use the Peak Find feature to automatically jump 
between peaks in the spectral display: 

 

MSO/DPO5000 Series Procedure: 

 Press the Next>> button twice to 
jump the little red marker to the 
fifth harmonic Notice that the 
readout in the Marker Position 
section shows the Frequency and 
Amplitude at the marker. 
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Turn On Time Measurement 

Key Take Away Points 

 To demonstrate DC-DC turn-on time measurements, this 
section of the lab measures the voltage across the DC 
input and DC output sections of the demo board: 

 

 The turn-on time setup control window for the input section 
should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 On the demo board, move SW1 
to the right position. 

 Press Default Setup. 

 Connect a TDP0500 or TDP1000 
differential probe to channel 1 of 
the oscilloscope. 

 Set the channel 1 Vertical Scale 
to 5 V/div. 

 Connect a TPP0500 or TPP1000 
passive probe to the channel 2 
input. 

 Press the channel 2 button to turn 
on the display of channel 2. 

 Set the channel 2 Vertical Scale 
to 5 V/div. 

 Select Horiz/Acq -> Roll Mode 
Auto to deselect it. 

 Disconnect the power from the 
demo board. 

 Press the front panel Clear 
button. 

 Select Analyze -> Power 
Analysis. 

 Press the Input/Output Analysis 
tab near the left side of the 
control window. 

 Press the Turn On Time button. 

 Press the Configure tab on the 
left side of the control window. 

 Make sure the Input tab is 
selected. 

 Press the DC-DC Convertor 
button. 

 Double-click on the Max Voltage 
text box and enter the AC voltage 
of about 15V. 

 Double-click on the Trigger Level 
text box and enter the trigger 
level value of about 7V. 

 Double-click on the Max Turn On 
Time text box and enter a value 
of about 2s. 

VIN 

+5DC 
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Key Take Away Points 

 The turn-on time setup control window for the output 
section should look about like this: 

 

 The turn-on time measurement results control window 
should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the Output tab. 

 Press the Single button at the 
right side of the control window. 

 Wait for the Arm light and then 
the Ready light on the front panel 
to light. 

 Re-connect the power to the 
demo board. 

 At the selected Horizontal Scale 
setting, it will take a few seconds 
from the time the green Trig’d 
light is lit until the waveform is 
completely acquired. 

 Press the Yes button in the 
popup dialog. 
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Magnetics Measurements 

As with the dynamic on-resistance of the MOSFET, the characteristics of the magnetic components in a 
power supply are different in the circuit and may not match the specifications in the component data sheet. 

The magnetic measurements are based on an XY display of the current through the inductor and the 
integral of the voltage across the inductor. This curve typically shows hysteresis or “path dependence” 
where a point on the curve is dependent upon the location of the previous point. 

In this figure: 

H is the Magnetic Field Strength, measured in Amperes / meter. 

Hc is the Coercive Force, or the magnetic field that must be applied to 
reduce the magnetization to zero after the magnetization has been 
driven into saturation. 

B is the Magnetic Flux Density, measured in Teslas. 

Bs is the Saturation Flux Density, or the maximum magnetic flux density 
induced in the material regardless of the applied field H. 

Br is the Remanence Flux Density, or the magnetization remaining in a 
magnetic device after an external magnetic field is removed. (Only 
ferromagnetic materials such as iron have remanence.) 

µi is the Initial Permeability, and µa is the Maximum Amplitude 
Permeability. 

Inductance is the electromagnetic property where a change in the current through a device induces an 
opposing voltage. The electrical current i produces a magnetic field, where the magnetic flux Φ is measured 
in webers. The self-inductance of the device is the ratio of the magnetic flux times turns of wire to the 
current, or L = N*Φ/L, which is measured in Henrys. The current through an inductor and the voltage across 
the inductor are related as di/dt = v/L, or L= ∫v / I, so the inductance can be directly calculated from the XY 
display. 

Transformers and coupled inductors can also be measured with DPOPWR. Inductance measurements on 
one winding is similar to an inductor, but the other windings must not be loaded. 

Magnetic Loss is a composite measurement of the losses within the magnetic device. There are three 
components to this loss. 

 Copper Loss is the loss due to the resistance in the wire used in the inductor or transformer. This 
power loss is proportional to the resistance of the wire and the square of the current through the 
device, just like a resistor. 

 Hysteresis Loss occurs when the magnetization of the core material changes and the magnetic 
domains expand and contract within the imperfect crystal structure. The energy loss is proportional 
to the area inside the B-H curve’s hysteresis loop and increases with frequency. 

 Eddy Current Loss is due to eddy currents flowing within the core material. Eddy currents and the 
resulting losses are minimized by increasing the resistance of the core material, with techniques 
such as laminating the materials or using the core of a non-conductive magnetic material like ferrite. 
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Key Take Away Points 

 To demonstrate magnetics measurements, this section of 
the lab measures the voltage across and current through 
the inductor on the right side of the demo board. 

 

 Inductance is the most basic specification for a magnetic 
device such as an inductor or transformer. Although the 
nominal inductance value may be specified in the 
component data sheet, the effective inductance value 
depends upon the actual signal characteristics in the 
circuit. 

 The inductance measurement display should look about 
like this: 

 

MSO/DPO5000 Series Procedure: 

 On the demo board, move SW1 
to the right position to enable the 
magnetics measurements. 

 On the demo board, move SW2 
to the left position to turn off the 
varying load and flashing LED. 

 Connect a TDP0500 or TDP1000 
differential probe to channel 1 of 
the oscilloscope. 

 Press the Menu button on the 
probe’s comp box. 

 Connect the + and – inputs. 

 Press the AutoZero button. 

 Connect the - probe input to the 
+5DC test point. 

 Connect + probe input on channel 
1 to the DRAIN test point. 

 Connect a TCP0030 current 
probe to channel 2. 

 Press the front panel 2 button to 
turn on channel 2. 

 Press the Menu button on the 
probe’s comp box. 

 In the Range section of the 
control window, select Manual. 

 Set the Range to 5A. 

 Make sure that the current 
probe’s jaw is closed. Press the 
Degauss AutoZero button on the 
probe. 

 Connect the current probe around 
the CORE_CURRENT current 
loop and close the probe jaws. 

 Press the front panel 2 button to 
turn on channel 2. 

 Press the Select tab on the left 
side of the control window. 

 Press the Magnetics tab near the 
left side of the control window. 

 Press the Inductance button. 

 Press the Single button on the 
right side of the control window. 

 

DRAIN 

+5DC 

CORE_ 
CURRENT 
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Key Take Away Points 

 To measure the magnetic properties of the inductor, the 
control window should look about like this: 

 

 In most power supply designs, the dominant losses (which 
limit the power supply’s efficiency) are switching loss and 
magnetic loss. Magnetic power loss is a composite value 
which includes core losses, eddy current loss, hysteresis 
and copper losses in the inductor or transformer. 

 The magnetic power loss measurement display should look 
about like this: 

 

MSO/DPO5000 Series Procedure: 

 Press the Select tab on the left 
side of the control window. 

 Press the Magnetic Property 
button. 

 Press the Single button on the 
right side of the control window. 

 

 

 

 

 

 

 

 

 

 

 Press the Select tab on the left 
side of the control window. 

 Press the Magnetic Loss button. 

 Press the Single button on the 
right side of the control window. 
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Optional Power Efficiency Measurement 

Key Take Away Points 

 This optional lab requires the use of two differential probes 
and two current probes. Because these four probes draw 
more power from the oscilloscope than it can supply alone, 
the external probe power adapter must be used. 

 To demonstrate power efficiency measurements, this 
section of the lab measures the AC input power to the 
demo board. 

 

 The display should look about like this, with the input 
voltage on yellow channel 1 and the input current on cyan 
channel 2: 

 

MSO/DPO5000 Series Procedure: 

 Connect the external probe power 
adapter (119-7465-xx) to the rear 
of the oscilloscope and connect it 
to line power. 

 On the demo board, move SW1 
to the left position. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Connect a TDP0500 or TDP1000 
differential probe to channel 1 of 
the oscilloscope. 

 Press the Menu button on the 
probe’s comp box. 

 In the Range section of the 
control window, select Manual. 

 Make sure that the Range is set 
to 42V. 

 Connect the + and – inputs. 

 Press the AutoZero button. 

 Connect the - input of the 
differential probe to the GND test 
point. 

 Connect the + input of the 
differential probe to the AC High 
test point. 

 Set the Horizontal Scale to 
5ms/div. 

 Press the front panel 2 button to 
turn on channel 2. 

 Connect a TCP0030 current 
probe to channel 2 on the 
oscilloscope. 

 Press the Menu button on the 
probe’s comp box. 

 In the Range section of the 
control window, select Manual. 

 Set the Range to 5A. 

 Make sure that the current 
probe’s jaw is closed. Press the 
Degauss AutoZero button on the 
probe. 
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Key Take Away Points 

 The display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Connect the current probe around 
the AC_CURRENT current loop 
and close the probe jaws. 

 Scale and position the signals as 
shown at the left. 

 In this case, the voltage and 
current waveforms are in phase. If 
the phase of channel 2 signal is 
opposite of the channel 1 signal, 
remove the current probe, turn it 
over, and reconnect it. 

 Select Horiz/Acq->Acquisition 
Mode->HiRes. 

 Select Horiz/Acq->Resolution… 
or Horiz/Acq-
>Horizontal/Acquisition 
Setup…. 

 Set the Sample Rate to 20 MS/s. 
This will set the record length to 
1M points. 

 To simplify the next part of the lab 
setup, press the front panel 1 and 
2 buttons to temporarily turn off 
the display of channels 1 and 2. 
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Key Take Away Points 

 To demonstrate power efficiency measurements, this 
section of the lab measures the AC output power delivered 
to the resistive load on the demo board. 

 

 The display should now look about like this, with the 
voltage across the load on purple channel 3 and the load 
current on green channel 4: 

 

MSO/DPO5000 Series Procedure: 

 Press the front panel 3 button to 
turn on channel 3. 

 Connect a TDP0500 or TDP1000 
differential probe to channel 3 of 
the oscilloscope. 

 Press the Menu button on the 
probe’s comp box. 

 In the Range section of the 
control window, select Manual. 

 Make sure that the Range is set 
to 42V. 

 Connect the + and – inputs. 

 Press the AutoZero button. 

 Connect the - input of the 
differential probe to the FET 
DRAIN test point at the top of the 
board. 

 Connect the + input of the 
differential probe to the DC High 
test point on the left side of the 
board. 

 Press the front panel 4 button to 
turn on channel 4. 

 Connect a TCP0030 current 
probe to channel 4 on the 
oscilloscope. 

 Press the Menu button on the 
probe’s comp box. 

 In the Range section of the 
control window, select Manual. 

 Set the Range to 5A. 

 Make sure that the current 
probe’s jaw is closed. Press the 
Degauss AutoZero button on the 
probe. 

 Connect the current probe around 
the FET_CURRENT current loop 
at the top of the board and close 
the probe jaws. 

 Scale and position the signals as 
shown at the left. 

 The voltage and current should 
be in phase. If they are out of 
phase, remove the current probe, 
turn it over, and re-connect it. 
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Key Take Away Points 

 Now that the oscilloscope is acquiring the input and output 
voltages and currents, we need to measure the 
instantaneous input and output power. Instantaneous 
power is simply the product of the voltage and the current, 
so we use the multiplication function in math to generate 
the instantaneous power waveform. 

 The instantaneous input power waveform should look 
about like the orange waveform below. Notice that the 
power is 0 when the current is 0, and a positive value 
whenever the voltage*current product is positive. 

 

 To measure the average input power, we can use the 
automatic mean measurement. However, we want to 
measure the average across an integer number of cycles to 
get a correct and stable value, so we will use the special 
cycle mean measurement. With the measurement enabled, 
the display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Scale and position all of the 
signals so each vertically fills 
most of the graticule without 
going outside the graticule. 

 Turn on the display of channels 1 
and 2 by pressing the front panel 
1 and 2 buttons. 

 To simplify the next part of the lab 
setup, press the front panel 3 and 
4 buttons to temporarily turn off 
the display of channels 3 and 4. 

 Select Math -> Ch1*Ch2. 

 

 

 

 

 

 

 

 

 

 

 Select Measure -> Measurement 
Setup…. 

 In the center of the control 
window, press the Math tab and 
press the Maths 1 button. 

 At the left side of the control 
window, press the Ampl tab. 

 In the Measurements window, 
press the More button to display 
the next page of measurements. 

 Press the Cycle Mean button. 

 Notice the measurement 
annotations on the display, 
showing where the cycle mean 
measurement is being made. 
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Key Take Away Points 

 The instantaneous output power waveform should look 
about like the purple waveform below. Notice that the 
power is 0 when the voltage and current are 0, and a 
positive value whenever the voltage*current product is 
positive. 

 To measure the average output power, we can use the 
automatic mean measurement. Again, we want to measure 
the average across an integer number of cycles to get a 
correct and stable value, so we will use the special cycle 
mean measurement. With the measurement enabled, the 
display should look about like this: 

 

 NOTE: All of the voltage, current, and instantaneous power 
waveforms in this lab have a dominant fundamental 
component and have duty cycles near 50%. In these 
cases, the automatic cycle measurements work very well. 
In some power supplies, the waveforms have very high or 
low duty cycles and may exhibit high noise or ringing on the 
signal. In these cases, you may need to use cursor gating 
on the measurements to get accurate and repeatable 
results. 

 So far in this lab, we have set up the oscilloscope to 
measure the average input power and the average output 
power. Now we can calculate the input-to-output efficiency. 

MSO/DPO5000 Series Procedure: 

 Turn on the display of channels 3 
and 4 by pressing the front panel 
3 and 4 buttons. 

 Select Math -> Ch3*Ch4. 

 In the center of the control 
window, press the Maths 2 
button. 

 Press the Cycle Mean button. 

 Again, notice the measurement 
annotations on the display, 
showing where the cycle mean 
measurement is being made. 
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Key Take Away Points 

 To calculate the efficiency, we need to divide the average 
output power by the average input power, so we use the 
division function in math to generate the value. 

 

 The output of the efficiency calculation is a math waveform. 
To provide a numerical readout, we can use the automatic 
measurement system again. The measurement below 
indicates an efficiency of about 47%: 

 

 Clearly, this demo board circuit is a very inefficient supply, 
but this measurement technique is valid and can be very 
useful. 

MSO/DPO5000 Series Procedure: 

 Select Math -> Math Setup…. 

 Press the Math3 tab at the left 
side of the control window. 

 Press the Editor button. 

 Press the Meas tab near the left 
side of the control window. 

 Press the Cycle Mean (M2) 2 
button. 

 Press the / division button. 

 Press the Cycle Mean (M1) 1 
button. 

 Press the OK button. This will 
display a red math waveform 
which represents the ratio of 
average output power to average 
input power. 

 Select Measure -> Measurement 
Setup…. 

 In the center of the control 
window, press the Math tab and 
press the Maths 3 button. 

 At the left side of the control 
window, press the Ampl tab. 

 In the Measurements window, 
press the More button to display 
the next page of measurements. 

 Press the Mean button. 
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Understanding the TekVPI Interface 

Introduction 

The TekVPI (Tektronix Versatile Probe Interface) architecture is the new-generation probe interface 
architecture for the MSO/DPO5000 Series oscilloscopes. TekVPI probes combine excellent electrical probe 
performance with advanced, bidirectional serial interface communications with the oscilloscope. The design 
architecture of TekVPI provides users improved ease-of-use in probe setup, easy selection of displayed 
probe status and setup information, as well as accurate probe measurement performance results all 
intended to simplify and improve the performance of the user’s test and measurement experience. 
 
In 1969, Tektronix introduced a probe interface which used a BNC type connector for passing the acquired 
analog signal and added an analog-encoded scale factor detection pin, which enabled the compatible 
oscilloscope to automatically detect and scale the displayed vertical attenuation range appropriately. Today, 
we refer to this interface as TekProbe™ Level 1. A P6139A or P6139B passive probe is a common example. 
 
In 1986, probe usability was further enhanced with the introduction of the TekProbe-BNC Level 2 probe 
interface architecture which supports the required operating power requirements for “active” probe types 
which contained transistors, IC’s, or other active components as part of the probe’s signal conditioning 
network design. TekProbe-BNC Level 2 further extended the capabilities of Level 1 designs by adding probe 
communications with the oscilloscope to improve the usability of increasingly sophisticated probe types and 
to accomplish calibrated offset at the probe tip. 
 
In early 2006, Tektronix introduced the next generation of probe interface, the TekVPI architecture. Each 
TekVPI probe features controls and indicators right on the probe for quick and easy access to the probe’s 
most commonly required setup controls and operating status. TekVPI probes also have a Menu button that 
enables users to quickly and easily access a probe setup menu on the oscilloscope. The instrument 
provides comprehensive probe information including: probe model type, probe serial number, probe 
operating status and warnings. Additionally, all probe setup controls can be changed and monitored from the 
instrument display. Because of the probe communications, the oscilloscope can save the probe setup and 
provide remote control of the probes through the programmable interfaces (USB, GPIB, and Ethernet). 
 
Traditionally, the precisely-regulated power resources for the active probes 
were provided by the host oscilloscope. Therefore, every oscilloscope was 
burdened with the cost and weight of the power conditioning circuits. 
Sometimes, instrument constraints limited the number or type of probes which 
were supported. The TekVPI architecture moves the complexity of the power 
conditioning into the probe itself, where the design can be optimized for that 
specific probe. The TekVPI host oscilloscope distributes a +12 VDC bulk power 
supply which each probe or adapter regulates to meet its own needs, providing 
more flexibility in probe support. An example of this benefit is found with the 
TCP0030, 30 Ampere AC/DC current probe. Previous current probes of this 
measurement range required external power supplies to provide the necessary 
resources required for “bucking currents” and to perform degaussing operations 
necessary to maintain accurate measurement capability. The TCP0030 and 
TCP0150 TekVPI current probes now eliminate this need for an external power supply when used with the 
MSO/DPO5000 series. The MSO/DPO5000 series oscilloscopes can provide up to 10W of probe power 
(supporting two of these current probes) as described in more detail at the end of this section. An external 
power adapter is also available to support those applications requiring more power. 
 
The TekVPI design also simplifies the attachment of the probe or adapter, allowing the user to simply insert 
the probe connector into the oscilloscope’s TekVPI input channel connector. The probe is locked in place 
until the user presses the push-button lock release. To assure electrical signal integrity of the probe 
interface connections gold-plated spring contacts are used. In addition to TekVPI probes, the interface is 
directly compatible with BNC cables and TekProbe level 1 probes such as the P6139A and P6139B. 
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Note: On the MSO/DPO5000 Series, the front panel Aux In connector provides full power and 

communication capabilities, but only offers 1 M termination. Therefore, when probes which expect 50 
termination (such as TekVPI active and differential probes) are connected, you will see an error message 
pop up and the probes are not powered up: 

 

Lab Objectives 

For this lab, if you have the optional probes and the time, go through the procedure on the right side of each 
page. If not, simply follow the pictures and text on the left side of each page. 

- Obtain a basic understanding of the TekVPI interconnect. 

- Learn how to control the TekVPI probes with the MSO/DPO5000 Series oscilloscope. 

- Learn about some basic applications of the new TekVPI probes. 
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Coaxial Cable 

Key Take Away Points 

 Coaxial cables with BNC connections are directly 
compatible with the TekVPI interface on the 
MSO/DPO5000 Series oscilloscope. 

 

 

 

 

 

 When a coax cable is connected to an analog channel on 
an MSO/DPO5000 Series oscilloscope, the relevant 
readouts for the probe appear in the Probe Controls control 
window. 

 Advanced probes can be individually calibrated. Since this 
is not relevant for cables, the Calibration should be cleared 
or “initialized”. 

 The probe controls such as Deskew Time and External 
Attenuation for the probe appear in that channel’s Probe 
Setup menu. 

 The Attenuation control allows you to specify the amount of 
external attenuation that has been applied to the signal. 
Notice that the displayed waveform amplitude and/or the 
units/div value on the channel 1 readout reflect this 
selection. 

 

 Notice the vertical readout. Since the Termination is set to 
1MΩ, the channel’s bandwidth is at the maximum 500 
MHz. If the Termination is set to 50Ω and the bandwidth is 
set to full, the channel bandwidth would be the instrument’s 
maximum bandwidth. 

MSO/DPO5000 Series Procedure: 

 Power up the oscilloscope. 

 Press the front panel Default 
Setup button to set the 
oscilloscope into a known state. 

 Connect a coax cable to the 
Channel 1 input. (Since there is 
no communication from the cable, 
it doesn’t really matter if you do 
this step or not.) 

 Select Vertical->Probe Controls. 

 Using the Source drop down 
menu, select Ch 1. 

 Press the Setup button. 

 If the Calibration Probe Status is 
not already “Initialized”, press the 
Clear ProbeCal button. 

 

 

 Touch the External Atten text 
box to attach the Multipurpose 
controls to the Attenuation 
controls. 

 Using the Multipurpose a control, 
adjust the External Atten. 
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P6139A and P6139B Passive Probes 

Key Take Away Points 

 The P6139A andP6139B are examples of TekProbe level 1 
probes. It uses a BNC connector to transmit the analog 
signal, and transmits the probe’s voltage scale factor data 
via a spring-loaded pin. (See picture at right.) 

 The P6139A and P6139B 10X passive voltage probes are 
directly compatible with the TekVPI interface on the 
MSO/DPO5000 Series oscilloscope. 

 

P6139B passive probe 

 When a probe is connected to an analog channel on an 
MSO/DPO5000 Series oscilloscope, the relevant readout 
and controls for the probe appear in that channel’s Probe 
Setup menu. 

 In the case of a P6139A and P6139B, there are no 
controls, and the menu displays that the probe is a 10X 
voltage probe. 

 Notice that the units on the channel 1 readout are Volts. 

 

 Note that the P6139A and P6139B expect 1M termination 
to work correctly. On an MSO/DPO5000, if the termination 

is set to 50, the probe will not work as expected. 

MSO/DPO5000 Series Procedure: 

 

TekProbe level 1 probe 

 Connect the P6139A or P6139B 
10X passive voltage probe to the 
Channel 1 input. 

 Select Vertical->Probe Controls. 

 Press the Setup button to display 
the available Probe Setup 
controls such as Deskew Time 
and External Atten. 

 And, again, if the Calibration 
Probe Status is not already 
“Initialized”, press the Clear 
ProbeCal button. 

 Press the Probe Properties 
button to display the available 
information about the probe. 

 When you are done, click the X in 
the upper right corner of the 
Probe Properties control window 
to close it. 

 

 

 

 Look at the probe accessories 
that come with the P6139B. The 
probe accessories, including the 
hook tip, ground leads, ground 
spring, and colored bands are 
now common across the general-
purpose passive probe portfolio 
(P6139B, P5050B, and the new 
TPP Series). 

Data 
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TPA-BNC Adapter 

Key Take Away Points 

 TekProbe level 2 probes include power connections for 
active probes and increased data communications with the 
scope. However, they are not mechanically compatible with 
the TekVPI connector. 

 The data and clock signals are I
2
C serial bus connections. 

 The TPA-BNC adapter is designed to allow the user to 
connect legacy TekProbe level 2 probes, such as the 
P624X series active and differential probes and the 
TCP202 current probes, to the MSO/DPO5000 Series. 

 When the TPA-BNC by itself is attached to channel 1 and 
the channel’s Probe Setup menu is selected, the display 
should look about like this: 

 

 When a TekProbe level 1 probe (such as the P6139A or 
P6139B) or a TekProbe BNC level 2 probe (such as the 
P6243) is attached to the TPA-BNC, the probe information 
is displayed in the Probe Properties control window. 

MSO/DPO5000 Series Procedure: 

 

TekProbe level 2 probe 

 

 Connect the TPA-BNC adapter to 
the Channel 1 input. 

 Select Vertical->Probe Controls. 

 Press the Setup button to display 
the available Probe Setup 
controls such as Deskew Time 
and External Atten. 

 Press the Properties button and 
notice that the TPA-BNC status 
information such as serial number 
is displayed. Close the Probe 
Properties control window. 

 Connect the P6139A or P6139B 
to the input of the TPA-BNC. 

 Notice that the 10X attenuation of 
the probe appears in the Probe 
Type readout in the control 
window. 

 If you connect a supported 
TekProbe level 2 probe such as a 
TCP202, you will see the probe 
name appear in the Probe Type 
readout. 

 Press the Properties button and 
notice that the probe status 
information such as serial number 
is displayed. 
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TPA-BNC – Just A Mechanical Adapter? 

   
 
There is more under the cover than meets the eye! Although described as an adapter, the TPA-BNC is 
much more than a passive signal path, mechanical adapter. It contains sophisticated circuit boards, ICs, 
connectors and shielding. 
 
It is a mechanical adapter (TEKPROBE BNC to TekVPI), but it also is a power converter and a TEKPROBE 
Level 2 to TekVPI control signal converter allowing the use of existing TEKPROBE Level 2 interface active 
voltage probes, high and low voltage differential probes, micro-volt pre-amplifier probe, and current probes 
to name a few with the Tektronix oscilloscope products that use the TekVPI probe interface. 
 

 Power Conversion – requires circuitry to convert the TekVPI voltage levels (12V, 5V) and provide the 
voltage levels (+15V, -15V, +5V, -5V) required for TEKPROBE interface probing solutions to function. 

 

 Control Signal Conversion – requires circuitry to convert TEKPROBE control signaling; such as 
attenuation factor, range, product serial number, and product type into TekVPI control signaling formats. 

 

 Backward Compatibility – allows moving into the next generation of test and measurement tools while 
maintaining compatibility to use existing TEKPROBE interface tools without losing your present DUT test 
fixtures and testing setups. 

 
 

TPA-BNC – NOT JUST ANOTHER ADAPTER! 
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TPP0500 and TPP1000 Passive Probes 

Key Take Away Points 

 For high-fidelity acquisition of high-speed ground-
referenced voltage signals, the TPP0500 / TPP1000 is an 
excellent choice: 

o 500 MHz / 1 GHz probe bandwidth provides wide-
bandwidth general-purpose probing for any of the 
MSO/DPO5000 Series scopes. 

o ≤4 pF input capacitance minimizes probe AC 
loading on the circuit. 

o 10 MΩ input resistance at the probe tip minimizes 
probe DC loading on the circuit. 

o 300 V CAT II Maximum Input Voltage provides 
wide dynamic range while minimizing AC 
(capacitive) loading. 

 The TekVPI connector on the TPP0500 / TPP1000 has a 
mechanical key which corresponds to the TekVPI 
connector on the front of the MSO/DPO5000 Series. This 
mechanical lockout prevent attachment of the probe to 
oscilloscopes which do not support these probes: 

    

 Notice that the vertical readout indicates that the TPP1000 
provides 1 GHz bandwidth! The display should look about 
like this: 

 

MSO/DPO5000 Series Procedure: 

 

 Connect a TPP0500 or TPP1000 
probe to channel 1. 

 Press the front panel Vertical 
Menu button. 

 Select Vertical->Probe Controls. 

 Press the Setup button to display 
the available Probe Setup 
controls such as Deskew Time 
and External Atten. 

 The TPP probes have an 
automated AC calibration 
capability. 

 Connect the probe tip to the 
PROBE COMP signal on the 
lower right corner of the 
oscilloscope. 

 Connect the probe ground to the 
ground connection just above the 
PROBE COMP signal. 

 Press the Calibrate Probe 
button. 
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TPP0502 and TPP0850 Passive Probes 

Key Take Away Points 

 For high-fidelity acquisition of low-amplitude, high-speed 
ground-referenced voltage signals, the TPP0502 is an 
excellent choice: 

o 500 MHz probe bandwidth and only 2X attenuation 
provides low-noise, wide-bandwidth probing for 
small signals with any of the MSO/DPO5000 
Series scopes. 

o 2 MΩ input resistance and ≤12.7 pF input 
capacitance minimizes probe loading on the circuit. 

o 300 V CAT II Maximum Input Voltage provides 
wide dynamic range while minimizing AC 
(capacitive) loading. 

 For high-fidelity acquisition of high-voltage, high-speed 
ground-referenced voltage signals, the TPP0850 is an 
excellent choice: 

o 800 MHz probe bandwidth and 50X attenuation 
provides wide-bandwidth general-purpose probing 
for high-voltage signals with any of the 
MSO/DPO5000 Series scopes. 

o ≤1.8 pF input capacitance minimizes probe AC 
loading on the circuit. 

o 40 MΩ input resistance at the probe tip minimizes 
probe DC loading on the circuit. 

o 2.5 kVPeak, 1000 VRMS CAT II Maximum Input 
Voltage provides wide dynamic range while 
minimizing AC (capacitive) loading. 

 Like the TPP0500 / TPP1000, the TekVPI connector on the 
TPP0502 and TPP0850 probes have a mechanical key 
which corresponds to the TekVPI connector on the front of 
the MSO/DPO5000 Series. This mechanical lockout 
prevent attachment of the probe to oscilloscopes which do 
not support these probes: 

    

MSO/DPO5000 Series Procedure: 

 

 Connect a TPP0502 or TPP0850 
probe to channel 1. 

 Press the front panel Vertical 
Menu button. 

 Select Vertical->Probe Controls. 

 Press the Properties button to 
display probe information and 
connection status. 

 Click the white X in the upper 
right corner to close the pop-up 
window. 

 Press the Setup button to display 
the available Probe Setup 
controls such as Deskew Time 
and External Atten. 

 The TPP probes have an 
automated AC calibration 
capability. 

 Connect the probe tip to the 
PROBE COMP signal on the 
lower right corner of the 
oscilloscope. 

 Connect the probe ground to the 
ground connection just above the 
PROBE COMP signal. 

 Press the Calibrate Probe 
button. 

 



 

MSO5000 / DPO5000 Lab Exercise Book 

Version 1.1   5/11/2012 48W-26279-3   385 of 394 

 

TAP1500, TAP2500, and TAP3500 Active Probes 

Key Take Away Points 

 For highest-fidelity acquisition of high-speed ground-
referenced voltage signals, the TAP series active probes 
are an excellent choice: 

 TAP1500 TAP2500 TAP3500 

Bandwidth ≥1.5 GHz ≥2.5 GHz ≥3.5 GHz 

Attenuation 10:1 10:1 10:1 

Input 
Impedance 

1 M || 
≤ 1 pF 

40 k || 
≤ 0.8 pF 

40 k || 
≤ 0.8 pF 

Input Dynamic 
Range 

-8 V to +8 V -4 V to +4 V -4 V to +4 V 

Input Offset 
Range 

-10 V to +10 
VDC 

-10 V to +10 
VDC 

-10 V to +10 
VDC 

Max Input 
Voltage 
(nondstruct) 

±15 V (DC + 
peak AC) 

±30 V (DC + 
peak AC) 

±30 V (DC + 
peak AC) 

 Notice that you can call up the MSO/DPO5000 Series 
Probe Controls control window simply by pressing the 
Menu button on the probe. The display should look about 
like this: 

 

MSO/DPO5000 Series Procedure: 

 

 Connect a TAP Series active 
probe to channel 1. Make sure 
the green Status LED on the 
probe is lit. 

 Press the Menu button on the 
probe. Notice that the probe is 
identified in the Probe Type 
readout. 

 To offset the input signal in the 
probe, use the Multipurpose a 
control. 

 Press the Setup button to display 
the available Probe Setup 
controls such as Deskew Time 
and External Atten. 

 Press the Properties button and 
notice that the probe status 
information such as serial number 
is displayed. Close the Probe 
Properties control window. 

 To minimize any DC offsets in the 
probe, after the probe and 
oscilloscope have warmed up for 
at least 20 minutes, short the 
probe input to ground and press 
the AutoZero button on the 
oscilloscope. 
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TCP0020 and TCP0030 Current Probes 

Key Take Away Points 

 For high-fidelity acquisition of high-speed current signals, 
the TCP0020 or TCP0030 are excellent choices: 

o DC to >50 MHz or 120 MHz bandwidth. 
o 20 ARMS or 30 ARMS current capability. 
o Provides automatic units scaling and readout on 

the oscilloscope display. 

 When you first connect the current probe, you will see a 
pop-up notifier in the middle of the display if the probe 
needs to be degaussed and the offsets zeroed out. Also, 
notice the red error icon and the mouse-over message 
which appears when the probe jaws are open: 

 

 You can call up the MSO/DPO5000 Series Probe Controls 
control window simply by pressing the Menu button on the 
probe. The display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 

 Connect a TCP0020 or TCP0030 
current probe to channel 1. 

 To remove any residual magnetic 
fields and DC offsets in the 
current probe, press the Degauss 
/ AutoZero button, either on the 
probe or in the control window on 
the oscilloscope. 

 

 

 

 Press the Menu button on the 
probe. Notice that the probe is 
identified in the Probe Type 
readout. 

 To manually match the vertical 
sensitivity of the probe to the 
signal, press the Range button, 
either on the probe or in the 
control window on the 
oscilloscope. However, automatic 
scaling is the default, so you may 
not ever need to use this control. 

 Press the Setup button to display 
the available Probe Setup 
controls such as Deskew Time 
and External Atten. 

 Notice that the units on the 
vertical and trigger readouts 
change to units of current (mA 
and A). 
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TCP0150 Current Probe 

Key Take Away Points 

 For high-fidelity acquisition of large current signals, the 
TCP0150 is an excellent choice: 

o DC to 20 MHz bandwidth. 

o Provides automatic units scaling and readout on 
the oscilloscope display. 

o 150 ARMS / 500 Apeak pulse current capability. 

 You can call up the MSO/DPO5000 Series Probe Controls 
menu simply by pressing the Menu button on the probe. 
The display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 

 Connect a TCP0150 probe to 
channel 1. 

 To remove any residual magnetic 
fields and DC offsets in the 
current probe, press the Degauss 
/ AutoZero button, either on the 
probe or in the control window on 
the oscilloscope. 

 

 

 

 Press the Menu button on the 
probe. Notice that the probe is 
identified in the Probe Type 
readout. 

 To manually match the vertical 
sensitivity of the probe to the 
signal, press the Range button, 
either on the probe or in the 
control window on the 
oscilloscope. However, automatic 
scaling is the default, so you may 
not ever need to use this control. 

 Press the Setup button to display 
the available Probe Setup 
controls such as Deskew Time 
and External Atten. 

 Notice that the units on the 
vertical and trigger readouts 
change to units of current (mA 
and A). 
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TDP0500, TDP1000, TDP1500, and TDP3500 Differential Probes 

Key Take Away Points 

 For high-fidelity acquisition of high-speed differential 
voltage signals, the TDP Series differential probes are 
excellent choices: 

 TDP0500 / 
TDP1000 

TDP1500 TDP3500 

Bandwidth 500 MHz / 
1 GHz 

1.5 GHz 3.5 GHz 

Attenuation 5:1 and 50:1 1:1 and 10:1 5:1 

Differential 
Input 
Impedance 

1 M || 
< 1 pF 

200 k || 
< 1 pF 

100 k || 
≤ 0.3 pF 

Differential 
Mode Input 
Voltage Range 

±42 V (DC + 
peak AC) 

±8.5 V (10X) 
±0.85 V (1X) 

±2 V 

Common Mode 
Input Voltage 
Range 

±35 V (DC + 
peak AC) 

7 V -4 V to +5 V 

Input Offset 
Range 

±42 V ±7 V ±1 V 

Max Input 
Voltage 
(nondestruct) 

±100V 
(DC+ peak 

AC) 

±25 V (DC + 
peak AC) 

±25 V (DC + 
peak AC) 

 

MSO/DPO5000 Series Procedure: 

 

 Connect a TDP Series differential 
probe to channel 1. 

 
TDP1000 Controls 
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Key Take Away Points 

 You can call up the MSO/DPO5000 Series Probe Controls 
control window simply by pressing the Menu button on the 
probe. The display should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Select Vertical->Deskew… to 
display the available Probe 
Deskew Time and External Atten 
controls. 

 Press the Menu button on the 
probe. Notice that the probe is 
identified in the Probe Type 
readout. 

 To manually match the vertical 
sensitivity of the probe to the 
signal, press the Range button, 
either on the probe or in the 
control window on the 
oscilloscope. However, automatic 
scaling is the default, so you may 
not ever need to use this control. 

 To offset the input signal in the 
probe, touch the Offset text box 
and use the Multipurpose a 
control to adjust the DC offset. 

 To minimize any DC offsets in the 
probe, after the probe and 
oscilloscope have warmed up for 
at least 20 minutes, set the range 
to the desired setting, short both 
probe inputs to ground and press 
the AutoZero button in the 
control window. 
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Key Take Away Points 

 The TDP Series probe adds new bandwidth and coupling 
capabilities. Before you connect the probe, the channel’s 
menu looks something like this: 

 

 After connecting the TDP Series probe, the menu changes 
to look something like this: 

 

 Notice that additional bandwidth selections have been 
added. 

MSO/DPO5000 Series Procedure: 

 Remove the probe from channel 
1. 

 Select Vertical->Bandwidth 
Limit…. 

 Press the down arrow on the 
Bandwidth text box to display the 
available bandwidth settings. 

 

 

 

 

 

 

 

 

 

 Connect the TDP series probe to 
channel 1. 

 Press the probe Menu button to 
display the full Probe Controls 
control window. 

 Press the down arrow on the 
Bandwidth text box and notice 
the additional bandwidth 
selections have been added. 

 To minimize noise on the display, 
select the lowest bandwidth 
setting that does not distort the 
signal. 
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Key Take Away Points 

 Notice that the DC Reject (“Rej”) capability of the probe has 
replaced the channel’s AC coupling selection in the menu. 

 DC Reject is useful when you are measuring small 
amplitude signals superimposed on a large differential 
offset component. DC Reject generates an internal offset 
that cancels the DC component of the signal. 

 Because the input is always directly coupled, the DC reject 
mode does not increase the common and differential mode 
dynamic ranges for DC components. The DC reject mode 
also disables any capability of external offset adjustment. 

 In the screen shot below, the probe is connected between 
the CAN_H and GND signals. With the probe and 
oscilloscope DC-coupled, the signal appears as a 1Vpp AC 
signal riding on a 2.5V DC baseline, as shown in the white 
reference trace below. (The CAN_H signal is positive 
relative to the baseline, and the CAN_L signal is negative 
relative to the baseline.) When the probe’s DC Reject 
enabled, you’ll notice that most of the DC offset has been 
removed, similar to AC coupling. 

 

 Finally, notice the variety of probing accessories for the 
TDP series for versatile connectivity to the device under 
test: point probing, variable spacing, square pin connection, 
KlipChip connection, and a new solder-down connection 
that incorporates damping networks for improved signal 
fidelity. 

MSO/DPO5000 Series Procedure: 

 Connect the probe to a signal 
with significant DC offset, such as 
CAN_H on the demo board. 

 

 

 

 

 

 

 

 Make sure that the probe Offset 
is set to 0 V. 

 Press the DC Reject button on 
the TDP probe, or select Vertical-
>Coupling… and press the DC 
rej Coupling button, and notice 
the effect on the display. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Look at the box of probing 
accessories provided with the 
TDP Series of probes. 
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Key Take Away Points 

(optional) Measuring Current with Differential Probes 

 Differential probes can also provide wideband current 
measurements by measuring the voltage drop across a 
known impedance. For example, the 3PQS power demo 

board has a 1 resistor in series with the load, as shown 
below: 

 

 For comparison purposes, the screen shot below shows 
the TCP0030 current measurement on channel 2. The 
display of the current waveform should look about like this: 

 

MSO/DPO5000 Series Procedure: 

 Connect the 12VAC power 
adapter to the power demo board 
and plug it in. 

 On the 878-0544-XX demo board, 
connect the differential probe to 
the DRAIN_SENSE and 
FET_DRAIN test points. 

 On the 3PQS board, connect the 
differential probe across the large 

1 resistor which is in series with 
the load. 

 Select Vertical->Vertical 
Setup…. 

 Double-click on the Units text 
box, enter A, and press Enter to 
set the units to Amperes to 
display the signal (and automatic 
measurements) in Amps. 

 Press the front panel Autoset 
button. 

 If the signal looks too noisy, you 
can filter the display with HiRes. 
Press the front panel Acquire 
button, press Acquisition tab, 
and press the Hi Res Acquisition 
Mode button. 
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TxDP0x00 and P52xxA Series High-Voltage Differential Probes 

Key Take Away Points 

 For high-fidelity acquisition of high-voltage differential 
voltage signals, the TxDP0x00 and P52xxA Series 
differential probes are excellent choices. 

 The TxDP0x00 TekVPI probes are similar to the existing 
P52xxA probes, but they have double the bandwidth of the 
P52xxA probes and do not require the TPA-BNC adapter 
for use on TekVPI

®
 scopes. 

For reference, the nomenclature acronyms have the 
following definitions:  
TMDP0200: Tektronix Medium-Voltage Differential Probe 
                    with 200 MHz bandwidth 
THDP0200: Tektronix High-Voltage Differential Probe 
                    with 200 MHz bandwidth  
THDP0100: Tektronix High-Voltage Differential Probe 
                    with 100 MHz bandwidth 

 

Characteristic TMDP0200 THDP0200 THDP0100 
Attenuation 25X/250X 50X/500X 100X/1000X 

Dynamic Range 
250X: +/- 750V 

25X: +/- 75V 
500X: +/- 1500 V 

50X: +/- 150V 
1000X: +/- 6000V 
100X: +/- 600V 

Common Mode 
Voltage 

250X: +/- 750V 
25X: +/- 75V 

500X: +/- 1500V 
50X: +/- 150V 

1000X: +/- 6000V 
100X: +/- 600V 

Bandwidth 200 MHz 200 MHz 100 MHz 

Rise Time < 1.8 ns < 1.8 ns < 3.5 ns 

Slew Rate 
< 275 V/ns  

@ 1/250 gain 
< 650 V/ns  

@ 1/500 gain 
< 2500 V/ns  

@ 1/1000 gain 

Input Impedance at 
the Probe Tip 

5 MΩ || <2 pF 10 MΩ || < 2 pF 40 MΩ || < 2.5 pF 

 

 For comparison, these are the basic specifications for the 
P52xxA Series differential probes: 

Characteristic P5200A P5202A P5205A P5210A 

Attenuation 
50X / 500X 20X / 

200X 
50X / 500X 100X / 

1000X 

Differential Input 
Voltage 

500X: 
±1300V 

50X: ±130V 

200X: 
±640V 

20X: ±64V 

500X: 
±1300V 

50X: ±130V 

1000X: 
±5600V 

100X: ±560V 

Common Mode 
Voltage 

500X: 
±1300V 

50X: ±130V 

200X: 
±640V 

20X: ±64V 

500X: 
±1300V 

50X: ±130V 

1000X: 
±5600V 

100X: ±560V 

Bandwidth 50 MHz 100 MHz 100 MHz 50 MHz 

Note: P5202A, P5205A, and P5210A require the use of the TPA-
BNC adapter with the MSO/DPO5000 Series. 

 

 

THDP0200 Probe and 
Accessories 
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MSO/DPO5000 Probe Power 

Key Take Away Points 

 The MSO/DPO5000 oscilloscopes contain the TekVPI probe interface that provides power to 
qualifying TekVPI voltage and current probes. The oscilloscopes internal power supply can provide 
up to about 15W (12W with software versions ≤6.2.0) of power to all the TekVPI probe inputs 
located on the front of the oscilloscope (Channels 1, 2, 3, 4, and the Aux In). 

 Because some of the available TekVPI probes can draw a significant amount of power, possibly 
collectively exceeding the 15W of integrated power the MSO/DPO5000 oscilloscope can provide, 
Tektronix offers an external power supply accessory (Tek Part Number 119-7465-xx). The TekVPI 
external power supply can provide up to 50W of power through the rear panel connector to the 
TekVPI front panel probe inputs, enabling the usage of any combination of qualifying probes without 
exceeding power requirements. 

 The oscilloscope will display this message when the power draw has been exceeded, indicating the 
need for a TekVPI external power supply: 

 

 The table below lists the maximum power draw
1
 associated with each type of TekVPI probe or 

accessory that can be used with the MSO/DPO5000 Series oscilloscopes. This table can help you 
determine if you potentially need the external power supply for your application. 

TekVPI Probe/Accessory Description Max Power Draw 

TAP1500 1.5 GHz Single-ended Active FET Voltage Probe 1.5W 

TAP2500 2.5 GHz Single-ended Active FET Voltage Probe 1.5W 

TAP3500 3.5 GHz Single-ended Active FET Voltage Probe 1.5W 

TDP0500 500 MHz Differential High Voltage Probe (± 42 V) 1.5W 

TDP1000 1 GHz Differential High Voltage Probe (± 42 V) 1.5W 

TDP1500 1.5 GHz Differential Voltage Probe (± 8.5 V) 1.9W 

TDP3500 3.5 GHz Differential Voltage Probe (± 2 V) 1.5W 

TCP0020 15 A, 50MHz, AC/DC Current Probe 4.0W 

TCP0030 30 A, 120MHz, AC/DC Current Probe 8.4W 

TCP0150 150 A, 20 MHz, AC/DC Current Probe 9.2W 

TMDP0200 200 MHz High Voltage Differential Probe 2.7W 

THDP0100 100 MHz High Voltage Differential Probe 2.7W 

THDP0200 200 MHz High Voltage Differential Probe 2.7W 

TPA-BNC
2 TekVPI Interface Adapter 2.5W 

TEK-DPG TekVPI Deskew Pulse Generator 1.5W 

Note1: The power numbers listed in the table are theoretical maximum values.  The actual power draw from the probe depends on 
several factors, including the parameters of the circuit being measured (especially for current probes) and the type of probe connected 
to the TPA-BNC adapter. 
 
Note 2: The TPA-BNC will only draw a maximum of 2.5W of power from the oscilloscope no matter which TekProbe Level 2 interface 
probe is used with it. 

 


